Subject: Re: can't install clisp in NeXTStep 3.0

From: [email-masked] (Norihiko Ono)
Date: Thu, 8 Sep 94 16:32:56 +0900

Hello,

Recently I have started subscribing this mailing-list and found:

> I can't seem to install clisp on NeXTStep 3.0 because of problems  

> with libnoreadline.a and libreadline.a. Any idea what the workaround  

> is? im using the clisp version from  

> binaries/next/clisp-english.tar.gz 

> 	% cc lisp.a libnoreadline.a -ltermcap -s -o lisp.run
> 	/bin/ld: libnoreadline.a bad magic number (not a Mach-O file)
> 

> -Rick Taube
> [email-masked]
> Zentrum fuer Kunst und Medientechnologie
> Ritterstr. 42 76137 Karlsruhe Germany

I encountered the same problem under Japanese version of NeXTSTEP 3.0
-- NeXTSTEP 3.0J. Probably this problem has been already resolved by
someone, but I've just bypassed it.

The following steps seem to be needed before using cc:

  jenny libnoreadline.a
  ranlib libnoreadline.a
  ranlib lisp.a

However, yet another problem I have with thus generated clisp. When I
try to let it evaluate `(fact 1000)' employing the following
definition:

  (defun fact (n) (if (zerop n) 1 (* n (fact (1- n)))))

`memory fault' error happens on my NeXTstation Turbo. So long as
parameter of `fact' is a small positive integer, say 100, the
function is evaluated successfully.

Any suggestion would be appreciated. Thank you.
--
Norihiko Ono
Dept. of Information Science and Intelligent Systems
Faculty of Engineering, University of Tokushima
Email: [email-masked]
Phone: +81 886 56 7509
F A X: +81 886 56 7511

---

From: [email-masked] (Marcus Daniels)
Date: Thu, 8 Sep 94 02:45:05 PDT

>>>>> "Norihiko" == Norihiko Ono <[email-masked]> writes:

Norihiko> `memory fault' error happens on my NeXTstation Turbo. So
Norihiko> long as parameter of `fact' is a small positive integer, say
Norihiko> 100, the function is evaluated successfully.

Rebuild from a recent source-haible and the problem with disappear.