Subject: Re: terminal-raw mode

From: haible (Bruno Haible)
Date: Fri, 14 Jan 94 17:43:08 +0100

> my program is the following
>   (system::terminal-raw *keyboard-input* t)
...
>   (system::terminal-raw *keyboard-input* nil)

I suggest you use the macro WITH-KEYBOARD documented in impnotes.txt instead
of using Unix specific, undocumented CLISP internals. A look into the
CLISP source reveals that system::terminal-raw expects *terminal-io* as
argument, not *keyboard-input*.

Btw, your comparison should read  (>= i field-length)  in

> (let ((s (make-string field-length)))
>    (do ((i 0)) ((> i field-length))
>      ...
>      (setf i (+ i 1)))

                    Bruno Haible
                    [email-masked]

---

From: Joachim Schrod <[email-masked]>
Date: Fri, 14 Jan 1994 18:06:22 +0100 (MEZ)

Bruno wrote:
> 
> I suggest you use the macro WITH-KEYBOARD documented in impnotes.txt

Apropos impnotes.txt... It (and CHANGES.LOG) describe the new
support for some CLtL2 constructs. This was not updated in cltl2.txt.
Is there anything to note concerning this new features? Or may I just
change all `no' entries to `yes' for the respective X3J13 votes? (We
supply cltl2.txt as one of the information files to our users.)

	Joachim

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Joachim Schrod			Email: [email-masked]
Computer Science Department
Technical University of Darmstadt, Germany

---

From: [email-masked] (Marcus Daniels)
Date: Fri, 14 Jan 94 09:47:08 PST

>>>>> "JS" == Joachim Schrod <[email-masked]> writes:

JS> Apropos impnotes.txt... It (and CHANGES.LOG) describe the new
JS> support for some CLtL2 constructs. This was not updated in
JS> cltl2.txt.  Is there anything to note concerning this new
JS> features? Or may I just change all `no' entries to `yes' for the
JS> respective X3J13 votes? (We supply cltl2.txt as one of the
JS> information files to our users.)

Thanks, I'll update cltl2.txt with these notes.

Marcus