Subject: stdwin (under x11)

From: Aaron Neerenberg <[email-masked]>
Date: Mon, 27 Jun 1994 09:17:17 -0700 (PDT)

Could be that I just didn't read as closely as i should have, but 
how does one call xlib and stdwin functions from within clisp?

---

From: haible (Bruno Haible)
Date: Mon, 27 Jun 94 18:58:08 +0200

> how does one call xlib and stdwin functions from within clisp?

The STDWIN functions are present in the STDWIN package (but not exported,
I think) if you built clisp using the --with-stdwin option.

You cannot access Xlib function since the purpose of STDWIN is to hide
the underlying X11.

If you want to use the X11 protocol directly, either use CLX or write
a foreign function interface to the Xlib (not easy)...

                    Bruno Haible
                    [email-masked]