Subject: bug in prompting loops

From: [email-masked] (Rick Taube)
Date: Mon, 9 May 94 07:07:02 GMT+0100

there is a stream bug in both the DOS and the NeXTStep versions of  
CLISP that causes output in a PROMPT/READ loop to get multiply  
printed after some number of correct occurences. On the NeXT the bug  
starts after 6 times through the loop, (after 12 on my DOS machine).  
Once the bug starts, with a bogus line getting printed) the prompt  
appears to gets doubled, then tripled, etc.  The bug is very easy to  
tickle, just eval this loop and type 1 as the answer. It may take a  
few time, but you should notice that the prompt starts going haywire  
fairly soon: 

> (loop (format t "type value:") (read))
type value:1
type value:1
type value:1
type value:1
type value:1
type value:1
type value:
1
type value:
type value:1
type value:
type value:type value:1
type value:
type value:type value:type value:1
type value:
type value:type value:type value:type value:1
type value:
type value:type value:type value:type value:type value:1
type value:
type value:type value:type value:type value:type value:type value:1
type value:
type value:type value:type value:type value:type value:type  
value:type value:

---

From: [email-masked] (Joerg-Cyril Hoehle)
Date: Mon, 9 May 94 11:25:59 +0200

Rick Taube wrote:
>printed after some number of correct occurences.
[...]

Weird, this doesn't happen in the January versions of CLISP for Sun4
and Amiga.

 	Joerg Hoehle.
[email-masked]