Subject: problem building clisp for AMIGA NetBSD 1.0

From: [email-masked] (Michel Loi)
Date: Wed, 2 Nov 94 09:29:16 +0100

Hello,

I am trying to build the last version of B. Haible clisp
(ma2s2.mathematik.uni-karlsruhe.de:/pub/lisp/clisp/source-haible)
for AMIGA NetBSD 1.0.

lisp.run dumps core when loading "defmacro.lsp"

I use the following flags:
- -DNO_MULTIMAP_SHM -DNO_MULTIMAP_FILE
- unixconf.h is OK
- I've modified lispbibl.d (appropriately ?):
  the address space layout of NetBSD 1.0 seems
  to be the same as the "ATARITT" one:
  address: bits 0..25
  (shared libraries are mapped above 0x02000000 ?)
  and tag: 31..26
  thus I have followed the definitions for "ATARITT"
- I've also tried -DWIDE: same result
- I've tried older versions of clisp: same result
  these versions work fine with AMIX 2.1 and
  NetBSD 0.9 (!)
- I've used gcc 2.4.5 and 2.6.0: same result

I suspect I am missing something.
Has anybody built clisp for amiga NetBSD 1.0 ?
(at least someone has built it for 386 NetBSD 1.0 Beta)

Any help is welcome.
Thanks.

-- Michel LOI

---

From: [email-masked] (Joerg-Cyril Hoehle)
Date: Wed, 2 Nov 94 12:32:14 +0100

> for AMIGA NetBSD 1.0.
Well, I've never tried this OS but I've got some experience with
CLISP, GCC and the Amiga :-)

 > lisp.run dumps core when loading "defmacro.lsp"

I'd suggest that you try to find the bug more closely. Sometimes, when
I succeeded in generating a lisp.run that would start, later crashes
would be caused by GCC bugs inside a specific function, e.g. I had to
patch a little of assembly output for GCC260 and -DWIDE in CONTROL:_C_go.

 >   these versions work fine with AMIX 2.1 and

As the writers of NetBSD 1.0 were so crazy as to require 64 bit
pointers for every platform, a GCC bug is possibility to think of. I'm
not yet too confident in GCC 64 bit usage on m68k now, but I didn't
test the latest beta2.6.1.

I'm not using the last source-haible myself, the snapshot I'm working
on is 1st Sep. Maybe something bad slipped in.

 	Joerg Hoehle.
[email-masked]
AMIGAOS-CLISP