Subject: Compiling on Ultrix

From: Peter Nilsson <[email-masked]>
Date: Fri, 02 Dec 94 09:43:25 +0100

Hi

As the clisp binary for Ultrix on the ftp site is rather old I am
trying to compile the src on my system.  I'm running 
Ultrix V4.4 (Rev. 69) on a DECstation 5000.

I have tried with and without the hints found in the file unix/PLATFORMS
supplied with the source code, that is:

  After executing "target ...", change the first line in makemake from
  "#! /bin/sh" to "#! /usr/bin/ksh". /bin/sh apparently doesn't support
  function definitions.
  Add -DNO_MULTIMAP_SHM to the CFLAGS in the makefile. Shared memory
  facilities do not work: even SHMLBA is not defined correctly in <sys/shm.h>.

Regardless of this I get an error while making the file control.c:

  gcc -O -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-    frame-pointer -O2 -c control.c
  In file included from /usr/local/gnu/lib/gcc-lib/mips-dec-ultrix4.4/2.6.1/inc    lude/sys/termio.h:59,
	from /usr/local/gnu/lib/gcc-lib/mips-dec-ultrix4.4/2.6.1/include/sys/
          termios.h:60,
        from /usr/include/termios.h:2,
        from unix.d:519,
        from lispbibl.d:1504,
        from control.d:4:
  /usr/local/gnu/lib/gcc-lib/mips-dec-ultrix4.4/2.6.1/include/sys/ioctl.h:473:     warning: `/*' within comment
  /usr/local/gnu/lib/gcc-lib/mips-dec-ultrix4.4/2.6.1/include/sys/ioctl.h:474:     warning: `/*' within comment
  /usr/local/gnu/lib/gcc-lib/mips-dec-ultrix4.4/2.6.1/include/sys/ioctl.h:475:     warning: `/*' within comment
  gcc: Internal compiler error: program cpp got fatal signal 4
  *** Error code 1

  Stop.

The warnings I get on a lot of other files too so they shouldn't be the
cause of the error.  Any hints on how to fix it will be very much
appreciated.  Alternatively, If anyone know of a fairly recently
compiled clisp binary for Ultrix I would like to know.

		Peter Nilsson
		[email-masked]

		Royal Institute of Technology, Stockholm, Sweden

---

From: haible (Bruno Haible)
Date: Fri, 2 Dec 94 15:54:21 +0100

>   frame-pointer -O2 -c control.c
...
> gcc: Internal compiler error: program cpp got fatal signal 4

The gcc-2.6.1 cpp has a bug, which is fixed in gcc-2.6.2.

                    Bruno Haible
                    [email-masked]