Subject: Re: CLisp, CLOS, and warning when you reload a file

From: haible (Bruno Haible)
Date: Fri, 25 Nov 94 02:20:25 +0100

Bruce O'Neel <[email-masked]> wrote:

> when I'm using a file which uses CLOS
> and I reload it I get a load'o warnings.  This is ok, but I'd prefer
> not to see them.  Is there a simple way to turn them off?

Yes, put a

  (handler-bind ((warning #'(lambda (w) (muffle-warning w)))) ... )

around your LOAD form.

Btw, we have already discussed the issue of the CLOS warnings on this
mailing list in July 1994.

                    Bruno Haible
                    [email-masked]

---

From: [email-masked] (Bruce O'Neel)
Date: Fri, 25 Nov 94 09:37 EST

>                     [email-masked]

Thanks!

bruce

[email-masked] -- Bruce O'Neel HSTX (301) 286-1511 -- Graphical
icons were intended to make software friendly, and easy to use.  Now Microsoft
applications have Tool Tips - Text labels that appear when you move the mouse
pointer over icons.  We used to call these "menus." -- D Kalman DBMS 9/94