Subject: CLISP on SunOS4

From: [email-masked]
Date: Mon, 21 Nov 1994 12:36:12 +0000

Hello,
	I'm sorry if this is in the archives but I need a rather quick
reply.

I'm trying to get CLISP running on a Sun under SunOS 4.1.3. A 'uname'
command gives:
	SunOS neptune 4.1.3 3 sun4

I've downloaded and extracted the files in
	'binaries/sun4-sunos4/clisp-sun4c.tar.z'
and run the compiler as per the README file.

However, when trying to get CLISP to start using the command given
in the README file I get the following error:
	lisp.run: initialisation file was not created by this version of LISP

I tried starting without the memory file and loaded the 'init.fas'
file and it seems to work O.K. Should I just save this memory image or
is it better to use the one supplied?

David.

-- 
-=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -=-
David Arnold                             ([email-masked])
Dept. Computer Science                   +44 (0)970-622449
University of Wales,Aberystwyth, Dyfed SY23 3DB, UK.
http://www.dcs.aber.ac.uk/~daa93
GCS -d+ p c++@ !l e++ m+++(*) s+/- n+ h(-) f !g w- t+@ y? 
-=- -=- -=- -=- -=- -=- -=- -=- -=- -=- -= -=- -=-- -=- -=-

---

From: haible (Bruno Haible)
Date: Fri, 25 Nov 94 01:34:18 +0100

> 	lisp.run: initialisation file was not created by this version of LISP

I can't reproduce this.

> is it better to use the one supplied?

The memory image you get from running the command

       lisp.run -x '(load "init.fas") (saveinitmem)'

is good. It is safe to use this one, especially if the one I supplied
doesn't work.

                    Bruno Haible
                    [email-masked]