Subject: turning off continuable error messages

From: [email-masked] (Dan Stanger)
Date: Wed, 16 Feb 1994 13:42:02 -0700

it is possible to turn off the following messages.

;; Loading file /home/dxs/ai/norvig/loop.lsp ...
** - Continuable Error
Redefining the COMMON LISP macro LOOP
If you continue (by typing 'continue'): The old definition will be lost
1. Break>

i would like the lisp system to not query the user but just replace the
definition.

thanks,
dan stanger

---

From: [email-masked] (Don Cohen)
Date: Wed, 16 Feb 94 14:20:49 -0800

Dan Stanger <[email-masked]> says:
   (load "loop.lsp")
   > Redefining the COMMON LISP macro LOOP
Bruno Haible says:
   One should be able to handle this using the new condition system 

My answer:
   I assume the error message came from CERROR.
   In that case something like this ought to work:
   (handler-bind
     ((t ; provide a more specific condition if you know it
      #'(lambda (c) ; a condition argument
	  (when (find-restart 'continue)
	     ; cerror is supposed to provide this restart
	     (invoke-restart 'continue)))))
     (load "loop.lsp"))

Bruno responds:
   Yes, it does. One can also write "error" instead of "t".