Subject: Don't want floating point underflows

From: Kai Rainer Puolamaki <[email-masked]>
Date: Mon, 6 Jun 1994 14:51:56 +0300 (EET DST)

Hello,

CLISP considers floating point underflows to be errors.  However, I
would like (exp -100) return 0, not "*** - floating point underflow". 
Is there an easy fix for this?

Thanks for your help. 

Yours, Kai Puolamaki <[email-masked]>

---

From: haible (Bruno Haible)
Date: Mon, 6 Jun 94 15:19:31 +0200

> Is there an easy fix for this?

Try this patch (untested) and rebuild clisp from source.
(exp -100) should then return 0.0.

                    Bruno Haible
                    [email-masked]