Subject: problem creating makefile

From: [email-masked]
Date: Wed, 13 Jul 1994 16:52:50 -0400

Retrieved clisp-1994-07-04 version.
Trying to install following Unix instructions on DECstation 3100 running
	Ultrix 4.2.
Script below shows an error occurred on creating the makefile:

> Script started on Wed Jul 13 15:36:23 1994
csh> ./makemake > makefile
./makemake: syntax error at line 763: `(' unexpected
csh> exit
csh> script done on Wed Jul 13 15:37:06 1994

Line 763 is the echotab () line in makemake:

# Output the makefile:

# echotab line
# outputs a line, preceding it with a tab. cat is needed to output tabs.
if [ "$HSYSOS" != coherent ] ; then
echotab () {
cat <<!!
	$1
!!
}
else
# Coherent's ksh produces error relating to /tmp/sh<pid> files...
echotab () {
echo "\t""$1"
}
fi

I don't see the problem. Any help? Excuse my ignorance.

[email-masked]

================== RFC 822 Headers ==================
Date: Wed, 13 Jul 94 22:32:15 +0200
Originator: [email-masked]
Reply-To: [email-masked]
Sender: [email-masked]
Version: 5.5 -- Copyright (c) 1991/92, Anastasios Kotsikonas
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Subject: problem creating makefile

---

From: Joachim Schrod <[email-masked]>
Date: Thu, 14 Jul 1994 18:23:34 +0100 (MESZ)

[email-masked] wrote:
> Script below shows an error occurred on creating the makefile: [...]

That is a function definition. The Bourne shell on Ultrix 4.2 does not
support shell functions.

 (1) Check if ksh or bash is available on your system. You do this
     with the command 'type' or with 'whereis'.
	Use this shell; i.e., type 'ksh target ultrix-4.2' and 'ksh
     makemake'.

 (2) If you don't have such a shell, get the bash sources from a ftp
     server near you and compile them. (Reduce the problem to a known
     one... :-)

Cheers,
	Joachim

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Joachim Schrod			Email: [email-masked]
Computer Science Department
Technical University of Darmstadt, Germany