Subject: Compiling CLISP on NT experience

From: Blake McBride <[email-masked]>
Date: Wed, 13 Dec 1995 02:03:43 -0600

Not good.

I downloaded the latest CLISP (1995-12-08) and GCC for NT (b10) and attempted to
get it working under NT.  I haven't gotten it working but thought I'd share my
experience with others.  Perhaps someone can show me where I'm going astray.

1.  I didn't understand Marcus Daniels' instructions since I'm not trying to cross
compile anything.  I understand that I have to run configure and makemake from
linux, but I want to do the rest under NT.  What I did from linux is as follows:

        (from clisp root)

        configure --disable-nls --without-readline
        cd src
        makemake --disable-nls --without-readline i386-win32 gcc >makefile

I then copied everything to my DOS partition.  I tried "win32" at the end of the configure
command as recommended by Marcus but it didn't like it.

2.  I had many problems with the tools (make, bash, etc.) which came with gcc.  

First make didn't recognize the "copy" or "type" commands in the makefile since they 
are not .exe files - I changed them to cp and cat, etc.

The backslashes in paths in the makefile were acting like escape characters and nothing 
worked - I changed them to a forward slashes.

For some reason piping was causing anything compiled with gcc to randomly hang the command
shell.  I used a temporary file in those cases.

3.  lispbibl.d has a line which defines WIN32 commented out.  It is needed with the current
gcc for NT.

4.  Macros named PROT_READ and the like are used but not defined anywhere I could find.

I gave up.

At this point I am of the opinion that A) I probably configured the thing wrong, and
B) the gcc for NT tools are in flux and work differently from previous versions, and
C) I don't get the impression that all the necessary config stuff is included.

I'm interested in working on it further but would appreciate a few pointers to help
get me back on track.  I'll be happy to supply plenty of feedback and any code I
add.

Thanks.

--blake

-- 
Blake McBride				Algorithms Corporation
615-791-1636 voice			3020 Liberty Hills Drive
615-791-7736 fax			Franklin, TN  37067
[email-masked]				USA
See our WEB page at:  http://www.edge.net/algorithms

---

From: Marcus Daniels <[email-masked]>
Date: Wed, 13 Dec 1995 21:16:41 GMT

>>>>> "Blake" == Blake McBride <[email-masked]> writes:

Blake> 1.  I didn't understand Marcus Daniels' instructions since I'm
Blake> not trying to cross compile anything.  I understand that I have
Blake> to run configure and makemake from linux, but I want to do the
Blake> rest under NT. 

I'm afraid that procedure is not tested.

If you want to compile CLISP with gnu-win32, cross compilation will
really be the only option.  I haven't built CLISP for NT since about
version b5.  I know it won't compile on version b10 without some work.
I've done most of this work, and work in the direction of from-scratch
NT hosted builds, but the gnu-win32 toolchain is still fairly
volatile.  I didn't want to delay the release any more.

Tip: if you want to build the Cygnus toolchain on ELF-based Linux, grab
the bfd directory from a previous release or from gdb-4.15.1. The
library distributed is a bit too bleeding edge w.r.t. ELF -- it
won't compile.

Blake> 2.  I had many problems with the tools (make, bash, etc.) which
Blake> came with gcc.

Get in touch with [email-masked].
IMO they are making great progress.

Blake> 3.  lispbibl.d has a line which defines WIN32 commented out.
Blake> It is needed with the current gcc for NT.

Thanks.