Subject: problem with load

From: [email-masked] (Dan Stanger)
Date: Mon, 24 Jul 1995 17:14:19 -0600

when i execute the following code on aix (when x.x does not exist) i get:
clisp -q
 
> (load "x.x")
 
*** - A file with name x.x does not exist
1. Break> 

but on solaris i get
(load "x.x")
 
*** - UNIX error 90 (ELOOP): Too many levels of symbolic links
1. Break>

is this a known problem?

---

From: Marcus Daniels <[email-masked]>
Date: Tue, 25 Jul 1995 00:02:47 GMT

>>>>> "Dan" == Dan Stanger <[email-masked]> writes:

Dan> when i execute the following code on aix (when x.x does not
Dan> exist) i get: clisp -q
 
Dan> (load "x.x")
Dan> *** - A file with name x.x does not exist 1. Break>

Dan> but on solaris i get (load "x.x")
 
Dan> *** - UNIX error 90 (ELOOP): Too many levels of symbolic links
Dan> 1. Break>

I don't get this behavior.  Are you certain you don't have a looped symbolic
link somewhere?  CLISP recursively searches for the file starting in
your current directory as well as your home directory.