Subject: CLISP & WfW 3.11

From: [email-masked] (Dmitri Ivanov)
Date: Mon, 6 Mar 1995 17:32:44 +0200 (MSK)

Hello,

I have got clisp.zip from clisp/binaries/dos and tried to
install it on Windows for Workgroups 3.11. My settings in file
WINCLISP.PIF are like the following:

   Program:                c:\rsx\bin\rsx.exe
   Program title:          COMMON LISP
   Program parameters:     c:\lib\lisp\lisp.exe -M c:\lib\lisp\lispinit.mem
   etc. according to README.

When I try to start WINCLISP.PIF, I watch the picture as follows:
----------------------------------------------------------------------

  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I I I I I I I      8         8           8     8        8    8
  I I I I I I I      8         8           8      ooooo   8oooo
  I  \ `+' /  I      8         8           8           8  8
   \  `-+-'  /       8     o   8           8     o     8  8
    `-__|__-'         ooooo    8oooooo  ooo8ooo   ooooo   8
        |
  ------+------     Copyright (c) Bruno Haible, Michael Stoll 1992, 1993, 1994

> process 2 get hardware fault 12 (stack fault) at 115DC

Process terminated by SIGSEGV
---------------------------------------------------------------------

Adding the following line to AUTOEXEC.BAT

set RSX = C:\RSX\BIN\RSX.EXE

did not improve anything.

I am rather new in the EMS/RSX world and apologize beforehand if
the problem seems easy. I'd be grateful for any help.

Sincerely yours,
                                    Dmitri Ivanov
Email: [email-masked]         Russian Research Institute
Tel:   +7 (095) 152-0561            for Artificial Intelligence

---

From: haible (Bruno Haible)
Date: Thu, 9 Mar 95 17:20:24 +0100

> process 2 get hardware fault 12 (stack fault) at 115DC

If you are using RSX version 5, you need to pass it the command line option "-Ra".

                    Bruno Haible
                    [email-masked]