Subject: Multiple Threads in CLISP?

From: Wilhelm Burger <[email-masked]>
Date: Wed, 13 Sep 1995 10:44:35 +0200

Are there any plans/intentions to implement multi-processing (i.e.,
shallow processes, threads) in CLISP?

Wilbur.

---
Wilhelm Burger, Johannes Kepler University, A-4040 Linz, Austria
Email:[email-masked]/Tel: +43 732 2468 898, Fax: 893

---

From: Marcus Daniels <[email-masked]>
Date: Wed, 13 Sep 1995 11:58:12 GMT

>>>>> "Wilbur" == Wilhelm Burger <[email-masked]> writes:

Wilbur> Are there any plans/intentions to implement multi-processing
Wilbur> (i.e., shallow processes, threads) in CLISP?

Not as far as I know.  I've always been able to get by with IPC.  For
instance, via the FFI, I've used PVM (multiple hosts/processes) with
success.

In the next release will be `socket-streams'.  It is available
in the alpha-sources now: http://sayre.sysc.pdx.edu:8001/clisp.
It should be possible to make this work with winsock, but it doesn't, yet.

Process A:
> (socket-server 8001)
#<SOCKET-SERVER 8001>
> (socket-accept *)
#<SOCKET-STREAM :#<SOCKET-SERVER 8001>>
> (read *)     
(1 2 3)

Process B:
> (socket-connect 8001)
#<SOCKET-STREAM 8001:"localhost">
> (princ '(1 2 3) *)
(1 2 3)