Subject: Re: CLISP 1995-12-08 and NT

From: Blake McBride <[email-masked]>
Date: Tue, 12 Dec 1995 01:21:05 -0600

At 11:24 AM 12/11/95 +0100, you wrote:
>Portability
>-----------
>* Runs on Windows NT.

Sounds interesting.  

I downloaded clisp but had a hard time finding the above.  I saw some tests for WIN32, but
that was it.  Does it still require GCC (in other words will it compile under Microsoft C)?

If it requires GCC, what version?  Does this version support the real WIN32?

I didn't notice any makefiles or build instructions for NT (since autoconfig whould have a hard
time under NT) (although I was looking for references to the Microsoft compiler).  So are 
there any build notes?

Thanks for the help.

--blake

-- 
Blake McBride				Algorithms Corporation
615-791-1636 voice			3020 Liberty Hills Drive
615-791-7736 fax			Franklin, TN  37067
[email-masked]				USA
See our WEB page at:  http://www.edge.net/algorithms

---

From: Marcus Daniels <[email-masked]>
Date: Tue, 12 Dec 1995 13:05:01 GMT

>>>>> "you" == Blake McBride <[email-masked]> writes:

you> I downloaded clisp but had a hard time finding the above.  I saw
you> some tests for WIN32, but that was it.  Does it still require GCC
you> (in other words will it compile under Microsoft C)?

I used win32-gcc, but tried to avoid using the Unix-compatability 
features.  (ftp.cygnus.com:/pub/sac)

you> If it requires GCC, what version?  Does this version support the
you> real WIN32?

Last I compiled it with win32-gcc b7 or so.  I'm working with b10 now,
but since autoconf/bash isn't reliable enough, I didn't distribute the
changes.  The next minor version of CLISP will have another more unixy
win32-gcc configuration, as well as a minimal-assumption
configuration.  Not sure what you mean by "real WIN32" -- win32-gcc seems to
have DLL stubs for most of the stuff in my win32 reference book.

you> I didn't notice any makefiles or build instructions for NT (since
you> autoconfig whould have a hard time under NT) (although I was
you> looking for references to the Microsoft compiler).  So are there
you> any build notes?

After installing the gnu-win32 on Linux (or other Unix machine):
  configure --target=i386-win32 --enable-targets=i386-win32,i486-linux
  make 
  make install

And configuring CLISP:
  CC=i386-win32-gcc configure --disable-nls --without-readline win32

makemake --disable-nls --without-readline cross i386-win32 gcc > makefile

should provide a makefile to build the lisp.run for NT.