Subject: #(...) Simple Vectors

From: Wilhelm Burger <[email-masked]>
Date: Thu, 10 Aug 1995 14:48:20 +0200

Hello,
   I am new to this list, just started porting some older CL code
to CLISP (Version 1995-04-04):

> *package*
#<PACKAGE USER>
> #(9 9 9)          ;This should create a simple vector

*** - EVAL: illegal form #(9 9 9)

Is the form #(..) illegal in CLISP (vs. CLtL2 p.533)?

Help appreciated -
Wilhelm.

---

From: [email-masked] (Joerg-Cyril Hoehle)
Date: Thu, 10 Aug 95 15:19:13 +0200

> Is the form #(..) illegal in CLISP (vs. CLtL2 p.533)?
CLISP is not CLtL2 in every respect. The form #(...) is not
self-evaluating.

Use '#(9 9 9) (see the quote) and everything should be fine. This
difference mostly concerns top-level calls and constants in programs,
easy to locate in a source file.

 	Joerg Hoehle.
[email-masked]

---

From: [email-masked] (Martin Cracauer)
Date: Thu, 10 Aug 1995 15:32:24 +0200 (MET DST)

> Is the form #(..) illegal in CLISP (vs. CLtL2 p.533)?

It cannot be evaluated. Quote it. Or use it to set a variable.

-- 
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Martin Cracauer <[email-masked]>  
(private address)
Tel.: +49 40 / 522 18 29
Fax.: +49 40 / 522 85 36

---

From: [email-masked]
Date: Fri, 11 Aug 95 13:06:52 +0200

From: [email-masked] (Martin Cracauer)

It's easy to modify clisp to be cltl2 on this point.
It's just a matter of deleting a few lines from compiler.lsp and eval.d

I don't have my sources here, so I can't send the exact patch.
If there will be still interest in this on the end of Aug. when I'll come
back from vacation, I'll post the patch. 

Bye,  Pierpaolo.