Subject: Using functions written in C in a LISP program

From: Neven Tomov <[email-masked]>
Date: Mon, 16 Oct 1995 13:00:45 +0100

Hello Everyone,

In my LISP program there are several functions that I would like to write in C
instead of LISP, in the hope that the overall program will run faster.

Could anyone tell me how to do this with clisp or tell me where to look for a
way of doing it?

Thanks for your help.

Neven Tomov,
Strathclyde University, Glasgow, Scotland

---

From: [email-masked] (David Crosson)
Date: Mon, 16 Oct 1995 17:35:13 +0300

>Strathclyde University, Glasgow, Scotland

Hi!
There's a version of clisp which can deal with foreign function, inside the
distribution
of this version, you'll be able to find some explanations, here a short sample:

File foreign.txt of clisp_with_ffi.tgz
        
                         The Foreign Function Call Facility
                         ==================================

        A foreign function description is written as a Lisp file,
        and when compiled it produces a .c file which is then compiled
        by the C compiler and may be linked together with lisp.a.

        All symbols relating to the foreign function interface are exported from
        the package FFI. To use them, (USE-PACKAGE "FFI").

        Special FFI forms may appear anywhere in the Lisp file.
(...)

Bye
----------------------------------------------------------
-- David P. CROSSON <[email-masked]>
-- Ingenieur informaticien et cogniticien
-- Actuellement: Cooperant au service national francais
--               Responsable informatique
--               BCLE - Ambassade de France en Israel
----------------------------------------------------------
-- Les hommes sont comme les animaux :
-- les gros mangent les petits, et les petits les piquent.
--                                     Voltaire, 1694-1778
----------------------------------------------------------