Subject: about clisp-1995-01-01

From: [email-masked] (Tomohiro Shibata)
Date: Sat, 11 Feb 95 02:43:45 JST

Hi there,

I finally got the newest Mr. Haible's version of clisp.
And I'd like to write down some memos now.

	1) I couldn't build it with gcc-2.6.3.
	   Below is the error message of the log.

cc -O -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-frame-pointer -O2 -c lisparit.c
In file included from lisparit.d:23:
arilev1.d:226: ari80386.c: No such file or directory
make: *** [lisparit.o] Error 1

	  Above all, I could build it with gcc-2.6.2.

	2) It seems not to be able to expand some macros correctly.
	   I can't state exact description of it here. PUSH form in
	   the macro was expanded unusual. The error log is

*** - EVAL: undefined function (SETF DBCLASS-RULES)
2. Break> where
EVAL frame for form ((SETF DBCLASS-RULES) #:G710 #:G711)

	**** If you've been studying A.I., you may know the book,
	**** Building Problem Solver. Above is the result of executing
        **** one of its functions, called shakedown-jtre described in
	**** the chapter 8.

Sincerely,
---------------------------------------------------------------------------
Tomohiro Shibata 	          |email  [email-masked]
Inoue-Inaba Laboratory,           |www    http://www.jsk.t.u-tokyo.ac.jp/~tom/
Department of Mechano informatics,|
University of Tokyo; Japan        |

---

From: haible (Bruno Haible)
Date: Mon, 13 Feb 95 13:11:48 +0100

> EVAL frame for form ((SETF DBCLASS-RULES) #:G710 #:G711)

For (SETF (DBCLASS-RULES ...) ...) to work, you must have a

   (DEFMACRO DBCLASS-RULES ...)

or

   (DEFSETF DBCLASS-RULES ...)

form in your code *before* the occurrence of the (SETF (DBCLASS-RULES ...) ...).

                    Bruno Haible
                    [email-masked]