Subject: New version of old CLISP

From: haible (Bruno Haible)
Date: Sun, 1 Jan 95 18:19:18 +0100

A new version of my current personal source of CLISP is at the usual place,
in ma2s2.mathematik.uni-karlsruhe.de:/pub/lisp/clisp/source-haible/.

Change log since 26 October 1994:

1 January 1995
==============

Important note
--------------

* Changed bytecode format. All .fas files generated by previous CLISP versions
  are invalid and must be recompiled.

User visible changes
--------------------

* The destination file of a compilation can be specified by a command line
  option.

* X3J13 vote <152> is implemented: REDUCE has a keyword argument :KEY.

* The printed representation of file streams of element type STRING-CHAR now
  contains a line number.

* Fixed a bug which caused the interpreter to signal an error when evaluating
  nested DEFUNs.

* Fixed a bug which could cause a crash when a GC occurred during single or
  double float subtraction.

Portability
-----------

* More support for Acorn ARM running RISCOS. Thanks to Peter Burwood.

* Fixed a problem in the readline library on non-POSIX BSD systems: Only LF
  was output instead of CR/LF.

* Updated support for EMX.

* The `configure' script now caches its results.

Other modifications
-------------------

* New memory model TRIVIALMAP_MEMORY which supports generational garbage
  collection in combination with the WIDE tagging scheme.

* Generational garbage collection now also works on NeXTstep and OSF/1 3.0.

* When a memory image is loaded, the terminal stream from the previous
  session is closed.

* Renamed `target' to `configure'.

* Added a manual page in HTML format.

* Miscellaneous documentation updates.

CLISP now compiles and runs on
* microcomputers:
  * DOS
  * OS/2 2.0
  * MS Windows 3.1
  * Amiga 500-4000, Amiga OS
  * Atari ST/TT, TOS
  * Acorn ARM Risc PC, RISC OS
* Unix workstations:
  * PC, Linux
  * PC, USL SVR4
  * DEC Alpha AXP, OSF/1
  * Sun4, SunOS 4 or 5
  * HP9000/800, HP-UX
  * NeXT, NeXTstep 3.1
  * PC, NeXTstep 3.2
  * SGI Mips, Irix 4 or 5
  * SNI Mips, USL SVR4
  * DECstation 5000, Ultrix 4.2
  * IBM RS/6000, AIX 3.2
  * M88000
  * Sun386, SunOS 4
  * Sun3, SunOS 4 (?)
  * HP9000/300, HP-UX or NetBSD
  * Apple MacII, A/UX (?)
  * Amiga 3000, Amiga Unix 2.1
  * Sequent PTX
  * PC, 386BSD or NetBSD or BSDI/386
  * PC, UnixWare
  * PC, SCO (?)
  * PC, Coherent 4.0
  * Convex, ConvexOS
  * Atari ST/TT, MiNT

Generational GC works on
  * PC, Linux
  * Sun4, SunOS 4 or 5
  * NeXT, NeXTstep 3.1
  * PC, NeXTstep 3.2
  * DEC Alpha AXP, OSF/1 3.0

New binaries have been rebuilt for DEC Alpha AXP running OSF/1 3.0.

                    Bruno Haible
                    [email-masked]

----- End Included Message -----

---

From: [email-masked] (Alexander Shendi)
Date: Sun, 1 Jan 1995 22:19:38 +0100 (MET)

> in ma2s2.mathematik.uni-karlsruhe.de:/pub/lisp/clisp/source-haible/.

Could you please explain, what the difference between this version of
CLISP and the "standard" source is?

Thanks,

Alex

---

From: evan johnson <[email-masked]>
Date: Sun, 1 Jan 1995 17:35:30 -0500 (EST)

I just started using OS/2, and I noticed that CLISP for OS/2 doesn't have 
the feature that is present in the DOS version wherein the cursor 
momentarily reverts to the matching open parenthesis when a close 
parenthesis is typed.  I found this to be very helpful; could it be added 
to the OS/2 version?