Subject: [Q] lisp-file-types definition

From: [email-masked] (Matthias Fischmann)
Date: Wed, 27 Sep 1995 17:26:32 +0100 (MET)

hi all,

	I have trouble with the following code. 

(defconstant lisp-file-types
  ;; Thanks to PCL for providing all this info
  #+(and Genera imach)                `("lisp" 		"ibin")
  #+(and Genera (not imach))          `("lisp" 		"bin")
  #+CLOE-Runtime		      `("l"		"fas")
  #+Minima			      `("lisp"		"mebin")
  #+(and dec common vax (not ultrix)) `("LSP"		"FAS")
  #+(and dec common vax ultrix)       `("lsp"		"fas")
  #+KCL                               `("lsp"		"o")
  #+xerox                             `(("lisp" "cl" ""),il:fasl.ext)
  #+(and lucid MC68000) `(("lisp" "cl")	,lcl:*load-binary-pathname-types*)
  #+(and lucid VMS) 	`(("lisp" "cl")	,lcl:*load-binary-pathname-types*)
  #+(and lucid SPARC) 	`(("lisp" "cl")	,lcl:*load-binary-pathname-types*)
  #+excl		`(("lisp" "cl")		,excl:*fasl-default-type*)
  #+ibcl                `(("lisp" "lsp")  "o")
  #+lispworks 		`("lisp"	,ccl::*binary-file-type*)
  #+prime               `("lisp"	"pbin")
  #+hp                  `("l"		"b")
  #+TI                  `("lisp"	"xfasl")
  #+ccl                 `("lisp"        "fasl")
  #+cmu		     `("lisp" ,(c:backend-fasl-file-type c:*target-backend*)))

	clisp's opinion is that.

*** - The macro DEFCONSTANT may not be called with 1 arguments

	I am running clisp on a sunsparc 2 with sun4os. Compi-
lation with Allegro Common Lisp has led to different errors,
this system seems to be content with the above lines.

	Has anybody any hints what lisp-file-types should
look like? Or which line is the best for me and what #+ words
I have to change to make it work?

	Thanx in advance!			Matthias

-- 
Matthias Fischmann  Bismarckstr.6  66111 Saarbruecken  Germany
phone +49 (681) 37392/4  fax +49 (681) 37392/5  dfki +49 (681) 302-5302 
email: [email-masked]
*** pgp public key available on request ***

---

From: Marcus Daniels <[email-masked]>
Date: Thu, 28 Sep 1995 06:03:29 GMT

>>>>> "Matthias" == Matthias Fischmann <[email-masked]> writes:

Matthias> *** - The macro DEFCONSTANT may not be called with 1 arguments

Add a line for CLISP, like:

        [others]
        #+clisp `("lsp" "fas")
        )

---

From: Randy Calistri-Yeh <[email-masked]>
Date: Thu, 28 Sep 1995 10:22:03 -0400 (EDT)

> (defconstant lisp-file-types
[... snip]

This looks like it was taken from the UC defsystem package.  Here's my 
version, which seems to be very happy with CLISP:

(defconstant lisp-file-types
  #+(and clisp dos) '(("LSP" "LIS") "FAS")
  #+(and clisp (not dos)) '(("lsp" "lisp") "fas")
  ;; Thanks to PCL for providing all this info
  #+(and Genera imach)             '("lisp" 		"ibin")
  #+(and Genera (not imach))       '("lisp" 		"bin")
  #+CLOE-Runtime		   '("l"		"fas")
  #+(and dec common vax (not ultrix)) '("LSP"		"FAS")
  #+(and dec common vax ultrix)       '("lsp"		"fas")
  #+KCL                               '("lsp"		"o")
  #+xerox                             '(("lisp" "cl" "")"dfasl")
  #+(and lucid MC68000)		      '(("lisp" "cl")	"lbin")
  #+(and lucid VMS)		      '(("lisp" "cl")	"vbin")
  #+(and lucid SPARC)		      '(("lisp" "cl")	"sbin")
  #+ALLEGRO                           '(("lisp" "cl")	"fasl")
  #+MCL                                '(""             "fasl")
  #+ibcl                              '(("lisp" "lsp")  "o")
  #+lispworks                         '("lisp"          "wfasl")
 ; #+system::cmu                       '("slisp"		"sfasl")
  #+prime                             '("lisp"		"pbin")
  #+hp                                '("l"		"b")
  #+TI                                '("lisp"		"xfasl"))

I also have the necessary externalize-directory and internalize-directory 
functions if anyone is interested.

____________________________________________________________________________
                        ==> Randy Calistri-Yeh <==
Manager, AI Group		             email: [email-masked]
Odyssey Research Associates                  http://www.oracorp.com/ai/randy
301 Dates Dr.                                tel: (607) 277-2020
Ithaca, NY 14850-1326                        fax: (607) 277-3206
____________________________________________________________________________