Subject: compiler interaction with inline.

From: [email-masked] (Dan Stanger)
Date: Thu, 9 Nov 1995 11:56:08 -0700

how can i insure that functions generated by defstruct get
expanded inline.
thanks,
dan stanger

---

From: [email-masked] (Bruno Haible)
Date: Fri, 10 Nov 95 12:02:12 +0100

> how can i insure that functions generated by defstruct get

In Common Lisp in general, you can't, because the compiler is not required
to pay attention to (PROCLAIM (INLINE ...)) at all.

In CLISP, just compile the file containing the defstruct. And make sure
that you have loaded this file when you compile other files which make
use of the defstruct accessors.

Bruno Haible                                     email: <[email-masked]>
Software Engineer                                phone: +33-1-49083585