Subject: CLisp and EMACS

From: Pascal POIZAT - DEA Info <[email-masked]>
Date: Mon, 9 Jan 1995 08:20:31 +0100

I tried to use CLISP with GNU-EMACS doing:
- M-x run-lisp
-> lisp, command not found
- I edited this file:
   run LISP:lisp.run -M LISP:lispinit.mem
   named it clisp, put it in C: (I've got an Amiga, it's the equivalent of
   Unix's /bin), and did protect C:clisp +s (make it executable as a script).
 I did : (setq inferior-lisp-program "clisp")
 and M-x run-lisp
-> EXECUTE, PROGDIR:clisp command not found.
 (the OS uses the command EXECUTE to launch scripts)
I think I should use a clisp.el specially dedicated to use CLISP (besides that,
 run-lisp works if I use CLISP without argument -M).

Q1: where can I find a clisp.el NOT DEDICATED TO ANY SPECIAL OS but generic for
 every system/directory tree ? The one in mailing-list-archive-1993 works even
 on a configuration (i.e. directories) different from the one described ?

Q2: I know EMACS uses inferior-lisp-program for the path of the program he uses
 when one types in M-x run-lisp. Is there some kind of inferior-lisp-arguments to
 specify the arguments of the command ?

Q3: When will the next version of CLISP will be released on Amiga ?

Bye

Pascal

Pascal Poizat
DEA Informatique, Nantes, France
>> applying rewriting systems to object specifications (ideas ?) <<
[email-masked]

---

From: [email-masked] (Joerg-Cyril Hoehle)
Date: Tue, 10 Jan 95 13:46:35 +0100

Pascal POIZAT wrote:
(on an Amiga)
> I tried to use CLISP with GNU-EMACS doing:
I'd recommend using the cmulisp+comint.el package from Olin Shivers
(it's now the standard shell of EMACS 19). cmulisp.el does good
argument separating and passing and with it, I've been able to start
clisp in an inferior lisp buffer. The problem with the original
shell.el and M-x run-lisp is the passing of arguments, and you really
want to start clisp with a -M foo.mem argument. I'll send part of my
.emacs when I'll get back home.

> Q1: where can I find a clisp.el NOT DEDICATED TO ANY SPECIAL OS but generic for
what do you mean by clisp.el?

>  specify the arguments of the command ?
No, but cmulisp.el+comint.el solves this problem, using another variable.

> Q3: When will the next version of CLISP will be released on Amiga ?
When I'll have a somewhat usable FFI. That's what's missing.

	Joerg Hoehle.