Subject: problems compiling clisp on rs6000

From: [email-masked] (Dan Stanger)
Date: Tue, 9 May 1995 16:39:03 -0600

when i compiled foreign on the rs i got the following error.
        gcc -Dunix -O -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-frame-pointer -O2 -DDYNAMIC_FFI -DNO_SINGLEMAP -DNO_MULTIMAP_SHM -Iavcall -Ivacall -Itrampoline -c foreign.c
In file included from /usr/local/gcc/lib/gcc-lib/rs6000-ibm-aix3.2.5/2.6.3/include/time.h:27,
                 from unix.d:636,
                 from lispbibl.d:1553,
                 from foreign.d:5:
/usr/local/gcc/lib/gcc-lib/rs6000-ibm-aix3.2.5/2.6.3/include/stddef.h:273: warning: `offsetof' redefined
lispbibl.d:911: warning: this is the location of the previous definition
foreign.d: In function `foreign_layout':
foreign.d:602: `sint64' undeclared (first use this function)
foreign.d:602: (Each undeclared identifier is reported only once
foreign.d:602: for each function it appears in.)
foreign.d:602: parse error before `sint64'
foreign.d:602: warning: no semicolon at end of struct or union
foreign.d:603: `uint64' undeclared (first use this function)
foreign.d:607: parse error before `uint64'
foreign.d:607: warning: no semicolon at end of struct or union
foreign.d: In function `convert_from_foreign':
foreign.d:812: parse error before `val'
foreign.d:814: `val' undeclared (first use this function)
foreign.d:814: called object is not a function
foreign.d:814: called object is not a function
foreign.d:822: parse error before `val'
foreign.d:824: called object is not a function
foreign.d:824: called object is not a function
foreign.d: In function `convert_to_foreign':
foreign.d:1671: parse error before `val'
foreign.d:1673: `val' undeclared (first use this function)
foreign.d:1682: parse error before `val'
The error code from the last failed command is 1.

can anybody give me a suggestion about this problem?
thanks,
dan stanger

---

From: haible (Bruno Haible)
Date: Wed, 10 May 95 19:20:51 +0200

> foreign.d:602: `sint64' undeclared (first use this function)

Oops. To fix this, put
    #ifdef HAVE_LONGLONG
    ...
    #endif
wrappers around each piece of code in foreign.d which references a `sint64'
or `unit64' type.

            Bruno