Subject: how do i find the type of a clos slot?

From: [email-masked] (Dan Stanger)
Date: Tue, 7 Feb 1995 16:56:03 -0700

i need to know the type specified in the key word :type if any.
thanks,
dan stanger

---

From: haible (Bruno Haible)
Date: Wed, 8 Feb 95 16:57:06 +0100

Dan Stanger <[email-masked]> said:
> how do i find the type of a clos slot?

CLISP's CLOS doesn't save the type specified for a slot. Treat it as if
it were the type T.

You would need to redefine ENSURE-CLASS to save the type somewhere. On your
own risk.

                    Bruno Haible
                    [email-masked]