Subject: Re: CLISP is slow/ LANGUAGE

From: Pascal POIZAT - DEA Info <[email-masked]>
Date: Tue, 31 Jan 1995 17:26:08 +0100

Stop firing .... I'm dead ! :)

Hello once again.
Well I was sure that if I complained about CLisp here I'd receive "some" mails ...
Well I explain some things:

- I *i.e. myself with my 28Mhz Amiga* don't think Clisp is TOO slow.
     It is just perfect for my use, and I developped my MSc project with it
      last year with it.
- I just noticed the current version was slower than the one I had 1 or 2 years ago.

- Note: I really asked this question not for me but for someone else.
  (I agree it sounded like the little boy that telephones to Dr. Ruth (sex on radio)
   to ask - for one of his friend - a stupid question he fears asking for himself :)
   The problem is this: the man responsible for the work I do in the laboratory
   has a friend (another teacher) who needed a lisp. I told him CLIP was the best one I
   knew (cost nothing, easy to install, easy to use, mailing-list and support, ...)
   He eventually got it (he bought a PC).
   Then I had some kind of feed-back about it recently saying he thought CLisp was quite
   slow. SO (since I am really a good old chap :) i said I could ask the question to all
   of you (he doestn't have INTERNET access).

I'd like to thank everybody who answered me (and all the good jokes I read :) and I'll see
if I can have some more details about
	- his machine
	- his operating system
	- the way he installed it
	- the way he USES it !
	- what does he means by "SLOW"
Then I'll mail it back here.

Well, I think all this deserves some reward .... let's go.... another question to feed the 
CLisp ML Members :)  :
I change the language by doing
(setq *language* 'FRANCAIS)
If I do it after opening a CLISP session, I still have error messages in English.

Well, another one (more serious):
I currently work on applying rewriting techniques (conditional rewriting systems) to
the formal specifications in object languages (a model called Formal Classes). I use
CLOS for it.
I'll be very interrested in knowing the last results about MOP (Meta Object Protocol) in CLOS.
Will the standardization keep it as in Kickzales articles ? Will it follow the ObjVLisp model
of P.Cointe ? Sorry for all this technic stuff but if you could reply me with a technical
answer I'll be pleased (i.e. a pointer to some recent article describing the MOP).

Pascal
[email-masked]
(sorry, no signature today :)

---

From: [email-masked] (Joerg-Cyril Hoehle)
Date: Tue, 31 Jan 95 20:07:51 +0100

> - I just noticed the current version was slower than the one I had 1 or 2 years ago.
Granted. Somebody knows why?

 > (setq *language* 'FRANCAIS)
This is not the correct way of doing things
You must do it at start, with lisp.run -M lispinit.mem -L francais
(we'll implement -L fran<c-cedille>ais to the next version).

In fact, only a few things could be changed (initialization of UNIX
(and others) error messages, and CLISP could even switch languages
during run-time, but it's not possible now.

BTW, tell me about suggestions/errors for FRANCAIS, because it's not
been used to often for now.
 	Joerg Hoehle.
[email-masked]