Subject: Compiling error

From: Ricardo Aler Mur <[email-masked]>
Date: Tue, 10 Feb 1998 11:40:22 +0100 (CET)

Hi all,

I am trying to compile clisp-1997-09-25 in an Exemplar S Class () [SPP-UX
Release 5.2] (a parallel HP machine). I get this error: 

In file included from debug.d:5:
lispbibl.d:8906: warning: register used for two global register variables
lispbibl.d:8914: warning: register used for two global register variables
lispbibl.d:9077: warning: register used for two global register variables
debug.d: In function `print_stackitem':
debug.d:1010: structure has no member named
`showstack_string_CALLBACK_frame'
*** Error exit code 1

Help :)

Ricardo.
--------
mailto: "Ricardo Aler Mur" <[email-masked]>
http://grial.uc3m.es/~aler

---

From: Bruno Haible <[email-masked]>
Date: Tue, 10 Feb 1998 13:05:57 +0100 (MET)

> `showstack_string_CALLBACK_frame'

A small bug. In constobj.d, change the line 1047 from
  #ifdef HAVE_SAVED_STACK
to
  #ifdef HAVE_SAVED_REGISTERS

Bruno

---

From: Ricardo Aler Mur <[email-masked]>
Date: Tue, 10 Feb 1998 13:52:28 +0100 (CET)

>   #ifdef HAVE_SAVED_REGISTERS

Now it compiles fine, although it doesn't pass one of the tests in the
test suite:

cat suite/number2.erg

Form: (ISQRT 77371252437321868671713407)
SOLL: 8796093021183
CLISP: 8796093022207

Ricardo.
--------

---

From: Bruno Haible <[email-masked]>
Date: Wed, 18 Feb 1998 19:13:07 +0100 (MET)

> Form: (ISQRT 77371252437321868671713407)

We found out that changing the expression  (__GNUC_MINOR__ == 7)
in intsqrt.d to  (__GNUC_MINOR__ <= 7)  fixed the problem.

Bruno