Subject: clisp question

From: Jae-Youn Chung <[email-masked]>
Date: 19 Aug 1998 01:03:33 +0900

Hello clisp users,
About a weeks ago, I downloaded the clisp and became the happy user of
clisp. But I've got a few problems:

in cmulisp:
* #2a((1) (2) (3))

#2A((1) (2) (3))

this kind of sharp quote notation works fine.

in clisp:
>  #2a((1) (2) (3))

*** - EVAL: illegal form #2A((1) (2) (3))
1. Break> 

Why?

And one more question.
I can't make regexp library to work with current clisp.
Has anybody compiled the clispsrc-egexp.tar.gz?
Thanks in advance.

-jay

-- 
Chung jay youn
mailto:[email-masked]
http://pllab.kaist.ac.kr/~jay

---

From: Sam Steingold <[email-masked]>
Date: 18 Aug 1998 13:55:12 -0400

>>>> In message <[email-masked]>
>>>> Sent on Tue, 18 Aug 1998 08:59:04 -0700 (PDT)
>>>> Honorable Jae-Youn Chung <[email-masked]> writes
>>>> on the subject of "clisp question":
 >> Hello clisp users,

CLISP starts in USER package.

> '#2a((1) (2) (3))
#2A((1) (2) (3))
> (in-package :cl-user)
#<PACKAGE COMMON-LISP-USER>
[COMMON-LISP-USER]> #2a((1) (2) (3))
#2A((1) (2) (3))
[COMMON-LISP-USER]> 

you can make CLISP start in CL-USER:

$ clisp -p CL-USER
> *package*
#<PACKAGE COMMON-LISP-USER>
#2A((1) (2) (3))

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.1 GNU/Linux
Micros**t is not the answer. Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
If brute force does not work, you are not using enough.