Subject: Re: $ sign in path not recognized

From: [email-masked]
Date: Wed, 02 Sep 1998 10:35:48 EDT

I agree with Don that CLISP should not get into OS dependant functions.

Don Cohen wrote...
> I don't know exactly what the dos file system allows.
> I believe that in unix a file name can contain any character other
> than / (forward slash).
>
> I don't think clisp should address this issue at all.  If the file
> system functions give you an error when you try to create a file with
> a strange name then clisp should give you an error, and otherwise it
> should do whatever the system does.

Anyway, if CLISP has to limit the characters which are valid in a file name,
here is a list of them for DOS:

>Can you please give me the complete list of characters which should be
>allowed in DOS file name parts?
>
>  a...z A...Z            yes
>  0...9                  yes
>  - _                    yes
>  : / \ .                these have special meaning for the pathname syntax
>  %                      no, used for delimiting environment variables
>  ;                      no, used for delimiting pathnames in pathname lists
>
All these are correct.

> What about #\Space and !"#$&'()*+,<=>?@[]^`{|}~ ?
Of these last ones:

   The ones my DOS version found valid are: !#$&'()?@^`{}~?
   The invalid ones are: Space and "*+,<=>[]|
Leo

---

From: Joerg Hoehle <[email-masked]>
Date: Thu, 3 Sep 1998 17:14:52 +0200

> From [email-masked] Wed Sep  2 16:42 MET 1998
> >Received: from mail.gmd.de (postix) by zeus.gmd.de with SMTP id AA26629
>   (5.67b8/IDA-1.5 for <[email-masked]>); Wed, 2 Sep 1998 16:42:51 +0200
> Date: Wed, 2 Sep 1998 07:28:25 -0700 (PDT)
> Reply-To: [email-masked]
> Originator: [email-masked]
> Sender: [email-masked]
> From: [email-masked]
> To: Multiple recipients of list <[email-masked]>
> Subject: Re: $ sign in path not recognized
> X-Listprocessor-Version: 6.0 -- ListProcessor by Anastasios Kotsikonas
> X-Charset: LATIN1
> X-Char-Esc: 29
> Content-Type: text
> Content-Length: 1240
>

---

From: Joerg Hoehle <[email-masked]>
Date: Thu, 3 Sep 1998 17:19:50 +0200

[sorry for previous email, tty command line / ed / operator braindamage]

>    The invalid ones are: Space and "*+,<=>[]|

Looks a lot like command.com (i.e. shell syntax) restrictions.  Did
you try these by compiling a C program that directly calls
open("\"*+,<=>[]|","w") instead of copy config.sys *+,...| ?

	Jorg.