Subject: Re: latest version of CLISP

From: Don Cohen <[email-masked]>
Date: Mon, 26 Oct 1998 23:19:18 -0800

Latest clisp in linux has been giving me some problems.
Anyone have any ideas where to even start looking?
These are not trivially reproducible, which leads me to suspect GC.
Or maybe hardware.  (This machine is pretty flakey, but linux hasn't suffered
any obvious problems through all of this, so probably that's not it.)

(lisp-implementation-version)
"1998-08-29 (August 1998)"
================
*** - handle_fault error2 ! address = 0x8EFB43C not in [0x20194000,0x202DDA8C) !
SIGSEGV cannot be cured. Fault address = 0x8EFB43C.
Segmentation fault (core dumped)
================
*** - handle_fault error2 ! address = 0x2003BB18 not in [0x20194000,0x202930EC) !
SIGSEGV cannot be cured. Fault address = 0x2003BB18.
Segmentation fault (core dumped)
================
*** - handle_fault error2 ! address = 0x5 not in [0x20194000,0x20293690) !
SIGSEGV cannot be cured. Fault address = 0x5.
Segmentation fault (core dumped)
================
*** - handle_fault error2 ! address = 0x20F05D5C not in [0x20194000,0x20363AA8) !
SIGSEGV cannot be cured. Fault address = 0x20F05D5C.
Segmentation fault (core dumped)
================

---

From: Bruno Haible <[email-masked]>
Date: Wed, 28 Oct 1998 18:06:32 +0100 (MET)

> Anyone have any ideas where to even start looking?

The first thing to check is whether your shared libraries match the ones
the binaries were built with. Newer shared libraries usually work; older
ones sometimes don't. Here is the list of libraries Sam and I used to build
the binaries:

  i386-linux-libc5:
    base binary:
      libc.so.5.4.46
      libm.so.5.0.9
      libdl.so.1.9.9
      libncurses.so.3.0.980228
    full binary: same, plus
      libX11.so.6.1
      libXext.so.6.3
      libXpm.so.4.10

  i386-linux-libc6:
    base binary:
      libc.so.6 -> libc-2.0.7.so
      libdl.so.2 -> libdl-2.0.7.so 
      libtermcap.so.2.0.8
    full binary: same, plus
      libX11.so.6.1
      libXext.so.6.3
      libXpm.so.4.10

> Or maybe hardware.

If you can experience the same crash when running the same program with
the same input under the same circumstances (and it doesn't use random
or interactive input), then it's likely to be a problem with CLISP, maybe
GC. If you can't reproduce it, my guess it hardware problems, or an unstable
kernel version.

Bruno