Subject: Re: Confused by #() in clisp

From: "Zbyszek Jurkiewicz" <[email-masked]>
Date: Fri, 20 Nov 98 10:19:05 CST

On Fri, 20 Nov 1998 00:13:43 -0800 (PS, Dave Pearson wrote:

>First off I'll say that the following may simply be down to my lack of
>understanding of lisp, I dabble, that's all.
>
>I wonder if someone can explain why the following doesn't work with clisp?
>Correct me if I'm wrong but it is possible to "hard code" an array by doing
>something along the lines of:
>
>  (setq a #(1 2 3 4))
>
>and, if I do this in ACL or Corman Lisp it works fine. However, in clisp I
>get:
>
>> (setq a #(1 2 3 4))
>
>*** - EVAL: illegal form #(1 2 3 4)
>1. Break> 
>
>Is there are simple reason for this or am I missing something obvious? The
>version of clisp I'm running is:
>
>> (lisp-implementation-version )
>"1998-09-09 (September 1998)"

Simply use

> (setq a '#(1 2 3 4))
#(1 2 3 4)

In Clisp array constants must be quoted.

Regards

Zbyszek Jurkiewicz
University of Warsaw

---

From: Dave Pearson <[email-masked]>
Date: Fri, 20 Nov 1998 11:04:31 +0000

> >*** - EVAL: illegal form #(1 2 3 4)

Thanks, I notice that this works in ACL too. Is there any reason for this
difference?

-- 
Take a look in Hagbard's World: |   w3ng - The WWW Norton Guide reader.
http://www.acemake.com/hagbard/ |     eg - Norton Guide reader for Linux.
http://www.hagbard.demon.co.uk/ |    weg - Norton Guide reader for Windows.
Free software, including........| dgscan - DGROUP scanner for Clipper.