Subject: CLISP 1999.01.08 RPM aborts at startup under Red Hat Linux 5.2

From: [email-masked] (Paolo Amoroso)
Date: Sun, 21 Feb 1999 16:33:04 GMT

I've installed the RPM binaries of CLISP 1999.01.08 for i386 Linux with
libc6--i.e. file clisp-1999.01.08-2.i386.rpm--on my Red Hat Linux 5.2
system. By the way, glint complained about a missing group (I think it was
"src") for most files and used group root instead.

When I start CLISP, it immediately aborts execution and displays the
following message:

/usr/lib/clisp/lisp.run: error in loading shared libraries
: undefined symbol: __register_frame_info

Any suggestions?

Paolo
-- 
Paolo Amoroso <[email-masked]>

---

From: Sam Steingold <[email-masked]>
Date: 21 Feb 1999 14:25:00 -0500

>>>> In message <[email-masked]>
>>>> On the subject of "CLISP 1999.01.08 RPM aborts at startup under Red Hat Linux 5.2"
>>>> Sent on Sun, 21 Feb 1999 08:41:46 -0800 (PST)
>>>> Honorable [email-masked] (Paolo Amoroso) writes:

hmmm - I'll look at this.
Thanks.

 >> : undefined symbol: __register_frame_info

The RPMs are built with glibc2.1.
you will need to upgrade to the newest rawhide.

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Man has 2 states: hungry/angry and sate/sleepy.  Catch him in transition.

---

From: Bruno Haible <[email-masked]>
Date: Mon, 22 Feb 1999 12:09:41 +0100 (MET)

[Message forwarded from <[email-masked]>.]

-------------------------------------------------------------------------------
this has already been discussed on the list:

1: rebuild from sources

or

2: upgrade your glibc

either will fix the problem.

> Date: Sun, 21 Feb 1999 08:51:54 -0800 (PST)
> Reply-To: [email-masked]
> Originator: [email-masked]
> Sender: [email-masked]
> Precedence: bulk
> From: [email-masked] (Paolo Amoroso)
>