Subject: Q: Foreign Function Call Facility

From: Oliver Niggemann <[email-masked]>
Date: Mon, 01 Feb 1999 17:38:25 +0100

Hi,

I recently started to use CLISP (Version 8.1.1999 and 9.9.1998)
under Windows NT 4.0 and Windows 95 and
(besides from being impressed) I ended up with some questions:

I tried to use DDE using the Foreign Function Call Facility
(for some domain depending reasons I can't use sockets),
but as far as I understood I have to recompile CLISP in order to achieve
this
(Is this correct?).
I encountered some problems when compiling CLISP (using VC++ 6.0),
I seem to need some UNIX tools (e.g. uniq)?
What system and further tools did you use to compile CLISP?
Is there any way to use a dll directly?

Thanks for any help,

    Oliver Niggemann

---

From: Bruno Haible <[email-masked]>
Date: Mon, 1 Feb 1999 18:10:14 +0100 (MET)

> but as far as I understood I have to recompile CLISP in order to achieve

Yes, this is correct.

On Unix, the binary packages also contain clisp as a static library (lisp.a),
which can be used by a shell script (clisp-link) to create new executables.
This doesn't work on Wind0ws, however, because there is no /bin/sh on these
systems.

> Is there any way to use a dll directly?

The dynamic loading package from Eric Marsden [1] might be useful for
you.

> What system and further tools did you use to compile CLISP?

The makefile.msvc5 works for VC++ 6.0 as well. I use a commercial package
called MKS tools; probably you can use Cygwin20.1 instead. It contains most
of the Unix tools.

                         Bruno

[1] http://www.chez.com/emarsden/downloads/index.html

---

From: Oliver Niggemann <[email-masked]>
Date: Tue, 02 Feb 1999 09:30:54 +0100

> This doesn't work on Wind0ws, however, because there is no /bin/sh on these

If there exists a lisp.a under UNIX, would it be possible (or has it already been
done)to put CLISP into a Windows DLL? I personally know several people who
would be quite happy to use CLISP as an algorithmic backend ...

Thanks for any help,
    Oliver Niggemann

--
Oliver Niggemann
University of Paderborn
Germany
Room No. E4.164
Tel.: +49 5251 603345
EMail: [email-masked]