Subject: Is clisp available for Linux m68k?

From: Kevin Dalley <[email-masked]>
Date: 05 Feb 1999 00:15:02 -0800

Does anyone have a version of clisp for an m68k Linux.  Here is a bug
report from Roman Hodek <[email-masked]>, a
Debian Linux user.

I just tried to recompile clisp for m68k, but there were some build
errors :-(

make[1]: Entering directory `/usr/local/build/buildd/clisp-1997-12-06/src/avcall'
gcc -O -c ../../ffcall/avcall/avcall-m68k.s
../../ffcall/avcall/avcall-m68k.s: Assembler messages:
../../ffcall/avcall/avcall-m68k.s:8: Error: parse error -- statement `moveml #0x3020,sp@-' ignored
../../ffcall/avcall/avcall-m68k.s:9: Error: parse error -- statement `movel sp@(16),a2' ignored
../../ffcall/avcall/avcall-m68k.s:11: Error: operands mismatch -- statement `moveq #-32,d0' ignored
../../ffcall/avcall/avcall-m68k.s:12: Error: parse error -- statement `addl a2@(20),d0' ignored
../../ffcall/avcall/avcall-m68k.s:13: Error: operands mismatch -- statement `subl a2,d0' ignored
../../ffcall/avcall/avcall-m68k.s:14: Error: operands mismatch -- statement `asrl #2,d0' ignored
[...]

The file ffcall/avcall/avcall-m68k.s uses an old m68k assembler syntax
which isn't used anymore since a.out times... :-) Current assemblers
require a '%' prefix before register names.

In the current state, the package is uncompilable on m68k due to this.

--
Kevin Dalley
[email-masked]

---

From: Bruno Haible <[email-masked]>
Date: Fri, 19 Feb 1999 01:59:09 +0100 (MET)

> report from Roman Hodek <[email-masked]>, a

With the help of Roman and debian.org, I ported the ffcall package,
contained in clisp, to m68k-linux [1]. You should be able to replace
clisp's ffcall subdirectory with that one.

         Bruno

[1] ftp://ftp.santafe.edu/pub/gnu/ffcall-1.5.tar.gz