Subject: Require and CLOS

From: <[email-masked]>
Date: Fri, 26 Mar 1999 12:20:47 -0600 (CST)

Hello all, I am playing with CLISP on SCO and attempting
  to use CLOS. When I first start CLISP, CLOS is not loaded
  so I have a (require 'clos) at the top of my code. Is this
  not the proper way to do this? I get:

;; Loading file ele.lsp ...
;; Loading file /usr/local/lib/lisp/src/clos.lsp ...
** - Continuable Error
Redefining the COMMON LISP macro WITH-SLOTS
If you continue (by typing 'continue'): The old definition will be lost
1. Break>

  Thank you for your thoughts on this.

  -Dave

---

From: Sam Steingold <[email-masked]>
Date: 26 Mar 1999 14:15:06 -0500

>>>> In message <[email-masked]>
>>>> On the subject of "Require and CLOS"
>>>> Sent on Fri, 26 Mar 1999 10:24:20 -0800 (PST)
>>>> Honorable <[email-masked]> writes:

where did you get clisp?
what is the version (clisp --version)?
the current version of clisp has clos in it by default:

$ clisp -q

[1]> (defclass z () (a b c))
#<STANDARD-CLASS Z>
[2]> (describe (make-instance 'z))

Description of
#<Z #x2023EBE1>
This is an instance of the CLOS class #<STANDARD-CLASS Z>.
Slots:
  A  unbound
  B  unbound
  C  unbound

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
An elephant is a mouse with an operating system.

---

From: <[email-masked]>
Date: Fri, 26 Mar 1999 13:48:54 -0600 (CST)

>>>> Sam Steingold <[email-masked]> writes:

> where did you get clisp?

    Hmm. Good question. Is has been some months since I picked
    up this version (for SCO) and I don't recall where from.

> what is the version (clisp --version)?

    CLISP 1995-04-04 (April 1995)

    A bit old...

> [1]> (defclass z () (a b c))
<snip>

    And I get:

    $ clisp -q

    > (defclass z () (a b c))

    *** - EVAL: undefined function DEFCLASS
    1. Break> *features*
    (CLOS LOOP COMPILER CLISP CLTL1 COMMON-LISP INTERPRETER CLISP3
    LOGICAL-PATHNAMES UNIX)
    1. Break> *modules* 
    NIL

    Perhaps this package is badly damaged and I should dump it.
    Anyone have the current version of CLISP compiled for SCO.

    -Dave

---

From: Sam Steingold <[email-masked]>
Date: 26 Mar 1999 14:57:53 -0500

>>>> In message <[email-masked]>
>>>> On the subject of "Re: Require and CLOS"
>>>> Sent on Fri, 26 Mar 1999 13:48:54 -0600 (CST)

almost 4 years old.

please look at ftp://clisp.cons.org/pub/lisp/clisp

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Our business is run on trust.  We trust you will pay in advance.

---

From: Bjorn Remseth <[email-masked]>
Date: Sat, 27 Mar 1999 17:59:00 +0100

> please look at ftp://clisp.cons.org/pub/lisp/clisp

The most current file is always named ".../source/clispsrc.tar.gz".   This
is a really bad idea, since it makes it difficult to refer to a specific
uniquely to a specific snapshot. When making a FreeBSD port (or any other
installation system system using a specific release, fetched from an URL),
it may break whenever a new release is made. Not good.   

If instead the release snapshot was given an unique name, for instance
"clispsrc-1999-09-22.tar.gz", this problem should disappear.  The
"clispsrc.tar.gz" target may still exist, but should be updated to
point to the most current release.  

Bruno, is this something which is simple to do? I would start using it
almost immediately in our internal FreeBSD port (which then may be published
in the FreeBSD ports collection, something we can't do now since the port is
using our our internal (but uniquely named :) snapshot copy of clisp as an
authorative source.)

							(Rmz)