Subject: help!: installing CLISP

From: "john a. maurer iv" <[email-masked]>
Date: Sat, 10 Apr 1999 20:11:54 -0700 (PDT)

hello,

i am new at this downloading thing. I finally learned how
to "unzip" the "clisp-win32.zip" file I downloaded from the
web for my Windows 95 desktop. However, i press on the
LISP application file that is created and I get an error
message after the LISP application window opens saying
the following:

"This program has performed an illegal operation and
will be shut down." Details>>
"LISP caused an invalid page fault in module LISP.EXE, etc.
[lots of numbers and jargon follows]"

I didn't do anything to explicitly "install" LISP other
than unzipping the .zip file: i don't know what "installing"
really means or entails. Can anybody help me get CLisp
running? I'd really appreciate it!        

John

---

From: Sam Steingold <[email-masked]>
Date: 11 Apr 1999 13:59:28 -0400

>>>> In message <[email-masked]>
>>>> On the subject of "help!: installing CLISP"
>>>> Sent on Sat, 10 Apr 1999 20:15:14 -0700 (PDT)
>>>> Honorable "john a. maurer iv" <[email-masked]> writes:
 >> 
 >> i am new at this downloading thing. I finally learned how to "unzip"
 >> the "clisp-win32.zip" file I downloaded from the web for my Windows

Please mention where you downloaded CLISP from.  The exact URL.
The date on the file would help too.

 >> 95 desktop. However, i press on the LISP application file that is
 >> created and I get an error message after the LISP application window
 >> opens saying the following:

You should click on clisp.bat, not clisp.exe.
Or just create a shortcut to the following command:

c:\clisp\lisp.exe -M c:\clisp\lispinit.mem

[replace "c:\clisp" with the full path to the place you installed CLISP
in.]

 >> "This program has performed an illegal operation and will be shut
 >> down." Details>> "LISP caused an invalid page fault in module
 >> LISP.EXE, etc.  [lots of numbers and jargon follows]"

you will have to send all the jargon here, up to the last digit.

 >> running? I'd really appreciate it!

The best advice I can give you is to put Linux on your desktop. :-)

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Flying is not dangerous; crashing is dangerous.

---

From: "john a. maurer iv" <[email-masked]>
Date: Mon, 12 Apr 1999 23:12:55 -0700 (PDT)

Dear Mr. Steingold,

thank you for helping me try to install CLISP. the full jargon from the
error i get when i click on the "lisp" application file follows:

"LISP caused an invalid page fault in
module LISP.EXE at 014f:004014b9.
Registers:
EAX=00b41000 CS=014f EIP=004014b9 EFLGS=00010287
EBX=00b41000 SS=0157 ESP=0074d51c EBP=00aa006c
ECX=00000008 DS=0157 ESI=00ad88fc FS=10a7
EDX=00b50138 ES=0157 EDI=00b40068 GS=0000
Bytes at CS:EIP:
8b 40 04 0f be c8 49 83 f9 08 77 14 ff 24 8d 49 
Stack dump:
00402400 00b41000 0074d930 0074d7f8 00000004 00b50110 0040183e 00b50110
0000003c 00000000 004d08cc 00000000 00000000 00000000 00000000 00000000 "

any help?

i got this version of clisp on April 9th. The date on the "lisp" 
application file is 1/20/99, and i got it from
" ftp://ftp2.cons.org/pub/lisp/clisp/binaries/ ". I tried 
double clicking on the "lispinit" but it only tries to open
itself as a text file??? And i failed to complete the DOS
command, even with the right path name... i'm afraid i'm a
DOS novice... if there's a better way around things that'd
be great. i do work on Linux on campus, but i hesitate to
try putting a new platform on my friends desktop at home: that is
where i'm trying to get Lisp up and running for programs
i am trying to write. If you can be of any further help, i
would really appreciate your kindness. Maybe i just need to
try downloading it again??? Anyway, thank you.

John

---

From: Sam Steingold <[email-masked]>
Date: 13 Apr 1999 09:16:28 -0400

please try running CLISP like this:

c:\clisp\lisp.exe -M c:\clisp\lispinit.mem -m 10MB

sometimes this helps.  if you try c:\clisp\lisp.exe -h you will learn
that -m pre-allocates memory.

you might also want to put this line in a clisp.bat file.

>>>> In message <[email-masked]>
>>>> On the subject of "Re: help!: installing CLISP"
>>>> Sent on Mon, 12 Apr 1999 23:15:54 -0700 (PDT)

 ftp://ftp2.cons.org/pub/lisp/clisp/binaries/dos/
or
 ftp://ftp2.cons.org/pub/lisp/clisp/binaries/win32/
?

Please note that the `win32' binary would probably not work when started
from the console (it *is* a console app, but it has to opes its console
itself).  I think...

 >> itself as a text file??? And i failed to complete the DOS

I usually associate the following with a *.mem extension:

c:\clisp\lisp.exe -m10MB -M %s

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Warning! Dates in calendar are closer than they appear!

---

From: Charles Blair <[email-masked]>
Date: Tue, 13 Apr 1999 09:25:40 -0500

i have the same problem as well under windows 95:

LISP caused an invalid page fault in
module LISP.EXE at 0137:004020ec.
Registers:
EAX=804a9a1c CS=0137 EIP=004020ec EFLGS=00010246
EBX=804a9a19 SS=013f ESP=0074d50c EBP=0074d930
ECX=804a9a18 DS=013f ESI=80000000 FS=24f7
EDX=ffffffb1 ES=013f EDI=008783e5 GS=0000
Bytes at CS:EIP:
0f be 10 83 fa 01 7c 1e 83 fa 02 7e 4a 83 fa 03 
Stack dump:
004b11ac 00841fcc 0088c63c 00402312 008781b5 004cf5d8 00402242
00884de8 004b11ac 004a87f1 0088c63c 004016bf 0000003c 00000000
004d08cc 00000000 

the following suggestion:

produced this result:

[pathname.d:6240]
*** - Program stack overflow. RESET
*** - Program stack overflow. RESET

john> i got this version of clisp on April 9th. The date on the "lisp"
john> application file is 1/20/99, and i got it from "
john> ftp://ftp2.cons.org/pub/lisp/clisp/binaries/ ".

ditto on the date of the binary and the ftp site. (i downloaded it on
11 april.)

---

From: Sam Steingold <[email-masked]>
Date: 13 Apr 1999 12:09:21 -0400

You might try -s (increase stack).
first check whether your binary supports this option with "lisp.exe -h"

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Lisp: its not just for geniuses anymore.