Subject: Compiling LISP codes into executables?

From: [email-masked]
Date: Thu, 15 Apr 1999 19:44:52 +0800

Hi

   I wonder if it is possible to use CLISP to compile LISP codes into executables
on Windows platforms?  Or is it possible to use some libraries so that I can
execute LISP codes by calling these libraries?  Suggestions will be appreciated.

Thanks in advance!

Chi-Jen Lin

---

From: Sam Steingold <[email-masked]>
Date: 15 Apr 1999 09:25:14 -0400

>>>> In message <[email-masked]>
>>>> On the subject of "Compiling LISP codes into executables?"
>>>> Sent on Thu, 15 Apr 1999 05:46:41 -0700 (PDT)
>>>> Honorable [email-masked] writes:
 >> 
 >>    I wonder if it is possible to use CLISP to compile LISP codes
 >> into executables on Windows platforms?  Or is it possible to use

1. save the image:
   (lisp:saveinitmem "myimage.mem" :init-function #'my-func)

2. associate *mem type with the following:
        c:\clisp\lisp.exe -m10M -M "%s"

3. double-click on file myimage.mem - clisp will start and call
   `my-func'. 

 >> some libraries so that I can execute LISP codes by calling these
 >> libraries?  Suggestions will be appreciated.

you can connect to a running CLISP via a socket and send it expressions
to evaluate.

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat5.2 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
A professor is someone who talks in someone else's sleep.