Subject: Undefined function

From: Raymond Toy <[email-masked]>
Date: Tue, 13 Apr 1999 12:49:09 -0400

While trying to update my version of series, I've run into a small
problem with CLISP 1

(compile "s-code.lisp") works without any errors or warnings.  However, when
I try (load "s-code"), I get the message:

;; Loading file /apps/public/lib/lisp/code/iter/series-1/s-code.fas ...
*** - SYMBOL-FUNCTION: the function #:FUNCALL21015 is undefined

How can I track this down?  If it helps, here's a traceback:

1. Break SERIES[10]> backtrace-1

- NIL
- #<SYSTEM::SIMPLE-UNDEFINED-FUNCTION #x19C78B19>
frame binding variables (~ = dynamically):
  | ~ SYSTEM::*PRIN-STREAM* <--> #<UNBOUND>
- #<SYSTEM::SIMPLE-UNDEFINED-FUNCTION #x19C78B19>
- SYMBOL-FUNCTION
- #:FUNCALL21015
- #:FUNCALL21015
- #<COMPILED-CLOSURE #:TOP-LEVEL-FORM-162-3>
- #<COMPILED-CLOSURE #:TOP-LEVEL-FORM-162-3>
- #<COMPILED-CLOSURE #:TOP-LEVEL-FORM-162-3>
unwind-protect frame
frame binding variables (~ = dynamically):
  | ~ *READTABLE* <--> #<READTABLE #x19B41289>
frame binding variables (~ = dynamically):
  | ~ *PACKAGE* <--> #<PACKAGE USER>
frame binding variables (~ = dynamically):
  | ~ *LOAD-TRUENAME* <--> NIL
frame binding variables (~ = dynamically):
  | ~ *LOAD-PATHNAME* <--> NIL
frame binding variables (~ = dynamically):
  | ~ SYSTEM::*LOAD-INPUT-STREAM* <--> NIL
- #<CHARACTER-FILE-STREAM #P"/apps/public/lib/lisp/code/iter/series-1/s-code.fas" @3476>
- #<CHARACTER-FILE-STREAM #P"/apps/public/lib/lisp/code/iter/series-1/s-code.fas" @3476>
- #<COMPILED-CLOSURE LOAD>
- NIL
- NIL
- T
- NIL
- T
- #P"/apps/public/lib/lisp/code/iter/series-1/s-code.fas"
- #<COMPILED-CLOSURE LOAD>
EVAL frame for form (LOAD "s-code")
- #<CONCATENATED-STREAM #<STRING-INPUT-STREAM> #<SYNONYM-STREAM *TERMINAL-IO*>>
- #<SYNONYM-STREAM *TERMINAL-IO*>

I've run this same code through CMUCL and LWW without problems.
The strange part is that it worked a couple of days ago and CLISP
passed all of the series tests.  

Ray

---

From: Bruno Haible <[email-masked]>
Date: Tue, 13 Apr 1999 21:52:29 +0200 (MET DST)

> How can I track this down?  If it helps, here's a traceback:

The only useful information in this backtrace is the symbol
#:TOP-LEVEL-FORM-162-3. I would

  1. Try (load "s-code.lisp"),

  2. Try (load "s-code.fas" :print t),

  3. Search for #:TOP-LEVEL-FORM-162-3 in s-code.fas and try to guess
     which source form this comes from.

Bruno

---

From: Raymond Toy <[email-masked]>
Date: Tue, 13 Apr 1999 16:54:45 -0400

>>>>> "Bruno" == Bruno Haible <[email-masked]> writes:

    >> How can I track this down?  If it helps, here's a traceback:

    Bruno> The only useful information in this backtrace is the symbol
    Bruno> #:TOP-LEVEL-FORM-162-3. I would

    Bruno>   1. Try (load "s-code.lisp"),

It just loads the file.

    Bruno>   2. Try (load "s-code.fas" :print t),

It started sucking up lots of memory (107M) before I killed it.  It
didn't print out anything interesting.

    Bruno>   3. Search for #:TOP-LEVEL-FORM-162-3 in s-code.fas and try to guess
    Bruno>      which source form this comes from.

In any case, I must have screwed up my version of s-code.

>From a fresh clisp, if I compile-file and load the fas file,
everything loads just fine.

>From a fresh clisp, if I just load the fas file, I get the
undefined function error.

Thanks for you help!

Ray