Subject: compile-file

From: Josef Eschgfaeller <[email-masked]>
Date: Sat, 26 Jun 1999 01:09:57 +0200 (CEST)

Bruno Haible wrote:

> system::*source-file-types*

Thanks. But I tried now

  (push (make-pathname) system::*source-file-types*)

but compile-file still requires the suffix ".lsp".

J. Eschgfaeller

---

From: Sam Steingold <[email-masked]>
Date: 25 Jun 1999 19:25:23 -0400

>>>> In message <[email-masked]>
>>>> On the subject of "compile-file"
>>>> Sent on Fri, 25 Jun 1999 15:03:09 -0700 (PDT)
>>>> Honorable Josef Eschgfaeller <[email-masked]> writes:
 >> Bruno Haible wrote:
 >> 

what do you think this is supposed to accomplish?
did you evaluate system::*source-file-types* after you did this?

 >> but compile-file still requires the suffix ".lsp".

of course.

please try

(push (make-pathname :type ".lisp") system::*source-file-types*)

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat6.0 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Whether pronounced "leenooks" or "line-uks", it's better than Windows.

---

From: Joerg Hoehle <[email-masked]>
Date: Mon, 28 Jun 1999 10:34:55 +0200 (MEST)

Hi,

> (push (make-pathname :type ".lisp") system::*source-file-types*)

Shouldn't that be (make-pathname :type "lisp")?

You shouldn't rely on the dot being the separator of name and type.
CL tries to avoid such filesystem dependencies.

Using "/" or "." in code is probably as wrong as using EVAL.

Regards,
	Jo"rg Ho"hle.
[email-masked]		http://zeus.gmd.de/~hoehle/amiga.html