Subject: RE:my questions about Clisp

From: Anita Lilian <[email-masked]>
Date: Sat, 05 Jun 1999 11:14:13 -0300

thanks !!
for reply

but now I have another questions ... please ...
>
>> the compiler clisp create files * .exe or only * .fas * .lib
>
>Yes, it creates no *.exe. But you can create .bat files which call clisp
>with the right arguments, and it behave just like a .exe.

mmm
how can create *.bat files ?
I try but ...
nothing

and  how can see the error in an file ?
I try with ">" but this  non responde 
lisp.exe -M lispinit.mem -c filename > err.txt

thanks

Anita.

---

From: Sam Steingold <[email-masked]>
Date: 05 Jun 1999 15:06:01 -0400

>>>> In message <[email-masked]>
>>>> On the subject of "RE:my questions about Clisp"
>>>> Sent on Sat, 5 Jun 1999 08:12:50 -0700 (PDT)
>>>> Honorable Anita Lilian <[email-masked]> writes:
 >> >

Edit a file named "myfile.bat" and put there the following:

--- cut here ---
@lisp.exe -M lispinit.mem -m 10mb -i whatever.fas -x (main)
--- cut here ---

Put it somewhere in your path.  Now you can type "myfile" in the shell
window and it will start CLISP.

This question is not really CLISP-related but rather DOS- or
Win32-related.  You might want to RTFM (Read The Fine Manual).

Also, I must note that it would be nice if you could write in more
complete sentences.  Not everyone here is a native English speaker 
(e.g., my native language is Russian, Bruno's - German), and it is hard
to understand your questions unless you try to improve your English.

Good luck.

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat6.0 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
If a train station is a place where a train stops, what's a workstation?

---

From: Anita Lilian <[email-masked]>
Date: Tue, 08 Jun 1999 11:42:13 -0300

Hi

>@lisp.exe -M lispinit.mem -m 10mb -i whatever.fas -x (main)

but ...... I still I have problem for to create an executable file of a
file *.lsp

I have max.lsp
---------------
(max 3 4 5)
----------------

I compile
----------------------------------
lisp -M lispinit.mem -c max.lsp
------------------------------------

edit a file "max.bat
-----------------------------------------------------------------
@lisp.exe -M lispinit.mem -m 10mb -i max.fas -x (main)
-----------------------------------------------------------------

but
appears
;;loading file max.fas
;;loading of file max .fas is finished
*****EVAL undefined function MAIN

which is my error?

thanks...

Anita.

---

From: Sam Steingold <[email-masked]>
Date: 08 Jun 1999 12:04:56 -0400

>>>> In message <[email-masked]>
>>>> On the subject of "Re: my questions about Clisp"
>>>> Sent on Tue, 8 Jun 1999 08:42:15 -0700 (PDT)
 >> but ...... I still I have problem for to create an executable file
 >> of a file *.lsp
 >> 
 >> I have max.lsp
 >> ---------------
 >> (max 3 4 5)
 >> ----------------
 >> 
 >> 
 >> I compile

your error is that you did not modify my recommendations to suit your
situation.

Try this:

--- file1.lsp ---
(print (max 1 2 3))
--- file1.lsp ---

> lisp.exe -M lispinit.mem -c file1.lsp

--- file1.bat ---
@lisp.exe -M lispinit.mem -i file1.fas
--- file1.bat ---

> file1

 - OR -

--- file2.lsp ---
(defun my-main-function ()
  (print (max 1 2 3)))
--- file2.lsp ---

> lisp.exe -M lispinit.mem -c file2.lsp

--- file2.bat ---
@lisp.exe -M lispinit.mem -i file2.fas -x (my-main-function)
--- file2.bat ---

> file2

-i loads file, -x evaluates a form.

-- 
Sam Steingold (http://www.goems.com/~sds) running RedHat6.0 GNU/Linux
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
A year spent in artificial intelligence is enough to make one believe in God.