Subject: Trouble with build

From: "Jim Arvo" <[email-masked]>
Date: Thu, 1 Jul 1999 19:21:26 -0700

I've run into a mysterious problem while trying to build the latest
version of clisp on a Unix platform (Irix 6.2).  Almost everything works
without a hitch, then near the end I get "Error code 138".  The last
few lines of the transcript are below.  I have no idea how to diagnose
what the problem is.  Any suggestions would be appreciated.  Thanks.

-- Jim

..
..
..
installing en.gmo as ../../locale/en/LC_MESSAGES/clisp.mo
installing de.gmo as ../../locale/de/LC_MESSAGES/clisp.mo
installing fr.gmo as ../../locale/fr/LC_MESSAGES/clisp.mo
installing es.gmo as ../../locale/es/LC_MESSAGES/clisp.mo
        if test -d data; then rm -rf data; fi
        mkdir data
        ln -s ../../utils/unicode/ftp.unicode.org/UnicodeData.txt
data/UnicodeData.txt
        gcc -O -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type
-fomit-frame-pointer -O2 -DUNICODE -x none spvw.o  spvwtabf.o  spvwtabs.o
 spvwtabo.o  eval.o  control.o  encoding.o  pathname.o  stream.o  socket.o
 io.o  array.o  hashtabl.o  list.o  package.o  record.o  sequence.o  charstrg.o
 debug.o  error.o  misc.o  time.o  predtype.o  symbol.o  lisparit.o  unixaux.o
 arimips.o modules.o libsigsegv.a libintl.a libreadline.a  -ltermcap  -o
lisp.run
        sync
        ./lisp.run -m 750KW -B . -N locale -norc -x "(load \"init.lsp\")
(sys::%saveinitmem) (exit)"
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999

;; Loading file defseq.lsp ...
;; Loading of file defseq.lsp is finished.
;; Loading file backquot.lsp ...
;; Loading of file backquot.lsp is finished.
;; Loading file defmacro.lsp ...
;; Loading of file defmacro.lsp is finished.
;; Loading file macros1.lsp ...
;; Loading of file macros1.lsp is finished.
;; Loading file macros2.lsp ...
;; Loading of file macros2.lsp is finished.
;; Loading file defs1.lsp ...
;; Loading of file defs1.lsp is finished.
;; Loading file places.lsp ...
;; Loading of file places.lsp is finished.
*** - handle_fault error8 ! protection = 3
SIGSEGV cannot be cured. Fault address = 0x699BD570.
*** Error code 138 (bu21)

---

From: Bruno Haible <[email-masked]>
Date: Fri, 2 Jul 1999 19:03:13 +0200 (MET DST)

Jim Arvo <[email-masked]> writes:
> what the problem is.

I don't have the slightest idea either. All I know is that if you add
-DNO_GENERATIONAL_GC to the CFLAGS in the Makefile, remove all *.o files,
and rebuild, then it will work. At least, that worked for me on IRIX 6.5
a few weeks ago.

Bruno