Subject: ILISP - interrupt

From: Martin Atzmueller <[email-masked]>
Date: Sun, 25 Jul 1999 12:12:19 +0200

Hi,

if I evaluate something (function, form) that could run forever, for example
(LOOP WHILE t) in an ilisp-buffer (not in the toplevel!) I can't get out of it
and Clisp seems to hang, so I have to restart everything.

ILISP does an interrupt-subjob, but I can't get an appropriate
comint-interrupt-regexp for Clisp, or does it not support this?

Thanks,
Martin

---

From: Martin Atzmueller <[email-masked]>
Date: Wed, 28 Jul 1999 00:57:11 +0200

Hi,

> comint-interrupt-regexp for Clisp, or does it not support this?

Has no one besides me noticed this thing? Or is nobody using Clisp together
with ILISP?

Since the ilisp-list is not functional again yet and this thing is very related
to Clisp, I have to post it here.

To elaborate my problem a bit:
C-c C-c should achieve an 'comint-interrupt-subjob' in an ILISP-buffer. 
comint-interrupt-subjob finally does an interrupt-process.
The Emacs-help says to this:

"interrupt-process is a built-in function.
 
Interrupt process PROCESS.  May be process or name of one.
PROCESS may be a process, a buffer, or the name of a process or buffer.
nil or no arg means current buffer's process.
Second arg CURRENT-GROUP non-nil means send signal to
the current process-group of the process's controlling terminal
rather than to the process's own process group.
If the process is a shell, this means interrupt current subjob
rather than the shell.
 
(interrupt-process &optional PROCESS CURRENT-GROUP)"

So what does Clisp do with the interrupt-signal?

Martin

---

From: [email-masked] (Paolo Amoroso)
Date: Sat, 31 Jul 1999 09:25:42 GMT

> Has no one besides me noticed this thing? Or is nobody using Clisp together

I use ILISP 5.8-a04 with GNU Emacs 20.3 and I confirm this behavior. When I
evaluate (loop while t) from a Lisp mode buffer controlled by ILISP, Emacs
displays the message "Started initializing ILISP" and then hangs. I can
regain control of the Lisp mode buffer, but not of the inferior CLISP
process, with C-g.

Paolo
-- 
Paolo Amoroso <[email-masked]>