Subject: using logical-pathnames?

From: [email-masked] (Jorg-Cyril Hohle)
Date: Sat, 10 Jul 1999 11:48:10 +0200 (MET DST)

Hi,

is there anybody actually using logical pathnames in CLISP?  There was
some discussion about them in December 1998 here.

Maybe I got used to much to CMUCL's ext:search-list feature and the
AmigaOS filesystem's logical devices (which allow me to open a file
with short paths like "foo:zot/bar.lsp" in both CMUCL and Amiga-CLISP).

The logical pathnames section of CLtL2 is one of the more obscure
sections of the book, and so far I haven't seen code that makes use of
them (CL-HTTP maybe?).

Thanks for pointers,
	Jorg.
Amiga-CLISP		http://fit.gmd.de/~hoelhe/amiga-clisp.html

---

From: Martin Atzmueller <[email-masked]>
Date: Sun, 11 Jul 1999 20:39:37 +0200

> some discussion about them in December 1998 here.
Well I used logical pathnames in my last project that I did using ACL5, not
CLISP.

I tried the examples of CLTL2 in CLISP, but already the (modified) first did'nt
work in CLISP, but it did in ACL5(Linux):

(setf (logical-pathname-translations "bla") '(("**;*.*.*" "/foo/bar/**/") ) )

(translate-logical-pathname "bla:baz;x.lisp")

=>
[483]> ;;; Evaluating translate-logical-pathname
*** - MAKE-PATHNAME: illegal :DIRECTORY argument (:ABSOLUTE "foo" "bar" ("baz"))
1. Break BA[484]> *** - MAKE-PATHNAME: illegal :DIRECTORY argument (:ABSOLUTE "foo" "bar" ("baz"))
1. Break BA[484]> 

I suppose that there is an error when matching wildcard-inferiors ="**", since
I suceeded when matching only one subdirectory like in:

(setf (logical-pathname-translations "bla") '(("*;*.*.*" "/foo/bar/*/") ) )
(translate-logical-pathname "bla:foo;bla.lisp")
=> #P"/foo/bar/baz/x.lisp"

Any comments?

Martin
-----
E-Mail: [email-masked]