Subject: Re: ILISP - interrupt

From: Martin Atzmueller <[email-masked]>
Date: Sun, 1 Aug 1999 20:30:43 +0200

On Sat, 31 Jul 1999, you wrote:
> On Thu, 29 Jul 1999 03:44:02 -0700 (PDT), you wrote:
> 
> > > if I evaluate something (function, form) that could run forever, for example
> > > (LOOP WHILE t) in an ilisp-buffer (not in the toplevel!) I can't get out of it
> > > and Clisp seems to hang, so I have to restart everything.
> > > 
> > > ILISP does an interrupt-subjob, but I can't get an appropriate
> > > comint-interrupt-regexp for Clisp, or does it not support this?
> > 
> > Has no one besides me noticed this thing? Or is nobody using Clisp together
> > with ILISP?
> 
> I use ILISP 5.8-a04 with GNU Emacs 20.3 and I confirm this behavior. When I
> evaluate (loop while t) from a Lisp mode buffer controlled by ILISP, Emacs
> displays the message "Started initializing ILISP" and then hangs. I can
> regain control of the Lisp mode buffer, but not of the inferior CLISP
> process, with C-g.

I was able to debug ILISP so that I got a solution for this problem:
I changed my 'comint-prompt-regexp' in the dialect definition to:
>>    comint-prompt-regexp "^\\([^>]*> \\)\\|\\(\\*\\*\\)"      <<
(I hope Marco Antoniotti will include this in ILISP 5.9, too.)

Now I'm able to regain control of ILISP, and the prompt is displayed
thereafter, but no error message(for me this is not a great problem), while for
example in CMUCL there _is_ an error message that CMUCL was interrupted.

Martin

---

From: Marco Antoniotti <[email-masked]>
Date: Mon, 2 Aug 1999 09:20:03 +0200

> Topic No. 1
> 
> Date: Sun, 1 Aug 1999 20:30:43 +0200
> From: Martin Atzmueller <[email-masked]>
> To: [email-masked]
> Subject: Re: ILISP - interrupt
> Message-ID: <99080120381601.00374@Io>
> 
  ...

> (I hope Marco Antoniotti will include this in ILISP 5.9, too.)

I sure will.  This is a nice little bug fix. :)

Cheers

-- 
Marco Antoniotti ===========================================
PARADES, Via San Pantaleo 66, I-00186 Rome, ITALY
tel. +39 - 06 68 10 03 17, fax. +39 - 06 68 80 79 26
http://www.parades.rm.cnr.it/~marcoxa