Subject: English README file for Win 32

From: Benjamin Shults <[email-masked]>
Date: Mon, 09 Aug 1999 14:26:49 -0400

The README files in the Win32 version have some important
information missing in the installation instructions.
In fact, the line 

  lisp -M lispinit.mem

never occurs in the installation instructions.  So a
person who has never installed clisp will not be able
to figure this out, I think.

I have included a suggested new version of the English
Win32 README file.  I also suggest that the German
and Spanish versions of the files be similarly changed.
Please feel free to improve on my wording in the changes
I made.

Cheers,

Benji

-- 
Benjamin Shults               FAX: 828 227 7240
Department of Math and CS     mailto:[email-masked]
Western Carolina University   Voice: 828 227 3825
Cullowhee, NC  28723          Office: 301-A Stillwell

This is CLISP, a Common Lisp implementation.

What is LISP?
-------------

LISP is a programming language. It was invented by J. McCarthy in 1959.
There have been many dialects of it, but nowadays LISP has been standardized
and wide-spread due to the industrial standard COMMON LISP. There are
applications in the domains of symbolic knowledge processing (AI), numerical
mathematics (MACLISP yielded numerical code as good as FORTRAN), and
widely used programs like editors (EMACS) and CAD (AUTOCAD).
There is an introduction to the language:

  Sheila Hughes: Lisp. Pitman Publishing Limited, London 1986.
  107 pages.

After a while wou will need the standard text containing the language
definition:

  Guy L. Steele Jr.: Common Lisp - The Language. Digital Press.
  1. edition 1984, 465 pages.
  2. edition 1990, 1032 pages.

This book is available in HTML form via FTP from
  ftp.cs.cmu.edu:/user/ai/lang/lisp/doc/cltl/cltl_ht.tgz
and can be viewed through WWW under
  http://www.cs.cmu.edu:8001/Web/Groups/AI/html/cltl/cltl2.html or
  http://www.cs.cmu.edu:8001/afs/cs/project/ai-repository/ai/html/cltl/cltl2.html .

For experts: This standard text has emerged into an ANSI standard, which
you can exceptionally get free of charge from
  http://www.harlequin.com/books/HyperSpec/

LISP is run in an interactive environment. You input forms, and they will be
evaluated at once. Thus you can inspect variables, call functions with given
arguments or define your own functions.

Contents:
---------

It consists of the following files:

      lispinit.mem       memory image needed for startup
      clisp.1            manual page in Unix man format
      clisp.man          manual page
      clisp.html         manual page in HTML format
      impnotes.html      implementation notes
      LISP-tutorial.txt  LISP tutorial for beginners
      CLOS-guide.txt     brief guide to CLOS
      editors.txt        some words about text editors for Lisp
      README             this text
      SUMMARY            short description of CLISP
      ANNOUNCE           announcement
      NEWS               list of modifications since the last version
      COPYRIGHT          copyright notice
      GNU-GPL            free software license
      config.lsp         site-dependent configuration

and - to your convenience, if you like reading source -

      *.lsp              the source of lispinit.mem
      *.fas              the same files, already compiled

Installation:
-------------

Change the strings in src/config.lsp, using a text editor.
Then start

      lisp -M lispinit.mem

When the LISP prompt

      > _

appears, type

        (compile-file "src/config.lsp")
        (load "src/config.fas")

and then

        (saveinitmem)

to overwrite the file lispinit.mem with your configuration. Then

        (exit)

Then create a directory, and put the executable and the memory image there.

Now, to start lisp, execute

     lisp -M lispinit.mem

You may want to write a .bat file with that line in it and put the .bat file
on your path.

When you encounter problems:
----------------------------

After errors, you are in the debugger:

     1. Break> _

You can evaluate forms, as usual. Furthermore:

     Help
               calles help
     Abort     or
     Unwind
               climbs up to next higher input loop
     Backtrace
               shows the contents of the stack, helpful for debugging

And you can look at the values of the variables of the functions where the
error occurred.

and how to produce it reliably to the authors or the maintainer. Please
accompany it with the CLISP version, which you get by calling
(lisp-implementation-version).

Sources:
--------

The sources of CLISP are available from
     ftp://ftp2.cons.org/pub/lisp/clisp/source/clispsrc*

Mailing List:
-------------

There is a mailing list for users of CLISP. It is the proper forum for
questions about CLISP, installation problems, bug reports, application
packages etc.

For information about the list and how to subscribe it, send mail to
[email-masked], with the two lines
          help
          information clisp-list
in the message body.

Acknowledgement:
----------------

We are indebted to
  * Guy L. Steele and many others for the Common Lisp specification.

Authors:
--------

        Bruno Haible
        Michael Stoll

Email: [email-masked]

Maintainer:
-----------

        Marcus Daniels

Email: [email-masked]

---

From: Bruno Haible <[email-masked]>
Date: Mon, 9 Aug 1999 23:32:17 +0200 (MET DST)

Benjamin Shults <[email-masked]> writes:

> never occurs in the installation instructions.

Ouch. Thanks for telling me about it. It will be fixed in the next
binary release.

Bruno