Subject: RE: [clisp-list] Problem with install.lisp in Windows

From: "Clementson, Bill" <[email-masked]>
Date: Sat Feb 23 11:17:08 2002

> > The install.lisp program (in CVS) creates a batch file for starting
> > CLISP in Windows. However, if CLISP is installed in a directory that
> > has spaces in it's name (e.g. - "c:\Program Files\clisp-2.27", the
> > batch file will not work correctly.
> 
> oops - my fault (I always put CLISP in c:/gnu/clisp)...
> just fixed it in the CVS

I tested the new version of the install.lisp program. It creates a batch
file that looks like the following:

@echo off
"C:\Program Files\clisp-2.27\lisp.exe" -B "C:\Program Files\clisp-2.27\" -M
"C:\Program Files\clisp-2.27\lispinit.mem" %1 %2 %3 %4 %5 %6 %7 %8 %9

However, when I run the batc h file, I get the following error message:

c:\>c:\clisp.bat
c:\clisp.bat

WARNING: No initialisation file specified.
Please try: C:\Program Files\clisp-2.27\lisp.exe -M lispinit.mem

*** - EVAL: the function SYSTEM::BATCHMODE-ERRORS is undefined

--
Bill Clementson

---

From: Sam Steingold <[email-masked]>
Date: Sat Feb 23 21:19:03 2002

> * In message <[email-masked]>
> * On the subject of "RE: [clisp-list] Problem with install.lisp in Windows"
> * Sent on Sat, 23 Feb 2002 12:16:00 -0700
> * Honorable "Clementson, Bill" <[email-masked]> writes:
>

curse be upon the moron who decided to use #\\ as the pathname
separator!
please try the appended patch.
win32 is supposed to understand the normal slashes as well.

to check the data directory (specified by the -B option) try calling
BLAHS or describing a UNICODE character.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Lisp: Serious empowerment.

--- install.lisp.~1.5.~	Fri Feb 22 21:12:01 2002
+++ install.lisp	Sun Feb 24 00:07:44 2002
@@ -5,7 +5,7 @@
 ;;  - to set the Registry appropriately
 ;;  - to create CLISP.BAT on your desktop
 
-(defvar *clisp-home* (namestring (default-directory)))
+(defvar *clisp-home* (substitute #\/ #\\ (namestring (default-directory))))
 (defvar *clisp-base-cmd*
   (concatenate 'string "\"" *clisp-home* "lisp.exe\" -B \""
                *clisp-home* "\" -M "))