Subject: [clisp-list] Re: clisp 2.32 with clx

From: [email-masked]
Date: Wed Mar 10 23:31:13 2004

Hallo, All
Sam writes
>either this is not CLISP or you have edited both prompts and output.
CLISP lives on another computer so editing is easier for me, sorry
>please copy and paste everything.
>if you are using interpreted code (which appears to be the case), you
>can evaluate the arguments to DRAW-GLYPHS (window &c).
>please do it.
--------------

diff hello.lisp hello.lisp_original
<     (width 500)
>      (width (+ text-width font string) (* 2 border)))
----------------
Using the original hello.lisp CLISP gives the Break-prompt with the same 
message further described
In CLOCC/src/gui/clx/demo I do: 
....clisp-2.32/full/lisp.run -M .....clisp-2.32/full/lispinit.mem
[1]> (lisp-implementation-version)
"2.32(2003-12-29) built on burivuh[127.0.0.1]"
[2]> (load  "hello.lisp")
[3]> (in-package :xlib)
XLIB[4]>(hello-world "k")  ;;; the window named "HELLO_WORLD" appears 
*** - SLOT-VALUE: The class #<BUILT-IN-CLASS T> has no slot named FONT-INFO
Break 1 [5]> :b
EVAL frame for form (DRAW-GLYPHS WINDOW GCONTEXT X Y STRING)
Break 1 XLIB[5]> window
#<WINDOW 500x15+0+0 k #x01200002 #x203A86B5>
Break 1 XLIB[5]> gcontext
#>GCONTEXT #x203A8750
Break 1 XLIB[5]> x
0
Break 1 XLIB[5]> y
12
Break 1 XLIB[5]> string
"Hello World"

K

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 11 07:54:20 2004

> *  <[email-masked]> [2004-03-11 02:02:16 -0500]:
>

I do not observer this with the CVS HEAD (and therefore this is fixed in
the next release.)

it appears that this bug was fixed on 2004-01-29.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
"Complete Idiots Guide to Running LINUX Unleashed in a Nutshell for Dummies"