Subject: [clisp-list] critique of default-foreign-language

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Tue Apr 23 03:28:03 2002

Hi,

I'll try to answer shortly, seeking a compromise. I'll drop the
long email I've prepared.

Sam steingold wrote:
> this is accomplished by ensuring that the macroexpansion of DEF-CALL-*
> contains a :LANGUAGE arg, whether it was supplied or not.
> this is not done now, and it is a bug.
> I will try to fix it soon.

This is what I understand:
So you seem to opt for choice "make :language required". That's ok.

So it's ok. Make :language required. As I said yesterday,
either of the 3 choices is fine with me.

Don't forget that it's not DEF-*-CALL-* that I've griefs with.
It's perfectly legal code (so far) like:
(CAST foo '(C-FUNCTION ...))
I.e. PARSE-C-TYPE and PARSE-C-FUNCTION, and impnotes must be
changed to provide the new behaviour: no :language -> error.

However,
I realize that your wording "by ensuring ... DEF-CALL-* ... a :LANGUAGE
arg, whether it was supplied or not" does not say anything about
PARSE-C-TYPE etc. It also does not imply that DEFAULT-FOREIGN-LANGUAGE disappear.

But please don't provide pluggable defaults, i.e.
drop default-foreign-language.

Indeed, when :language becomes required, I fail to see how
default-foreign-language is still used. Do I miss something?

Proposal:
PARSE-C-TYPE, PARSE-C-FUNCTION: no :language -> error
DEF-CALL-OUT: no :language -> error
DEF-C-CALL-OUT: provides (:language :stdc) to DEF-CALL-OUT, as always
DEf-LIB-CALL-OUT (Amiga) adds (:language :STDC) arbitrarily for compatibility?
DEF-LIB-CALL-OUT (truly dynamic FFI, if I keep this name): require :language

The result is predictable behaviour *in all situations*, with
slightly added verbosity for the (supposedly) minority of people
doing run-time stuff, as well as more verbosity for the people
using DEF-LIB-CALL-OUT, i.e. the new shared library API.

Regards,
	Jorg Hohle.
who stills prefers no :language -> :stdc

---

From: Sam Steingold <[email-masked]>
Date: Tue Apr 23 06:47:14 2002

I am sorry, but I do not understand a single word of what you are
saying.  (Remember, English is a second language for both of us!)
Could you please re-state briefly why you don't like the current system?
Specifically, how is it different from *PACKAGE* & IN-PACKAGE.

> * In message <[email-masked]>
> * On the subject of "[clisp-list] critique of default-foreign-language"
> * Sent on Tue, 23 Apr 2002 10:18:48 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> Sam steingold wrote:

nope.

> DEF-LIB-CALL-OUT (truly dynamic FFI, if I keep this name): require :language

wouldn't these be gone when all the FFI goes dynamic?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
<http://www.palestine-central.com/> <http://www.mideasttruth.com/>
All generalizations are wrong.  Including this.