Subject: [clisp-list] clisp and TK

From: David Hanley <[email-masked]>
Date: Fri Oct 19 13:05:13 2001

I'd like to distribute a few small useful lisp
apps--not with the idea of making money, just to be
useful to some people.

FRANZ makes a good tool, but it's too expensive for my
helping-people plan.

I have harlequin 4.1 but i find it's UI stuff very
hard to use, and flaky.  Some basic things don't work.
 There's no documented way to update a listbox after
you've already added items to it, and they acted like
i was crazy because i wanted to do that.

So, i had the idea to compile TK into clisp, and
distribute that with some .fasl files.  This seems
do-able.  It's also more work than i'd like to do, but
what the heck.  

Before i go whole-hog integrating clisp with TK,
though, i must ask:

1) has anyone done this before?
2) is this something people would generally like to
use?
3) Is there some applicable standard for integrating
GUI stuff to lisp?

I could sort-of forsee this being integrated into
future distributions with a compile-time flag. 

If this will not be useful, i'll probably not bother. 

dave

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Paolo Amoroso <[email-masked]>
Date: Sat Oct 20 04:46:10 2001

> distribute that with some .fasl files.  This seems
[...]
> 1) has anyone done this before?

Sort of. If you are willing to separately ship the Lisp application and a
standard Tcl/Tk distribution if the user's system doesn't come with it, you
may get some idea from the `lisp2wish' page at CLiki:

  http://ww.telent.net/cliki/

Paolo
-- 
EncyCMUCLopedia * Extensive collection of CMU Common Lisp documentation
http://web.mclink.it/amoroso/ency/README
[http://cvs2.cons.org:8000/cmucl/doc/EncyCMUCLopedia/]