Subject: [clisp-list] Logical pathnames trouble

From: "David E. Young" <[email-masked]>
Date: Thu, 15 Mar 2001 17:02:21 -0500

Greetings. I submitted the following bug report a few days ago and
received the accompanying response:

  "Greetings. It appears that CLISP's implementation of
   LOAD doesn't understand logical pathnames, as it apparently should
   according to CLtL2. 

   Evaluating the following in CLISP:

    (load "lisa:clocc;port;port.system")

  fails with the message

    *** - A file with name lisa:clocc;port;port.system does not exist

  If I replace the above LOAD form with

    (load (translate-logical-pathname "lisa:clocc;port;port.system"))

  CLISP doesn't complain and the load is successful.

  Three other Lisp platforms behave as expected."

Reply:

  "Please see the variable `lisp:*parse-namestring-ansi*' in the
  implementation notes, as well as symbol macro `lisp:*ansi*' and the
  -a command line switch. please report bugs on clisp mailing lists
  instead of here - you will get the response faster."

I installed CLISP 2.25 on my Redhat Linux box and tried the
suggestions above, to no avail; same trouble.

FYI, Redhat Linux 6.2, CLISP 2.25 built from source.

Regards,

-- 
-----------------------------------------------------------------
David E. Young
Fujitsu Network Communications  (defun real-language? (lang)
([email-masked])           (eq lang 'LISP))

"But all the world understands my language."
  -- Franz Joseph Haydn (1732-1809)

---

From: Sam Steingold <[email-masked]>
Date: 15 Mar 2001 18:44:14 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Logical pathnames trouble"
> * Sent on Thu, 15 Mar 2001 17:02:21 -0500
> * Honorable "David E. Young" <[email-masked]> writes:
>

I cannot reproduce your problem:

> clisp -a
cl-user[1]: > (load "clocc:clocc")
;; Loading file /usr/local/src/clocc/clocc.fas ...
;; Loading of file /usr/local/src/clocc/clocc.fas is finished.
t
cl-user[2]: > (load "clocc:src;cllib;base")
;; Loading file /usr/local/src/clocc/src/cllib/base.fas ...
;; Loading of file /usr/local/src/clocc/src/cllib/base.fas is finished.
t

could you please send more details?
like a full session transcript, including the value
of lisp:*parse-namestring-ansi*?
maybe you could just try "clisp -a"?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Don't ascribe to malice what can be adequately explained by stupidity.