Subject: [clisp-list] now you can use the regexp module on MS-Windows

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Apr 10 02:56:10 2002

Sam wrote:

> actually, the Emacs version does not cut it.
Pardon my poor english? That means you don't like the regexp library that's part of Emacs?

modules/regexp/README actually says:
"The library routines regex.[ch] come from the GNU findutils-4.1."

> please try the glibc version (attached, from the glibc 2.2.5 dist)
[oops, 260KB to the list]

It's no better at all w.r.t. to alloca() for M$-VC, witness:

/* Make alloca work the best possible way.  */
#   ifdef __GNUC__
#    define alloca __builtin_alloca
#   else /* not __GNUC__ */
#    if HAVE_ALLOCA_H
#     include <alloca.h>
#    endif /* HAVE_ALLOCA_H */
#   endif /* not __GNUC__ */

#  endif /* not alloca */

There's no alloca.h include file with (at least my) MS-VC 6.x

So we're left with few choices:
1. change modules/regexp/regex.c as by my patch, or
2. recommend MS-VC users to create alloca.h *and* compile with -DHAVE_ALLOCA_H
3. beg Emacs/FSF/Lignux-libc/xyz-people to care for MS-VC and incorporate patch

In any case:
0. document problem and patch probably needed within CLISP,
 .a either modules/regexp/README
 .b or win32msvc/INSTALL

I'd favour 0b+1!+2 as I have few hopes for 3.

It would be interesting to know whether the Intel C compiler (icc) provides alloca. I suppose no Linux/Free-/Open-/NetBSD (UNIX) user is interested by MS-VC, but icc is another issue.

Regards,
	Jorg Hohle.

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 10 07:34:28 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] now you can use the regexp module on MS-Windows"
> * Sent on Wed, 10 Apr 2002 11:55:09 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>

it does not compile without Emacs out of the box.

> [oops, 260KB to the list]

sorry.
RMS actually recommends using the GLIBC version with CLISP.

> There's no alloca.h include file with (at least my) MS-VC 6.x

Joerg, please submit your patch to the glibc developers.
<http://www.gnu.org/software/glibc/>
<[email-masked]>

> I'd favour 0b+1!+2 as I have few hopes for 3.

I am pretty sure your patch will be accepted by the GLIBC people
(especially if you accompany it with a standard ChangeLog entry).

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
All extremists should be taken out and shot.