Subject: [clisp-list] documentation

From: "Dave Richards" <[email-masked]>
Date: Tue Nov 27 20:38:02 2001

How do I retrieve the documentation string associated with a method created
by defmethod? e.g.

	(defmethod foo ((instance standard-object))
	  "foo doesn't so anything useful."
	  t)

	Thanks!

	Dave

---

From: Sam Steingold <[email-masked]>
Date: Wed Nov 28 07:18:06 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] documentation"
> * Sent on Tue, 27 Nov 2001 20:37:34 -0800
> * Honorable "Dave Richards" <[email-masked]> writes:
>

this doc string is now discarded.
CLISP DOCUMENTATION has cltl1 implementation (not a generic function).

When DOCUMENTATION is implemented correctly, this doc should be available as

(documentation (find-method #'foo nil (list (find-class 'standard-object))) t)

would you like to work on this?

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Live free or die.