Subject: [clisp-list] clisp on windows/95

From: [email-masked]
Date: Mon, 30 Jul 2001 12:17:00 +0100

Could anyone familiar with setting up clisp on windows possibly advise this very green would-be user? I want it to load and use a package called Common Music Notation. So far I've got a clisp window with the lisp prompt, but it complains about lack of initialisation and installation, and the remedies it suggests have had no effect. When I try to load CMN it says "function PUSHNEW is undefined". Very grateful for any suggestions at all.

Tom

---

From: Reini Urban <[email-masked]>
Date: Mon, 30 Jul 2001 18:58:54 +0100

Tom,
To my knowledge the "good parts" of common music (CM, CLM, CMN) are X Windows
based.
Also CMN which previewer uses X/Motif.
At least the clm-2 soundlib runs fine on windows.

maybe you can compile xcmnw.c with cygwin-xfree86, but that's a minefield.
And I don't know any Windows Motif libs. 
All the other libs are included in cygwin-xfree86.
  -L/usr/X11R6/lib -lXm -lXp -lXt -lXext -lX11 -lm, 
just Xm is missing.

the rest works fine, even with my very old clisp

> n:\usr\local\bin\clisp -M n:\usr\local\lib\lisp\lispinit.mem --version
CLISP 1999-07-22 (July 1999)

> n:\usr\local\bin\clisp -M n:\usr\local\lib\lisp\lispinit.mem 

[1]> (load "cmn-all.lisp")
;; Loading file cmn-all.lisp ...
Compiling file R:\lisp\cm\cmn\cmn-loop.lisp ...
...
...
;;  Loading file R:\lisp\cm\cmn\quarter.fas ...
;;  Loading of file R:\lisp\cm\cmn\quarter.fas is finished.
;; Loading of file cmn-all.lisp is finished.
T
[2]> (saveinitmem)
2830344 ;
707586
[3]> (in-package :cmn)
[4]> (cmn staff treble c4 q)
#<SCORE #x1A46E731>

...

-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Raymond Toy <[email-masked]>
Date: 31 Jul 2001 14:10:00 -0400

>>>>> "Reini" == Reini Urban <[email-masked]> writes:

    Reini> Tom,
    Reini> To my knowledge the "good parts" of common music (CM, CLM, CMN) are X Windows
    Reini> based.
    Reini> Also CMN which previewer uses X/Motif.
    Reini> At least the clm-2 soundlib runs fine on windows.

    Reini> maybe you can compile xcmnw.c with cygwin-xfree86, but that's a minefield.
    Reini> And I don't know any Windows Motif libs. 
    Reini> All the other libs are included in cygwin-xfree86.
    Reini>   -L/usr/X11R6/lib -lXm -lXp -lXt -lXext -lX11 -lm, 
    Reini> just Xm is missing.

Not really relevant to clisp, but for Xm, you could probably use
LessTif instead.  Should compile without problems on cygwin, but I've
never done that.

Ray