Subject: [clisp-list] saveinitmem bug

From: Bernard Urban <[email-masked]>
Date: Wed Oct 17 07:27:22 2001

ramses@merceron:~/work$ clisp -q

[1]> (lisp-implementation-version)
"2.27 (released 2001-07-17) (built 3212300364) (memory 3212303009)"
[2]> (system::saveinitmem)
965396 ;
524288
[3]> 
ramses@merceron:~/work$ clisp -q -M lispinit.mem 

[1]> (lisp-implementation-version)

*** - Date incorrecte : 300364/0/364, 0h0m0s, heure NIL
1. Break [2]> 
[3]> 
ramses@merceron:~/work$

I suspect the bug as beeing in the C function savemem(), where a time
stamp is computed.

-- 

Bernard Urban

---

From: Sam Steingold <[email-masked]>
Date: Wed Oct 17 11:10:16 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] saveinitmem bug"
> * Sent on 17 Oct 2001 16:26:32 +0200
> * Honorable Bernard Urban <[email-masked]> writes:
>
> ...

this appears to have been fixed in the current sources.
could you please try CVS?

thanks!

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I'd give my right arm to be ambidextrous.