Subject: [clisp-list] regexp example in the doc

From: "Evgeni V. Trifonov" <[email-masked]>
Date: Tue, 31 Jul 2001 17:15:53 +1100 (VLAST)

Hi, clispers.

I suppose this is an error in the documentation (file impnotes.html):
-------------------------------------------------------------------
(use-package :regexp)
(sexp ((h (make-hash-table :test #'equal :size 10)) (n 0))
  (with-open-file (f "/etc/passwd")
    (with-loop-split (s f ":")
      (let ((sh (seventh s)))
        (if (gethash sh h)
            (incf (gethash sh h))
            (setf (gethash sh h) 1)))))
  (with-hash-table-iterator (i h)
    (loop (multiple-value-bind (r k v) (i)
            (unless r (return))
            (format t "[~d] ~s~30t== ~5:d~%" (incf n) k v)))))
---------------------------------------------------------------

I believe the right version should be with "let" instead of "sexp".

--evt

---

From: Sam Steingold <[email-masked]>
Date: 31 Jul 2001 18:35:16 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] regexp example in the doc"
> * Sent on Tue, 31 Jul 2001 17:15:53 +1100 (VLAST)
> * Honorable "Evgeni V. Trifonov" <[email-masked]> writes:
>

fixed in the CVS - thanks!

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
My other CAR is a CDR.