Subject: [clisp-list] DELETE-FILE & TRUENAME

From: Sam Steingold <[email-masked]>
Date: Thu Oct 10 09:41:02 2002

DELETE-FILE in CLISP deletes the truename of the file, so you cannot
delete a symbolic link, only its target:

$ touch foo
$ ln -s foo bar
$ clisp -q -norc -x '(delete-file "foo")
$ ls
foo
$

i.e., `bar' is gone, but `foo' is still there.

I think it is better to remove the symlink.
(the current behavior is always available with (DELETE-FILE (TRUENAME x))).

comments?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
"A pint of sweat will save a gallon of blood."          -- George S. Patton

---

From: Arseny Slobodjuck <[email-masked]>
Date: Fri Oct 11 03:42:04 2002

Hello Sam,

> comments?

I think same. I will do that if there will no objections.

-- 
Best regards,
 Arseny

---

From: Sam Steingold <[email-masked]>
Date: Fri Oct 11 09:00:10 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] DELETE-FILE & TRUENAME"
> * Sent on Fri, 11 Oct 2002 11:07:48 -0400
> * Honorable Marco Antoniotti <[email-masked]> writes:
>

> Is there a consensus among other implementors about what to do in this
> case?

CMUCL removed the symlink, not the target.

can someone try LW and ACL?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Yeah, yeah, I love cats too... wanna trade recipes?

---

From: Pascal Bourguignon <[email-masked]>
Date: Fri Oct 11 09:33:02 2002

> From: Sam Steingold <[email-masked]>
> Date: 11 Oct 2002 12:00:11 -0400
> 
> > > > I think it is better to remove the symlink.  (the current
> > > > behavior is always available with (DELETE-FILE (TRUENAME x))).
> 
> > Is there a consensus among other implementors about what to do in
> > this case?
> 

emacs too.

-- 
__Pascal_Bourguignon__                   http://www.informatimago.com/
----------------------------------------------------------------------
 The name is Baud,...... James Baud.

---

From: Edi Weitz <[email-masked]>
Date: Fri Oct 11 09:50:05 2002

> > can someone try LW and ACL?

LW 4.2.7, ACL 6.2, and SBCL 0.7.6 on Linux all removed the symlink.

Edi.