Subject: [clisp-list] clisp on Mac OS X Server

From: Robert Gottlieb <[email-masked]>
Date: Mon, 03 Apr 2000 14:14:55 -0700

Hi,

Has anyone successfully compiled Clisp on Mac OS X Server?  If so, could you please email me a tar or some binary, or tell me how?

thanks,

Robert Gottlieb
[email-masked]

---

From: Bruno Haible <[email-masked]>
Date: Mon, 3 Apr 2000 23:25:02 +0200 (MET DST)

> Has anyone successfully compiled Clisp on Mac OS X Server?  If so, could
> you please email me a tar or some binary, or tell me how?

clisp version 2000-03-06 should build on MacOS X Server. There are a few
quirks mentioned in the unix/PLATFORMS file, however:

! On Apple PowerPC running MacOS X Server:
! 
! The /bin/sh shell has at least two bugs which make it unusable for the
! configuration scripts. As a workaround, you have to set the environment
! variable CONFIG_SHELL to "/bin/bash", and start
! "$CONFIG_SHELL ./configure ..." instead of "./configure ...".
! 
! The default stack size limit is 512 KB, which is too small for bootstrapping
! CLISP. Even 1 MB is too small. Try "ulimit -S -s 8192" before starting
! "make".
! 
! Remove all optimization options ("-O", "-O2") from the CC and CFLAGS
! variables in the Makefile. Apple's cc crashes when compiling eval.d with
! optimization.

For this latter reason, binary packages are not on our ftp server: I wait
until they provide a reasonable C compiler.

Bruno