Subject: [clisp-list] Problem compiling CLISP under MacOS X

From: Rainer Joswig <[email-masked]>
Date: Sun, 8 Apr 2001 02:18:32 +0200

Hi,

I've tried to compile CLISP 2.25.1 under MacOS X (10.0.1 4L7) with
Apple's developer tools installed.

I did:

[localhost:/Lisp/CLisp/clisp-2.25.1] joswig% ./configure darwin-clisp
executing darwin-clisp/configure ...
creating cache ./config.cache
checking for gcc... no
checking for cc... cc
checking whether the C compiler (cc  ) works... yes
checking whether the C compiler (cc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking how to run the C preprocessor... cc -O -E -traditional-cpp
checking for AIX... no
checking whether using GNU C... yes
checking whether using C++... no
checking whether using ANSI C... yes
checking whether CPP likes indented directives... yes
checking whether CPP likes empty macro arguments... yes
checking for underscore in external names... yes
checking for ranlib... ranlib
checking for a BSD compatible install... /usr/bin/install -c
checking how to copy files... cp -p
checking how to make hard links... ln
checking whether ln -s works... yes
checking how to make hard links to symlinks... ln
checking for groff... groff
checking for getpwnam... yes
checking for DYNIX/ptx libseq or libsocket... no
checking whether gethostent requires -lnsl... no
checking whether setsockopt requires -lsocket... no
checking whether CC works at all... yes
checking host system type... powerpc-apple-darwin1.3

...

creating Makefile
creating config.h
case "darwin1.3" in \
  aix3*) syntax=aix.old;; \
  aix*) syntax=aix.new;; \
  linux*) syntax=linux;; \
  *) syntax=sysv4;; \
esac; \
/bin/sh ./libtool --mode=compile cc -O -traditional-cpp -x none -c ../../ffcall/avcall/avcall-rs6000-${syntax}.s ; \
cp avcall-rs6000-${syntax}.lo avcall-rs6000.lo ; rm -f avcall-rs6000-${syntax}.lo ; \
if test -f avcall-rs6000-${syntax}.o; then mv avcall-rs6000-${syntax}.o avcall-rs6000.o; fi
cc -O -traditional-cpp -x none -c ../../ffcall/avcall/avcall-rs6000-sysv4.s -o avcall-rs6000-sysv4.o
avcall-rs6000.c:3:Expected comma after segment-name
avcall-rs6000.c:3:Rest of line ignored. 1st junk character valued 32 ( ).
avcall-rs6000.c:5:Unknown pseudo-op: .type

...

After some more errors in this file it then fails...

Any ideas?

Rainer Joswig

-- 

Rainer Joswig
Email: mailto:[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: 12 Apr 2001 14:29:17 -0400

Hi,

> * In message <a05100901b6f55b62d989@[194.163.195.67]>
> * On the subject of "[clisp-list] Problem compiling CLISP under MacOS X"
> * Sent on Sun, 8 Apr 2001 02:18:32 +0200
> * Honorable Rainer Joswig <[email-masked]> writes:
>

this means that FFI has not been ported to MacOS X yet - this should not
prevent you from building the rest of CLISP.

1. specify --with-no-dynamic-ffi to configure
2. make sure that /bin/sh is present and good (or set CONFIG_SHELL to
/bin/ksh or /bin/bash).

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Profanity is the one language all programmers know best.