Subject: [clisp-list] command-oriented-history with readline in CLISP

From: Sam Steingold <[email-masked]>
Date: 27 Jun 2001 15:23:12 -0400

bash has a variable, command_oriented_history, which controls whether
$ for x in *
> do echo $x
> done
$

is saved in history as one line or 3.
CLISP always saved 3 lines, which was bad.
now it will save one line.
the question is: do we need a similar backwards-compatibility option?
IOW, are there people around who _like_ the current behavior better than
the proposed one?
speak up or you will be stuck with "command_oriented_history" in the
next release.
[bash replaces newlines with "; " -- nothing like this will be done]

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
The early worm gets caught by the bird.

---

From: Peter Wood <[email-masked]>
Date: Thu, 28 Jun 2001 19:15:12 +0200

> bash has a variable, command_oriented_history, which controls whether
 ...<3 bash lines cut>
> the question is: do we need a similar backwards-compatibility option?

It's a _big_ improvement to have the history saved as 1 line. Thanks.
I personally don't need the backwards-compatibility option.  Does
paren matching work after pressing return?

Peter

---

From: Reini Urban <[email-masked]>
Date: Fri, 29 Jun 2001 08:03:28 -0100

how about comments?

"^\s*;+(.*)" => ? 
  "#|\1|#" or just ""

-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/