Subject: [clisp-list] Re: new DIRECTORY argument :IF-DOES-NOT-EXIST

From: Arseny Slobodjuck <[email-masked]>
Date: Tue Oct 15 00:30:01 2002

Hi,

Sunday, October 13, 2002, 1:50:29 AM, you wrote:

> comments are welcome

>The  argument  :IF-DOES-NOT-EXIST  controls  the  treatment  of links
>pointing to non-existent files and can take the following values:
>
>:DISCARD (default)
>discard the bad directory entries
>:ERROR
>SIGNAL  an  ERROR  on  bad directory entries (this corresponds to the
>default behavior of DIRECTORY in CMU CL)
>:KEEP
>keep  bad  directory  entries  in  the  returned  list  (this roughly
>corresponds to the (DIRECTORY ... :TRUNAMEP NIL) call in CMU CL)

What to do when :FULL T and :IF-DOES-NOT-EXIST :KEEP ?
Don't do :FULL ?

-- 
Best regards,
 Arseny

---

From: Sam Steingold <[email-masked]>
Date: Tue Oct 15 08:35:04 2002

> * In message <[email-masked]>
> * On the subject of "Re: new DIRECTORY argument :IF-DOES-NOT-EXIST"
> * Sent on Tue, 15 Oct 2002 18:28:59 +1000
> * Honorable Arseny Slobodjuck <[email-masked]> writes:
>

do :FULL for all existing files.
i.e., (delete-if #'consp (directory X :if-does-not-exist :keep :full t))
will return the list of symlinks that cannot be resolved.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Binaries die but source code lives forever.