Subject: [clisp-list] build problem on OpenBSD (was Re: bootstrapping with CLISP)

From: William Harold Newman <[email-masked]>
Date: Tue, 31 Jul 2001 07:55:10 -0500

(Since this is evidently a real problem, not just a temporary 
problem with the current CVS state or something, I'll start discussing
it on the clisp mailing list instead of by private email.

On Mon, Jul 30, 2001 at 04:17:14PM -0400, Sam Steingold wrote:
> > I'm having some sort of dumb problem building CLISP, so I've gotten
> > nowhere bootstrapping SBCL under it.
> 
> :-)
> 
> > Before I tried working on it myself, I mentioned it on the sbcl-devel
> > mailing list, and Martin Atzmueller replied with some information.
> > I've included a copy below in case you don't read sbcl-devel.
> 
> no, I do not read sbcl-devel mailing list, but he CCed it to me.
> I would appreciate it if you CCed clisp-list all messages related to
> CLISP.  All CLISP bug reports should go there anyway (or the SF bug
> tool, if you wish)
> 
> > When I try to build CLISP on my system (OpenBSD 2.9) from a CVS
> > snapshot I downloaded about an hour ago, I get
> 
> what is a "CVS snapshot"?
> a result of `cvs up`?

Basically, yes. (It was actually a result of "cvs checkout", in this case.)
 
> > $ ./configure
> > ../configure[276]: test: /usr/local/src/clisp: unexpected operator/operand
> 
> this is unusual - I have never seen anything like this before, and I do
> not have an OpenBSD machine to investigate (actually, I have never used
> an OpenBSD box!)
> 
> neither the top-level ./configure, nor ./src/configure (which you should
> never run by have anyway) have a test statement on line 276

In the top-level "configure" file in my version, line 276 is 'fi'. That
'fi' corresponds to an 'if test -n "$srcdir" ; then'. I don't know exactly
how 'sh' does its error reporting but I'd guess that it's complaining about
the 'test' in the leading 'if' statement, or failing that, one of the other
'test' operations inside the 'if'. However, 'if test -n "$srcdir" ; then'
looks pretty reasonable to me, so I have no idea why 'sh' or 'test' would
complain about it.
 
> CLISP builds cleanly out of the box on win32, linux/x86, solaris and
> freebsd - all the machines I have regular access to.
> 
> Could you please investigate?
> 
> 1. get the current CVS CLISP from SF
> 2. do `./configure --build build` in the toplevel directory.

balefire:clisp/ $ cvs update ; beep
U src/readline/CHANGELOG
U src/readline/CHANGES

balefire:clisp/ $ date
Mon Jul 30 16:55:55 CDT 2001
balefire:clisp/ $ ./configure --build build
./configure[276]: test: /usr/local/src/clisp: unexpected operator/operand
./configure[280]: test: /usr/local/src/clisp/build: unexpected operator/operand
./configure[485]: [: /usr/local/src/clisp/build/readline: unexpected operator/operand
./configure[485]: [: /usr/local/src/clisp/build/gettext: unexpected operator/operand
./configure[485]: [: /usr/local/src/clisp/build/termcap: unexpected operator/operand
./configure[485]: [: /usr/local/src/clisp/build/readline: unexpected operator/operand
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/build: is a directory

For good measure, I also went back to another piece of freeware in my 
/usr/local/src/ directory (cgoban-1.9.11) and ran its 'configure' script,
in case I'd somehow messed up my environment or exhausted some resource
or something. But the cgoban script ran without complaint.

I also did a simple experiment to try to check that I wasn't being
tripped up by some OpenBSD-specific quirk of 'sh' syntax parsing:

balefire:clisp/ $ /bin/sh
\h:\W/ $ if test -n 'zoo' ; then echo foo ; fi
foo
balefire:clisp/ $

I also got a fresh copy with

balefire:src/ $ cvs -z3 -d:pserver:[email-masked]:/cvsroot/clisp co clisp

starting about 17:10 CDT, and tried "./configure --build build" again
with the fresh copy. It failed the same way as before.

-- 
William Harold Newman <[email-masked]>
PGP key fingerprint 85 CE 1C BA 79 8D 51 8C  B9 25 FB EE E0 C3 E5 7C

---

From: Sam Steingold <[email-masked]>
Date: 16 Aug 2001 18:26:12 -0400

can someone give me shell access to an OpenBSD box?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
There is an exception to every rule, including this one.

---

From: Sam Steingold <[email-masked]>
Date: Mon Sep 10 07:44:14 2001

> * In message <20010731075510.D23958@rootless>
> * On the subject of "[clisp-list] build problem on OpenBSD (was Re: bootstrapping with CLISP)"
> * Sent on Tue, 31 Jul 2001 07:55:10 -0500
> * Honorable William Harold Newman <[email-masked]> writes:
>
> > > $ ./configure

I suspect a broken shell.
please install /bin/bash and do
$ CONFIG_SHELL=/bin/bash; export CONFIG_SHELL
$ bash ./configure

thanks!

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
non-smoking section in a restaurant == non-peeing section in a swimming pool

---

From: William Harold Newman <[email-masked]>
Date: Mon Sep 10 14:00:02 2001

> $ CONFIG_SHELL=/bin/bash; export CONFIG_SHELL

I tried that, and it didn't work. (See below.)

I'm still very interested in getting the system to boot under CLISP,
but for at least the next week I'll be busy getting sbcl-0.7.0 ready,
and booting under CLISP isn't a must-have feature for that. (I'm trying
to put all the breaks-backwards-compatibility and might-introduce-bugs
and might-break-patches stuff in this release; 0.7.1 and so forth are
fine for incremental changes like booting under CLISP.)

I'm also waiting to hear from someone else who posted on sbcl-devel
last month (?) about work on booting SBCL under CLISP, but hasn't sent
in his patches yet.

So in a while I'll be more motivated to figure out what's going on, 
but for now I'm going to work on other things unless someone just
hands me a no-muss, no-fuss working solution.

balefire:clisp/ $ type bash
bash is /usr/local/bin/bash
balefire:clisp/ $ export CONFIG_SHELL=/usr/local/bin/bash
balefire:clisp/ $ bash ./configure 
./configure: test: too many arguments
./configure: test: too many arguments
./configure: [: /usr/local/src/clisp/src: binary operator expected
./configure: [: /usr/local/src/clisp/src: binary operator expected
./configure: [: /usr/local/src/clisp/src: binary operator expected
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
./configure: [: /usr/local/src/clisp/src: binary operator expected
/usr/local/src/clisp/src
rm: /usr/local/src/clisp/src: is a directory
^C
balefire:clisp/ $ 

-- 
William Harold Newman <[email-masked]>
"Sometimes if you have a cappuccino and then try again it will work OK."
  -- Dr. Brian Reid, 1992, quoted by mjr
"Sometimes one cappucino isn't enough."
  -- mjr = Marcus J. "will do TCP/IP for food" Ranum <[email-masked]>
PGP key fingerprint 85 CE 1C BA 79 8D 51 8C  B9 25 FB EE E0 C3 E5 7C

---

From: Hannah Schröter <[email-masked]>
Date: Tue Sep 11 05:22:02 2001

Hello!

On Mon, Sep 10, 2001 at 03:41:18PM -0500, William Harold Newman wrote:
>[...]

>[... many more errors ...]

Did you try using the clisp from the ports (or if that version is too
old, adapting the port / following the steps of the port)?
/usr/ports/lang/clisp, that is.

Kind regards,

Hannah.
-- 
  Hannah Schröter                Entwicklung          [email-masked]
  Bei Schlund + Partner AG       Erbprinzenstr. 4-12  D-76133 Karlsruhe
This specification allows any of these approaches.  Solving the
Halting Problem is considered extra credit. (draft-showalter-sieve-12.txt)