Subject: [clisp-list] common lisp book

From: Ricardo <[email-masked]>
Date: Wed Apr 7 09:56:14 2004

Hi, i'm trying to learn Common Lisp and i'm trying to find a good book 
for that purpose, i've encountered "Common Lisp The Language 2nd 
edition" of 1989, my doubt is, will the contents of this book work with 
Common Lisp 2.33(since the book is a bit old)?
Thanks in advance.

Ricardo

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 7 10:08:09 2004

> * Ricardo <[email-masked]> [2004-04-07 17:55:43 +0100]:
>
> edition" of 1989, my doubt is, will the contents of this book work
> with Common Lisp 2.33(since the book is a bit old)?

CLISP implements ANSI CL, which is slightly different from the language
described in CLtL2 (which is not suitable as a textbook anyway).
I recommend "ANSI Common Lisp" by Paul Graham as the textbook and the
CLHS as the on-line reference.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Abandon all hope, all ye who press Enter.

---

From: Gene Michael Stover <[email-masked]>
Date: Wed Apr 7 10:25:03 2004

Ricardo,  I add my recommendation to what Sam said (Graham's
"ANSI Common Lisp").  Paul Graham has a personal web site, &
you can get a pointer there to where you can order the book,
if I remember right.  (Google for "Paul Graham".)

gene

   Reply-to: [email-masked]
   Mail-Copies-To: never
   From: Sam Steingold <[email-masked]>
   Mail-Followup-To: [email-masked], Ricardo
    <[email-masked]>
   X-Spam-Score: 0.0 (/)
   X-Spam-Report: Spam Filtering performed by sourceforge.net.
	   See http://spamassassin.org/tag/ for more details.
	   Report problems to http://sf.net/tracker/?func=add&group_id=1&atid=200001
   Sender: [email-masked]
   X-Original-Date: Wed, 07 Apr 2004 13:07:16 -0400
   Date: Wed, 07 Apr 2004 13:07:16 -0400

   -------------------------------------------------------
   This SF.Net email is sponsored by: IBM Linux Tutorials
   Free Linux tutorial presented by Daniel Robbins, President and CEO of
   GenToo technologies. Learn everything from fundamentals to system
   administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
   _______________________________________________
   clisp-list mailing list
   [email-masked]
   https://lists.sourceforge.net/lists/listinfo/clisp-list

---

From: Ricardo <[email-masked]>
Date: Sat Apr 10 12:24:01 2004

> CLHS as the on-line reference.
Thanks