Subject: [clisp-list] rename-file not calling translate-logical-pathname ?

From: [email-masked] (Don Cohen)
Date: Sun Feb 1 13:15:03 2004

This is clisp 2.31 on linux
I do (rename-file x y)
where y is something like (logical-pathname "PERSIST:FOO.BAR")
and get files with names like "PERSIST:FOO.BAR"
rather than what I want, which is something like
"persistent-data/foo.bar". 

Shouldn't rename translate the name?
The spec does say that rename returns a logical pathname in this case
and that the new name of the file is supposed to be that value, but
of course the new file name can't actually be a logical pathname at
all.

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 1 17:31:01 2004

> * Don Cohen <[email-masked]> [2004-02-01 13:13:34 -0800]:
>
> Shouldn't rename translate the name?  The spec does say that rename
> returns a logical pathname in this case and that the new name of the
> file is supposed to be that value, but of course the new file name
> can't actually be a logical pathname at all.

I do not observe this with the current CVS on w2k.

is <[email-masked]> a real address?
if not, please make it more obvious.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
All extremists should be taken out and shot.

---

From: [email-masked] (Don Cohen)
Date: Sun Feb 1 17:40:05 2004

> I do not observe this with the current CVS on w2k.

How about linux?
Has the code been fixed recently?

 > is <[email-masked]> a real address?
Sure.  Why do you doubt it?

 > if not, please make it more obvious.
What does that mean?

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 1 18:17:11 2004

> * Don Cohen <[email-masked]> [2004-02-01 17:38:19 -0800]:

I do not have a working clisp on linux (my fedora coredump1 does not let
me build either clisp or emacs.)

I hope other linux users will help us here.

> Has the code been fixed recently?

my version is separated from yours by 1.5 years.
lots of things changed.

> Sure.  Why do you doubt it?
"xx" that do not make sense.

>  > if not, please make it more obvious.
I thought that was one of those detestable "[email-masked]" addresses.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
(let ((a "(let ((a %c%s%c)) (format a 34 a 34))")) (format a 34 a 34))

---

From: [email-masked] (Don Cohen)
Date: Sun Feb 1 19:18:02 2004

> my version is separated from yours by 1.5 years.
More like .5
This is actually later than .31 - built from CVS as of ~Sept
including my write-byte-seq :no-hang modifications

 > I thought that was one of those detestable "[email-masked]" addresses.

Well, yes it is a nospam address - now that this one is going to be
out on the mailing lists I'll probably start getting spam sent to it
and then change it again.