Subject: [clisp-list] gnuplot

From: "Rehm, Keith" <[email-masked]>
Date: Thu Dec 27 13:59:02 2001

Hello,

I am using CLISP-2.27 on Win2K machine.

I have made CLOCC and would like to run gnuplot from CLISP.

I set:

(defcustom *gnuplot-path* simple-string
  #+(or win32 mswindows)
  "c:\\documents and settings\\keithr\\desktop\\gp371w32\\wgnupl32.exe"
;;  "c:/gnu/gp371w32/wgnupl32.exe"
  ;; "c:/bin/gnuplot/wgnuplot.exe"
  #+unix (if (string-equal (machine-type) "linux")
             "/usr/bin/gnuplot" "/usr/local/bin/gnuplot")
  "*The path to the windows gnuplot executable.")

and 

(defcustom *gnuplot-path-console* simple-string
  "c:\\documents and settings\\keithr\\desktop\\gp371w32\\pgnuplot.exe"
;;(defcustom *gnuplot-path-console* simple-string
"c:/gnu/gp371w32/pgnuplot.exe"
  "*The path to the console gnuplot executable.")

in gnuplot.lisp.

I made clocc using the lisp method with CLISP -- it seemed to be successful

Running:

[16]> (setq gp-stream (cllib:make-plot-stream :print)) 

[%s:14330]
*** - Win32 error 193 (ERROR_BAD_EXE_FORMAT): %1 is not a valid Win32
application.
1. Break [17]>

I am uncertain how to actually execute gnuplot commands but it seems one
needs to open a stream....

How do I run, for example:

	gnuplot> plot sin(x) w l

from within CLISP?

Perhaps this should be directed to CLOCC list.....

Thank you,
Keith

---

From: Sam Steingold <[email-masked]>
Date: Tue Jan 1 16:13:04 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] gnuplot"
> * Sent on Thu, 27 Dec 2001 15:58:22 -0600
> * Honorable "Rehm, Keith" <[email-masked]> writes:
> 
> I set:

it's better not to modify <gnuplot.lisp> but set these variables in
your ~/.clisprc.

> [16]> (setq gp-stream (cllib:make-plot-stream :print)) 
this is for defining new kinds of plot streams, not for UI.

> 	gnuplot> plot sin(x) w l

(plot-functions (list (cons 'sine #'sin) (cons 'cosine #'cos)) 0 pi 100
                :legend '(:bot :left :box) :grid t :plot :wait)

if a function is marked with ";;;###autoload", it's for you to use.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Those who value Life above Freedom are destined to lose both.