Subject: [clisp-list] defsystem: a system which depends on another system

From: Sam Steingold <[email-masked]>
Date: 08 Jan 2001 14:36:09 -0500

Suppose I have a system which depends on some files in another system.
is there a way to specify this in *.system?
I mean, is there an easier alternative to

$ cd sys1
$ make system
$ cd ../sys2
$ make system

etc?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Do not worry about which side your bread is buttered on: you eat BOTH sides.

---

From: Raymond Toy <[email-masked]>
Date: 08 Jan 2001 15:07:12 -0500

>>>>> "Sam" == Sam Steingold <[email-masked]> writes:

    Sam> Suppose I have a system which depends on some files in another system.
    Sam> is there a way to specify this in *.system?
    Sam> I mean, is there an easier alternative to

    Sam> $ cd sys1
    Sam> $ make system
    Sam> $ cd ../sys2
    Sam> $ make system

    Sam> etc?

The docs for defsystem says you can make systems depend on other
systems.

(defsystem sys2
  (:depends-on "sys1")
  ...)

or something like that.

Never really tried it though.

Ray

---

From: Sam Steingold <[email-masked]>
Date: 08 Jan 2001 16:12:04 -0500

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] defsystem: a system which depends on another system"
> * Sent on 08 Jan 2001 15:07:12 -0500
> * Honorable Raymond Toy <[email-masked]> writes:
>

yeah - I tried that already:
it cannot find the "sys1" dependency even though I load sys1.system
within sys2.system!

> Never really tried it though.

it shows :-)

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
I don't have an attitude problem. You have a perception problem.

---

From: Marco Antoniotti <[email-masked]>
Date: Mon, 8 Jan 2001 17:28:24 -0500

> X-Envelope-To: 	<[email-masked]>
> Reply-To: [email-masked]
> Mail-Copies-To: never
> From: Sam Steingold <[email-masked]>
> User-Agent: Gnus/5.0807 (Gnus v5.8.7) Emacs/20.7
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <http://lists.sourceforge.net/mailman/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <http://lists.sourceforge.net/mailman/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://lists.sourceforge.net/archives//clisp-list/>
> Date: 08 Jan 2001 14:36:09 -0500
> Content-Length: 657
> 

They shouldn't. If this is the case the dependency should be on the
whole "other" system.

> I mean, is there an easier alternative to

Apart from the above comment, this is one of the subtle semantics
issues that should be resolved prior to implementation.  At the time
of this writing MK-DEFSYSTEM-3.2i pretty much forces you to do what
you say you do.

Cheers

-- 
Marco Antoniotti =============================================================
NYU Bioinformatics Group			 tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                          fax  +1 - 212 - 995 4122
New York, NY 10003, USA				 http://galt.mrl.nyu.edu/valis
             Like DNA, such a language [Lisp] does not go out of style.
			      Paul Graham, ANSI Common Lisp

---

From: Marco Antoniotti <[email-masked]>
Date: Mon, 8 Jan 2001 18:04:53 -0500

As an aside,

the clocc-* and clisp-* postings have started to appear as coming from
a number of different addresses: [email-masked],
[email-masked] and so on.

Is this a Sourceforge quirkiness or it is something that people do?
It is messing up my .procmailrc. :)

Cheers

---

From: Reini Urban <[email-masked]>
Date: Tue, 09 Jan 2001 03:12:05 +0200

> [email-masked] and so on.

<[email-masked]> and <[email-masked]> for me so
far.
my new filter is only '^clisp-list@' now.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/autocad/news/faq/autolisp.html

---

From: Hannu Koivisto <[email-masked]>
Date: 09 Jan 2001 10:06:42 +0200

Sam Steingold <[email-masked]> writes:

| > * Honorable Raymond Toy <[email-masked]> writes:
...
| > The docs for defsystem says you can make systems depend on other
| > systems.
| > 
| > (defsystem sys2
| >   (:depends-on "sys1")
| >   ...)
| > 
| > or something like that.
| 
| yeah - I tried that already:
| it cannot find the "sys1" dependency even though I load sys1.system
| within sys2.system!

Try

(defsystem sys2
  ...
  :depends-on (sys1)
  ...)

instead.

I use this feature a *lot* so I know it definitely works.  If it
doesn't for you, then there is something fishy going on :)

-- 
Hannu

---

From: Peter Van Eynde <[email-masked]>
Date: Tue, 9 Jan 2001 20:28:41 +0100

> my new filter is only '^clisp-list@' now.

My .procmail has:

:0 H
* ^List-Id: .*[<].*\.lists\.sourceforge\.net[>]
* ^List-Id: .*[<] *\/[^.]*
$MATCH

and it seems to work...

Groetjes, Peter

-- 
It's logic Jim, but not as we know it. | [email-masked]
"God, root, what is difference?" - Pitr|
"God is more forgiving." - Dave Aronson| http://cvs2.cons.org/~pvaneynd/