Subject: [clisp-list] [announce] CLISP for BeOS

From: Bruno Haible <[email-masked]>
Date: Mon, 3 Apr 2000 18:56:46 +0200 (MET DST)

Binaries and source of CLISP for BeOS 5 are available at

   ftp://clisp.cons.org/pub/lisp/clisp/binaries/i586-beos/

This is based on a snapshot of clisp, but should be as reliable as the
previous 2000-03-06 release.

Part of the work was done in collaboration with Alexis Rivera Rios,
at that time on BeOS 4.5, but we had problems because the gcc shipped
with that BeOS version was not a stable released version of gcc.

When building from source, I encountered a problem: After compilation
of some Lisp file, the command to rebuild the image, of the form

   ./lisp.run ....... -x "(load \"init.lisp\")"

crashes. To fix this, replace lisp.run by a copy of itself (run
"clean lisp.run" - see below), and rerun "make". I would be interested
in hearing whether this problem appears in real use as well, or only
while building clisp.

Enjoy CLISP. I enjoy BeOS.

                     Bruno

====================== /boot/home/config/bin/clean =======================
#!/bin/sh
# Usage: clean executable
if test $# != 1; then
  echo "Usage: clean executable" 1>&2
  exit 1
fi
cp -p "$1" "$1.tmp"
mv "$1.tmp" "$1"
==========================================================================

---

From: Travis Seymour <[email-masked]>
Date: Mon, 03 Apr 2000 13:06:23 -0500

Great! I got some diffs from Alexis a little while ago and succeeded in 
reproducing the problems she (I apologize if Alexis is a he!!??) had but 
could not make much progress.  I'm glad for both of us that you don't think 
it was our fault!
Thanks for working on this, both of you.

Travis

>   echo "Usage: clean executable" 1>&2

------------------------------------------------------------------------------
Travis L. Seymour               4443 East Hall
University of Michigan          734-764-4488
Cognitive Psychology            734-763-7480 (fax)
       homepage: http://www.umich.edu/~nogard
------------------------------------------------------------------------------