Subject: [clisp-list] clisp-2.32 vs. asdf.lisp

From: Joe Corneli <[email-masked]>
Date: Sun Feb 29 23:40:03 2004

I had asdf.lisp from cclan working with clisp-2.29, but now

[~]% clisp
clisp
STACK depth: 16367
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2003

;; Loading file /Users/arided/.clisprc ...
;;  Loading file /usr/local/src/clocc/src/port/ext.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/ext.lisp
;;  Loading file /usr/local/src/clocc/src/port/gray.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/gray.lisp
;;  Loading file /usr/local/src/clocc/src/port/path.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/path.lisp
;;  Loading file /usr/local/src/clocc/src/port/proc.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/proc.lisp
;;  Loading file /usr/local/src/clocc/src/port/shell.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/shell.lisp
;;  Loading file /usr/local/src/clocc/src/port/sys.lisp ...
;;  Loaded file /usr/local/src/clocc/src/port/sys.lisp
;;  Loading file /usr/local/src/asdf/asdf.lisp ...
*** - Error: ~:@> not implemented
Current point in control string:
  ~@<erred while invoking ~A on ~A~@:>
  |

---

From: "Steven E. Harris" <[email-masked]>
Date: Mon Mar 1 16:23:06 2004

> I had asdf.lisp from cclan working with clisp-2.29, but now

See this comp.lang.lisp thread¹ from January for a workaround.

Footnotes: 
¹ http://groups.google.com/groups?threadm=sqad4rof0k.fsf%40lambda.dyndns.org

-- 
Steven E. Harris        :: [email-masked]
Raytheon                :: http://www.raytheon.com