Subject: [clisp-list] REGEXP problem with CLISP 2.26

From: Aurelio Bignoli <[email-masked]>
Date: Sun, 27 May 2001 16:23:00 +0200

I just compiled CLISP 2.26 with the REGEXP module and I have the
following problem with it:

[1]> (lisp-implementation-version)
"2.26 (released 2001-05-23) (built on dalet.fauser.it [192.168.1.2])"
[2]> (regexp:match "abcd" "abcdefgh")

*** - FUNCALL: the function REGEXP::FINALIZE is undefined
1. Break [3]> 

The error seems to be in the function REGEXP-COMPILE in regexp.lisp:
FINALIZE is now in the EXT package.

Ciao,
Aurelio

---

From: Sam Steingold <[email-masked]>
Date: 27 May 2001 11:18:02 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] REGEXP problem with CLISP 2.26"
> * Sent on Sun, 27 May 2001 16:23:00 +0200
> * Honorable Aurelio Bignoli <[email-masked]> writes:
>

thanks for the report - I just fixed it.
please get the latest CLISP from CVS.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Apathy Club meeting this Friday.  If you want to come, you're not invited.

---

From: Bruce <[email-masked]>
Date: Mon, 28 May 2001 07:45:08 +0800

> FINALIZE is now in the EXT package.

But the clisp.sourceforge.net says the latest version is 2.25.1
(2001-04-06). And it's OK on 2.25.1.

-- 
You will be audited by the Internal Revenue Service.

---

From: Sam Steingold <[email-masked]>
Date: 28 May 2001 11:07:31 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] REGEXP problem with CLISP 2.26"
> * Sent on Mon, 28 May 2001 07:45:08 +0800
> * Honorable Bruce <[email-masked]> writes:
>

2.26 was released on 2001-05-23.
I just fixed the homepage - it will reflect it tomorrow

Live free or die.