Subject: [clisp-list] nclx for clisp install problem

From: "isaac councill" <[email-masked]>
Date: Fri, 27 Apr 2001 10:14:51 -0400

Hello,

I'm not sure if this is the right place for this question, but I did not know where else to go.  I am in need of a working clisp/clx/garnet on x86 Linux but I cannot seem to get nclx working properly (mit-clx is even more problematic).  It compiles fine but complains that there is no package XLIB.  Do any of you know where I might be able to find this XLIB package?

thank you,
Isaac Councill

---

From: Sam Steingold <[email-masked]>
Date: 01 May 2001 12:10:52 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] nclx for clisp install problem"
> * Sent on Fri, 27 Apr 2001 10:14:51 -0400
> * Honorable "isaac councill" <[email-masked]> writes:
>
> I'm not sure if this is the right place for this question, but I did
> not know where else to go.

this is the right place to ask the question.

> I am in need of a working clisp/clx/garnet on x86 Linux but I cannot
> seem to get nclx working properly (mit-clx is even more problematic).
> It compiles fine but complains that there is no package XLIB.  Do any
> of you know where I might be able to find this XLIB package?

You did not give us enough information.  Sorry.

Where did you get the sources?
Is it the release (2.25.1)?  CVS (pre-2.26)?
What did you do to compile CLISP?
what is the exact error message you are getting
(and what exactly did you do to get it)?

Thanks.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Oh Lord, give me the source code of the Universe and a good debugger!

---

From: Peter Wood <[email-masked]>
Date: Wed, 2 May 2001 05:59:31 +0200

> I'm not sure if this is the right place for this question, but I did not know where else to go.  I am in need of a working clisp/clx/garnet on x86 Linux but I cannot seem to get nclx working proper…

Hi

If you have compiled CLISP correctly, specifying the clx module to
compile, you should not get the message.  Are you starting CLISP with
"clisp -K full" ?  The default is to use the base system, which does
not include the modules.

Regards,
Peter

---

From: "isaac councill" <[email-masked]>
Date: Sat, 28 Apr 2001 11:16:47 -0400

I disovered yesterday that I was overlooking something pretty obvious.  I
needed to load "clx-preload.lsp" first which makes the XLIB package (now I
can get the demo qix to work).  This is not to say that my problem is
solved, however; I still cannot get garnet to load.
    When I load "garnet-loader.lisp" after I load
"garnet-prepare-compile.lisp" and "clx-preload.lsp" it loads garnet but
after it says "loading file .../clx.lsp" I get the error message:

***-SYMBOL-FUNCTION: undefined function CLOSE-DOWN-MODE-SETTER
Break XLIB[10]:

The line in clx.lsp that uses CLOSE-DOWN-MODE-SETTER is:

(setf
    (fdefinition '(SETF CLOSE-DOWN-MODE))     #'CLOSE-DOWN-MODE-SETTER

and that is the first in a series of lines following the above pattern, all
no doubt would produce similar error messages if loaded.  I don't know yet
if I am just missing code (whether it is not on my machine or if I am
overlooking something else) or if the XLIB package is not doing its thing.
Advice would be appreciated.
    To answer your previous questions regarding my clisp, I am using clisp
version 2000-03-06.  I did not have to do anything strange to compile it,
just follow the unix directions (I think those are standard in the different
clisp versions - forgive me if I am wrong).  I did edit the makefile as
instructed to build nclx instead of doing the build separately.

Thank you,
Isaac Councill

----- Original Message -----
From: Sam Steingold <[email-masked]>
To: isaac councill <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, May 01, 2001 12:10 PM
Subject: Re: [clisp-list] nclx for clisp install problem

> _______________________________________________
> clisp-list mailing list
> [email-masked]
> http://lists.sourceforge.net/lists/listinfo/clisp-list
>

---

From: Sam Steingold <[email-masked]>
Date: 02 May 2001 13:10:19 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] nclx for clisp install problem"
> * Sent on Sat, 28 Apr 2001 11:16:47 -0400
>     To answer your previous questions regarding my clisp, I am using
> clisp version 2000-03-06.  

The fact that you are _loading_ clx.lsp and clx-preload.lsp means that
you are doing something very wrong.

Please follow these steps:

1. download CLISP 2.25.1 (2001-04-06)
2. build it with this command:
   $ ./configure --with-module=clx/new-clx --build build-dir
3. install it with this command:
   # cd build-dir; make install
4. run it like this to build garnet (or better follow garnet
   instructions - I don't use it!):
   $ clisp -K full -norc -i garnet-prepare-compile.lisp

CLISP builds 2 "linking sets" - "base" and "full".  "base" has just the
bare-bones CLISP, while "full" contains all the modules you specified
(like nclx in my example above).  You should _NOT_ load modules at run
time, instead you should use the "full" linking set.

If you lack root privileges and cannot install CLISP, you can still run
the full image using this command:

FOO=/usr/local/src/clisp/build-dir; # whatever
${FOO}/full/lisp.run -B ${FOO} -M ${FOO}/full/lispinit.mem

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
main(a){printf(a,34,a="main(a){printf(a,34,a=%c%s%c,34);}",34);}