Subject: [clisp-list] Need help building 2.28 on NetBSD-1.5.3/sparc

From: Jon Buller <[email-masked]>
Date: Mon Jun 24 10:34:02 2002

2.27 did something really similar, but here's what 2.28
does first.

     gcc -g -O2 -I. -I../../ffcall/avcall -c ../../ffcall/avcall/minitests.c
     /bin/sh ./libtool --mode=link gcc -g -O2 -x none minitests.o libavcall.la -o minitests
     gcc -g -O2 -x none minitests.o -o minitests  ./.libs/libavcall.a
     ./minitests > minitests.out
     uniq -u < minitests.out > minitests.output.sparc-unknown-netbsdelf1.5.3.
     test '!' -s minitests.output.sparc-unknown-netbsdelf1.5.3.
     *** Error code 1
     
     Stop.
     
     To continue building CLISP, the following commands are recommended
     (cf. unix/INSTALL step 4):
         cd netbsd-gcc
         ./makemake  --with-readline --with-gettext > Makefile
         make config.lisp
         vi config.lisp
         make
         make check

minitests.output.sparc-unknown-netbsdelf1.5.3. contains this:

     Int f(Int,Int,Int):({1},{2},{3})->{6}
     Int f(Int,Int,Int):({1},{2},{3})->{84552}
     J f(J,int,J):({47,11},2,{73,55})->{120,68}
     J f(J,int,J):({47,11},2,{73,55})->{84552,131072}

Any hints on how to track this down?  Just ignoring the problem
just generates a core file when doing the make later on.

Jon

---

From: Will Newton <[email-masked]>
Date: Mon Jun 24 15:38:03 2002

> 2.27 did something really similar, but here's what 2.28

I believe this is fixed in CVS. 

> just generates a core file when doing the make later on.

This is the more serious problem, which I am not sure how to fix.

---

From: Jon Buller <[email-masked]>
Date: Mon Jun 24 17:04:15 2002

> I believe this is fixed in CVS. 

The current CVS sources (20020624 @ about 1500 GMT-0800)  have this
one about half solved.  Provided I understand correctly that
output of "minitests | uniq -u" should be zero length.
minitests.output.sparc-unknown-netbsdelf1.5.3. now contains half
the number of lines that it did before:

     Int f(Int,Int,Int):({1},{2},{3})->{6}
     Int f(Int,Int,Int):({1},{2},{3})->{-268439644}

I'm using egcs-1.1.2 if it matters. I found a message in the archive
about what I assume is the difference between 2.28 and the cvs
sources WRT my problem, and when I poked into the configure script,
I guessed it was an optimizer bug with the -O2 flag, rather than
something caused by -g unless the two flags interact somehow, which
is reasonably possible.  I assume this one is similar, but for a
different test in the configure script.  Just not sure which one.

> This is the more serious problem, which I am not sure how to fix.

Well, I may think about it if I get there... I hope it magically
goes away before then... 8^)

Jon

---

From: Sam Steingold <[email-masked]>
Date: Tue Jun 25 06:28:05 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Need help building 2.28 on NetBSD-1.5.3/sparc "
> * Sent on Mon, 24 Jun 2002 17:03:53 -0700
> * Honorable Jon Buller <[email-masked]> writes:
>
> I'm using egcs-1.1.2 if it matters.

can you upgrade to a mainstream GCC distribution, like 2.95 or 3.0 or 3.1?

> goes away before then... 8^)

it won't, unless _you_ track it down.
please configure --without-dynamic-ffi --with-debug.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
We are born naked, wet, and hungry.  Then things get worse.