Subject: [clisp-list] build fails on MacOS 10.1

From: Eric Marsden <[email-masked]>
Date: Thu Oct 18 11:17:09 2001

Hi,

I tried compiling version 2.27 on MacOS 10.1, with the Apple Developer
Tools installed (gcc 2.95.2). It segfaults while building:

,----
| test -d bindings || mkdir bindings
| ./lisp.run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load \"init.lisp\") (sys::%saveinitmem) (exit)"
| ;; Loading file defseq.lisp ...
| ;; Loading of file defseq.lisp is finished.
| ;; Loading file backquote.lisp ...
| ;; Loading of file backquote.lisp is finished.
| ;; Loading file defmacro.lisp ...
| ;; Loading of file defmacro.lisp is finished.
| ;; Loading file macros1.lisp ...
| ;; Loading of file macros1.lisp is finished.
| ;; Loading file macros2.lisp ...
| ;; Loading of file macros2.lisp is finished.
| ;; Loading file defs1.lisp ...
| ;; Loading of file defs1.lisp is finished.
| ;; Loading file places.lisp ...
| make: *** [interpreted.mem] Segmentation fault
`----

Running lisp.run under gdb (5.0) complains that the
sigsegv_handler_failed in .gdbinit is not defined.

Any hints on how to debug this?

-- 
Eric Marsden                          <URL:http://www.laas.fr/~emarsden/>

---

From: Sam Steingold <[email-masked]>
Date: Thu Oct 18 11:59:18 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] build fails on MacOS 10.1"
> * Sent on Thu, 18 Oct 2001 20:16:24 +0200
> * Honorable Eric Marsden <[email-masked]> writes:
>

I have seen this report, unfortunately.  On a more optimistic note,
others have succeeded (see cvs2.cons.org:/pub/lisp/clisp/binaries/2.27)

if you would like to pursue this issue, please get the CVS version,
set SAFETY=3 in the Makefile and try again.
Your help is appreciated.

> sigsegv_handler_failed in .gdbinit is not defined.

edit .gdbinit :-)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I'm a Lisp variable -- bind me!

---

From: Josh Flowers <[email-masked]>
Date: Thu Oct 18 12:09:29 2001

Well, I'm the one who built the binary for 10.0.4, but I'm afraid I 
don't remember all of the hoops I needed to jump through to get things 
working.  The only thing I remember for sure is needing to remove all of 
the optimization flags that get passed to the compiler (-O, or -O2 I 
think).

I may be revisiting this soon though, since I've just upgraded to 10.1...

> | ./lisp.run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load 
> \"init.lisp\") (sys::%saveinitmem) (exit)"
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list

---

From: Raymond Toy <[email-masked]>
Date: Fri Oct 19 11:41:21 2001

>>>>> "Josh" == Josh Flowers <[email-masked]> writes:

    Josh> Well, I'm the one who built the binary for 10.0.4, but I'm afraid I
    Josh> don't remember all of the hoops I needed to jump through to get things
    Josh> working.  The only thing I remember for sure is needing to remove all
    Josh> of the optimization flags that get passed to the compiler (-O, or -O2
    Josh> I think).

I've built Clisp 2.27 for 10.0.4 too.  (Works just great!  And with
the Rootless XDarwin, and xemacs, it's just like my Sun and Linux box.
Now, if I could just swap the capslock and ctrl keys on the iMac
keyboard....)  I thought the only real problem was to raise the stack
ulimit before compiling?  Anyway, the method required is on this
mailing list somewhere.

    Josh> I may be revisiting this soon though, since I've just upgraded to 10.1...

Me too!

Ray