Subject: [clisp-list] Re:[clisp-list]Q: problem with run-programm in Win32

From: lin8080 <[email-masked]>
Date: Wed Feb 20 16:11:08 2002

Sam Steingold schrieb:
> 
> > * In message <[email-masked]>
> > * On the subject of "[clisp-list] Q: problem with run-program in Win32"
> > * Sent on Tue, 19 Feb 2002 23:05:33 -0500
> > * Honorable [email-masked] writes:
> >
> > I'm trying to use the run-program command to simply run the "dir" command to
> > list the directory, but I must be doing something wrong:

> try
> (shell "dir")
> or
> (run-program "dir" :indirect t)
> or
> (run-program "cmd /c dir")

[1]>  (shell "dir")

[pathname.d:11395]
*** - Win32 error 2 (ERROR_FILE_NIT_FOUND): The system cannot find the
file spec
ified.
1. Break [2]> 

abort

[3]> (run-program "cmd /c dir")

 - same error as first.

[5]> (run-program "dir" :indirect t)

*** -  EVAL/APPLY: keyword :INDIRECT is illegal for #<COMPILED-CLOSURE
RUN-PROGRA
M>.  The possible keywords are (:ARGUMENTS :INPUT :OUTPUT
:IF-OUTPUT-EXISTS :INDI
RECTP)   

1.Break [6]> abort

[7]> (run-program "dir" :indirect t)

Datenträger in Laufwerk C: NEZPEC
Seriennummer des Datenträgers: xxxx-xxxx
Verzeichnis C:\CLISP

.             <DIR>         12-12-01  9:29a .
..            <DIR>         12-12-01  9:29a ..
CLIISP    BAT          135  09-14-01  4:24a CLISP.BAT
EDITOR    EXE       48,640  08-18-00  6:22a EDITOR.EXE
LISP      EXE    1,912,832  05-25-00 12:49p CLISP.EXE
LISPINIT  MEM      885,972  01-02-02 11:07p LISPINIT.MEM
SRC           <DIR>         12-31-01  5:57p SRC
          4 Datei(en)           2,847,579 Bytes
          3 Verzeichnis(se)   142,053,376 Bytes frei 
T

[8]> _

stefan

---

From: lin8080 <[email-masked]>
Date: Wed Feb 20 16:39:06 2002

Hallo again

I forgot the p. Line [7] should look like:

[7]> (run-program "dir" :indirectp t)

but testing the following:

[7]> (run-program "editor.exe" :indirectp t)

This programm must be run under Microsoft Windows.
T

no error. and testing:

[8]> (execute "editor.exe")

opens the Editor.exe in a new window. wow.

stefan