Subject: [clisp-list] clisp on os x

From: sol <[email-masked]>
Date: Fri Sep 13 08:22:59 2002

hi, a little new on the list. one quick question:
How do I get CLISP 2.29 to install on Mac OS X 10.1.4? The 
installation directions simply say to tun the makefile. so i did and 
i got:
localhost:~/clisp-2.29] shorser% make
cc -O  base/modules.o base/lisp.a base/libsigsegv.a base/libintl.a 
base/libiconv.a base/libreadline.a -ldl -o base/lisp.run
/usr/bin/ld: table of contents for archive: base/lisp.a is out of 
date; rerun ranlib(1) (can't load from it)
/usr/bin/ld: table of contents for archive: base/libsigsegv.a is out 
of date; rerun ranlib(1) (can't load from it)
/usr/bin/ld: table of contents for archive: base/libintl.a is out of 
date; rerun ranlib(1) (can't load from it)
/usr/bin/ld: table of contents for archive: base/libiconv.a is out of 
date; rerun ranlib(1) (can't load from it)
/usr/bin/ld: table of contents for archive: base/libreadline.a is out 
of date; rerun ranlib(1) (can't load from it)
/usr/bin/ld: can't locate file for: -ldl
make: *** [base/lisp.run] Error 1
[localhost:~/clisp-2.29] shorser%
I'm guessing that it can't find the file base/lisp.run (although I 
could be wrong, I'm a still a bit new to the unix world). Does anyone 
out there know how to fix this problem?

thanks a lot,
solomon

---

From: Marco Baringer <[email-masked]>
Date: Fri Sep 13 08:42:09 2002

sol <[email-masked]> writes:

> installation directions simply say to tun the makefile. so i did and i
> got:
[snip]
> out there know how to fix this problem?

did you run ./configure?

do you have the development tools and/or fink installed?

-- 
-Marco
Ring the bells that still can ring.
Forget your perfect offering.
There is a crack in everything.
That's how the light gets in.
     -Leonard Cohen