Subject: [clisp-list] Debugging clisp FFI calls into a newly created (c++) DLL

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Jun 3 07:50:13 2004

Hi,
Andreas Thiele wrote:
>Why does the debugger sense access violation while the program run
>standalone works fine?

I have no idea, I never used the MS-VC debugger and about to leave for a month, but if running without an image really works, then you could proceed as follows:
lisp.run
(load"init.fas") ; loads all of what would be in an image
(load "myapp")

This presupposes that you build the clisp sources. (load"init.lisp") without .fas is *not* recommended.

On UNIX, CLISP uses some signals, which annoys interaction with gdb. Thus there's the .gdbrc file which silences the messages. Maybe there's something equivalent for MS-VC? I just don't know.

Regards,
 Jörg Höhle.

---

From: "Andreas Thiele" <[email-masked]>
Date: Thu Jun 3 08:37:03 2004

> ... (load"init.fas") ; loads all of what would be in an image ...
Thanks a lot. This brought me much ahead. Indeed it is strange. At least on WinXP you can't start lisp.exe without an image specified. You'll obtain a message

module `syscalls' requires package POSIX.

and clisp quits. When starting from within the debugger you get

WARNING: No initialization file specified.
Please try: C:\clisp\base\lisp.exe -M lispinit.mem

and are confronted to a prompt. After typing (load "init.lisp") the access violation occurs when loading defs1.lisp. Thus I could narrow the problematic range. I'm sure I will isolate the problem and continue reporting ...

Thanks
Vielen Dank

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Jun 7 16:23:03 2004

Hi, Andreas,

> access violation occurs when loading defs1.lisp. Thus I could narrow
> the problematic range. I'm sure I will isolate the problem
> and continue reporting ...

You can now try to build debug version with MSVC (using the sources in
CVS).

-- 
Best regards,
 Arseny