Subject: [clisp-list] FPU_IEEE and clisp

From: Will Newton <[email-masked]>
Date: Tue Apr 9 18:38:20 2002

clisp sets the FPU mode to _FPU_IEEE (using functions from fpu_control.h). 
Why does it do this, and what specifc features are required? glibc on hppa 
does not have _FPU_IEEE, and it seems that fenv.h is the recommended way top 
control the FPU mode. Maybe if I know what I am trying to do I can set the 
FPU mode through fenv.h instead.

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 10 07:31:28 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] FPU_IEEE and clisp"
> * Sent on Wed, 10 Apr 2002 02:39:07 +0100
> * Honorable Will Newton <[email-masked]> writes:
>
> clisp sets the FPU mode to _FPU_IEEE (using functions from
> fpu_control.h).  Why does it do this, and what specifc features are

CLISP needs full control over the FP operations (i.e., no signals should
be raised, CLISP handles everything.)

> required? glibc on hppa does not have _FPU_IEEE, and it seems that
> fenv.h is the recommended way top control the FPU mode. Maybe if I
> know what I am trying to do I can set the FPU mode through fenv.h
> instead.

please go ahead.
See also
<http://sourceforge.net/tracker/index.php?func=detail&aid=429129&group_id=1355&atid=101355>
for a related bug.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Failure is not an option. It comes bundled with your Microsoft product.

---

From: Will Newton <[email-masked]>
Date: Wed Apr 10 07:39:01 2002

On Wednesday 10 Apr 2002 3:28 pm, you wrote:

> please go ahead.
> See also
> <http://sourceforge.net/tracker/index.php?func=detail&aid=429129&group_id=1
>355&atid=101355> for a related bug.

Hmm, once I get hppa building I'll look into this.