Subject: [clisp-list] Instructions for using new-clx on cygwin

From: Dan Stanger <[email-masked]>
Date: Wed Aug 6 18:11:01 2003

Here is the steps to follow:
You need to download the XFree86 package from cygwin that contains the
include
files,
when you download XFree86, its called XFree86-prog.
When thats installed, make sure the xserver starts with startx.

Then download the clisp-2.30.tar.bz2, which contains the source, and
untar it.
in a cygwin window configure it:
 ./configure --with-module=clx/new-clx test1
follow the makemake instructions.
The build will fail, so go to clx/new-clx, and delete e2d.exe, rebuild
it using the
-g option,
and cd back up and run make again.
That builds clisp, and the executable is also in the package
local.tar.bz2 I sent
CY.
Make sure the new-clx demo programs run.

For garnet, get the garnetx package I sent CY, and untar it,
modify garnet-loader for your paths, execute
(load 'garnet-prepare-compile)
(load 'garnet-loader)
in the running clisp, with X running.
You will have to continue past some locked modules.
Thats it.
Dan

Matt Kaufman wrote:

> Thanks, I'll take a shot at sleeping.
>
> Well, I downloaded the package of Clisp that said it was for Cygwin, and
> that did not seem to have a new-clx package.  Should I download a different
> package?  I tried getting new-clx from the web, but I had trouble finding
> it and I'm not confident I got all the pieces or put them in the right
> spots.  So I guess my questions are, which clisp package should I get, do I
> need any further files (and where would I put them), and then what build
> options should I run on which programs?
>
> I'm sorry for my general cluelessness, I'm rather new to Unix, very new to
> Linux, and completely inexperienced with both Cygwin and Clisp.  Heck, I
> haven't even been using LISP that long, but I got a new job :).
>
> Thanks again for your help.
> -Matt
>
> At 09:36 PM 7/24/2003 -0400, you wrote:
> >Perhaps you should get some sleep;)
> >What seems to be your problem?
> >Were you able to build clisp with new-clx on cygwin and run the test programs?
> >
> >I started with that, the problems were that e2d was broken, so it needs to be
> >compiled with -O,
> >not -O2.
> >Then there are some clisp related problems in garnet, but they have to do with
> >paths, extensions
> >and function coercion.
> >I sent my code to CY, so you can get it from him, he has a fast connection, I
> >have a dial up.
> >Dan
> >Matt Kaufman wrote:
> >
> > > Hi Dan-
> > >
> > > I noticed your post yesterday that you got new-clx running on Win2k with
> > > Cygwin and CLISP 2.30. That is exactly what I've been trying to do for the
> > > last 36 hours, more or less continuously.  I would be thrilled beyond
> > > belief if you would kindly tell me how you did it.  I will be leaving my
> > > high-bandwidth connection after tomorrow, so if you could possibly email me
> > > before then I would be greatly indebted.
> > >
> > > Thanks so much,
> > > Matt Kaufman

---

From: C Y <[email-masked]>
Date: Thu Aug 7 06:43:01 2003

--- Dan Stanger <[email-masked]> wrote:

> local.tar.bz2 I sent CY.

http://prdownloads.sourceforge.net/garnetlisp/local.tar.bz2?download

> For garnet, get the garnetx package I sent CY

http://prdownloads.sourceforge.net/garnetlisp/garnetx.tar.bz2?download

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com