Subject: [clisp-list] augmenting testsuite as bugs are solved (was: Confused by `requir e', *load-paths* and clisp 2.28)

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Mar 27 06:11:04 2002

Hi,

Sam steingold wrote:
> 2. this bug slipped through because, apparently, no pretester uses
>    REQUIRE.  I hope this will inspire you to participate in the next
>    pre-test. 

Wouldn't the better suggestion be the addition of a few lines to the testsuite, so as to automate testing instead of testers? Who'd be willing to do so for the now solved bug in REQUIRE?

To participate, here's something for a patch I submitted (see sourceforge bugtacker):
http://sourceforge.net/tracker/index.php?func=detail&aid=528886&group_id=1355&atid=101355

#+(and CLISP FFI)

(typep #\a 'ffi:foreign-address)
NIL

(multiple-value-list (subtypep 'ffi:foreign-function 'function))
(T T)

ChangeLog	partial test of (SUB-)TYPEP FFI:FOREIGN-* 

Is the testsuite separately maintained (like ffcall)? I heard that several groups had used it (CMUCL people?).

Regards,
	Jorg Hohle.

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 27 07:19:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] augmenting testsuite as bugs are solved (was: Confused by `requir e', *load-paths* and clisp 2.28)"
> * Sent on Wed, 27 Mar 2002 15:09:44 +0100
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> Sam steingold wrote:
> Wouldn't the better suggestion be the addition of a few lines to the
> testsuite, so as to automate testing instead of testers? Who'd be
> willing to do so for the now solved bug in REQUIRE?

whenever I fix a bug, I put a test for it into the testsuite.
nevertheless, it's hard to test _all_ the functionality in the testsuite.
patches are welcome.

> (multiple-value-list (subtypep 'ffi:foreign-function 'function))

thanks.

> Is the testsuite separately maintained (like ffcall)?

no, but there are several derived testsuites, like CLOCC/stc/tools/ansi-test

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
The difference between genius and stupidity is that genius has its limits.