Subject: [clisp-list] clx

From: "Dave Richards" <[email-masked]>
Date: Sat Feb 2 10:17:12 2002

I used configure/make to build the new-clx module in the 2.27 distribution.
After cleaning up the Makefile a bit to use correct paths, I got it to
generate a clx.lib/fas, image.lib/fas and a clx.o, which appear to be the
appropriate build targets.

What I do not understand is how to incorporate these into CLISP.  I tried to
load them in:

[1]> (load 'clx)
;; Loading file /home/dave/clisp-2.27/modules/clx/new-clx/clx.fas ...
*** - SYMBOL-FUNCTION: the function CLOSE-DOWN-MODE-SETTER is undefined
1. Break XLIB[2]>

I'm sure this is a bone-headed question, but what steps follow after
building the module?

	Thanks!

	Dave

---

From: Sam Steingold <[email-masked]>
Date: Sat Feb 2 13:16:13 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clx"
> * Sent on Sat, 2 Feb 2002 10:15:13 -0800
> * Honorable "Dave Richards" <[email-masked]> writes:
>

the modules are in the "full" image:

$ ./configure --with-module=clx/new-clx --build build
$ cd build
$ su make install
$ clisp -K full
> (xlib::....)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
nobody's life, liberty or property are safe while the legislature is in session