Subject: [clisp-list] Control-C no effect on windows 95?

From: "De Visser, Rene" <[email-masked]>
Date: Mon Feb 25 00:49:02 2002

Hello,

CLisp version 2.27

On windows 95 (at least on my computer) control-C does not seem to have any
effect.
My program continues to execute.

Is there some function that I can insert into my program that checks whether
control-C
has been pressed and then goes into the debugger?
(Or can I change some setting on windows 95 or clisp??)

I have tried the same thing on a computer installed with Windows 2000 and
had
no problems. Control-C stopped execution of the program immediately.

Rene.
[email-masked]

---

From: Will Mengarini <[email-masked]>
Date: Wed Feb 27 02:01:03 2002

On Mo 25 Feb 2002 "De Visser, Rene" <[email-masked]> wrote:

> CLisp version 2.27
>
> On windows 95 (at least on my computer) control-C does not
> seem to have any effect.  My program continues to execute.
>
> Is there some function that I can insert into my program that
> checks whether control-C has been pressed and then goes into the
> debugger?  (Or can I change some setting on windows 95 or clisp??)

Nobody else has answered this, so I'll try, though it's been a long
time since I escaped from Mordorsoft.  I vaguely remember that DOS
(and therefore effectively also Windows 95) had a BREAK command:

BREAK ON  => always check for ^C
BREAK OFF => only check during user I/O

The default was BREAK OFF, so I would always put "BREAK ON"
in my autoexec.bat.  It might also work inside a DOS Window
without rebooting, or inside a batch job that then runs Clisp.

--
                 Will Mengarini  <[email-masked]>
One .NET to rule them all, one .NET to find them,
one .NET to bring them all and in the darkness bind them!