Subject: [clisp-list] Unsatisfied symbols: divu_6432_3232_

From: Richard Ray <[email-masked]>
Date: Fri Jan 4 12:44:06 2002

While running make in src I get the following error.

  cc -Ae -Wp,-H1048576 -DUNICODE -DDYNAMIC_FFI  spvw.o  spvwtabf.o  
spvwtabs.o  
spvwtabo.o  eval.o  control.o  encoding.o  pathname.o  stream.o  socket.o  
io.o 
 array.o  hashtabl.o  list.o  package.o  record.o  sequence.o  charstrg.o  
debug
.o  error.o  misc.o  time.o  predtype.o  symbol.o  lisparit.o  foreign.o  
unixau
x.o  arihppa.o  gmalloc.o modules.o libsigsegv.a libintl.a libiconv.a 
libreadlin
e.a libavcall.a libcallback.a  -ltermcap   -o lisp.run
/usr/ccs/bin/ld: Unsatisfied symbols:
   divu_6432_3232_ (code)

Can someone tell from this what library I'm missing?

Richard

---

From: Kaz Kylheku <[email-masked]>
Date: Fri Jan 4 13:07:07 2002

On Fri, 4 Jan 2002, Richard Ray wrote:

> Date: Fri, 4 Jan 2002 14:42:32 -0600
> From: Richard Ray <[email-masked]>
> To: [email-masked]
> Subject: [clisp-list] Unsatisfied symbols: divu_6432_3232_
> 
> 

How convenient of you to mention that this is on HP-UX.
Some of us remember the peculiar compiler options, though. :)

> x.o  arihppa.o  gmalloc.o modules.o libsigsegv.a libintl.a libiconv.a 
           ^^^^

Another clue there.

> Can someone tell from this what library I'm missing?

Guessing by its name, it divides a 64 bit dividend by a 32
bit divisor to make a 32 bit quotient and remainder.

An assembly language function by that name appears in the source file
arihppa.d which corresponds to the arihppa.o object file above.

Note, however, that this function is removed with #if 0 with a German
comment which says ``Das funktioniert noch nicht''. Looks like there is
a little bit of work to do for the HP-UX/PA-RISC platform?

---

From: Richard Ray <[email-masked]>
Date: Fri Jan 4 14:06:02 2002

> Some of us remember the peculiar compiler options, though. :)

HP9000 S800 K200 HP/UX 10.20

> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list

For what it's worth the reference is from lisparit.o

$ nm lisparit.o | grep divu_6432_3232_
divu_6432_3232_     |          |undef |code   |

I tried to attach the full make output but it was too big.