Subject: [clisp-list] Script cannot find package

From: Ng Pheng Siong <[email-masked]>
Date: Thu Dec 19 20:16:02 2002

Hi,

I'm playing with CLISP and Kevin Rosenberg's LML, a HTML generator.

A simple LML program looks like this:

  (in-package :lml)

  (page index
    (head
      (title "Testing"))
    (body
      (h1 "Welcome")))

Running CLISP interactively, with :lml loaded via .clisprc.lisp, the above
works.

When I put the above code into a file, added "#!/usr/local/bin/clisp" to
it, and run it from the shell, I get:

  $ ./index.lisp 

  *** - SYSTEM::%FIND-PACKAGE: There is no package with name "LML"

This is CLISP 2.30 on FreeBSD 4.7.

I must be missing something simple... Hints appreciated. 

Cheers.

-- 
Ng Pheng Siong <[email-masked]> * http://www.netmemetic.com

---

From: Sam Steingold <[email-masked]>
Date: Fri Dec 20 06:45:01 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Script cannot find package"
> * Sent on Fri, 20 Dec 2002 11:45:40 +0800
> * Honorable Ng Pheng Siong <[email-masked]> writes:
>
> Running CLISP interactively, with :lml loaded via .clisprc.lisp, the
> above works.
> 

<http://clisp.cons.org/clisp.html#opt-exec-file>
scripts do not load RC.
dump your image or load LML from your scripts explicitly.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
In C you can make mistakes, while in C++ you can also inherit them!

---

From: Ng Pheng Siong <[email-masked]>
Date: Sun Dec 22 00:54:06 2002

> dump your image or load LML from your scripts explicitly.

Thank you. Cheers.