Subject: [clisp-list] clisp as root? was: Separate Unix error stream keyword for ext:ru n-shell-command

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Jun 5 09:05:14 2003

Hi,

Sam Steingold wrote:
>if you are worried about "safety and security",
>then don't run CLISP as root.

Why not!?

Running clisp as root is exactly what I had plans to do.
I'd prefer having clisp run as root than perl do that any day.

And I'd prefer not having perl on a security-related system (it's like meeting the hacker's expectations).
So clisp maybe a good replacement. Maybe I should learn scsh.

Of course, one may argue that that's just another instance of "security by obscurity". Yet attacks on standard server port numbers (e.g. 1521 or 1433 etc. for database servers) or MS-Outlook show that such cheap measures nevertheless help.

However these days, having a system without perl is hard to achieve. It comes with a lot of software, even from security companies.

Regards,
	Jorg Hohle.

---

From: Sam Steingold <[email-masked]>
Date: Thu Jun 5 11:03:14 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp as root? was: Separate Unix error stream keyword for ext:ru n-shell-command"
> * Sent on Thu, 5 Jun 2003 18:04:27 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> Sam Steingold wrote:

if you are worried about "safety and security", you never do anything
as root. :-)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
History doesn't repeat itself, but historians do repeat each other.