Subject: [clisp-list] continue and undefined function

From: Gabor Melis <[email-masked]>
Date: Wed Jun 30 05:31:08 2004

This code endlessly invokes the continue restart:

(handler-bind ((error #'continue))
   (foo))

I don't understand is why does undefined function have a continue restart?

Clisp 2.33.2 on Debian/Sarge/i386.

Gabor Melis

---

From: Sam Steingold <[email-masked]>
Date: Wed Jun 30 06:41:02 2004

> * Gabor Melis <[email-masked]> [2004-06-30 14:27:31 +0200]:
>

the idea was that you would define the function at the debug prompt and
proceed.
this has now been replaced with the RETRY restart in the CVS.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
To understand recursion, one has to understand recursion first.