Subject: [clisp-list] permissions problem on cfgunix.lisp/config.lisp from CVS

From: Russell Senior <[email-masked]>
Date: Thu Mar 14 14:05:05 2002

I may be somewhat confused, but I just ran into a problem trying to
build on Linux 2.4.x from CVS:

   $ cvs -z3 -d:pserver:[email-masked]:/cvsroot/clisp co clisp

   $ cd /build/clisp

   $ /src_archive/lang/lisp/clisp/cvs/clisp/configure --srcdir=/src_archive/lang/lisp/clisp/cvs/clisp --prefix=/packages/development/lisp/clisp

   $ ./makemake  --prefix=/packages/development/lisp/clisp --with-readline --with-gettext --with-dynamic-ffi > Makefile

   $ make config.lisp
   cp -p /src_archive/lang/lisp/clisp/cvs/clisp/src/cfgunix.lisp config.lisp
   echo '(setq *clhs-root-default* "http://www.lisp.org/HyperSpec/")' >> config.lisp
   /bin/sh: config.lisp: Permission denied
   make: *** [config.lisp] Error 1

The problem appears to be that src/cfgunix.lisp has -r--r--r--
permissions and the make rule says to preserve those permissions,
which then conflicts with the rule's desire to append to the file.

-- 
Russell Senior         ``The two chiefs turned to each other.        
[email-masked]      Bellison uncorked a flood of horrible       
                         profanity, which, translated meant, `This is
                         extremely unusual.' ''

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 14 16:33:04 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] permissions problem on cfgunix.lisp/config.lisp from CVS"
> * Sent on 14 Mar 2002 14:04:20 -0800
> * Honorable Russell Senior <[email-masked]> writes:
>

I modified makemake.in to take care of this.
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Trespassers will be shot.  Survivors will be SHOT AGAIN!