Subject: [clisp-list] tiny suggestion about foreign1.lisp (FFI)

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Fri Mar 8 01:59:02 2002

:language defaults to :C (flag 512) for functions defined via
(c-function ...).

I propose
1. document the default ("Choice of C flavour") in impnotes.html

2. change the default to :stdc (ANSI) instead of :C (K&R)

Cost of change, to users: def-c-call-in/out is unaffected, and I believe only a tiny portion of users ever used c-function directly. Most stuff just passes ints and c-strings around.

In todays's context, I find it not meeting common sense expectations about program behaviour that things defined via (ffi:c-function (:arguments ...)) must not forget (:language :stdc) or they'll get K&R :C calling conventions.

3. please document what :stdc-stdcall means.

Thanks,
	Jörg Höhle.

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 11 10:15:02 2002

> * In message <DFD875E85664D3118FA6080006277DE7052163FE@U8PN2>
> * On the subject of "[clisp-list] tiny suggestion about foreign1.lisp (FFI)"
> * Sent on Fri, 8 Mar 2002 10:58:11 +0100
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>

done.  DEF-C-CALL-* are now deprecated and the default should be set
using DEFAULT-FOREIGN-LANGUAGE (just like IN-PACKAGE).
If no DEFAULT-FOREIGN-LANGUAGE form is given, a warning is issued and
:STDC is used.

> 3. please document what :stdc-stdcall means.

this is a dos/windows specific extension to :stdc, I think.
not really implemented :-)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
He who laughs last thinks slowest.