Subject: [clisp-list] Still Problems compiling on HP

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Tue Apr 2 16:23:04 2002

I am getting closer but not there yet.

>> gcc -g -O2 -x none minitests.o -o minitests  ./.libs/libavcall.a
>> ./minitests > minitests.out
>> uniq -u < minitests.out > minitests.output.hppa2.0-hp-hpux10.20
>> test '!' -s minitests.output.hppa2.0-hp-hpux10.20
>> make: *** [check] Error 1
>
>this should be fixed in the CVS.

Getting the CVS fixed this problem.

>> > cc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type
>> > -fomit-frame-pointer -Wno-sign-compare -O2 -fno-strength-reduce
>> > -DUNICODE -c arihppa.s || /usr/ccs/bin/as arihppa.s -o arihppa.o ||
>> > /bin/as arihppa.s -o arihppa.o
>> > arihppa.s: Assembler messages:
>> > arihppa.s:1: Error: Unknown pseudo-op:  `.shortdata'
>> > arihppa.s:8: Error: The .ENTER pseudo-op is not supported
>> > arihppa.s:30: Error: The .LEAVE pseudo-op is not supported
>> > arihppa.s: Assembler messages:
>> > arihppa.s:1: Error: Unknown pseudo-op:  `.shortdata'
>> > arihppa.s:8: Internal error, aborting at targ-cpu.c line 4493
>> > Please report this bug.
>
>
>
>GNU as and the binutils will not help you. You need the assembler that
>is shipped with the system!

Switching to the HP assembler fixed this problem.

It now continues until it reaches the point where it runs lisp.run and then
core dumps.

gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type
-fomit-frame-pointer -Wno-sign-compare -O2 -fno-strength-reduce -DUNICODE
-DDYNAMIC_FFI -x none spvw.o spvwtabf.o spvwtabs.o spvwtabo.o eval.o
control.o encoding.o pathname.o stream.o socket.o io.o array.o hashtabl.o
list.o package.o record.o sequence.o charstrg.o debug.o error.o misc.o
time.o predtype.o symbol.o lisparit.o i18n.o foreign.o unixaux.o arihppa.o
gmalloc.o modules.o libsigsegv.a libintl.a libiconv.a libreadline.a
libavcall.a libcallback.a  -ltermcap   -o lisp.run
sync
./lisp.run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load
\"init.lisp\") (sys::%saveinitmem) (exit)"
/bin/sh: 14998 Memory fault(coredump)
make: *** [interpreted.mem] Error 139

Any ideas what I am overlooking?

Thanks for help,

Art Nuzzo

[email-masked]

---

From: Will Newton <[email-masked]>
Date: Wed Apr 3 03:39:39 2002

> make: *** [interpreted.mem] Error 139

Would it be possible to get a backtrace of this?

With gdb:

% gdb ./lisp.run
>> run
>> backtrace

There is a similar crash with Sparc, and also with m68k so it would be 
intersting to see if they are related.

Thanks.