Subject: [clisp-list] lisp2wish - getting started problem

From: [email-masked]
Date: Mon Jan 21 05:22:04 2002

Hi,

I want to use CLISP, lisp2wish and wish83 on Windows XP.
As a bloody beginner I run into some troubles.

I installed clisp 2.27
I installed wish83
I downloaded / copied lisp2wish.lisp

Now:
I start wish83    --- works
I started clisp and then: (load "lisp2wish.lisp") --- okay
Then I typed (test-wish) and got this:

*** - EVAL: the function WISH::RUN-PROGRAM is undefined

At next I typed  (run-program "notepad.exe") and notepad starts,
so run-program is available.

So, what's wrong?  Do I have to change something in lisp2wish.lisp?

And could anybody give me a very simple "hello world, getting
started with lisp2wish" tutorial?

Best regards,
Johann Murauer
[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: Mon Jan 21 06:35:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] lisp2wish - getting started problem"
> * Sent on Mon, 21 Jan 2002 14:24:29 +0100
> * Honorable [email-masked] writes:
>

find the definition of the package WISH and make it use EXT.
(add a (:USE "EXT") clause to the DEFPACKAGE form)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
cogito cogito ergo cogito sum