Subject: [clisp-list] seg fault during compilation

From: Ruhan Alpaydin <[email-masked]>
Date: Fri Apr 30 14:25:00 2004

I get the following error during compilation of clisp-2.31-1. Please reply to
this email address as well since I am not subscribed to the list.

My system is a HP Linux box running Fedore Core 1.0.

-Ruhan

* * * * *

[root@localhost with-gcc-wall]# make interpreted.mem
./lisp.run -B . -N locale -Efile UTF-8 -Eterminal UTF-8 -norc -m 750KW -x
"(and (load \"init.lisp\") (sys::%saveinitmem) (ext::exit))"
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8
 
Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2003
 
;; Loading file defseq.lisp ...
;; Loaded file defseq.lisp
;; Loading file backquote.lisp ...
;; Loaded file backquote.lisp
;; Loading file defmacro.lisp ...make: *** [interpreted.mem] Parcalanma
Arizasi (means 'segmentation fault')

____________________________________________________________________

---

From: Sam Steingold <[email-masked]>
Date: Sat May 1 19:12:02 2004

> * Ruhan Alpaydin <[email-masked]> [2004-05-01 00:23:49 +0300]:
>
> I get the following error during compilation of clisp-2.31-1.

latest is 2.33.

> My system is a HP Linux box running Fedore Core 1.0.

this is a known problem with some FC1 installations.
you probably also cannot build Emacs (crash on unexec).

it might be helpful if you could try to describe your system in more
details, e.g., cpu/ram/video &c.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
When you are arguing with an idiot, your opponent is doing the same.