Subject: [clisp-list] MOP

From: Augusto <[email-masked]>
Date: Mon Jul 8 06:30:12 2002

Hi,

I start to move my code (www.ircam.fr/openmusic) to clisp, but I have a
little problem :

I try to define a new class  by

 (defclass omclass (standard-class) ())

but i get the error

*** - DEFCLASS OMCLASS : La classe sup?eure #<STRUCTURE-CLASS
STANDARD-CLASS> n'appartient pas ?a classe STANDARD-CLASS.

Can somebody help me ?

I use clisp-2.28 on MacOs X

thanks,

Carlos Agon

---

From: John Jorgensen <[email-masked]>
Date: Mon Jul 8 07:24:02 2002

I'm not a lisp expert, but I thought with ANSI LISP it would be;
(defclass () ()) with an assumed standard class.

J*
-----------------------
> -------------------------------------------------------
> This sf.net email is sponsored by:ThinkGeek
> Oh, it's good to be a geek.
> http://thinkgeek.com/sf
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list
>

---

From: Augusto <[email-masked]>
Date: Mon Jul 8 07:32:09 2002

Thanks for your answer John, but I want to define a meta-class

and then use it as meta-class of new classes, i.e.

(defclass new-class ()  ()
  (:metaclass omClass))

thanks again,

Carlos Agon

---

From: Peter Denno <[email-masked]>
Date: Mon Jul 8 07:45:04 2002

Hi,

Clisp doesn't have a MOP. In theory at least, you should be able to replace 
its CLOS implementation with PCL (Portable Common Loops), which is fairly 
close to the MOP described in Kiczales' book. There is, in fact, a source 
distribution of PCL that includes the low-level routines to apply PCL to 
CLisp. However, it is out of date with Clisp. I have spent some time trying 
to get it to work again, but have not completed this work. 

-- 
Best Regards, 
- Peter 

Peter Denno 
National Institute of Standards and Technology, 
Manufacturing System Integration Division, 
100 Bureau Drive, Mail Stop 8260             Tel: +1 301-975-3595 
Gaithersburg, MD, USA 20899-8260          FAX: +1 301-975-4694

---

From: Sam Steingold <[email-masked]>
Date: Mon Jul 8 09:16:07 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] MOP"
> * Sent on Mon, 08 Jul 2002 16:26:17 +0200
> * Honorable Augusto <[email-masked]> writes:
>

[8]> (defclass omclass (standard-class) () (:metaclass structure-class))
#<structure-class omclass>
[9]> (defclass new-class ()  () (:metaclass omClass))
#<omclass new-class>

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
It's not just a language, it's an adventure.  Common Lisp.