Subject: [clisp-list] CLISP GUI: japi

From: Sam Steingold <[email-masked]>
Date: Fri Mar 21 07:40:02 2003

japi <http://www.japi.de/> appears to be an easy way to get a GUI.
any volunteers to make a CLISP module based on it?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Don't use force -- get a bigger hammer.

---

From: Sam Steingold <[email-masked]>
Date: Fri Mar 21 08:43:21 2003

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] CLISP GUI: japi"
> * Sent on Fri, 21 Mar 2003 08:50:12 -0700
> * Honorable Dan Stanger <[email-masked]> writes:
>
> Is there a lgpl'd version of the java runtime that this will run against?

GCC 3 comes with /usr/bin/java that runs gij.
unfortunately, it appears to lack awt:

Exception in thread "Thread-1" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at 0x4027fd57: java.lang.Throwable.Throwable(java.lang.String) (/usr/lib/libgcj.so.3)
   at 0x40272bce: java.lang.Error.Error(java.lang.String) (/usr/lib/libgcj.so.3)
   at 0x4034051a: java.awt.AWTError.AWTError(java.lang.String) (/usr/lib/libgcj.so.3)
   at 0x40357c39: java.awt.Toolkit.getDefaultToolkit() (/usr/lib/libgcj.so.3)
   at 0x4035840a: java.awt.Window.getToolkit() (/usr/lib/libgcj.so.3)
   at 0x40349004: java.awt.Container.addImpl(java.awt.Component, java.lang.Object, int) (/usr/lib/libgcj.so.3)
   at 0x40348e8a: java.awt.Container.add(java.awt.Component, java.lang.Object) (/usr/lib/libgcj.so.3)
   at 0x4039a117: ffi_call_SYSV (/usr/lib/libgcj.so.3)
   at 0x4039a0d7: ffi_raw_call (/usr/lib/libgcj.so.3)
   at 0x402475e8: _Jv_InterpMethod.continue1(_Jv_InterpMethodInvocation) (/usr/lib/libgcj.so.3)
   at 0x40247ee4: _Jv_InterpMethod.run(ffi_cif, void, ffi_raw, _Jv_InterpMethodInvocation) (/usr/lib/libgcj.so.3)
   at 0x402454e4: _Jv_InterpMethod.run_normal(ffi_cif, void, ffi_raw, void) (/usr/lib/libgcj.so.3)
   at 0x40399f8c: ?? (??:0)
   at 0x4039a117: ffi_call_SYSV (/usr/lib/libgcj.so.3)
   at 0x4039a0d7: ffi_raw_call (/usr/lib/libgcj.so.3)
   at 0x402475e8: _Jv_InterpMethod.continue1(_Jv_InterpMethodInvocation) (/usr/lib/libgcj.so.3)
   at 0x40247ee4: _Jv_InterpMethod.run(ffi_cif, void, ffi_raw, _Jv_InterpMethodInvocation) (/usr/lib/libgcj.so.3)
   at 0x402454e4: _Jv_InterpMethod.run_normal(ffi_cif, void, ffi_raw, void) (/usr/lib/libgcj.so.3)
   at 0x40399f8c: ?? (??:0)
   at 0x40266b7c: _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.3)
   at 0x40388ec0: ?? (??:0)
   at 0x40390a55: GC_start_routine (/usr/lib/libgcj.so.3)
   at 0x406151ff: ?? (??:0)
   at 0x420d8397: __clone (/lib/tls/libc.so.6)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Those who can laugh at themselves will never cease to be amused.

---

From: Edi Weitz <[email-masked]>
Date: Fri Mar 21 09:14:09 2003

> unfortunately, it appears to lack awt:

Maybe you have to install it separately, something like

  <http://www.gnu.org/software/classpath/>

Edi.