Subject: [clisp-list] Postgres642 FFI compilation error in RedHat 7.2

From: "Jack Crosscope" <[email-masked]>
Date: Tue Jan 15 16:50:02 2002

When I run make with the postgresql642 module option on CLISP v. 2.27, on
RedHat Linux v. 7.2, Intel architecture, a Lisp process breaks with error
message:

*** - Incomplete FFI type ConnStatusType is not allowed here.

(Where exactly is "here" anyhow?  Can I do a backtrace somehow?  I tried the
usual way to no avail.)

The postgres postmaster is running (version 7.1.3), and I have postgres
source files from RedHat SRPMS.  My libpq-fe.h is in /usr/include/pgsql, as
usual.

My clisp Makefile options include dynamic-FFI, regexp, gettext, readline,
and clx/mit.

If I don't include a postgresqlxxx option, the rest compiles fine.  For
example, I've been able to run the clx/mit demo/hello.lisp after installing
and running clisp -K full.

Insights appreciated.  Thanks,

Jack Crosscope
[email-masked]

---

From: Dave <[email-masked]>
Date: Tue Jan 15 17:46:03 2002

On a somewhat side, isn't postgresql642 for version 6.4.2?

Jack Crosscope wrote:
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list
>

---

From: Sam Steingold <[email-masked]>
Date: Wed Jan 16 07:10:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Postgres642 FFI compilation error in RedHat 7.2"
> * Sent on Tue, 15 Jan 2002 19:53:59 -0500
> * Honorable "Jack Crosscope" <[email-masked]> writes:
>
> (Where exactly is "here" anyhow?  Can I do a backtrace somehow?  I
> tried the usual way to no avail.)

this is generated by a "clisp -c" (compile-file) command.
start CLISP in the right directory, type
(compile-file "foo" :print t)
and you will see which form generates the error.

it might be that you will have to wrap the def-c-enum form in an
eval-when.

> The postgres postmaster is running (version 7.1.3), and I have
> postgres source files from RedHat SRPMS.

it would be nice to unify our Postgres642 and Postgres632 into
PostgreSQL that would work with PostgreSQL 7.
Would you like to do this?

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
A computer scientist is someone who fixes things that aren't broken.

---

From: [email-masked] (Dr. Edmund Weitz)
Date: Wed Jan 16 07:53:08 2002

Sam Steingold <[email-masked]> writes:

> PostgreSQL that would work with PostgreSQL 7.  Would you like to do
> this?

I think it would be more worthwhile to provide CLISP-related patches
to the UncommonSQL <http://alpha.onshored.com/lisp-software/>
maintainers. They're actively soliciting them.

Just my $.02,
Edi.