Subject: [clisp-list] running lisp program from command line

From: Stanislav Baranov <[email-masked]>
Date: Mon, 19 Mar 2001 22:39:44 -0800

Hello,

I guess I have problems running lisp programs from command line
with clisp (under w2k).

Suppose I have such a file test.lisp:

    (print "load")
    (defun test ()
      (print "test"))

I'm trying to run it like this:

    .\lisp.exe -M .\lispinit.mem -B . test.lisp

I see nothing on the console. I think it just silently exits,
because I tried this file with the same effect:

    (print "load")
    (defun test ()
      (print "test")
      (test))
    (test)

If I start lisp in interactive mode, it prints all my test strings OK:

    .\lisp.exe -M .\lispinit.mem -B . test.lisp
    (load "test")
    (test)

Of course, I can run it like this:

    .\lisp.exe -q -M .\lispinit.mem -B . -x "(load \"test\") (test)"

But this is firstly workaround, and secondly, it prints all the
system stuff like "Loading file ...", "Successfully loaded...",
etc. (even if I specify -q flag).

So what do you guys think about this?

Thanks,
Stas

---

From: Sam Steingold <[email-masked]>
Date: 20 Mar 2001 10:34:48 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] running lisp program from command line"
> * Sent on Mon, 19 Mar 2001 22:39:44 -0800
> * Honorable Stanislav Baranov <[email-masked]> writes:
>

yep - confirmed on nt4sp6.

Bruno, do you have an idea?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Don't take life too seriously, you'll never get out of it alive!