Subject: [clisp-list] Q: what causes sigsegv

From: bruce <[email-masked]>
Date: Sun, 17 Dec 2000 10:11:50 +0800

Dear list members,

What does the following sigsegv mean?

   *** - handle_fault error2 ! address = 0x6C0078 not in
[0x20234000,0x2098DDC4) !
   SIGSEGV cannot be cured. Fault address = 0x6C0078.

After the signal the CLISP process died.

Does it mean that there is some bug in my programs,  such as array index
out of range?

Best!

Shouxun

--
The perversity of nature is nowhere better demonstrated by the fact that, when
exposed to the same atmosphere, bread becomes hard while crackers become soft.

---

From: Sam Steingold <[email-masked]>
Date: 17 Dec 2000 01:31:39 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Q: what causes sigsegv"
> * Sent on Sun, 17 Dec 2000 10:11:50 +0800
> * Honorable bruce <[email-masked]> writes:
>

no, this is a bug in CLISP.
which version are you using?
on what OS?
architecture?

Please try to create a self-contained bug report and send it to this
list. 

Thanks.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Don't take life too seriously, you'll never get out of it alive!

---

From: bruce <[email-masked]>
Date: Sun, 17 Dec 2000 16:46:53 +0800

> Please try to create a self-contained bug report and send it to this

I'm using clisp-2000-03-06 on Linux/i686.

In order to produce such a bug report, I need detailed help.

I found one previous message from Bruno in that direction, but that requires
recompile clisp using different compile parameter, which seems not for this case.

Best!

Shouxun

---

From: Sam Steingold <[email-masked]>
Date: 17 Dec 2000 17:40:26 -0500

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Q: what causes sigsegv"
> * Sent on Sun, 17 Dec 2000 16:46:53 +0800

you need to tell us how to reproduce your crash.
I.e., you will have to send us the transcript of the entire session.
E.g., like this:

$ clisp -q

> (load "crash.lisp")

segmentation fault
$

and then send us the file "crash.lisp".
please try to make the file as small as possible.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
MS DOS: Keyboard not found. Press F1 to continue.

---

From: bruce <[email-masked]>
Date: Thu, 21 Dec 2000 21:14:04 +0800

> I.e., you will have to send us the transcript of the entire session.

I came across `sigsegv' twice before reporting to the list, but I cannot
reproduce it now.  One reason is that my program is data-intensive and it takes
too much time for a run.  The power was down before the run could be completed
and before another `sigsegv' occurred.

Another thing is that the clisp process died quietly when I started Star Office
5.2.  Star Office took quite a lot of memory at startup, I must say.

GC is quite frequent when my program is running.  How can one control when GC
occurs? Perhaps when there are enough memory, clisp does not have to do frequent
GC.

Best!

shouxun