Subject: [clisp-list] Re: Building CLISP for Windows: modules

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Mon Mar 11 02:03:04 2002

Hi,

> > o genclisph.exe and as a consequence clisp.h are not generated and
> > there's even no makefile target for them.
> > Did anyone ever build a module on MS-windows?
> 
> IIUC, you need add an interface to LoadLibrary (win32 version 
> of dlopen) to spvw.d:dynload_modules().
> Bruno proposed using libltdl from GNU libtool.

No, modules are usable on MS-Windows as well, even if possibly nobody ever did so. It's independent from the ability to load shared libraries via LoadLibrary() libtool, or dynload_modules. I built a module last week and wrote a nearly finished article this weekend, documenting how CLISP modules work and how to put them to use.

BTW, what's a good place to publish CLISP documentation or CLISP specific articles? I feel this is too specific for the cookbook.

> would you like to do this?
As I've laid out in my article on FFI design (a few people received drafts), I consider the addition of a dynamic loading facility and API not a trivial concept to define. Implementaion would be easy. There have been thoughts on this five years ago, and again in 1999. Nothing usable came yet out of this... Maybe I should take a worse is better approach -- again.

Regards,
	Jorg Hohle.

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 11 08:50:04 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Re: Building CLISP for Windows: modules"
> * Sent on Mon, 11 Mar 2002 11:01:18 +0100
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> No, modules are usable on MS-Windows as well, even if possibly nobody
> ever did so. It's independent from the ability to load shared
> libraries via LoadLibrary() libtool, or dynload_modules. I built a
> module last week and wrote a nearly finished article this weekend,
> documenting how CLISP modules work and how to put them to use.

great!

> BTW, what's a good place to publish CLISP documentation or CLISP
> specific articles? I feel this is too specific for the cookbook.

this should go into the impnotes.
please see doc/impext.xml.

> As I've laid out in my article on FFI design (a few people received
> drafts), I consider the addition of a dynamic loading facility and API
> not a trivial concept to define. Implementaion would be easy. There
> have been thoughts on this five years ago, and again in 1999. Nothing
> usable came yet out of this... Maybe I should take a worse is better
> approach -- again.

I take it for a "yes" and awaiting patches. :-)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Don't hit a man when he's down -- kick him; it's easier.