Subject: [clisp-list] Problems building on m68k-apple-NetBSD1.5.1

From: Alexander Klein <[email-masked]>
Date: Thu Sep 6 15:42:02 2001

Hi!

I tried to build clisp 2.27 on the machine mentioned in the subject, but
encountered serious problems:

1. 'Checking for working mmap' blew up the machine with a kernel panic, the
workaround was to set an environment variable indicating that mmap doesn't
work.

2. Later on, the configure script called a program 'minitests' that seemed
to run fine ...

void f(void):
void f(void):
int f(void):->99
int f(void):->99
int f(int):(1)->2
int f(int):(1)->2
int f(2*int):(1,2)->3
int f(2*int):(1,2)->3
int f(4*int):(1,2,3,4)->10
int f(4*int):(1,2,3,4)->10
int f(8*int):(1,2,3,4,5,6,7,8)->36
int f(8*int):(1,2,3,4,5,6,7,8)->36
int f(16*int):(1,2,3,4,5,6,7,8,9,11,12,13,14,15,16,17)->143
int f(16*int):(1,2,3,4,5,6,7,8,9,11,12,13,14,15,16,17)->143
float f(float):(0.1)->1.1
float f(float):(0.1)->1.1
float f(2*float):(0.1,0.2)->0.3
float f(2*float):(0.1,0.2)->0.3
float f(4*float):(0.1,0.2,0.3,0.4)->1
float f(4*float):(0.1,0.2,0.3,0.4)->1
float f(8*float):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8)->3.6
float f(8*float):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8)->3.6
float
f(16*float):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8,0.9,1.1,1.2,1.3,1.4,1.5,1.6,1.7)->1
4.3
float
f(16*float):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8,0.9,1.1,1.2,1.3,1.4,1.5,1.6,1.7)->1
4.3
double f(double):(0.1)->1.1
double f(double):(0.1)->1.1
double f(2*double):(0.1,0.2)->0.3
double f(2*double):(0.1,0.2)->0.3
double f(4*double):(0.1,0.2,0.3,0.4)->1
double f(4*double):(0.1,0.2,0.3,0.4)->1
double f(8*double):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8)->3.6
double f(8*double):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8)->3.6
double
f(16*double):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8,0.9,1.1,1.2,1.3,1.4,1.5,1.6,1.7)->
14.3
double
f(16*double):(0.1,0.2,0.3,0.4,0.5,0.6,0.7,0.8,0.9,1.1,1.2,1.3,1.4,1.5,1.6,1.7)->
14.3
uchar f(uchar,ushort,uint,ulong):(97,2,3,4)->255
uchar f(uchar,ushort,uint,ulong):(97,2,3,4)->255
double f(int,int,double,double):(1,2,0.3,0.4)->3.7
double f(int,int,double,double):(1,2,0.3,0.4)->3.7
double f(int,double,int,double):(1,0.2,3,0.4)->4.6
double f(int,double,int,double):(1,0.2,3,0.4)->4.6
ushort f(char,double,char,double):('a',0.2,'Ä',0.4)->65506
ushort f(char,double,char,double):('a',0.2,'Ä',0.4)->65506
long long f(float,long
long,int):(1.4,0x35c6f707fffffffa,0xe)->0x35c6f70800000009
long long f(float,long
long,int):(1.4,0x35c6f707fffffffa,0xe)->0x35c6f70800000009
void* f(void*,double*,char*,Int*):(0x81e0,0x8168,0x2746,0x8278)->0x8169
void* f(void*,double*,char*,Int*):(0x81e0,0x8168,0x2746,0x8278)->0x8169
Int f(Int,Int,Int):({1},{2},{3})->{6}
Int f(Int,Int,Int):({1},{2},{3})

... but then died with a segfault.

Has anyone any hints what I could try to get the thing running?

Best regards!

	Alex

---

From: Sam Steingold <[email-masked]>
Date: Thu Sep 6 16:11:01 2001

> * In message <l03130300b7bd737c7b57@[134.176.249.87]>
> * On the subject of "[clisp-list] Problems building on m68k-apple-NetBSD1.5.1"
> * Sent on Thu, 6 Sep 2001 20:54:02 +0200
> * Honorable Alexander Klein <[email-masked]> writes:
>
> 1. 'Checking for working mmap' blew up the machine with a kernel
> panic, the workaround was to set an environment variable indicating
> that mmap doesn't work.

this should be reported to the autoconf maintainers (I think)

> ...... [sds: lots deleted]
> .... but then died with a segfault.

either build without dynamic ffi, of bypass the test: just above the
minitest you should see a command like this

cd foo; make && make check && make install-lib .....
execute the "make install-lib" part by hand and proceed.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
When C++ is your hammer, everything looks like a thumb.