Subject: [clisp-list] Maxima using CLISP

From: "Lizardo H. C. M. Nunes" <[email-masked]>
Date: Thu, 12 Jul 2001 01:28:42 -0300

Hi,

I'm trying to port "Maxima 5.6" using "clisp 2.25.1".
After editing the file "../src/ suprv1.lisp" I simply typed:

#cd src
#make clisp-compile CLISP=clisp
and it compiles without errors...

I want to know what I should do next. If somebody already used CLISP to port
Maxima and wants to give me a hand, I'd really appreciate.

Thanks,
Lizardo.
--

---

From: James Amundson <[email-masked]>
Date: Thu, 12 Jul 2001 11:17:50 -0500

> Maxima and wants to give me a hand, I'd really appreciate.

You want to do "clisp -M maxima-clisp.mem". Here's an example:

---------------------------------------------------------
|abacus>clisp -M maxima-clisp.mem 
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo 
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999

Maxima 5.6 Tue Jul 10 15:41:45 CDT 2001 (with enhancements by W.
Schelter).
Licensed under the GNU Public License (see file COPYING)
(C1) integrate(sin(x),x);
(D1) 				   - COS(x)
(C2) quit();
Bye.
|abacus>
---------------------------------------------------------

You will probably also want to try "make test-clisp", which should give
you a great deal of text, ending with

----------------------------------------
..Which was correct
Congratulations: No differences!
No Errors Found
Real time: 19.924162f0 sec.
Run time: 7.92f0 sec.
Space: 24513380 Bytes
GC: 36, GC time: 0.76f0 sec.
----------------------------------------

I hope this helps.

--Jim