Subject: [clisp-list] how to start the lisp memory file in C application

From: Huaiyan Gao <[email-masked]>
Date: Thu Aug 15 04:49:03 2002

Hi, CLISP huggers.

Who knows how to execute memory image file which is distributed with clisp function "saveinitmem" in C program, I ceate a *.bat file, it can initialize my clisp memory file mylispprogram.bat like this :@echo off
"C:/clisp/lisp.exe" -B "C:/clisp/" -M "C:/clisp/a.mem" %1 %2 %3 %4 %5 %6 %7 %8 %9
Now, mylispprogram.bat file can work well, but I want to design a priendly and convenient user interface so that users can call my lisp functions to do their work in the user interface. I means that how to set up a connection from C program to lisp memory file, i.e, how to start the lisp memory file in C program first step? Certainly, other lisp dialects such as lispworks, Allegro CL, they provide built-in CAPI packages through which we can develop user interface conveniently, but they are not free. So I study clisp for windows to see whether I can develop a user interface to deal with lisp calling.

Thanks.

HuaiYan Gao

---------------------------------
Get a bigger mailbox -- choose a size that fits your needs.

http://uk.docs.yahoo.com/mail_storage.html

---

From: Sam Steingold <[email-masked]>
Date: Thu Aug 15 06:36:09 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] how to start the lisp memory file in C application"
> * Sent on Thu, 15 Aug 2002 12:48:44 +0100 (BST)
> * Honorable Huaiyan Gao <[email-masked]> writes:
>
> Now, mylispprogram.bat file can work well, but I want to design a
> priendly and convenient user interface so that users can call my lisp
> functions to do their work in the user interface. I means that how to
> set up a connection from C program to lisp memory file, i.e, how to
> start the lisp memory file in C program first step?

I think I (and others) answered this question already.

1. there is GDI interface from Dan Stanger.

2. there is inspect.lisp which uses your web browser for GUI.

3. you can write your own C program that will display GUI and
   communicate with the lisp process via a socket.

Please choose your path and ask more specific questions.

If your question is actually "How can I use CLIM with CLISP", then the
answer is "you cannot at this time - unless you implement it first,
which you are welcome to do".

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
There are two ways to write error-free programs; only the third one works.