Subject: [clisp-list] Other builtin method combinations

From: Daniel Barlow <[email-masked]>
Date: 04 Aug 2001 22:09:33 +0100

[ I'm not subscribed to this list, but I'm tracking responses on the
web archive; if you want to be absolutely sure I see something, please
CC me directly ]

With clisp version "2000-03-06 (March 2000)", my attempt to use a
method combination other than STANDARD fails - 

[1]> (defgeneric depends-on (operation component) (:method-combination list))

*** - DEFGENERIC DEPENDS-ON: The only valid method combination is STANDARD : (:METHOD-COMBINATION LIST)

Is this fixed in any more recent version?  If not, is anyone working
on it?

-dan

-- 

  http://ww.telent.net/cliki/ - Link farm for free CL-on-Unix resources

---

From: Sam Steingold <[email-masked]>
Date: 05 Aug 2001 00:22:54 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Other builtin method combinations"
> * Sent on 04 Aug 2001 22:09:33 +0100
> * Honorable Daniel Barlow <[email-masked]> writes:
>

this is documented in the impnotes.

> Is this fixed in any more recent version?
no.

> If not, is anyone working on it?
no, and help is welcome.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
In the race between idiot-proof software and idiots, the idiots are winning.