Subject: [clisp-list] Warnings setting FFI:DEFAULT-FOREIGN-LANGUAGE

From: "John K. Hinsdale" <[email-masked]>
Date: Mon Sep 16 11:21:02 2002

For my "C" oracle module I'm moving to the new syntax for defining "C"
call-out functions (DEF-C-CALL-OUT --> DEF-CALL-OUT) but when I set
the default language with

	(default-foreign-language :stdc)

I get :
	Compiling file /u/hin/src/clisp/mysrc/oracle/oracle.lisp ...
	WARNING:
	SETQ(FFI::*FOREIGN-LANGUAGE*): #<PACKAGE FFI> is locked
	Ignore the lock and proceed
	WARNING in (DEFAULT-FOREIGN-LANGUAGE :STDC)-3 in lines 30..31 :
	SETQ: assignment to the internal special symbol FFI::*FOREIGN-LANGUAGE*

No big deal, but I am doing things just as in the examples and it
seems that should produce no warning.

---
John Hinsdale, Alma Mater Software, Inc., Tarrytown, NY 10591-3710 USA
[email-masked] | http://www.alma.com/staff/hin | +1 914 631 4690

---

From: Sam Steingold <[email-masked]>
Date: Wed Sep 18 17:52:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Warnings setting FFI:DEFAULT-FOREIGN-LANGUAGE"
> * Sent on Mon, 16 Sep 2002 14:20:01 -0400
> * Honorable "John K. Hinsdale" <[email-masked]> writes:
>

You are rigth - this is a bug, and I just fixed it.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
You can have it good, soon or cheap.  Pick two...