Subject: [clisp-list] Re: [clisp-announce] GNU CLISP 2.28 release

From: Randall R Schulz <[email-masked]>
Date: Mon Mar 4 13:39:02 2002

Sam,

Is there a timetable on availability of a pre-built Win32 binary for 2.28?

Also, this URL:

         <ftp://ftp.gnu.org/pub/ftp/clisp/release/latest>

is incorrect. I believe it should be one of the following, all apparently 
equivalent owing to the use of symlinks on <ftp://ftp.gnu.org/>:

         <ftp://ftp.gnu.org/gnu/clisp/latest>
         <ftp://ftp.gnu.org/gnu/clisp/release/latest>
         <ftp://ftp.gnu.org/pub/gnu/clisp/latest>
         <ftp://ftp.gnu.org/pub/gnu/clisp/release/latest>

Randall Schulz
Mountain View, CA USA

At 08:42 2002-03-04, you wrote:
>The following message is a courtesy copy of an article
>that has been posted to comp.os.linux.announce as well.
>
>GNU CLISP 2.28 is now available at
>  <http://clisp.cons.org>
>  <http://www.clisp.org>
>  <http://sourceforge.net/project/showfiles.php?group_id=1355>
>  <ftp://ftp.gnu.org/pub/ftp/clisp/release/latest>
>  <ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/>
>  <ftp://cvs2.cons.org/pub/lisp/clisp/binaries/latest/>
>please ask questions about CLISP on <[email-masked]>.
>if you would like to contribute to CLISP development, please subscribe
>to <[email-masked]> and send patches there.
>
>...
>
>
>--
>Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 4 14:25:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-announce] GNU CLISP 2.28 release"
> * Sent on Mon, 04 Mar 2002 13:38:37 -0800
> * Honorable Randall R Schulz <[email-masked]> writes:
>

I have no access to win32.
I asked Arseny Slobodjuck and Todd Sabin to build a win32 distribution.
Unfortunately, I made a strategic mistake of letting each of them know
that I asked _both_, so, I guess, both of them are waiting for the
other to do it.  :-)

Okay, in alphabetical order:
(random t)
131100680
(aref ["Todd Sabin" "Arseny Slobodjuck"] (random 2))
"Arseny Slobodjuck"

Arseny, please create a win32 distribution.

Thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Why use Windows, when there are Doors?

---

From: Randall R Schulz <[email-masked]>
Date: Mon Mar 4 14:34:02 2002

Sam,

I suppose I should educate myself, but if you or someone would indulge a 
quick and trivial question, what compiler is used to produce the Win32 
binaries? MSVC, or something else?

Thank you.

Randall Schulz
Mountain View, CA USA

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 4 16:18:06 2002

> * In message <[email-masked]>
> * On the subject of "Building CLISP for Windwos"
> * Sent on Mon, 04 Mar 2002 14:33:14 -0800
> I suppose I should educate myself, but if you or someone would indulge
> a quick and trivial question, what compiler is used to produce the
> Win32 binaries? MSVC, or something else?

see CLISP/win32*/
I used msvc6 with CLISP/win32msvc/makefile.msvc5 and followed the
instructions in CLISP/win32msvc/INSTALL
everything worked just dandy.
win32gcc (not cygwin, but mingw) did not work for me.
YMMV.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
When we write programs that "learn", it turns out we do and they don't.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Mar 4 16:24:02 2002

Hello Sam,

Tuesday, March 05, 2002, 8:19:25 AM, you wrote:

Sam> Arseny, please create a win32 distribution.
You didn't asked to upload it !

I started this day from formatting C: instead of D:,
so I should recover a bit...

Formatting is not my mistake - it's some strange
windows behavior - it formatted both volumes !
Actually I have nonusual partition configuration,
but it had to warn me ...

I hope I can upload a new version in 12 - 24 hours,
just say where to put it.

-- 
Best regards,
 Arseny                            mailto:[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 5 16:55:22 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Re: [clisp-announce] GNU CLISP 2.28 release"
> * Sent on Tue, 5 Mar 2002 10:23:12 +1000
> * Honorable Arseny Slobodjuck <[email-masked]> writes:
>

I am sorry to hear this.

Whoever makes a binary of CLISP (win32, RPM, whatever), please put it
somewhere I can download it from (these days everyone has a homepage,
right? :-)

BTW, any RPM gurus here?
I did not touch the beast for 3 years and I don't have time to re-learn
the stuff right now, so maybe someone "in the know" could build the
current RPM?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Diplomacy is the art of saying "nice doggy" until you can find a rock.

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 5 17:50:13 2002

> * On the subject of "[clisp-list] Re: [clisp-announce] GNU CLISP 2.28 release"

Arseny Slobodjuck just built a binary for you -
find it in the usual places.

Thanks Arseny!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I want Tamagochi! -- What for?  Your pet hamster is still alive!