Subject: [clisp-list] Observations on 2.30.1 beta

From: "John" <[email-masked]>
Date: Fri Aug 15 14:53:02 2003

I notice a performance degradation on the native windows version 2.30.1 beta
vs the 2.30 release. I thought I would pass this information on incase it
hadn't been previously discovered.  Running the following code snippet
compiled to a .fas file, the beta version takes nearly 3 times as long to
run. I'm currently on XP Pro. I also noticed the size of the lisp.exe file
has grown by almost a megabyte.

(let ((x 0) (y 0) start stop elapsed)
    (setq start (GET-INTERNAL-RUN-TIME))
    (loop for i from 1 to 10000000 do
         (setq x i)
         (setq y (* i i)))
    (format t "x=~D y=~D~%" x y)
    (setq stop (GET-INTERNAL-RUN-TIME))
    (setq elapsed (- stop start))
    (format t "elapsed time: ~F seconds~%" (/ elapsed
INTERNAL-TIME-UNITS-PER-SECOND))
)

Output from version 2.30.1 beta
x=10000000 y=100000000000000
elapsed time: 19.18759 seconds

Output from version 2.30
x=10000000 y=100000000000000
elapsed time: 6.7296767 seconds

I also see this message printed to the console and have found no way to
disable it. Hopefully this message will be removed in the future.

Reserved address range 0x1a4b0000-0x5ad6ffff .
STACK depth: 16363

Hope you find this info useful.

---

From: Sam Steingold <[email-masked]>
Date: Sat Aug 16 18:45:04 2003

> * In message <001c01c36375$40e8d4f0$81a2590c@mako>
> * On the subject of "Observations on 2.30.1 beta"
> * Sent on Fri, 15 Aug 2003 17:35:42 -0400
> * Honorable "John" <[email-masked]> writes:
>

this means that you compiled --with-debug, meaning that most
optimizations are off.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
A professor is someone who talks in someone else's sleep.