Subject: [clisp-list] error C2099 and warning C4047 in 2.33.2

From: Mike Teixeira <[email-masked]>
Date: Wed Jul 21 13:03:01 2004

Hello,

I am building 2.33.2 on a Windows XP box with Visual Studio .NET 2003. 
I am getting the following errors when I build:

spvwtabf.i.c
subr.d(165) : error C2099: initializer is not a constant
subr.d(165) : warning C4047: 'initializing' : 'uintL' differs in levels 
of indirection from 'void *'
subr.d(166) : error C2099: initializer is not a constant
subr.d(166) : warning C4047: 'initializing' : 'uintL' differs in levels 
of indirection from 'void *'
subr.d(167) : error C2099: initializer is not a constant
...
...
...
subr.d(282) : error C2099: initializer is not a constant
subr.d(282) : warning C4047: 'initializing' : 'uintL' differs in levels 
of indirection from 'void *'
subr.d(284) : error C2099: initializer is not a constant
subr.d(284) : warning C4047: 'initializing' : 'uintL' differs in levels 
of indirection from 'void *'
subr.d(286) : error C2099: initializer is not a constant
subr.d(286) : fatal error C1003: error count exceeds 100; stopping 
compilation

Has anyone had any experience with this issue?

Thanks,
Mike

---

From: Sam Steingold <[email-masked]>
Date: Thu Jul 22 11:36:03 2004

> * Mike Teixeira <[email-masked]> [2004-07-21 13:02:07 -0700]:
>
> I am building 2.33.2 on a Windows XP box with Visual Studio .NET
> 2003. I am getting the following errors when I build:
>
> spvwtabf.i.c

I do not use msvc (mingw produces faster CLISP binaries).
I hope Arseny will help you.

If you look at spvwtabf.i.c, you will probably be able to find the
specific expressions that cause this.  If you do, please post them here.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
My inferiority complex is the only thing I can be proud of.