Subject: [clisp-list] impnotes.{tex|dvi} ?

From: Peter Wood <[email-masked]>
Date: 19 Mar 2001 22:11:03 +0100

Hi

Is there a recent latex or dvi version of impnotes.html?  The manual
package in the contrib directory at cons.org is quite old (1995).

Regards,
Peter

---

From: Bruno Haible <[email-masked]>
Date: Mon, 19 Mar 2001 22:30:39 +0100 (CET)

> package in the contrib directory at cons.org is quite old (1995).

We've decided not to use TeX or (even worse) LaTeX for the CLISP
documentation.

For printing CLISP's impnotes.html there are three options:

  - Use the html2ps converter.
  - Use the amaya browser's print function,
  - Use netscape navigator's print function.

Bruno

---

From: Sam Steingold <[email-masked]>
Date: 19 Mar 2001 16:32:37 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] impnotes.{tex|dvi} ?"
> * Sent on 19 Mar 2001 22:11:03 +0100
> * Honorable Peter Wood <[email-masked]> writes:
>
> Is there a recent latex or dvi version of impnotes.html?  

The master source for the impnotes manual is in doc/imp*.xml in
DocBook/XML format.
I can generate HTML using XALAN, but that's about it.
If you can find a way to generate other formats, we would appreciate it!

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Oh Lord, give me the source code of the Universe and a good debugger!

---

From: Peter Wood <[email-masked]>
Date: 20 Mar 2001 09:06:02 +0100

> If you can find a way to generate other formats, we would appreciate it!

Hi,

I used db2dvi to generate dvi pages of impext.xml. (Which is what I
was interested in).  There are places where there appear to be some
problems, (maybe because I used an old docbook dtd) but it looks ok,
generally speaking.
 
According to the LDAP guide at:

 http://sunsite.dk/ldp/LDP/LDP-Author-Guide/jadewrappers.html#cygnus

You need the following packages:

sgml-common-0.1-8.noarch 
docbook-3.1-4.noarch 
stylesheets-1.54.13rh-1.noarch 

Updates at:

 http://www.redhat.com/support/errata/RHBA-2000022-01.html.

I had to boot up an old RedHat installation, as I don't have RPM on my
regular system.  I suspect these packages may be RedHat specific.

Regards,
Peter