Subject: RE: [clisp-list] Still Problems compiling on HP

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Wed Apr 3 07:19:10 2002

> 
> 
> On Tuesday 02 Apr 2002 4:17 am, Nuzzo Art-CINT116 wrote:
> 
> > ./lisp.run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load
> > \"init.lisp\") (sys::%saveinitmem) (exit)"
> > /bin/sh: 14998 Memory fault(coredump)
> > make: *** [interpreted.mem] Error 139
> 
> Would it be possible to get a backtrace of this?
> 
> With gdb:
> 
> % gdb ./lisp.run
> >> run
> >> backtrace
> 
> There is a similar crash with Sparc, and also with m68k so it 
> would be 
> intersting to see if they are related.
> 

Sure, no problem. I had to install gdb first.  I haven't really used a
debugger much so you might need to help me here. Here is what I get when I
ran the debugger command:

artn@bs742> gdb ./lisp.run
GNU gdb 5.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "hppa2.0-hp-hpux10.20"...(no debugging symbols
found)...
(no debugging symbols found)...Breakpoint 1 at 0x14c09c
Breakpoint 2 at 0x148dcc
Breakpoint 3 at 0x13d310
Num Type           Disp Enb Address    What
1   breakpoint     keep n   0x0014c09c <funcall+20>
        zout fun
2   breakpoint     keep n   0x00148dcc <eval+8>
        zout form
3   breakpoint     keep n   0x0013d310 <gar_col+16>
.gdbinit:37: Error in sourced command file:
Function "sigsegv_handler_failed" not defined.
(gdb) run 
Starting program: /tmp_mnt/users/artn/clisp-2.28-CVS/src/lisp.run -B . -M
lispinit.mem -q -norc

Now it will just hang there.  I'm not sure if it is from lisp.run or I did
something wrong when I compiled gdb or it is waiting for me to do something.

Thanks for any help.

Art

---

From: Will Newton <[email-masked]>
Date: Wed Apr 3 08:22:51 2002

> something wrong when I compiled gdb or it is waiting for me to do

The problem is that for some reason (I assume it is an error, I cannot 
believe it has any use) there is a .gdbinit file in the source directory. To 
make matters worse it is copied to the build directory also. If you have the 
time could you please try this:

(% is shell propmt, >> is gdb prompt)

% cd to wherever you are building, defaults to clisp-2.28/src
% rm .gdbinit
% gdb ./lisp.run
>> run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load \"init.lisp\") 
(sys::%saveinitmem) (exit)"

And see if that crashes - it should drop to the debugger with SIGSEGV caught 
or something along those lines.

>> backtrace

Hopefully that should print something.

NB: It would be really nice if someone would remove that .gdbinit file, it 
makes it a lot harder to get good bug reports.

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 3 09:03:21 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Still Problems compiling on HP"
> * Sent on Wed, 3 Apr 2002 16:58:12 +0100
> * Honorable Will Newton <[email-masked]> writes:
>
> believe it has any use) there is a .gdbinit file in the source
> directory. To make matters worse it is copied to the build directory
> also.

this is intentional.
I use this to debug CLISP.
note that emacs comes with a much more extensive src/.gdbinit

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
(let((a'(list'let(list(list'a(list'quote a)))a)))`(let((a(quote ,a))),a))

---

From: Will Newton <[email-masked]>
Date: Wed Apr 3 11:07:47 2002

> note that emacs comes with a much more extensive src/.gdbinit

It just throws out errors with my version of gdb.

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 3 11:52:01 2002

> * In message <[email-masked]>
> * Sent on Wed, 3 Apr 2002 19:56:37 +0100

what version?
what errors?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Bus error -- driver executed.