Subject: [clisp-list] Linking problems on Win32

From: "V.Krishna Kumar" <[email-masked]>
Date: Sun, 5 Aug 2001 18:58:43 +0530

Hi! ALL,

I've had some linking problems especially with MSVCRT and LIBC. As instructed in the Makefile, if I use MSVCRT I get __errno not defined error and if I use LIBC (single threaded) I get a different set of unresolved symbols. Has anybody built recent versions of clisp on Win32 ?

BTW, I use VC 6.0 

-cheers,
Krishna Kumar

---

From: Sam Steingold <[email-masked]>
Date: 05 Aug 2001 14:34:40 -0400

> * In message <000701c11db5$4e098f60$63e3e30a@turing>
> * On the subject of "[clisp-list] Linking problems on Win32"
> * Sent on Sun, 5 Aug 2001 18:58:43 +0530
> * Honorable "V.Krishna Kumar" <[email-masked]> writes:
>
> I've had some linking problems especially with MSVCRT and LIBC. As
> instructed in the Makefile, if I use MSVCRT I get __errno not defined
> error and if I use LIBC (single threaded) I get a different set of
> unresolved symbols. Has anybody built recent versions of clisp on
> Win32 ?

I am stuck with nt4sp6 and msvc 6 and I build CLISP regularly, without
any problems.

Please make sure that you do this:

set MSDEVDIR=C:\msvs
set Include=%MSDEVDIR%\VC98\include
set Lib=%MSDEVDIR%\VC98\lib
set PATH=%MSDEVDIR%\VC98\bin;%MSDEVDIR%\Common\MSDev98\Bin;%PATH%

cd utils\gcc-cccp
nmake -f Makefile.msvc clean
nmake -f Makefile.msvc
cd ..\..

cd ffcall
nmake -f Makefile.msvc clean
nmake -f Makefile.msvc check
cd ..

cd libiconv
nmake -f Makefile.msvc clean
nmake -f Makefile.msvc check
cd ..

cd sigsegv
nmake -f Makefile.msvc clean
nmake -f Makefile.msvc check
cd ..

copy win32msvc\makefile.msvc5 src\makefile
cd src
nmake clean
nmake

> BTW, I use VC 6.0 
yep.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
UNIX is as friendly to you as you are to it. Windows is hostile no matter what.