Subject: [clisp-list] editing using notepad or another editor

From: Sophronis Mantoles <[email-masked]>
Date: Sat Sep 7 13:57:01 2002

I am new to the list and I am pretty sure this came up before.  I am using
clisp version 2.29 for windows running on windows XP.  
I am trying to call an editor from the clisp prompt by typing:

[1]>(load "editor") 

and I can not get it to work.

The editor called in my config.lsp file is the notepad.exe
actually when I load the config.lsp file I am getting error loading.
Everything else seems to be working.  The readme file on the distribution
for version 2.29 calls for a set of instructions to create a batch file
etc.  I just used the batch file that came with the distribution.  Am I off
on a tangent on this one?

any help would be appreciated.

I would rather be on a unix environment but I am on windows by necessity.  

Thank you,

Sophronis Mantoles

---

From: Marco Baringer <[email-masked]>
Date: Sat Sep 7 15:00:04 2002

> and I can not get it to work.

you want to read up the docs on the function ED. the function LOAD
loads a file (evals all the forms in the file sequentially), so what
you're doing there is trying to load a file named editor.lisp (or
editor.fasl if it exists and is newer than editor.lisp).
 
> on a tangent on this one?

i suggest you get Emacs+ILISP working. at first it can seem like a lot
of work just to get started, but it's well worth it.
 
> I would rather be on a unix environment but I am on windows by necessity.  

that's why we have Emacs.

-- 
-Marco
Ring the bells that still can ring.
Forget your perfect offering.
There is a crack in everything.
That's how the light gets in.
     -Leonard Cohen

---

From: Edi Weitz <[email-masked]>
Date: Sat Sep 7 15:24:01 2002

> I would rather be on a unix environment but I am on windows by necessity.  

You might want to read this text by Bill Clementson:

  <http://cl-cookbook.sourceforge.net/windows.html>

Edi.