Subject: [clisp-list] CLISP 2.28 Working On FreeBSD/Alpha

From: Jeffrey Katcher <[email-masked]>
Date: Mon Jun 17 13:48:02 2002

lispbibl.d:2404 changed to
#if defined(DECALPHA) && (defined(UNIX_OSF)
defined(UNIX_LINUX) || defined(UNIX_FREEBSD))

CLISP 2.28 now will successfully make/make check using
the system gcc2.95.2 compiler.  I haven't yet
validated dynamic-ffi, but everything else looks good.

FYI:
Code address range = 0x0000000120000000
Malloc address range = 0x0000000120000000
Shared library address range = 0x0000000160000000
Stack address range = 0x0000000011000000

BTW, It cores in the config process using gcc31 and
there's a preprocessor issue with the Compaq C
compiler (ccc).

Very excited about getting this working,

Jeff Katcher

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Mon Jun 17 14:08:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLISP 2.28 Working On FreeBSD/Alpha"
> * Sent on Mon, 17 Jun 2002 13:47:05 -0700 (PDT)
> * Honorable Jeffrey Katcher <[email-masked]> writes:
>
> CLISP 2.28 now will successfully make/make check using the system
> gcc2.95.2 compiler.  I haven't yet validated dynamic-ffi, but
> everything else looks good.

great!

> BTW, It cores in the config process using gcc31 and

this is a known bug in gcc31.
add "-fno-gcse" to CFLAGS
(this is actually in the CVS development version)

> there's a preprocessor issue with the Compaq C compiler (ccc).

What is the issue?
CLISP comes with a CPP specifically for this case.
Search src/makemake.in for XCC_UNUSABLE_CPP.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
"A pint of sweat will save a gallon of blood."          -- George S. Patton

---

From: Jeffrey Katcher <[email-masked]>
Date: Mon Jun 17 14:19:03 2002

I was incorrect about the Compaq C issue involving the
preprocessor.  

As Compaq C for Linux (hacked to generate FreeBSD
binaries) is basically the DU compiler, I thought I
was seeing the issue discussed in the release notes. 

All I needed to do was to tweak the alloca definition
in lispbibl.d:1083 (along with the previous fix) to
get things to build.

I am seeing a Seg Fault after config.lisp is loaded
when the make is building the clisp image.  Back to
the drawing board...