Subject: [clisp-list] CLISP stack & hash tables (9nines crash on MS-Windows)

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Mar 27 05:57:03 2002

Hi,

I'm glad to see that progress is made in this area.

Arseny Slobodjuck wrote:
>Thus, it is not a crash, but a nice stack overflow handling.

You seem to forget that in my initial mail I reported that using
(EXT:SPACE (9nines)) causes a program crash. It's not nice in any way.

Invoking (9nines) without EXT:SPACE causes "only" a STACK overflow/RESET error message, as you mention, without exiting the Lisp session.

Regards,
	Jorg Hohle.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Mar 28 02:54:11 2002

Hi,

Wednesday, March 27, 2002, 11:56:17 PM, you wrote:

>>Thus, it is not a crash, but a nice stack overflow handling.

Joerg-Cyril> You seem to forget that in my initial mail I reported that using
Joerg-Cyril> (EXT:SPACE (9nines)) causes a program crash. It's not nice in any way.

Yes, I forgot this. Anyway, I think, the matter is in the GC, so actual progress
is deferred to the time when I'll understand how GC works (or somebody
else will fix it). Now my knowledge about GC algorithms is very weak. Links
are welcome. I heard Cohen-1981 is good, but cannot find it in pdf or
ps.

Thanks for the regexps (didn't test yet) !

-- 
Best regards,
 Arseny                            mailto:[email-masked]