Subject: [clisp-list] REINITIALIZE-INSTANCE problems

From: Stig E Sandoe <[email-masked]>
Date: Thu Feb 21 08:41:02 2002

hei,

I have some troubles getting REINITIALIZE-INSTANCE to work in
CLISP.  The following test-case:

(in-package :cl-user)

(defclass component ()
  ((name :type string :accessor component-name :initarg :name)
   (version :accessor component-version :initarg :version)
   (in-order-to :initform nil :initarg :in-order-to)
   (inline-methods :accessor component-inline-methods :initform nil)
   (relative-pathname :initarg :pathname)))

(defun upd-inst (obj &rest args)
  (apply #'reinitialize-instance obj args))

;;(trace reinitialize-instance)

(let ((foo (make-instance 'component :name "gib")))
  (warn "Going 1")
  (upd-inst foo :name "gah1")
  (warn "Going 2")
  (upd-inst foo :name "gah2")
  (warn "Going 3")
  (upd-inst foo :name "gah3")
  )

Gives me: 

$ clisp -q -ansi reinit.lisp

WARNING:
Going 1
WARNING:
Going 2
WARNING:
Going 3
*** - handle_fault error2 ! address = 0x4556454F not in 
[0x202A6000,0x2036220C) !
SIGSEGV cannot be cured. Fault address = 0x4556454F.
Segmentation fault (core dumped)

This is quite problematic, and it's not a good thing that clisp 
crashes and dumps core.  Anyone? 

-- 
------------------------------------------------------------------
Stig Erik Sandoe     [email-masked]    http://www.ii.uib.no/~stig/

---

From: Sam Steingold <[email-masked]>
Date: Sat Feb 23 10:03:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] REINITIALIZE-INSTANCE problems"
> * Sent on Thu, 21 Feb 2002 17:40:12 +0100
> * Honorable Stig E Sandoe <[email-masked]> writes:
>

just fixed this in the CVS.
thanks for the bug report.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Those who can't write, write manuals.

---

From: Stig E Sandoe <[email-masked]>
Date: Sat Feb 23 10:11:02 2002

Quoting Sam Steingold ([email-masked]):
| > * In message <[email-masked]>
| > * On the subject of "[clisp-list] REINITIALIZE-INSTANCE problems"
| > * Sent on Thu, 21 Feb 2002 17:40:12 +0100
| > * Honorable Stig E Sandoe <[email-masked]> writes:
| >
| > *** - handle_fault error2 ! address = 0x4556454F not in 
| > [0x202A6000,0x2036220C) !
| > SIGSEGV cannot be cured. Fault address = 0x4556454F.
| > Segmentation fault (core dumped)
| 
| just fixed this in the CVS.

good :-)

| thanks for the bug report.

do you have an estimate when this (imho important) fix comes
in a released clisp?  ie when will the next clisp be released,
it has been quite awhile, and looking at clisp-devel it seems
to me that current cvs contains many important bug-fixes.

May I politely ask for "release early, release often"? :-)

---

From: Sam Steingold <[email-masked]>
Date: Sat Feb 23 21:34:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] REINITIALIZE-INSTANCE problems"
> * Sent on Sat, 23 Feb 2002 19:09:52 +0100

read CLISP/src/ChangeLog, find the bug you need, get the fixes you need
from the CVS, apply the patches, build from the sources.

> May I politely ask for "release early, release often"? :-)

may I politely ask for money? :-)

I have been unemployed for 3 weeks now, and if you can offer me a
contract doing CLISP development, it would be nice.
If you have a permanent position for me in the Boston, MA area, it
would be even better (<http://www.podval.org/~sds/resume.html>).

[just in case - CLISP is and always will be under GPL.  don't worry]

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Trespassers will be shot.  Survivors will be SHOT AGAIN!

---

From: Todd Sabin <[email-masked]>
Date: Thu Feb 28 15:01:04 2002

> from the CVS, apply the patches, build from the sources.

Are there things that you feel need to be done before the next
release?  In other words, are there things people can do (besides
donate funding) to hasten the next release of clisp?

Todd

---

From: Sam Steingold <[email-masked]>
Date: Thu Feb 28 20:54:11 2002

> * In message <[email-masked]>
> * Sent on 28 Feb 2002 18:00:15 -0500
> * Honorable Todd Sabin <[email-masked]> writes:
>
> release?

I just committed the last (3rd) pre-test.
All the brave, please do "cvs up" and try it out.
I added weak hash-tables, which necessitated yet another fas-file format
change - the last before the release (I wanted to get weak HTs into 2.28
because I want to avoid fas-file format changes for some time).

Now, the things on the TODO list
(FIUAR = "Forget It Until After Release"):

1. trace of flet/label locals (me, FIUAR)

2. Todd's patches (require Bruno's approval, FIUAR)

3. iconv compilation issues on some platforms (Bruno)

4. Solaris/gcc3/FFC failures (Bruno)

5. format/pplb, other pretty-print issues (me, FIUAR)

6. message translations; so far we have Stefan <[email-masked]>
   doing the German messages.  We need French, Spanish and Dutch.
   Arseny, are you doing Russian?

7. libltdl integration for portability of dynamic modules, including
   woe32 (Bruno, FIUAR)

8. dirkey/ldap (me, FIUAR)

9. linux.lisp wait/waitpid patch needs to be tested and comitted...

...
   
Bruno is very busy, so we will not wait for him (unless he speaks up and
tells us to wait :-), even though the release quality will probably
suffer.

thus: as soon as the message translations are in, the release is out.

you are _very_ welcome to pick up the aforementioned tasks, especially 5&8.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I'm a Lisp variable -- bind me!

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Feb 28 22:20:03 2002

Hello, Sam,

Friday, March 01, 2002, 2:49:20 PM, you wrote:

Sam>    Arseny, are you doing Russian?
There is about 1/3 left (2/3 done). If translation detains the
release, I'll speed translation up.

-- 
Best regards,
 Arseny                            mailto:[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: Fri Mar 1 18:39:02 2002

> Are there things that you feel need to be done before the next

I want the release out by Monday.

I tested it on Linux and FreeBSD.

There will be _NO_ release until I get confirmation from the users that
the current CVS CLISP compiles out of the box on at least win32 and
Solaris.

The translations can wait for the next release, but if I receive no
build reports from Solaris and win32 people in the near future, I
cannot make a release, thus the translations will get in &c.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Life is like a diaper -- short and loaded.

---

From: Sam Steingold <[email-masked]>
Date: Fri Mar 1 18:42:16 2002

> * In message <[email-masked]>
> * On the subject of "Re[2]: [clisp-list] next release"
> * Sent on Fri, 1 Mar 2002 16:18:57 +1000
> * Honorable Arseny Slobodjuck <[email-masked]> writes:
>

Arseny, I don't think you will finish it by 2.28.
testing on win32 has much higher priority right now.
Can you do it?  (I do not have access to a woe32 machine)
you need to build, do a 'make check', and try install.bat
thanks.

Russian translations will be added in 2.29.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Don't ascribe to malice what can be adequately explained by stupidity.

---

From: Todd Sabin <[email-masked]>
Date: Fri Mar 1 21:39:08 2002

> I tested it on Linux and FreeBSD.

Current CVS is failing for me on Redhat62, due to an ICONV_CONST
mismatch.  I think I've figured out the problem.  unixconf.h.in
has a line:

#define ICONV_CONST

but the autoconf sed stuff can't change it because there's no symbol
it's defined to, which causes the sed expressions autoconf uses not to
work.  Apparently, the way to address that is by changing it thusly:

diff -u -r1.30 unixconf.h.in
--- src/unixconf.h.in	25 Dec 2001 17:48:28 -0000	1.30
+++ src/unixconf.h.in	2 Mar 2002 04:56:38 -0000
@@ -653,7 +653,7 @@
    iconv_open, iconv, iconv_close functions. */
 #undef HAVE_ICONV
 /* Define as const if the declaration of iconv() needs const. */
-#define ICONV_CONST
+#undef ICONV_CONST

 /* OS services */

which matches the way all the other *_CONST stuff in there is done.
And it does fix the build on Redhat 6.2.  Redhat 7.2 also still works
(and does without the patch).  Unfortunately, with the patch the build
doesn't work on FreeBSD 4.5 (I haven't tried 4.5 without the patch).
The problem in that case is that it doesn't have ICONV at all, so no
line is added to confdefs.h one way or the other about ICONV_CONST,
which leaves the undef as is.  So the compiler complains about
ICONV_CONST being unrecognized.  A possible way around _that_ is this:

diff -u -r1.30 unixconf.h.in
--- src/unixconf.h.in	25 Dec 2001 17:48:28 -0000	1.30
+++ src/unixconf.h.in	2 Mar 2002 05:18:32 -0000
@@ -653,8 +653,11 @@
    iconv_open, iconv, iconv_close functions. */
 #undef HAVE_ICONV
 /* Define as const if the declaration of iconv() needs const. */
-#define ICONV_CONST
+#undef ICONV_CONST
 
+#ifndef ICONV_CONST
+#define ICONV_CONST
+#endif
 
 /* OS services */

which makes sure that ICONV_CONST is defined as nothing, if not
defined yet.  Probably the right way is to use just the first patch,
but also fix the code in configure to put a line in confdefs.h even if
iconv isn't present, but it seems that configure itself is
auto-generated somehow.  I really have no idea how this autoconf stuff
is supposed to work, in case you couldn't tell... :) Hopefully,
someone else does...

Anyway, with this second patch, Redhat 6.2 and 7.2 build for me fine.
FreeBSD 4.5 manages to build the clisp binaries, but chokes on the
Makefile in the suite directory, saying:

LISP="`pwd`/lisp.run -M `pwd`/lispinit.mem -B `pwd` -N `pwd`/locale -Efile UTF-8 -norc"; export LISP; cd suite; make LISP="$LISP"
"Makefile", line 2: Missing dependency operator
"Makefile", line 5: Need an operator
"Makefile", line 8: Need an operator
make: fatal errors encountered -- cannot continue
*** Error code 1

> the current CVS CLISP compiles out of the box on at least win32 and

I'll try the windows build tomorrow.  Don't have any Solaris...

Todd

---

From: Arseny Slobodjuck <[email-masked]>
Date: Sat Mar 2 03:14:14 2002

Hello Sam,

Saturday, March 02, 2002, 12:37:02 PM, you wrote:

Sam> Arseny, I don't think you will finish it by 2.28.
Sam> testing on win32 has much higher priority right now.
Sam> Can you do it?  (I do not have access to a woe32 machine)
Sam> you need to build, do a 'make check', and try install.bat
Sam> thanks.
It compiles fine except file spvw_language.d which needs declaration
of uint. It seems to be declared in intparam.d -> intparam.h, which
is not available in win32 (I think). So I suggest change uint to uintL
- see patch.

Install.bat and generated clisp.bat works fine.

Tests are passed. Make check ok.

CLHS doesn't work:
[1]> (clhs 'car)

*** - There is no package with name "NIL"
1. Break [2]> abort

*** - There is no package with name "NIL"
1. Break [3]> abort

Note: I tried to abort twice !

Maybe that will help

[3]> (load "clhs.lisp")
;; Loading file clhs.lisp ...
;; Loading of file clhs.lisp is finished.
T

[5]> (clhs 'car)

*** - There is no package with name "NIL"
1. Break [6]> up

EVAL frame for form
(PROGN (SYSTEM::%SET-PACKAGE-LOCK #:WOPL-1231 NIL)
 (SETQ SYSTEM::*CLHS-TABLE*
  (READ-FROM-FILE (SYSTEM::CLISP-DATA-FILE "clhs.txt") :OUT SYSTEM::OUT
   :PACKAGE "COMMON-LISP")))

(describe (code-char 1234)) works.

I cannot makemake nor make distrib since I only have small subset of
cygwin which moreover I didn't used much. I'll try to download and use
it. Or I'll try to do distrib in FreeBSD (mount the FAT drive and make
distrib with win32 makefile - is it valid approach ?).

---

From: Arseny Slobodjuck <[email-masked]>
Date: Sat Mar 2 07:57:13 2002

Hello Sam,

Sam> testing on win32 has much higher priority right now.
I suggest that patch. The new data : section of makefile
was totally unixoid and didn't work in win32.
With that patch I was able to make distrib (from FreeBSD)
which contained amongst other files
data/UnicodeData.txt,
data/clhs.txt,
emacs/clisp-coding.el,
emacs/clisp-indent.el,
emacs/clisp-indent.lisp.

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 2 11:43:17 2002

Hi Arseny,

> * In message <[email-masked]>
> * On the subject of "Re[4]: [clisp-list] next release"
> * Sent on Sun, 3 Mar 2002 01:55:36 +1000

> -echotab "cd data && \$(LN_S) ${PARENT_SRCTOPDIR}utils${NEXT}unicode${NEXT}ftp.unicode.org${NEXT}UnicodeData.txt UnicodeData.txt"
> -echotab "cd data && \$(LN_S) ${PARENT_SRCTOPDIR}src${NEXT}clhs.txt clhs.txt"
> +echotab "\$(LN_S) ${SRCTOPDIR_M}utils${NEXT_}unicode${NEXT_}ftp.unicode.org${NEXT_}UnicodeData.txt data${NEXT_}UnicodeData.txt"
> +echotab "\$(LN_S) ${SRCTOPDIR_M}src${NEXT_}clhs.txt data${NEXT_}clhs.txt"

this is broken when LN_S is "ln -s".

please try the appended patch

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Oh Lord, give me the source code of the Universe and a good debugger!

--- makemake.in.~1.225.~	Tue Feb 26 13:35:49 2002
+++ makemake.in	Sat Mar  2 14:35:48 2002
@@ -2677,7 +2677,7 @@
 
 DATA_FILES="UnicodeData.txt clhs.txt"
 echol "data :"
-echotab "if test -d data; then rm -rf data; fi"
+echotab "rm -rf data"
 echotab "mkdir data"
 echotab "cd data && \$(LN_S) ${PARENT_SRCTOPDIR}utils${NEXT}unicode${NEXT}ftp.unicode.org${NEXT}UnicodeData.txt UnicodeData.txt"
 echotab "cd data && \$(LN_S) ${PARENT_SRCTOPDIR}src${NEXT}clhs.txt clhs.txt"

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 2 12:19:33 2002

> * In message <[email-masked]>
> * Sent on Sat, 2 Mar 2002 21:13:17 +1000

that was actually a typo.
thanks.

> *** - There is no package with name "NIL"
fixed -- thanks!

please try again.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
MS DOS: Keyboard not found. Press F1 to continue.

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 2 15:40:04 2002

> * In message <[email-masked]>
> * Sent on 02 Mar 2002 00:37:59 -0500

I _think_ I just fixed this, hopefully forever.
Please _do_ test it on all your platforms.

And I do not mean just you, Todd.
Everyone who has been saying "release early; release often" -
please do "cvs up" and build CLISP on your platform.
You have nothing to lose: if you succeed, you will have the next stable
version of CLISP a couple of days before everyone else, if you fail and
report your problem, the next CLISP version will work on your platform
out of the box, so you will not have to wait until the next release.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Do not worry about which side your bread is buttered on: you eat BOTH sides.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Sat Mar 2 16:42:19 2002

Hello Sam,

>> +echotab "\$(LN_S) ${SRCTOPDIR_M}src${NEXT_}clhs.txt data${NEXT_}clhs.txt"

Sam> this is broken when LN_S is "ln -s".
Sam> please try the appended patch

Sam> DATA_FILES="UnicodeData.txt clhs.txt"
Sam> echol "data :"
Sam>-echotab "if test -d data; then rm -rf data; fi"
Sam>+echotab "rm -rf data"
Then, maybe, "-rm -rf data" ?
Sam> echotab "mkdir data"
Sam> echotab "cd data && \$(LN_S) ${PARENT_SRCTOPDIR}utils${NEXT}unicode${NEXT}ftp.unicode.org${NEXT}UnicodeData.txt

I tried a lot of ways. In win32 LN_S=copy , which doesn't understand
forward slashes on NT (it counts it as option). Since we use sed
and rm (I personally use set of GNU file utilities ported for NT,
must have for developer) we can use LN_S=cp.

Or we need ${PARENT_SRCTOPDIR_} in addition to ${PARENT_SRCTOPDIR}.
But rm still remains. To remove it we need
$(RMRF1)=del /q /s  $(RMRF2)=rmdir /q /s on win32 and
$(RMRF1)=rm -rf  $(RMRF2)=  on unix and use both it every time
or something similar (bat file rmrf.bat for example). Brrr...
Using rm is less painful. BTW, there is ln port, it even gets
rid of NT hardlinks.

It seems to me that Makefile was revised to remove use of such
utilities for win32 since last year, is it ?

Another problem is data dependency. VC nmake looks to data directory
creation date and does nothing if it exists (but files in it may be
obsolete). I don't know whether it is a big problem.

clhs working now.

---

From: Todd Sabin <[email-masked]>
Date: Sat Mar 2 18:32:05 2002

> Please _do_ test it on all your platforms.

Works on Redhat 6.2 and 7.2.  FreeBSD 4.5 builds to the point where it
complains about the Makefile in suite, as mentioned in the last mail.
Is that normal?

I tried win32 with VS6 earlier today.  Builds with a couple minor
problems fixed.  The first is that del fails on non-existant files,
so

--- ../win32msvc/makefile.msvc5	Mon Nov 19 14:38:15 2001
+++ makefile	Sat Mar  2 16:40:50 2002
@@ -50,10 +50,10 @@
 MSVCDIR = "C:/Program Files/Microsoft Visual Studio/VC98"
 
 MAKE = nmake
-RM = del
+RM = -del
 CP = copy
 LN_S = copy
 MV = ren

The other is that the supplied install.bat is referencing
src/install.lisp, but appears to want to be run from src itself, which
doesn't work.

RCS file: /cvsroot/clisp/clisp/src/install.bat,v
retrieving revision 1.2
diff -u -b -r1.2 install.bat
--- install.bat	9 Jun 2001 17:03:13 -0000	1.2
+++ install.bat	3 Mar 2002 02:11:53 -0000
@@ -6,6 +6,6 @@
 echo press C-c to abort
 pause
 
-lisp.exe -B . -M lispinit.mem -norc -C src/install.lisp
+lisp.exe -B . -M lispinit.mem -norc -C install.lisp
 
 pause

Todd

---

From: Arseny Slobodjuck <[email-masked]>
Date: Sat Mar 2 20:37:27 2002

Hello Todd,

Sunday, March 03, 2002, 12:31:43 PM, you wrote:

Todd>  MAKE = nmake
Todd> -RM = del
Todd> +RM = -del
Always in makemake.in, Makefile.msvc5 just needs to be recreated.

Todd> The other is that the supplied install.bat is referencing
Todd> src/install.lisp, but appears to want to be run from src itself, which
Todd> doesn't work.
install.bat intended to be called from distribution, where src/ and
data/ (which also is in makefile.in) exists.

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 2 21:54:02 2002

> * In message <[email-masked]>
> * Sent on 02 Mar 2002 21:31:43 -0500
> FreeBSD 4.5 builds to the point where it complains about the Makefile
> in suite, as mentioned in the last mail.  Is that normal?

I just fixed this.
unfortunately this required removing the gnu-make-specific IF construct
(is there a portable on across all make implementations? :-)
this means that cygwin users will have to edit the Makefile to run the
testsuite or specify the LISP make var on the command line.

> +++ makefile	Sat Mar  2 16:40:50 2002

please regenerate your makefile.msvc5 using
make -f Makefile.devel win32msvc/makefile.msvc5

> src/install.lisp, but appears to want to be run from src itself, which

you are missing the point.
install.bat is for the users of the binary distributions.
a binary distribution has lisp.exe and lispinit.mem at the top-level
and install.lisp in the src subdirectory.
you should use cygwin to create a binary distribution
        $ make distrib
and then install it somewhere and run install.bat there.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Why use Windows, when there are Doors?

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 2 22:37:03 2002

Hi Arseny,

> * In message <[email-masked]>
> * On the subject of "Re[6]: [clisp-list] next release"
> * Sent on Sun, 3 Mar 2002 10:40:43 +1000

i do not recall it.
when?
what ChangeLog entry?
CVS revision?

> obsolete). I don't know whether it is a big problem.
this is not a big deal.

> clhs working now.
good.

I _think_ I fixed the problems you mention in the makemake.in in the
CVS.
please regenerate your makefile and try again.
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Those who can laugh at themselves will never cease to be amused.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Sun Mar 3 02:17:13 2002

Hello Sam,

>> utilities for win32 since last year, is it ?

Sam> i do not recall it.
Sam> when?
Sam> what ChangeLog entry?
Sam> CVS revision?
I remember that when I tried compile clisp on win32 for the first
time, it was impossible to compile without cp, sed and uniq. I didn't
tried recently w/o utilities, but at least cp was changed to copy.
Uniq was removed at all. Sed is called on distrib stage only. In
last patch you removed call to rm and added del instead. That's what
I mean.

Sam> I _think_ I fixed the problems you mention in the makemake.in in the
Sam> CVS.
Sam> please regenerate your makefile and try again.
Genialno. Works. Del asks permission to delete files by pattern, so
it needs the /q switch:

Index: makemake.in
===================================================================
RCS file: /cvsroot/clisp/clisp/src/makemake.in,v
retrieving revision 1.226
diff -u -r1.226 makemake.in
--- makemake.in 3 Mar 2002 06:34:17 -0000       1.226
+++ makemake.in 3 Mar 2002 09:11:42 -0000
@@ -612,7 +612,7 @@
 
 # RM = command for deleting files
 if [ $H_DOS = "true" ] ; then
-  RM='del'
+  RM='del /q'
 else
   if [ $HOS = acorn ] ; then
     RM='remove'

Problems with make check (I didn't make check with newly generated
makefile until now):
  francais
  spanish
  comp.exe returns error on compare (because of gensyms).
    I never went further, but now when I changing comp to
    -comp, testsuite doesn't work: copy doesn't take arbitrary
    number of args:

        mkdir suite
        cd suite && copy ..\..\tests\Makefile ..\..\tests\*.lisp ..\..\tests\*.tst .    

    Recently I created separate makefile for tests and it was
    passed.

This is not vitally important though.

WARNING:
INTERN("STOREFORM"): #<PACKAGE LDAP> is locked
Ignore the lock and proceed

  Is that normal ?  A lot of such warnings prints out during make
  check.

---

From: Eric Marsden <[email-masked]>
Date: Sun Mar 3 09:40:03 2002

>>>>> "Sam" == Sam Steingold <[email-masked]> writes:

  Sam> I tested it on Linux and FreeBSD.

on Linux, I get an error during "make install". I build in a private
directory (last argument to configure is the directory
/tmp/clisp-gcc). Build and tests work fine (including modules wildcard
and regexp and --export-syscalls), then in the /tmp/clisp-gcc
directory,

,----
| % sudo make install
| test -d /usr/local || mkdir /usr/local
| test -d /usr/local || mkdir /usr/local
| test -d /usr/local/lib || mkdir /usr/local/lib
| test -d /usr/local/lib/clisp || mkdir /usr/local/lib/clisp
| test -d /usr/local/lib/clisp/data || mkdir /usr/local/lib/clisp/data
| /usr/bin/install -c -m 644 data/UnicodeData.txt /usr/local/lib/clisp/data/UnicodeData.txt
| /usr/bin/install: cannot stat `data/UnicodeData.txt': No such file or directory
| make: *** [install-bin] Error 1
| % ls -l data
| total 0
|    0 lrwxrwxrwx    1 emarsden tsf            73 Mar  3 18:24 UnicodeData.txt -> ..//opt/src/cvs-clisp/clisp/utils/unicode/ftp.unicode.org/UnicodeData.txt
|    0 lrwxrwxrwx    1 emarsden tsf            40 Mar  3 18:24 clhs.txt -> ..//opt/src/cvs-clisp/clisp/src/clhs.txt
| %       
`----

I ran configure from the directory /opt/src/cvs-clisp/clisp. 

  Sam> There will be _NO_ release until I get confirmation from the users that
  Sam> the current CVS CLISP compiles out of the box on at least win32 and
  Sam> Solaris.

is the FFI supposed to work on Solaris?  I generally build without it,
but I just tried to build with the regexp and wildcard modules, and it
fails with

,----
| /tmp/clisp-gcc/lisp.run -M /tmp/clisp-gcc/lispinit.mem -B /tmp/clisp-gcc -N /tmp/clisp-gcc/locale -Efile UTF-8 -norc -q -c regexp.lisp
| Compiling file /tmp/clisp-gcc/regexp/regexp.lisp ...
| *** - There is no package with name "FFI"
`----

This is on SunOS 5.7 with gcc 2.95.2. The avcall stuff seems to have
compiled ok:

,----
| /tmp/clisp-gcc$ cat avcall/minitests.output.sparc-sun-solaris2.7 
| Int f(Int,Int,Int):({1},{2},{3})->{6}
| Int f(Int,Int,Int):({1},{2},{3})->{9}
| J f(J,int,J):({47,11},2,{73,55})->{120,68}
| J f(J,int,J):({47,11},2,{73,55})->{9,902231815}
`----
  
-- 
Eric Marsden                          <URL:http://www.laas.fr/~emarsden/>

---

From: Sam Steingold <[email-masked]>
Date: Sun Mar 3 09:51:07 2002

Hi Arseny

> * In message <[email-masked]>
> * On the subject of "Re[8]: [clisp-list] next release"
> * Sent on Sun, 3 Mar 2002 20:15:36 +1000
done

>   comp.exe returns error on compare (because of gensyms).
that's okay.

>     -comp, testsuite doesn't work: copy doesn't take arbitrary
fixed.

> Ignore the lock and proceed

this is normal when running "make test"

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
MS Windows: error: the operation completed successfully.

---

From: Sam Steingold <[email-masked]>
Date: Sun Mar 3 18:27:02 2002

> * In message <[email-masked]>
> * Sent on Sun, 03 Mar 2002 18:39:04 +0100
> * Honorable Eric Marsden <[email-masked]> writes:
>

okay - fixed, please try again.
(this "try again", unfortunately, includes those of you, who have
already tested the latest CVS CLISP and reported success.
sorry guys. )-:

> is the FFI supposed to work on Solaris? 
yes.

> I generally build without it, but I just tried to build with the
> regexp and wildcard modules, and it fails with
> 
> ,----

try
$ ./configure --with-dynamic-ffi

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
A man paints with his brains and not with his hands.

---

From: Eric Marsden <[email-masked]>
Date: Mon Mar 4 01:10:07 2002

>>>>> "Sam" == Sam Steingold <[email-masked]> writes:

  Sam> okay - fixed, please try again.
  Sam> (this "try again", unfortunately, includes those of you, who have
  Sam> already tested the latest CVS CLISP and reported success.
  Sam> sorry guys. )-:

right, it works now, thanks.  
    
  ecm> is the FFI supposed to work on Solaris? 
  Sam> yes.

  Sam> try
  Sam> $ ./configure --with-dynamic-ffi

thanks, is there a reason why this defaults to on for linux/x86, but
needs to be specified explicitly on Solaris?  Also, it would be nice
if it appeared in the output of «configure --help».

Apparently the avcall tests fail:

,----
| /tmp/clisp-gcc$ more avcall/minitests.output.sparc-sun-solaris2.7 

I'm afraid that the error in avcall-sparc.s isn't immediately evident
to me :-)

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 4 06:20:06 2002

> * In message <[email-masked]>
> * On the subject of "prerelease testing (was Re: [clisp-list] REINITIALIZE-INSTANCE problems)"
> * Sent on Mon, 04 Mar 2002 10:08:27 +0100
> needs to be specified explicitly on Solaris?

because FFI tests fail on Solaris but pass on Linux.

> Also, it would be nice

it is supposed to be auto-detected.
the right solution is to fix FFI on Solaris.

> Apparently the avcall tests fail:
here you go.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
"A pint of sweat will save a gallon of blood."          -- George S. Patton