Subject: [clisp-list] Please explain

From: Barry Friedman <[email-masked]>
Date: Wed May 1 07:02:44 2002

Hi,

  I'm using GNU CLISP 2.27 (released 2001-07-17) and am trying to
  invoke a lisp program from a cgi script.  This now produces the
  message: 

    *** - The value of *TERMINAL-IO* was not a stream: 
    #<CLOSED TERMINAL-STREAM>. 
    It has been changed to #<IO TERMINAL-STREAM>

    and terminates.

  (This did not happen with an older version of clisp: 1999-07-22 )

  How can I prevent this from happening?

Thanks in advance,
-- 
Barry Friedman                         
Emax Computer Systems Inc., 440 Laurier Ave. W., Ottawa, Ont. Canada K1R 7X6
ESN: 395-4270  NET: [email-masked]    Phone: (613) 782-2389  Fax: 782-2228

---

From: Sam Steingold <[email-masked]>
Date: Wed May 1 11:22:29 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Please explain"
> * Sent on Mon, 1 May 1972 09:57:12 -0400
> * Honorable Barry Friedman <[email-masked]> writes:
>
please upgrade.

>     It has been changed to #<IO TERMINAL-STREAM>

I think something like this was reported some months ago.
if there was a reproducible test case, them it was fixed,
so either 2.28 or at least CVS should work.

>   (This did not happen with an older version of clisp: 1999-07-22 )

interesting.

>   How can I prevent this from happening?

please try to create a reproducible test case.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.palestine-central.com/> <http://www.mideasttruth.com/>
He who laughs last thinks slowest.