Subject: [clisp-list] FAQ

From: "Herve Franceschi" <[email-masked]>
Date: Mon Jun 23 16:49:06 2003

I am using clisp 2.30.1
when I type 

(defun f(x) 6)

I get the following error
*** - EVAL: the function DEFUN is undefined

I also tried the factorial function from the tutorial ==> same problem

What am I doing wrong?

Herve Franceschi

---

From: Sam Steingold <[email-masked]>
Date: Mon Jun 23 16:57:06 2003

> * In message <000201c339e1$db37fc10$0000a398@hewlett2ih5nie>
> * On the subject of "[clisp-list] FAQ"
> * Sent on Mon, 23 Jun 2003 19:43:55 -0400
> * Honorable "Herve Franceschi" <[email-masked]> writes:
>
> I am using clisp 2.30.1
> when I type 
> 
> (defun f(x) 6)
> 

do you have _clisprc?
what is the value of CL:*PACKAGE*?
did you change it?
what is the prompt?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
There is Truth, and its value is T.  Or just non-NIL.  So 0 is True!

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Jun 23 17:17:17 2003

Hello Herve,

Tuesday, June 24, 2003, 10:43:55 AM, you wrote:

Herve> I am using clisp 2.30.1
Herve> when I type 

Herve> (defun f(x) 6)

Herve> I get the following error
Herve> *** - EVAL: the function DEFUN is undefined

Herve> I also tried the factorial function from the tutorial ==> same problem

Herve> What am I doing wrong?

Possibly you're starting clisp without memory image. What command
line do you use to start clisp (if any). Do you just click on lisp.exe
in explorer ? Please use install.bat or supply a memory image with -M
commandl line option.

-- 
Best regards,
 Arseny                            mailto:[email-masked]

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Jun 23 18:44:01 2003

Hello Herve,

Tuesday, June 24, 2003, 11:54:55 AM, you wrote:

Herve> To start clisp, I just double click on clisp.exe
Herve> I ran install.bat but I still have the same problem
Herve> Memory image:  what is this?
Herve> what shall I type at command line ?
Uhhh...

- html email
- faq question (though there's no FAQ)
- top quoting

considered bad things here AFAIK.

install.bat creates clisp.bat at the desktop, which properly calls
clisp with memory image supplied. Memory image is lispinit.mem so
whole minimal command line is 'lisp.exe -M lispinit.mem'.