Subject: [clisp-list] socket-status question

From: "Jan Marecek" <[email-masked]>
Date: Tue Apr 2 03:44:49 2002

hello, i'm trying to write a server in clisp but I can't work out how to
pass
a list of sockets to socket-status.
this is the error i get:

(setq server (socket-server 8888))
=> #<SOCKET-SERVER 0.0.0.0:8888>
(setq client (socket-accept server))
=> #<IO UNBUFFERED SOCKET-STREAM CHARACTER 0.0.0.0:8888>
(socket-status server 0)
=> NIL
(socket-status client 0)
=> :OUTPUT
(socket-status '(server (client . :io)))
=> *** - SOCKET-STATUS: argument SERVER should be a stream

I looked in src/stream.d and at line 14996 i found:
  var bool many_sockets_p =
    (consp(all) && !(symbolp(Cdr(all)) && keywordp(Cdr(all))));
this looks to me like it be
    (consp(all) && !(symbolp(Car(all)) && keywordp(Cdr(all))));
but I couldn't find any clues as to why a list wouldn't work.

I'm using clisp-2.28 and get the same error on linux and win32(98 & 2000).

- jan

---

From: Sam Steingold <[email-masked]>
Date: Tue Apr 2 07:50:06 2002

> * In message <001101c1dad1$dc7a30e0$179986cb@abe>
> * On the subject of "[clisp-list] socket-status question"
> * Sent on Tue, 2 Apr 2002 21:39:00 -0800
> * Honorable "Jan Marecek" <[email-masked]> writes:
>

try
(socket-status (list server (cons client :io)))
and think about evaluating and quoting

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Any connection between your reality and mine is purely coincidental.