Subject: AW: RE: [clisp-list] CLISP an German charcters

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Sep 11 04:39:02 2002

Hi,

>Could you help me?

It looks like you're sitting on a MS-windoes box with Emacs and CLISP.

1. find out what encoding your dos box window uses,

2. find out what encoding Emacs uses for files,

3. find out what encoding Emacs uses for communication with an embedded CLISP *process*.

> (format nil "~@C" #\ä) ; helps you
"#\\LATIN_SMALL_LETTER_A_WITH_DIAERESIS"

If the encoding is wrong, you may see an ä but CLISP sees a different character, not a small letter a! The character name will show this.

You may need to (run-lisp "clisp -E terminal iso-8859-1 ... other options" instead of the default CP850 codepage.

E.g. I use -Efile UTF-8 -Eterminal ISO-8859-1 when running inside Emacs.
o UTF-8 for files because that's what CLISP source files use -- This may be counterproductive for your own CLISP files, e.g. you might be using iso-8859-1.
o iso-8859-1 because that's what I found out Emacs sends to the CLISP process in my environment.

I'm using Emacs-20.7.x

Regards,
	Jörg Höhle.

---

From: [email-masked]
Date: Wed Sep 11 06:02:02 2002

Hi,

Now I use '-Efile iso-8859-1 -Eterminal iso-8859-1'
in the clisp-call and everything is fine.

Thank you for your help!

best regards
jens himmelreich