Subject: [clisp-list] sigsegv?

From: Yuri Kostylev <[email-masked]>
Date: Wed Jan 29 02:53:05 2003

clisp-2.30

$ base/lisp.run -M base/lispinit.mem

[1]> (without-package-lock ()
        (compile-file "src/config.lisp")
        (load "src/config.fas"))

*** - handle_fault error2 ! address = 0x88000013 not in [0x68054B98,0x6807E000)
!
SIGSEGV cannot be cured. Fault address = 0x88000013.
Segmentation fault (core dumped)

$ gdb -core=core base/lisp.run
GNU gdb 4.17.0.11 with Linux support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `base/lisp.run -M base/lispinit.mem'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libreadline.so.4.1...done.
Reading symbols from /usr/lib/libncurses.so.4...done.
Reading symbols from /lib/libdl.so.2...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /usr/lib/gconv/KOI8-R.so...done.
#0  0x8054cc7 in unwind ()
(gdb) bt
#0  0x8054cc7 in unwind ()
#1  0x4009fbe4 in __sigjmp_save (env=0x20298aa9, savemask=539593336)
#2  0x805b336 in funcall_closure ()
#3  0x805b336 in funcall_closure ()
#4  0x805b336 in funcall_closure ()
#5  0x40099cc3 in __libc_start_main (main=0x80518d4 <main>, argc=3,
    argv=0xbffffc24, init=0x804a084 <_init>, fini=0x80e52fc <_fini>,
    rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffffc1c)
    at ../sysdeps/generic/libc-start.c:78
(gdb)

---

From: Sam Steingold <[email-masked]>
Date: Wed Jan 29 07:15:02 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] sigsegv?"
> * Sent on Wed, 29 Jan 2003 14:52:20 +0400 (SAMT)
> * Honorable Yuri Kostylev <[email-masked]> writes:
>

please rebuild like this:

$ ./configure --with-debug --build build-g
$ cd build-g
$ gdb

and then try your code again.

thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
A professor is someone who talks in someone else's sleep.