Subject: [clisp-list] Fw: [Lisa-users] Trouble building PORT with CLISP 2.26

From: "David E. Young" <[email-masked]>
Date: Tue, 26 Jun 2001 12:35:54 -0400

Greetings. I've a LISA user that has reported trouble building the CLOCC PORT module using CLISP 2.26. He has built CLISP from source on RedHat 7.0, and the test suite indicates no problems. I've not seen this trouble, but my CLISP is at version 2.25.1 and my Linux installation is inaccessible at the moment so I can't build 2.26 and check.

It looks like the trouble is in function GC in file ext.lisp; the symbol LISP:GC is missing. I've included his problem report; please contact Art Nuzzo ([email-masked]) for additional questions. Also, please CC me on replies. Thanks much.

---- Original report -----

First I downloaded and complied version 2.26 from the source.  Make check said all tests passed. 

Next I downloaded the latest version of LISA from Sourceforge. When I tried to compile LISA (Clisp was started with the -ansi option) I got the following error:

[1]> (load "misc/defsystem.lisp")
;; Loading file misc/defsystem.lisp ...
;; Loading of file misc/defsystem.lisp is finished.
T
[2]> (load "defsys.lisp")
;; Loading file defsys.lisp ...
;;  Loading file #S(LOGICAL-PATHNAME :HOST LISA :DEVICE NIL :DIRECTORY (ABSOLUTE CLOCC PORT) :NAME PORT :TYPE SYSTEM :VERSION NIL) ...
;;  Loading of file #S(LOGICAL-PATHNAME :HOST LISA :DEVICE NIL :DIRECTORY (ABSOLUTE CLOCC PORT) :NAME PORT :TYPE SYSTEM :VERSION NIL) is finished.
;; Loading of file defsys.lisp is finished.
T
[3]> (mk:compile-system :lisa)
PORT/ALL (6 files) totals 58,980 bytes (58 kB)
PORT/NEW-SOURCE-AND-DEPENDENTS (6 files) totals 58,980 bytes (58 kB)
Compiling file /v1/usr/local/src/lisa-0.9.2/contrib/clocc/port/./ext.lisp ...
*** - READ from #<BUFFERED FILE-STREAM CHARACTER #P"/v1/usr/local/src/lisa-0.9.2/contrib/clocc/port/./ext.lisp" @94>: #<PACKAGE COMMON-LISP> has no external symbol with name "GC"
1. Break PORT[4]> 

Regards,

-----------------------------------------------------------------
David E. Young
[email-masked]
http://lisa.sourceforge.net

"But all the world understands my language."
  -- Franz Joseph Haydn (1732-1809)

---

From: Sam Steingold <[email-masked]>
Date: 26 Jun 2001 13:02:09 -0400

> * In message <00e201c0fe5e$12bd9850$6501a8c0@tinian>
> * On the subject of "[clisp-list] Fw: [Lisa-users] Trouble building PORT with CLISP 2.26"
> * Sent on Tue, 26 Jun 2001 12:35:54 -0400
> * Honorable "David E. Young" <[email-masked]> writes:
>
> Greetings. I've a LISA user that has reported trouble building the
> CLOCC PORT module using CLISP 2.26.

CLOCC/PORT builds just fine with CLISP 2.26, but the obsolete version
distributed with LISA does not.
Moreover, I warned you (_before_ CLISP 2.26 was released) about this
upcoming incompatibility, and asked you to upgrade your LISA/PORT
distribution and try the pre-release CLISP version.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
You can have it good, soon or cheap.  Pick two...

---

From: "David E. Young" <[email-masked]>
Date: Tue, 26 Jun 2001 13:53:02 -0400

----- Original Message -----
From: "Sam Steingold" <[email-masked]>
To: "David E. Young" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 26, 2001 1:02 PM
Subject: Re: [clisp-list] Fw: [Lisa-users] Trouble building PORT with CLISP
2.26

> distributed with LISA does not...

Then the solution is obvious.

> distribution and try the pre-release CLISP version.

Actually, if memory serves you asked me to try the pre-release version
without clearly stating there would be an upcoming incompatibility. Or
perhaps you did and it was muddled by the surrounding context; we were
working on another CLISP issue at the time.

In any event, since I haven't a copy of your warning I can't make an
iron-clad case. No matter; appreciate your help.

Regards,