Subject: [clisp-list] Debug build under Visual C++?

From: [email-masked] (Thaddeus L. Olczyk)
Date: Tue Jan 29 05:30:08 2002

1) I have not seen the C-c error with the 2.27 version.
     later I will build the newest CVS source and see if I see the 
     bug.
2) Someone might be able to save me sometime if they explain how to do

    a Debug build for the Visual C++.

---

From: Sam Steingold <[email-masked]>
Date: Tue Jan 29 07:51:12 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Debug build under Visual C++?"
> * Sent on Tue, 29 Jan 2002 13:29:48 GMT
> * Honorable [email-masked] (Thaddeus L. Olczyk) writes:
>

edit Makefile and set MSVCDIR there correctly.
then edit CC and CFLAGS like this:
CC = cl $(MFLAGS) -G6 -Ge -Os -Oy- -Gf -Gy -Zi
CFLAGS =  -DUNICODE -DEXPORT_SYSCALLS -DDIR_KEY -DDYNAMIC_FFI -DNO_GETTEXT -DSAFETY=3 -DDEBUG_SPVW

YMMV, do it the way you like (cl /help will help!)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Profanity is the one language all programmers know best.