Subject: [clisp-list] printing unicode characters

From: Sam Steingold <[email-masked]>
Date: 04 Apr 2000 13:21:39 -0400

when a string contains unicode characters it often cannot be printed.
can i arrange that such characters are printed as &#nnnn; (or #\unnnn)?

-- 
Sam Steingold (http://www.podval.org/~sds)
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Microsoft: announce yesterday, code today, think tomorrow.

---

From: Bruno Haible <[email-masked]>
Date: Tue, 4 Apr 2000 20:52:02 +0200 (MET DST)

> can i arrange that such characters are printed as &#nnnn; (or #\unnnn)?

The closest you can get is to print them as \uNNNN.

(setq *terminal-encoding* charset:java)

This encoding is known the "JAVA" encoding, but you can write Unicode
characters this way in C (ISO C 99) and C++ (ISO/ANSI C++) as well.

Bruno