Subject: [clisp-list] CLISP 2.30 SIGSEGV Error on fas load

From: "Blake McBride" <[email-masked]>
Date: Thu May 8 12:11:37 2003

Greetings,

I am using CLISP 2.30 on Windows with SnePs 2.6.0
(http://www.cse.buffalo.edu/sneps/)
I can compile the whole system without a problem but when I attempt to load
the .fas files
I get:

[....]
;; Loading ATN C:\sneps\snepslog\recognizer\recognizer.atn
;; Loading ATN C:\sneps\snepslog\generator\generator.atn
;;   Loading file C:\sneps\snepslog\printer.fas ...
;;   Loaded file C:\sneps\snepslog\printer.fas
;;   Loading file C:\sneps\snepslog\reader.fas ...
;;   Loaded file C:\sneps\snepslog\reader.fas
;;   Loading file C:\sneps\snepslog\snepslog.fas ...
;;   Loaded file C:\sneps\snepslog\snepslog.fas
;;   Loading file C:\sneps\snepslog\commands.fas ...
;;   Loaded file C:\sneps\snepslog\commands.fas
;;   Loading file C:\sneps\snepslog\toplevel.fas ...
;;   Loaded file C:\sneps\snepslog\toplevel.fas
;;   Loading file C:\sneps\snepslog\tellask.fas ...
;;   Loaded file C:\sneps\snepslog\tellask.fas
;;   Loading file C:\sneps\snepslog\mode3.cl ...
;;   Loaded file C:\sneps\snepslog\mode3.cl
;;   Loading file C:\sneps\snepslog\snepslog-perform.cl ...
;;   Loaded file C:\sneps\snepslog\snepslog-perform.cl
;;   Loading file C:\sneps\nlint\englex\lenglex.fas ...
;;   Loaded file C:\sneps\nlint\englex\lenglex.fas
*** - handle_fault error2 ! address = 0x1A594E74 not in
[0x1A400000,0x1A50EA7C)
!
SIGSEGV cannot be cured. Fault address = 0x1A594E74.

C:\Sneps>

Any help would be appreciated.

Blake McBride
[email-masked]

---

From: Arseny Slobodjuck <[email-masked]>
Date: Fri May 9 07:24:07 2003

> SIGSEGV cannot be cured. Fault address = 0x1A594E74.
C:\Sneps>>

> Any help would be appreciated.

Too few information. What's supposed to happen after loading
of lenglex.fas in generator.atn ?

-- 
Best regards,
 Arseny

---

From: Sam Steingold <[email-masked]>
Date: Fri May 9 07:46:02 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLISP 2.30 SIGSEGV Error on fas load"
> * Sent on Thu, 8 May 2003 09:04:48 -0500
> * Honorable "Blake McBride" <[email-masked]> writes:
>
> I can compile the whole system without a problem but when I attempt to
> load the .fas files I get:

I do not observe this with the CVS head (and an older versions I have
here).  Quite a few bugs have been fixed since the last release, and it
is quite possible that this one is dead too.

Could you please try the `beta' binary (built by Arseny)?
<http://prdownloads.sourceforge.net/clisp/clisp-2.30.1-win32.zip?download>

Thanks!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
The world is coming to an end.  Please log off.

---

From: "Blake McBride" <[email-masked]>
Date: Fri May 9 15:04:07 2003

That seems to work.  Thanks!

--blake

"Sam Steingold" <[email-masked]> wrote in message
news:[email-masked]...
> <http://www.mideasttruth.com/>
<http://www.palestine-central.com/links.html>
> -------------------------------------------------------
> Enterprise Linux Forum Conference & Expo, June 4-6, 2003, Santa Clara
> The only event dedicated to issues related to Linux enterprise solutions
> www.enterpriselinuxforum.com