Subject: [clisp-list] Regexp

From: "Ribeiro, Glauber" <[email-masked]>
Date: Fri, 25 May 2001 12:32:45 -0700

> Message: 3
> Date: Fri, 25 May 2001 09:29:23 -0700
> From: Miles Egan <[email-masked]>
> To: [email-masked]
> Subject: [clisp-list] pcre & clisp
>
> Would anyone use CLISP -> pcre (perl-compatibility regexp library) ?  It's
> faster and more full-featured than the gnu regexp stuff.

Just a reminder, there's a nice Perl-compatible regexp package in
http://www.cs.rice.edu/~dorai/pregexp/pregexp.html (written in Scheme,
mechanically ported to Common Lisp, no C involved). I've use it with CLISP.
It's fast enough for what i've needed so far, but i haven't made any speed
comparisons. It implements all of the Perl regexp oddities.

g

---

From: Miles Egan <[email-masked]>
Date: Fri, 25 May 2001 13:01:24 -0700

> comparisons. It implements all of the Perl regexp oddities.

I wasn't aware of this.  Pretty cool.  I suspect the c version would be quite a
bit faster, especially in clisp, but it probably wouldn't matter in a lot of
cases.  I think I'll still take a stab at pcre bindings, if only for my own
education.

-- 
miles

---

From: Marco Antoniotti <[email-masked]>
Date: Fri, 25 May 2001 17:29:57 -0400

> From: "Ribeiro, Glauber" <[email-masked]>
> Content-Type: text/plain;
> 	charset="iso-8859-1"
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.5
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <http://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <http://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://lists.sourceforge.net/archives//clisp-list/>
> Date: Fri, 25 May 2001 12:32:45 -0700
> Content-Length: 818
> 
> > Message: 3

Yep.  But the Scheme to CL translator is really hairy and obviously
writte by somebody who doas not know much about CL.

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.