Subject: [clisp-list] FFI and CORBA

From: "V.Krishna Kumar" <[email-masked]>
Date: Tue, 3 Jul 2001 00:06:49 -0400

Hi! ALL,

1)
Is the FFI working on Win32 platforms ? If so, how do I build the linking 
set on those platforms ?

2)
Instead of writing an ORB in LISP, is it possible to interface with a C based 
ORB (such as ORBit) using the FFI ? The advantages are
  i.  You get a lot of free code (ORB itself)
  ii. Colocated servers & clients can be optimised to use function calls
      rather than sockets.

Any thoughts ?

cheers,
Krish

-------------------------------------------
The Fastest Browser on Earth now for FREE!!
Download Opera 5 for Windows now! Get it at
http://www.opera.com/download/
-------------------------------------------

---

From: Eric Marsden <[email-masked]>
Date: 11 Jul 2001 13:51:09 +0200

>>>>> "vkk" == V Krishna Kumar <[email-masked]> writes:

  vkk> Instead of writing an ORB in LISP, is it possible to interface with a C based 
  vkk> ORB (such as ORBit) using the FFI ? The advantages are
  vkk> i.  You get a lot of free code (ORB itself)
  vkk> ii. Colocated servers & clients can be optimised to use function calls
  vkk> rather than sockets.

I don't think this is a good idea. An ORB needs to be tightly
integrated with the system's I/O and threading subsystems, which will
be difficult via a FFI.

For your point (i) see CLORB, a free CL ORB, and for (ii) I don't see
any reason why this would not be possible in a CL implementation; it
should be much easier than fiddling with object keys via the FFI.

<URL:http://clorb.sourceforge.net/>

-- 
Eric Marsden                          <URL:http://www.laas.fr/~emarsden/>