Subject: [clisp-list] debugging help

From: David Morse <[email-masked]>
Date: Wed Aug 13 07:12:04 2003

Sorry for the newbie question, but how would you use the debugger to 
figure out what line of code is calling a structure slot reader with nil?

[39]> (find-best-outcome (fen-pos "r7/8/8/8/8/8/8/R6b w - - 0 1") 3)

*** - SYSTEM::%STRUCTURE-REF: NIL is not a structure of type POS
1. Break [40]> :bt

EVAL frame for form (FIND-BEST-OUTCOME (FEN-POS "r7/8/8/8/8/8/8/R6b w - 
- 0 1") 3)
1. Break [40]>

---

From: Sam Steingold <[email-masked]>
Date: Wed Aug 13 07:42:10 2003

> * In message <[email-masked]>
> * On the subject of "debugging help"
> * Sent on Wed, 13 Aug 2003 10:08:32 -0400
> * Honorable David Morse <[email-masked]> writes:
>

run interpreted.

> EVAL frame for form (FIND-BEST-OUTCOME (FEN-POS "r7/8/8/8/8/8/8/R6b w - 

CVS head :bt gives full lisp function/special form call stack.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
If I had known that it was harmless, I would have killed it myself.