Subject: [clisp-list] search sequence for loaded files

From: Christian Schuhegger <[email-masked]>
Date: Wed Mar 27 08:16:07 2002

hello,

i am just trying to write a makefile for a project of mine and found out
that the pwd is always searched before any other directories in
custom:*load-paths*. how can i change this search sequence?

many thanks for any hints!

--
Christian Schuhegger

---

From: Marco Antoniotti <[email-masked]>
Date: Wed Mar 27 09:07:07 2002

> X-Authentication-Warning: smtp3.cern.ch: Host pcitco48.cern.ch [137.138.62.140] claimed to be cern.ch
> From: Christian Schuhegger <[email-masked]>
> X-Accept-Language: en
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.5
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://www.geocrawler.com/redir-sf.php3?list=clisp-list>
> X-Original-Date: Wed, 27 Mar 2002 17:15:17 +0100
> Date: Wed, 27 Mar 2002 17:15:17 +0100
> Content-Length: 420
> 
> hello,
> 

If you are writing something Lisp only, you are better off using
DEFSYSTEM.  Why do you need `make' for that?

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 27 13:46:04 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] search sequence for loaded files"
> * Sent on Wed, 27 Mar 2002 17:15:17 +0100
> * Honorable Christian Schuhegger <[email-masked]> writes:
>
> i am just trying to write a makefile for a project of mine and found
> out that the pwd is always searched before any other directories in

LOAD, as per CLHS, loads its arg after merging in
*DEFAULT-PATHNAME-DEFAULTS*.
When it fails, then, as an extension, it searches *LOAD-PATHS*.

Thus, you should modify *DEFAULT-PATHNAME-DEFAULTS*.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
There are two kinds of egotists: 1) Those who admit it  2) The rest of us