Subject: [clisp-list] make-pathname question

From: Russell McManus <[email-masked]>
Date: Mon Nov 25 14:23:58 2002

Should make-pathname support :type :unspecific ?

clisp-2.30 says:

*** - MAKE-PATHNAME: illegal :TYPE argument :UNSPECIFIC

But 

  http://www.lispworks.com/reference/HyperSpec/Body/26_glo_v.htm#valid_pathname_type

Says: 

  valid pathname type n. a string, nil, :wild, :unspecific.

-russ

---

From: Sam Steingold <[email-masked]>
Date: Mon Nov 25 15:17:58 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] make-pathname question"
> * Sent on 25 Nov 2002 17:14:36 -0500
> * Honorable Russell McManus <[email-masked]> writes:
>

what's the semantic difference between :UNSPECIFIC and NIL in this context?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Parachute for sale, used once, never opened, small stain.

---

From: Sam Steingold <[email-masked]>
Date: Sun Dec 1 10:32:02 2002

> Should make-pathname support :type :unspecific ?

no, we do not have to.
see 19.2.2.2.3 and 19.2.2.2.3.1.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
char*a="char*a=%c%s%c;main(){printf(a,34,a,34);}";main(){printf(a,34,a,34);}

---

From: Russell McManus <[email-masked]>
Date: Sun Dec 1 17:39:53 2002

> see 19.2.2.2.3 and 19.2.2.2.3.1.

You are correct, I should have read the hyperspec more carefully.  I
missed this section, actually.

-russ