Subject: [clisp-list] garnet on m$windows

From: [email-masked]
Date: Tue Mar 5 11:56:04 2002

I have been trying to port garnet to m$windows.
The approach I have taken is to compile clisp using cygwin,
building new-clx, linking it against libW11, a gpl'd implementation
of xlib on m$windows.
After adding some unimplemented functions to libW11, I got the test
programs distributed with mit-clx to run, but I am having trouble
with garnet, in particular, I am getting problems which I think are
caused by a uninitialized variable.
My question is:
Is there documentation on the build process for new-clx, in particular
the conversion process between the combination c and lisp like code in
the clx.f file to the clx.c file which finally gets built?
Is there documentation on the clisp functions which are called?
I am thinking about just writing a new package calling win32 functions
instead of the Xlib ones, instead, as libW11 is not very complete.
Dan Stanger

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 5 22:29:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] garnet on m$windows"
> * Sent on Tue, 5 Mar 2002 12:55:16 -0700 (MST)
> * Honorable [email-masked] writes:
>

not really - just Makefile and the source code.
note that the e2d program appears to have a Solaris-specific bug. :-(
it appears to work fine on Linux though.
it should have been written in CLISP actually - by the time we get to
the modules, we already have a working CLISP image.

> Is there documentation on the clisp functions which are called?
which ones?

> instead of the Xlib ones, instead, as libW11 is not very complete.

great!

[actually, I would prefer GTK bindings instead of CLX tweaks -
 I hear GTK works on win32 also, right?]

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Those who can laugh at themselves will never cease to be amused.

---

From: IPmonger <[email-masked]>
Date: Tue Mar 5 23:28:05 2002

>>    Is there documentation on the build process for new-clx, in
>>  particular the conversion process between the combination c and lisp
>>  like code in the clx.f file to the clx.c file which finally gets
>>  built?

> Sam Steingold <[email-masked]> responds:
>
>     not really - just Makefile and the source code.  note that the e2d
>   program appears to have a Solaris-specific bug. :-(  it appears to
>   work fine on Linux though.

    I have problems compiling new-clx due to missing semi-colons in the
  use of the macros UNDEFINED and NOTIMPLEMENTED.

-jon
-- 
------------------
Jon Allen Boone
[email-masked]
CCIE #8338

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 6 10:13:11 2002

> * In message <[email-masked]>
> * On the subject of "new-clx/Linux (was Re: [clisp-list] garnet on m$windows)"
> * Sent on Wed, 06 Mar 2002 02:27:57 -0500
> * Honorable IPmonger <[email-masked]> writes:
>

<[email-masked]> sent a patch for that already.
either put in the semicolons yourself, or get the CVS CLISP

Type louder, please.

---

From: Jon Allen Boone <[email-masked]>
Date: Wed Mar 6 10:23:23 2002

Sam Steingold <[email-masked]> writes:

>    <[email-masked]> sent a patch for that already. either put in
>  the semicolons yourself, or get the CVS CLISP 

    I did that last night.  Provided I remove all Optimization options,
  everything compiles fine.  I even played the Sokoban demo found in the
  clx/new-clx/demos directory.  :-)

    Thanks for your help!

-jon
-- 
------------------
Jon Allen Boone
[email-masked]
CCIE #8338