Subject: [clisp-list] CLISP-2.28 Win98 Installation Problem

From: Helmut Leitner <[email-masked]>
Date: Mon Mar 11 14:48:13 2002

I try to install CLISP 2.28 on my Windows 98 system.

But 
  [1]> (compile-file "src/config.lisp")

results in:
  Compiling file C:\P\CLISP\clisp-2.28\src\config.lisp ...
  ** - Continuable Error
  INTERN("FILE"): #<PACKAGE EXT> is locked
  If you continue (by typing 'continue'): Ignore the lock and proceed
  1. Break EXT[2]>

I am able to continue (and , but then the next command
  (load "src/config.fas")
leads to uncontinuable errors:

  1. Break EXT[2]> continue

  Compilation of file C:\P\CLISP\clisp-2.28\src\config.lisp is finished.
  0 errors, 0 warnings
  #P"C:\\P\\CLISP\\clisp-2.28\\src\\config.fas" ;
  NIL ;
  NIL
  [3]> (load "src/config.fas")
  ;; Loading file src\config.fas ...
  ** - Continuable Error
  DEFUN/DEFMACRO(SHORT-SITE-NAME): #<PACKAGE COMMON-LISP> is locked
  If you continue (by typing 'continue'): Ignore the lock and proceed
  1. Break EXT[4]>

Can anyone explain and help?

--
Helmut Leitner    [email-masked]   
Graz, Austria   www.hls-software.com

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 11 15:13:20 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLISP-2.28 Win98 Installation Problem"
> * Sent on Mon, 11 Mar 2002 23:46:29 +0100
> * Honorable Helmut Leitner <[email-masked]> writes:
>

this step is optional.

> leads to uncontinuable errors:

where?

> Can anyone explain and help?

this is continuable too!

Please see <http://clisp.cons.org/impnotes.html#pack-lock> for
information on package locking.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Every day above ground is a good day.