Subject: [clisp-list] Re: GNU CLISP 2.27 release

From: [email-masked]
Date: Tue, 17 Jul 2001 09:35:48 -0500

-----BEGIN PGP SIGNED MESSAGE-----

Your message has been rejected because it is crossposted to
more than 5 usenet groups, which is against the charter of
comp.os.linux.announce, or it is crossposted to another
moderated group, or it has excessive quoting. 

Read charter of comp.os.linux.announce in 

	http://stump.algebra.com/~cola

Please direct your queries to [email-masked].

Thank you,

	- Moderator.

============================================ Full text of your message follows
> From [email-masked]  Tue Jul 17 09:34:52 2001
> Return-Path: <[email-masked]>
> Received: from kantti.Helsinki.FI (kantti.helsinki.fi [128.214.205.12])
> 	by ak47.algebra.com (8.11.1/8.11.1) with ESMTP id f6HEYpp07756
> 	for <[email-masked]>; Tue, 17 Jul 2001 09:34:51 -0500
> Received: (from mjrauhal@localhost)
> 	by kantti.Helsinki.FI (8.11.4/8.11.4-SPAMmers-sod-off) id f6HEYoa19197
> 	for [email-masked]; Tue, 17 Jul 2001 17:34:50 +0300 (EET DST)
> Received: from post.it.helsinki.fi (post.it.helsinki.fi [128.214.205.24])
> 	by kantti.Helsinki.FI (8.11.4/8.11.4-SPAMmers-sod-off) with ESMTP id f6HEYnj29383
> 	for <[email-masked]>; Tue, 17 Jul 2001 17:34:49 +0300 (EET DST)
> Received: from sws1.ctd.ornl.gov (sws1.ctd.ornl.gov [160.91.20.101])
> 	by post.it.helsinki.fi (8.11.4/8.11.4-SPAMmers-sod-off) with SMTP id f6HEYlb30235
> 	for <[email-masked]>; Tue, 17 Jul 2001 17:34:48 +0300 (EET DST)
> Received: (qmail 15533 invoked by alias); 17 Jul 2001 14:34:46 -0000
> Delivered-To: [email-masked]
> Received: (qmail 31076 invoked from network); 17 Jul 2001 14:34:45 -0000
> Received: from sjc3-1.relay.mail.uu.net (199.171.54.122)
>   by sws1.ctd.ornl.gov with SMTP; 17 Jul 2001 14:34:45 -0000
> Received: from supernews.net by sjc3sosrv11.alter.net with ESMTP 
> 	(peer crosschecked as: pa-01.supernews.net [209.249.90.75])
> 	id QQkybq21964
> 	for <[email-masked]>; Tue, 17 Jul 2001 14:34:43 GMT
> Received: from news by supernews.net with local (Exim 3.20 #1)
> 	id 15MVvu-000HsN-00
> 	for [email-masked]; Tue, 17 Jul 2001 14:34:42 +0000
> To: [email-masked]
> From: Sam Steingold <[email-masked]>
> Newsgroups: comp.lang.lisp,comp.os.linux.announce
> Subject: GNU CLISP 2.27 release
> Followup-To: poster
> Organization: disorganization
> Message-ID: <[email-masked]>
> Reply-To: [email-masked]
> X-Attribution: Sam
> X-Disclaimer: You should not expect anyone to agree with me.
> User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.105
> MIME-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> X-Complaints-To: [email-masked]
> 
> GNU CLISP 2.27 is now available at
>  http://clisp.cons.org
>  https://sourceforge.net/project/showfiles.php?group_id=1355
>  ftp://clisp.cons.org/pub/lisp/clisp/source/latest/
>  ftp://clisp.cons.org/pub/lisp/clisp/binaries/latest/
>  ftp://clisp.sourceforge.net/pub/clisp/latest/
> please ask questions about CLISP on [email-masked]
> if you would like to contribute to CLISP development, please subscribe
> to [email-masked] and send patches there.
> 
> CLISP Common Lisp Summary
> 
> Common Lisp is a high-level, all-purpose, object-oriented, dynamic,
> functional programming language.
> 
> CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
> University and Michael Stoll of Munich University, both in Germany.
> It mostly supports the Lisp described in the ANSI Common Lisp standard.
> 
> CLISP includes an interpreter, a compiler, a large subset of CLOS, a
> foreign language interface and a socket interface. An X11 interface is
> available through CLX and Garnet. Command line editing is provided by
> GNU ReadLine.
> 
> CLISP runs on microcomputers (OS/2, Windows 95/98/2000/NT, Amiga
> 500-4000, Acorn RISC PC) as well as on Unix workstations (GNU/Linux,
> BSD, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and
> others) and needs only 2 MB of RAM.
> 
> CLISP is Free Software and may be distributed under the terms of GNU
> GPL. You may distribute commercial applications compiled with CLISP, see
> file COPYRIGHT in the CLISP distribution.
> 
> The user interface comes in German, English, French, Spanish and Dutch,
> and can be changed at run time.
> 
> 
> CHANGES.LOG:
> 
> 2.27 (2001-07-17)
> =================
> 
> User visible changes
> --------------------
> 
> * EXT:GETENV is now setfable.
> 
> * Hostname resolution is now optional in
>   EXT:SOCKET-STREAM-PEER and EXT:SOCKET-STREAM-LOCAL.
> 
> * EXT:SOCKET-STATUS now accepts SOCKET-SERVERs too
>   and the direction of the checks can be specified.
> 
> * Added install.bat for win32 installation.
> 
> * ANSI CL compliance: more conformant pathname handling.
> 
> * Fixed handling of circular structs and pointers to functions in the FFI.
> 
> * Fixed binary I/O for streams with element type longer than one byte,
>   but not a whole number of bytes.
> 
> -- 
> Sam Steingold (http://www.podval.org/~sds)
> Lisp: Serious empowerment.
>

---

From: Bruce <[email-masked]>
Date: Wed, 18 Jul 2001 08:23:23 +0800

>> ftp://clisp.sourceforge.net/pub/clisp/latest/

The latest release seems not to produce suggestions with how to "makemake" when running "./configure".

Since I forgot what arguments I did with previous releases, I ran with
"./makemake >Makefile". When running "make", it says "No targets
specified and no makefile found. Stop." when entering the directory
"clisp-2.27/src/gettext/intl".

Any ideas?

---

From: Bruce <[email-masked]>
Date: Wed, 18 Jul 2001 14:35:13 +0800

> "clisp-2.27/src/gettext/intl".

Sorry, I made the mistake of running "./configure" in the "src"
directory rather than "clisp-2.27" directory.

-- 
But, for my own part, it was Greek to me.
		-- William Shakespeare, "Julius Caesar"