Subject: [clisp-list] is regexp included in CLISP 2.29 binary for ms-windo ws (native, not cygwin)?

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Aug 1 08:07:20 2002

Hi,

Arseny Slobodjuck wrote:
>Joerg-Cyril> does the MS-win32 binary for 2.29 found on
>Joerg-Cyril> sourceforge/FILES include the regexp module?

>I think it doesn't (if it's mine). I never worked with
>clisp modules in its native enviroinment (UNIX), so
>was unable to produce such distribution. You mentioned
>your article about clisp modules, is it ready ?

I don't understand how UNIX, "native environment" or my article on modules come into play with having the regexp module in the MS-win32 native distribution.

In March, I gave (hopefully) repeatable instructions on how to compile CLISP with modules/regexp/ using MS-VC++6. Everything needed (except 1-2 patches to sources found in the CLISP distribution) is either in the CLISP source archive, or your C compiler. It's trivial to do.

Similarly, it's IMHO trivial to build CLISP modules with any C compiler on any platform where CLISP has been ported to, except that on UNIX you additionaly have those clisp-link shell scripts. I never built a module on UNIX. I have a rough idea of what these scripts do.

What is open is whether my suggested alloca() patch to modules/regexp/regex.c could be accepted by some GNU regexp/Emacs/whoever maintainers.

Another thing, which does not in any way affect my patches, is whether to replace the ~6-year old modules/regex.c by some newer GNU code. Did anyone ever complain about this module being old or buggy?

I'll send you the current version of my article on modules in a separate e-mail.

Regards,
	Jorg Hohle.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Aug 1 14:33:56 2002

Hi,

Friday, August 02, 2002, 1:06:19 AM, you wrote:

>>> does the MS-win32 binary for 2.29 found on
>>> sourceforge/FILES include the regexp module?

> I  don't  understand how UNIX, "native environment" or my
> article  on modules come into play with having the regexp
> module in the MS-win32 native distribution.

I tried to make it and didn't succeeded. Regex package seems
don't appearing in memory image.

> In  March,  I gave (hopefully) repeatable instructions on
> how to compile CLISP with modules/regexp/ using MS-VC++6.
> Everything needed (except 1-2 patches to sources found in
> the  CLISP  distribution)  is  either in the CLISP source
> archive, or your C compiler. It's trivial to do.
Sorry, I forgot about it. In march I was deeply in win32 stack
handling and didn't read it.

> I'll send you the current version of my article on modules in a separate e-mail.
Thank you.

-- 
Best regards,
 Arseny

---

From: Reini Urban <[email-masked]>
Date: Fri Aug 2 03:23:53 2002

> Another thing, which does not in any way affect my patches, is whether to replace the ~6-year old modules/regex.c by some newer GNU code. Did anyone ever complain about this module being old or bug…

BTW: I recently worked on a PCRE FFI module for cormanlisp,
which can be easily ported to UFFI or CLISP using
regexp/regexp.lisp.

The replace function doesn't work yet as expected
(in spirit to perl s/from/to/ig...)

My server is currently offline but it should be somewhere at my 
cormanlisp src dir.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/