Subject: AW: [clisp-list] Enumerating directories and files

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Mar 21 02:38:03 2002

Paolo Amoroso wrote:
> I would like to enumerate the directories and files in a 
> given directory under Linux. 

(directory "*" :full t)
and
(directory "*/")
You need two calls to get both files and directories with CLISP.

DIRECTORY is Common Lisp standard

Regards,
	Jorg Hohle.

---

From: Paolo Amoroso <[email-masked]>
Date: Fri Mar 22 02:03:04 2002

> You need two calls to get both files and directories with CLISP.

It looks like I missed the DIRECTORY information in the CLISP impnotes...

> DIRECTORY is Common Lisp standard

Yes, but I also missed an important detail in the CLHS entry for DIRECTORY:

   Function DIRECTORY
   
   Syntax:
   
   directory pathspec &key => pathnames
   
   Arguments and Values:

   pathspec---a pathname designator, which may contain wild components.
                                                       ^^^^
Thanks,

Paolo
-- 
EncyCMUCLopedia * Extensive collection of CMU Common Lisp documentation
http://www.paoloamoroso.it/ency/README
[http://cvs2.cons.org:8000/cmucl/doc/EncyCMUCLopedia/]