Subject: RE: [clisp-list] overflow during multiplication of large numbers

From: Ben Pharr - Lists <[email-masked]>
Date: Tue Oct 9 13:36:10 2001

I tried starting with:

clisp -m 300MB

then

(load "ackermann.fas")

then

(ackermann 4 3)

It still gives me the same error. Any more ideas?

Ben Pharr

At 03:10 PM 10/9/01 -0500, you wrote:

>look at the "-m" on startup...
>
>Randy
>
>-----Original Message-----
>From: Ben Pharr - Lists 
>[<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Tuesday, October 09, 2001 3:03 PM
>To: [email-masked]
>Subject: [clisp-list] overflow during multiplication of large numbers
>
>I have programmed a partially iterative function to calculate Ackermann's
>function. The iterative part is for cases of m=0 through m=3. Anything
>above that is done with recursion. I have compiled the function. A(4, 2)
>can be calculated in a fraction of a second. The result is a number with
>more than 19,000 digits. However, A(4, 3) gives me an error. It says:
>
>*** - overflow during multiplication of large numbers
>
>This occurs within a second of executing the function. I am doing this on
>Debian Linux, so I thought maybe the ulimit was getting in the way. ulimit
>is set to unlimited, and I have 320MBs of RAM. I thought maybe unlimited
>wasn't really unlimited, so I set it to 300MB and tried again with the same
>results.
>
>While it is possible A( 4, 3) would cause an overflow, I don't think it's
>taking enough time to find out, given how quickly A(4, 2) is computed. Can
>anyone give me some advice. Thanks!
>
>Ben Pharr
>
>_______________________________________________
>clisp-list mailing list
>[email-masked]
><https://lists.sourceforge.net/lists/listinfo/clisp-list>https://lists.sourceforge.net/lists/listinfo/clisp-list 
>

---

From: "Justice, Randy -CONT(DYN)" <[email-masked]>
Date: Tue Oct 9 13:45:05 2001

It might not be the best method, but use the "top" command and check the
memory usage. 

It should be available on your unix box....

-----Original Message-----
From: Ben Pharr - Lists [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 3:35 PM
To: [email-masked]
Subject: RE: [clisp-list] overflow during multiplication of large
numbers

I tried starting with:

clisp -m 300MB

then

(load "ackermann.fas")

then

(ackermann 4 3)

Ben Pharr

_______________________________________________
clisp-list mailing list
[email-masked]
https://lists.sourceforge.net/lists/listinfo/clisp-list

---

From: Ben Pharr - Lists <[email-masked]>
Date: Tue Oct 9 15:46:10 2001

I've tried that and as best as I can tell lisp.run takes up 1.1% of my 
memory at it's maximum. I'm confused as to why it doesn't take longer (and 
more of my memory) to overflow.

Ben Pharr