Subject: [clisp-list] sql-odbc

From: "Roland Averkamp" <[email-masked]>
Date: Thu Mar 11 13:02:02 2004

Hello,
I added some ffi-code to Paul Meurers SQL-ODBC, so it runs now with clisp
too.
His original version is available at
http://helmer.aksis.uib.no/hit/paul-cv.htm

If anyone is interested I can sent him my version.

I have tested basic functionality on linux with unixODBC-2.2.6 as
drivermanager and postgresql and mysql,
on winxp with sql-server, access and oracle. 

I did not test the reader macros for sql of sql-odbc.

No extra binary code is needed, libodbc.so respectively odbc32.dll are
loaded
as dynamic library.

Regards
Roland Averkamp

-- 
+++ NEU bei GMX und erstmalig in Deutschland: TÜV-geprüfter Virenschutz +++
100% Virenerkennung nach Wildlist. Infos: http://www.gmx.net/virenschutz

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 11 13:54:07 2004

> * Roland Averkamp <[email-masked]> [2004-03-11 21:42:51 +0100]:
>
> I added some ffi-code to Paul Meurers SQL-ODBC, so it runs now with
> clisp too.

excellent!  thanks!

> http://helmer.aksis.uib.no/hit/paul-cv.htm

<ftp://amirani.hit.uib.no/sql-odbc/>
is 2.5 years old.
is it still being actively maintained?
will your patches be included in the next release?

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
The plural of "anecdote" is not "data".