Subject: [clisp-list] c-ptr nil vs c-pointer

From: [email-masked]
Date: Wed Mar 27 08:51:18 2002

I am modifying cparse, written by Tim Moore to produce clisp ffi code
rather than cmucl foreign code.  From the impnotes table, I saw that
the ctype void corresponded to the lisp type nil, so I assumed that
one could refer to a pointer to void by c-ptr nil.  This just means
that I have to filter the code at the end.  Btw, I noticed that you
are writing a ffi document.  Would you email me a copy, as it might
be helpful.  My goal is to parse the cygwin win32 api headers and
produce ffi calls for them.  I have modified cparse and it now goes
thru the headers without failure, and I am checking the ffi output now.
Dan

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 27 13:47:27 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] c-ptr nil vs c-pointer"
> * Sent on Wed, 27 Mar 2002 09:50:51 -0700 (MST)
> * Honorable [email-masked] writes:
>
> rather than cmucl foreign code.

This is very interesting.
Did you consider SWIG?
<http://sourceforge.net/tracker/?func=detail&aid=429122&group_id=1645&atid=351645>

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
There are two kinds of egotists: 1) Those who admit it  2) The rest of us

---

From: Marco Antoniotti <[email-masked]>
Date: Thu Mar 28 05:16:08 2002

> Cc: [email-masked]
> Reply-To: [email-masked]
> Mail-Copies-To: never
> From: Sam Steingold <[email-masked]>
> User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2.50
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.5
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://www.geocrawler.com/redir-sf.php3?list=clisp-list>
> X-Original-Date: 27 Mar 2002 16:45:41 -0500
> Date: 27 Mar 2002 16:45:41 -0500
> Content-Length: 911
> 

The advantage of cparse is to be "Fully Lisp".
A very interesting project would be to be able to produce UFFI specs
from CParse.

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.