Subject: [clisp-list] runprog.lisp

From: Stanislav Tsekhmistroh <[email-masked]>
Date: Thu Sep 4 04:53:07 2003

Hi!

I found some trouble using this under Win32:

> (run-program ... :wait nil)

I. e. spawning new process does not work properly on Win32 (meaning of "&" is different)

Details:
product version: GNU CLISP 2.30 (released 2002-09-15)
source file: "runprog.lisp", lines: 176-177
function: run-shell-command

these lines:

>    (unless wait
>      (setq command (string-concat command " &")))

need to be rewrited like this:

>    #-WIN32
>    (unless wait
>      (setq command (string-concat command " &")))
>    #+WIN32
>    (unless wait
>      (setq indirectp t)
>      (setq command (string-concat "start " command)))

-- 
Best regards,
 Stanislav                          mailto:[email-masked]

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Sep 4 06:45:10 2003

Hello Stanislav,

>>      (setq command (string-concat "start " command)))
Hm.. Why didn't we think of start... Thank you!

-- 
Best regards,
 Arseny