Subject: [clisp-list] CLOS streams

From: Sam Steingold <[email-masked]>
Date: 23 Mar 2001 19:52:56 -0500

Where are we going WRT CLOS streams?
we have

 - industry-standard Gray streams and

 - CLISP-specific "generic-streams"
   (is anyone using them?
    should they be removed?)

What about the Franz streams?
        http://www.franz.com/support/documentation/6.0/doc/streams.htm
should we support them as well?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
MS: our tomorrow's software will run on your tomorrow's HW at today's speed.

---

From: [email-masked] (Don Cohen)
Date: Fri, 23 Mar 2001 17:50:12 -0800 (PST)

>  - CLISP-specific "generic-streams"
ME!

 >     should they be removed?)
I'd have to rewrite the stuff that uses them.
I'd probably try to live with the latest clisp that supports them
for a while.

---

From: Sam Steingold <[email-masked]>
Date: 23 Mar 2001 23:05:30 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLOS streams"
> * Sent on Fri, 23 Mar 2001 17:50:12 -0800 (PST)
> * Honorable [email-masked] (Don Cohen) writes:
>
> Sam Steingold writes:

any reason you don't like Gray streams?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Perl: all stupidities of UNIX in one.

---

From: [email-masked] (Don Cohen)
Date: Fri, 23 Mar 2001 23:13:08 -0800 (PST)

> any reason you don't like Gray streams?

No.
I used generic streams before Gray streams were available.
I assume (without having looked at all) that it wouldn't be difficult
to switch (switch streams in mid ... what?) but surely more trouble
than leaving the code alone.