Subject: [clisp-list] (code-char 160)

From: Raymond Toy <[email-masked]>
Date: 13 Jul 2001 15:18:01 -0400

Clisp 2.26 on solaris says:

(code-char 160)
#\NO-BREAK_SPACE

But there doesn't seem to be any such character.  If I try to type
#\NO-BREAK_SPACE into the listener, it complains:

 #\NO-BREAK_SPACE

*** - READ from #<CONCATENATED-STREAM #<STRING-INPUT-STREAM> #<SYNONYM-STREAM *TERMINAL-IO*>>: there is no character bit with name "NO"

This doesn't happen with (code-char 161)

Ray

---

From: Sam Steingold <[email-masked]>
Date: 15 Jul 2001 16:59:57 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] (code-char 160)"
> * Sent on 13 Jul 2001 15:18:01 -0400
> * Honorable Raymond Toy <[email-masked]> writes:
>
> (code-char 160)
> #\NO-BREAK_SPACE
> 

fixed in the CVS - thanks for the bug report.
(clisp tried to parse the old cltl1 "bits" - it doesn't now).

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
If you want it done right, you have to do it yourself

---

From: Raymond Toy <[email-masked]>
Date: 16 Jul 2001 10:56:51 -0400

>>>>> "Sam" == Sam Steingold <[email-masked]> writes:

    >> *** - READ from #<CONCATENATED-STREAM #<STRING-INPUT-STREAM> #<SYNONYM-STREAM *TERMINAL-IO*>>: there is no character bit with name "NO"

    Sam> fixed in the CVS - thanks for the bug report.
    Sam> (clisp tried to parse the old cltl1 "bits" - it doesn't now).

Thanks.  Actually, the bug report was from the maxima mailing list.  I
just sent it on....

Ray