Subject: [clisp-list] macros3.lisp documentation

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Fri Jul 26 03:58:03 2002

Hi,

at some time in CLISP history, src/macros3.lisp became included in the default image file (so everybody can immediately use the macros). However, the implementation notes don't reflect this change.

"
[Extensions-1.10. Additional Fancy Macros]

If you uncomment the (LOAD "macros3") line in the file init.lisp before doing make, or load the file macros3.lisp into a running CLISP, you can use the following macros:

[...]

You might want to add a (LOAD "macros3") statement to your .clisprc file if you do not want to dump your own memory image.
"

is now superfluous. Please delete these two paragraphs.

Thanks,
	Jörg Höhle.

---

From: Sam Steingold <[email-masked]>
Date: Fri Jul 26 05:52:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] macros3.lisp documentation"
> * Sent on Fri, 26 Jul 2002 12:57:13 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> If you uncomment the (LOAD "macros3") line in the file init.lisp
> before doing make, or load the file macros3.lisp into a running CLISP,
> you can use the following macros:

this has been fixed many months ago, as you can see in
<http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/~checkout~/clisp/clisp/doc/impnotes.html?content-type=text/html#macros3>
it will move to the official public pages when the next non-bug-fix
release is made.

BTW, do you have time now to finish your dynamic loading patch?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
My inferiority complex is the only thing I can be proud of.