Subject: [clisp-list] problem making clisp-2.30 on old version of FreeBSD continued...

From: "M.K." <[email-masked]>
Date: Tue Jul 1 16:27:06 2003

I have now progressed in my attempt to build clisp 2.30 on FreeBSD 3.4 and I
have managed to get past the error relating to readline. I am now getting a
new error when running make which is:

In file included from lisparit.d:41
ffloat.d:596 parse error
In file included from lisparit.d:42
dfloat.d:1157 parse error
*** Error code 1
Stop.

For the record, I have succesfully made & installed the following GNU
libs/progs:

libsigsegv 2.0
libiconv 1.9.1
readline 4.3
gettext 0.12.1

...and I have started the config/make process from the beginning with a
freshly untared source. Procedure follows:

./configure | tee config.log
cd src
./makemake --with-dynamic-ffi > Makefile
make config.lisp
make

I have the file (config.log) which contains a dump of configure's output to
screen just in case it will help anyone get a better idea of my system. I'm
not sure if I can send attachments to this group, so I will wait to see if
anyone can offer any help.

Also for the record, I successfully made and installed an older version of
clisp (2.27) on this system today.

Thanks and Regards, M.K.

---

---

From: Sam Steingold <[email-masked]>
Date: Wed Jul 2 06:13:02 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] problem making clisp-2.30 on old version of FreeBSD continued..."
> * Sent on Wed, 2 Jul 2003 09:26:43 +1000 (EST)
> * Honorable "M.K." <[email-masked]> writes:
>
> I have now progressed in my attempt to build clisp 2.30 on FreeBSD 3.4
> and I have managed to get past the error relating to readline. I am
> now getting a new error when running make which is:
> 

could you please look at the lines in question?
what exactly triggers the error?
gcc --version?
could you please try cvs head?

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
I don't have an attitude problem. You have a perception problem.