Subject: [clisp-list] CLISP 2.29 for NetBSD/Alpha

From: Indrayana Rustandi <[email-masked]>
Date: Wed Dec 25 12:45:03 2002

Hi,

By changing src/lispbibl.d:2405 to 

#if defined(DECALPHA) && (defined(UNIX_OSF) ||
defined(UNIX_LINUX) || defined(UNIX_NETBSD))

I managed to make a build of CLISP 2.29. I didn't
encounter any failures running "make test" and "make
testsuite". However, I once saw in the NetBSD's
port-alpha mailing list that CLISP may have LP64
problems. If this is the case, have they been fixed?

Thanks,

Indra

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Wed Jan 1 21:18:02 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLISP 2.29 for NetBSD/Alpha"
> * Sent on Wed, 25 Dec 2002 12:44:39 -0800 (PST)
> * Honorable Indrayana Rustandi <[email-masked]> writes:
>

what are the
        Code address range
        Malloc address range
        Shared libraries address range
        Stack address range

??

thanks.

> I managed to make a build of CLISP 2.29. I didn't encounter any
> failures running "make test" and "make testsuite". However, I once saw
> in the NetBSD's port-alpha mailing list that CLISP may have LP64

I am not aware of any such problems.
please try the CVS head CLISP.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
If You Want Breakfast In Bed, Sleep In the Kitchen.

---

From: Indrayana Rustandi <[email-masked]>
Date: Thu Jan 2 11:51:43 2003

Code address range: 0x0000000120000000
Malloc address range: 0x0000000120000000
Shared library address range: 0x0000000160000000
Stack address range: 0x00000001FF000000

So, I assume this build of CLISP is usable, right?

Indra

--- Sam Steingold <[email-masked]> wrote:
> > * In message
> <[email-masked]>
> encounter any
> <http://www.mideasttruth.com/>
> <http://www.palestine-central.com/links.html>

---

From: Sam Steingold <[email-masked]>
Date: Thu Jan 2 12:45:10 2003

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] CLISP 2.29 for NetBSD/Alpha"
> * Sent on Thu, 2 Jan 2003 11:49:29 -0800 (PST)

sure!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Binaries die but source code lives forever.