Subject: [clisp-list] Re: clisp 2.32 with clx

From: [email-masked]
Date: Sat Mar 6 00:33:00 2004

In einer eMail vom 05.03.04 15:23:21 (MEZ) Mitteleuropäische Zeit schreibt 
[email-masked]:

<< > *  <[email-masked]> [2004-03-05 04:24:47 -0500]:
 >
 > I compiled clisp 2.32 (2003-12-29/mandrake 9.0).
 
 which clx did you use? mit-clx or new-clx?
 
 > qix.lisp shows its picture, but -demo hello-world.lisp from clocc/clx
 > issues:"class #<BUILT-IN-CLASS T> has no slot named FONT-INFO.
 
 <http://clisp.cons.org/impnotes/environment.html#debugger>
 ":h" and ":bt" are your friends.
Thanks for the answer, and sorry for the noise in this list.
But I compiled a virgin dist from sf. Therefore it shouldn't happen that 
demos break, I thougt. 
I compiled clisp 2.32 with its clx, contained in the distrib(clx/new-clx)
in CLOCC/SRC/GUI/CLX/DEMO
...clisp-2.32/full/lisp.run -M ....lispinit.mem
[] (load "qix.lisp")
[] (in-package :xlib)
XLIB[] (qix :host "k")  => ok
[] (load "hello.lisp")
[] (in-package :xlib)
XLIB[] (hello-world "k")
*** SLOT-VALUE:The class #<BUILT-IN-CLASS T> has no slot named FONT-INFO
Is there needed some other package to run hello.lisp??
Konrad

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 6 07:44:01 2004

> *  <[email-masked]> [2004-03-06 03:16:48 -0500]:
>

this appears to be a bug.  we need to investigate it.
please try the above commands, start with ":bt".

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Only a fool has no doubts.