Subject: [clisp-list] dynload.d compilation problems

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Mon Apr 15 07:53:09 2002

Peter,

>  with_string_0(name,O(pathname_encoding),libname, {
>         begin_system_call();
>         #if defined(AMIGAOS)
>           libaddr = OpenLibrary(libname,0);
>         #elif defined(WANT_SYSDLL)
>           libaddr = dll_open(libname);
>         #else
>           #error "what dlopen implementation to use now?"
>         #endif
>         end_system_call();
>       });

You're right! That's must be the culprit.

I'll have a look at your file after I finish the stack allocator.
(with-stack-allocation (foo `(c-array-max character ,13) "abc")
  (describe foo)
  (ffi::foreign-value foo)
)
-> foreign-variable of type (c-array-max ...)
"abc"
(to be implemented :-)

Thanks!
	Jorg Hohle.

---

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Apr 17 08:50:42 2002

Hi,

Peter Wood wrote:
> CONST isn't used in dynload.  It's used in sysdll, and I didn't
> - but yes, CONST must be defined.

Please get a newer sysdll.c from XEmacs CVS, as I mentioned in my mail from 10.4.
CONST is not used anymore in it.

I then wrote:
JCH>I now use sysdll-1.7.c and sysdll-1.3.h from XEmacs CVS
This (or a newer if exists) is what should be integrated into
CLISP, not the older version that I got from Reini. Please test this one -- because:
JCH> I then need fewer -Dxyz (but others) [...]

> anyone went through the assembler code for stream.d, or pathname.d?
> :-) And if anyone ever did, is he out of hospital yet? poor guy :-)
Do you have reasons to believe I'm in hospital? :-)

Regards,
	Jorg Hohle.