Subject: [clisp-list] Linux/hppa crash

From: Will Newton <[email-masked]>
Date: Thu Sep 5 15:09:02 2002

The interpreter crashes with a SIGSEGV. I have included the backtrace.

I will try to debug it myself, but if anyone has any suggestions they would 
be gratefully received.

(gdb) run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load \"init.lisp\") 
(sys::%saveinitmem) (exit)"
Starting program: /home/will/debian/build/clisp/debian/build/lisp.run -B . -N 
locale -Efile UTF-8 -norc -m 750KW -x "(load \"init.lisp\") 
(sys::%saveinitmem) (exit)"

Program received signal SIGSEGV, Segmentation fault.
expand_deftype (type_spec=0x25d4e9, once_p=false) at predtype.d:1956
1956      pushSTACK(TheSubr(subr_self)->name);
(gdb) print subr_self
$1 = 0x0
(gdb) bt
#0  expand_deftype (type_spec=0x25d4e9, once_p=false) at predtype.d:1956
#1  0x000a094c in valid_type1 (name=0x25d4e9) at sequence.d:142
#2  0x000a0d38 in valid_type (name=0x25d4e9) at sequence.d:225
#3  0x000a240c in coerce_sequence (sequence=0x25d4e9, result_type=0x0,
    error_p=true) at sequence.d:994
#4  0x0003427c in match_subr_key (fun=0x256c32, argcount=0,
    key_args_pointer=0x4027e088, rest_args_pointer=0x4027e0a0) at eval.d:2776
#5  0x00038298 in funcall_subr (fun=0x256c32, args_on_stack=2) at eval.d:5381
#6  0x000759bc in allocate_syntax_table () at io.d:199
#7  0x00075ae4 in orig_readtable () at io.d:357
#8  0x00076240 in init_reader () at io.d:571
#9  0x0002ac2c in init_symbol_values () at spvw.d:1213
#10 0x0002b854 in initmem () at spvw.d:1432
#11 0x0002d4e8 in main (argc=8, argv=0x8010018) at spvw.d:2553
(gdb)

---

From: Sam Steingold <[email-masked]>
Date: Fri Sep 20 10:52:05 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Linux/hppa crash"
> * Sent on Thu, 5 Sep 2002 23:11:36 +0100
> * Honorable Will Newton <[email-masked]> writes:
>

Will, Stefan translated the comments in the relevant files, please
look at the current CVS HEAD.

thanks

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Any connection between your reality and mine is purely coincidental.

---

From: Will Newton <[email-masked]>
Date: Fri Sep 20 11:12:28 2002

> look at the current CVS HEAD.

I figured it out. I missed returning from an asm call.

Fix attached.
--- clisp-2.30.old/src/arihppa.d	2002-09-17 04:02:54.000000000 +0100
+++ clisp-2.30/src/arihppa.d	2002-09-19 23:46:44.000000000 +0100
@@ -71,6 +71,8 @@
                 # if (x & (bit(31-0)*(bit(1)-1)) != 0)
                 EXTRU,=         %arg0,0,1,%r0
                 ADDI            1,%ret0,%ret0           # y = y+1;
+		BV		0(%r2)			# Return
+		NOP
                 .EXIT
                 .PROCEND