Subject: [clisp-list] Installation problem

From: Luke Gorrie <[email-masked]>
Date: Tue Jan 13 00:31:05 2004

Ahoy,

I'm trying to install CLISP 2.32 on my Debian testing box. It fails
during 'make install':

  for f in clisp-link linkkit/* base/* full/*; do \
    case $f in \
      */lisp.run) /usr/bin/install -c $f /usr/local/lib/clisp/$f;; \
      *) /usr/bin/install -c -m 644 $f /usr/local/lib/clisp/$f;; \
    esac; \
  done
  /usr/bin/install: cannot stat `full/libavcall.a': No such file or directory
  /usr/bin/install: cannot stat `full/libcallback.a': No such file or directory
  ....

My full/ directory contains some very funny looking symlinks:

  lrwxr-xr-x    1 luke     foo            81 Jan 13 05:12 libavcall.a -> /home/luke/src/clisp-2.32/src/base?/home/luke/src/clisp-2.32/src/base/libavcall.a
  lrwxr-xr-x    1 luke     foo            83 Jan 13 05:12 libcallback.a -> /home/luke/src/clisp-2.32/src/base?/home/luke/src/clisp-2.32/src/base/libcallback.a
  lrwxr-xr-x    1 luke     foo            82 Jan 13 05:12 libcharset.a -> /home/luke/src/clisp-2.32/src/base?/home/luke/src/clisp-2.32/src/base/libcharset.a

Any ideas?

Cheers,
Luke

---

From: Sam Steingold <[email-masked]>
Date: Tue Jan 13 09:59:05 2004

> * Luke Gorrie <[email-masked]> [2004-01-13 09:28:14 +0100]:
>

weird.
full/ is created by clisp-link.
maybe you could add "-xv" to "#!/bin/sh" in clisp-link and see what
command creates these absurdities?

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Bus error -- please leave by the rear door.