Subject: [clisp-list] lisp and GUIs

From: Einar Karttunen <[email-masked]>
Date: Wed, 22 Aug 2001 10:26:16 +0300

Hello

What GUIs are commonly used in lisp applications?
Garnet seems quite big, but it is not developed
anymore. Is McClim or SLIK stable enough to use?
What about wxWindows? There is wxclisp 
(http://www.anthemion.co.uk/wxclips/) but it 
seems obsolete? Is any of the guis portable
for win32 and x?

- Einar Karttunen

---

From: Sam Steingold <[email-masked]>
Date: 22 Aug 2001 09:32:46 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] lisp and GUIs"
> * Sent on Wed, 22 Aug 2001 10:26:16 +0300
> * Honorable Einar Karttunen <[email-masked]> writes:
>
> Is any of the guis portable for win32 and x?

at the moment I can only recommend using socket interface to your
browser, like INSPECT in CLISP and CLOCC/CLLIB.

we _are_ interested in adding a GUI toolkit to CLISP.
wxWindows, TK, Qt are the options.
would you like to work on this?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
I don't want to be young again, I just don't want to get any older.

---

From: Paolo Amoroso <[email-masked]>
Date: Wed, 22 Aug 2001 18:10:00 +0200

> What GUIs are commonly used in lisp applications?

What are your requirements for a GUI?

> anymore. Is McClim or SLIK stable enough to use?

McCLIM (a.k.a. Free CLIM) is still under development and it lacks some CLIM
features, most notably presentation types, but work on it is increasing and
there are new developers contributing to the project. The development
mailing list provides a steady flow of commit logs.

As for SLIK, I think it's mainly used in the radiation treatment planning
system (PRISM) that motivated its development.

Paolo
-- 
EncyCMUCLopedia * Extensive collection of CMU Common Lisp documentation
http://web.mclink.it/amoroso/ency/README
[http://cvs2.cons.org:8000/cmucl/doc/EncyCMUCLopedia/]

---

From: Peter Wood <[email-masked]>
Date: Thu, 23 Aug 2001 07:04:27 +0200

> would you like to work on this?

wxWindows and Qt are C++ libraries.  So if you want to use the FFI  to
create bindings for them, you will first have to extend the FFI to
also support C++.

Or is it possible (and practical) to use the FFI for C++, already?

Regards,
Peter

---

From: Reini Urban <[email-masked]>
Date: Thu, 23 Aug 2001 19:21:08 +0100

> Or is it possible (and practical) to use the FFI for C++, already?

if you know exactly with which compiler version the c++ dll was compiled, 
it is possible now. you can just call any c++ function with the unmangled 
name. 
are there any other issues with callbacks and probably new/delete I oversaw?

if so we'll have to provide a wrapper dll which does the c++ memory
management.
this wrapper has to be produced automatically. the pythonwin folks (marc
hammond) 
did it by hand, but it was a lot of work. same for com 

just tried the mentioned wxclips. this is really old, but it works. 
even the html viewer and dialog builder.
so there is a successful wxwindows port for PLT scheme and clips.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/