Subject: Re: [clisp-list] module support

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Fri Apr 26 05:23:03 2002

Hi,

Peter asked:
> > What the fuck is going on?
[long hypothesis of mine deleted]

Maybe there's a simpler explanation:

I just created a new lisp.exe (no modules) and new lispimag.mem:
...\clisp-2.28\src>lisp.exe -B . -Efile UTF-8 -norc -m 750KW -x
 "(load \"init.fas\") (sys::%saveinitmem) (exit)"
...\clisp-2.28\src>lisp.exe -M lispimag.mem
[...]
[1]> (package-lock "FFI")
NIL
[2]> (package-lock "SYS")
NIL
?
Some older images of mine have the locks in them?!?!

I see, it should have been: -x "(load \"init.fas\") (saveinitmem) (exit)"

How did you dump your images?

Regards,
	Jorg Hohle.
Patch will be sent to SF. Now I can
> oldlisp.exe -M oldlispinit.mem -i gdi.fas
and don't need that stupid interim image anymore.

---

From: Peter Wood <[email-masked]>
Date: Fri Apr 26 09:59:37 2002

Hi,

> How did you dump your images?

I didn't.  The build process did it for me.  I am building with the
patches to 'configure' and 'makemake.in' which I sent to the list, and
which allow building the new ffi 'normally'.  There does not appear to
be any problem with package locking: certainly, I redefined ffi to
"FFI" in dynload.d and ffimext.d, and I do not get errors.

Regards,
Peter