Subject: [clisp-list] load bug or feature?

From: myriam <[email-masked]>
Date: Mon Feb 25 10:59:05 2002

Hi!

I'm at a loss to explain this behavior: 

NLP[11]> (defvar *blocks-home* "~/blocks")
*BLOCKS-HOME*
NLP[12]> (load (concatenate 'string *blocks-home* "/nlp-test.lisp"))
*** - A file with name /rhome/5510/abramson/blocksnlp does not exist
1. Break NLP[13]> (probe-file (concatenate 'string *blocks-home* "/nlp-test.lisp"))
#P"/rhome/5510/abramson/blocks/nlp-test.lisp"
1. Break NLP[13]> 

This does not work either

1. Break NLP[27]> (make-pathname :directory '(:absolute "rhome" "5510" "abramson" "blocks")
	        :name "nlp-test"
		:type "lisp")
#P"/rhome/5510/abramson/blocks/nlp-test.lisp"
1. Break NLP[27]> (load *)
*** - A file with name /rhome/5510/abramson/blocksnlp does not exist
2. Break NLP[26]> 

Thanks for any help. 
-- 

                                    myriam

---

From: myriam <[email-masked]>
Date: Mon Feb 25 11:14:05 2002

Sorry. My bug!

-- 

                                    myriam