Subject: [clisp-list] Problem compiling on hp-ux 11.11

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Mon May 24 05:30:13 2004

I am having a problem compliling clisp-2.33 on hp-ux 11.11.
 
It will get all the way to the point where it tries to run lisp.run and then coredumps:
 
chmod +w config.lisp
echo '(setq *clhs-root-default* " <http://www.lisp.org/HyperSpec/> http://www.lisp.org/HyperSpec/")' >> config.lisp
./lisp.run -B . -Efile UTF-8 -Eterminal UTF-8 -norc -m 750KW -x "(and (load \"init.lisp\") (sys::%saveinitmem) (ext::exit))"
make: *** [interpreted.mem] Bus error (core dumped)

I am using gcc version 3.2.

Any Ideas?

Thanks,

Art Nuzzo

---

From: Sam Steingold <[email-masked]>
Date: Mon May 24 07:32:09 2004

> * Nuzzo Art-CINT116 <[email-masked]> [2004-05-24 07:29:33 -0500]:
>

<http://clisp.cons.org/faq.html#bugs>
<http://clisp.cons.org/clisp.html#bugs>

please try

$ ./configure --with-debug --build build-g
$ cd build-g
$ gdb lisp.run
(gdb) run -B . -E utf-8 -i init.lisp

and report the backtrace.

thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Bus error -- please leave by the rear door.