Subject: [clisp-list] Next release of CLISP?

From: Bill Clementson <[email-masked]>
Date: Thu Feb 21 09:49:03 2002

I am preparing a set of instructions for setting up a Lisp development environment on Windows with configuration information for clisp/ilisp, acl/eli, corman/eshell & lw/ilisp for the Common Lisp Cookbook:

http://cl-cookbook.sourceforge.net/windows.html

Sam Steingold rightly pointed out some problems with my CLISP installation instructions in his posting to comp.lang.lisp:

http://groups.google.com/groups?hl=en&threadm=wksn7vwgcq.fsf%40attbi.com&prev=/groups%3Foi%3Ddjq%26as_ugroup%3Dcomp.lang.lisp

As I mentioned in my reply to his posting, I had some problems with the install.bat (actually install.lisp) installation. I just checked and see that a fix is already in CVS. I also pointed out (in an earlier email) that the clisp-indent.el file isn't available in the standard Windows distribution & Sam indicated that it would be included in the next release. 

I would like to update my instructions to allow users to correctly install CLISP on a Windows PC. I can do one of the following:

1. Include instructions on how to download the cvs version of clisp-indent.el (I do this already) and install.lisp (I don't do this - are there any dependencies that would make this not work properly if downloaded & installed on the standard CLISP 2.27 Windows distribution?). 

2. Change my instructions to refer to CLISP 2.28 which includes the necessary fixes. The only problem is that 2.28 hasn't been released yet :-( However, Sam alluded to the fact that it's been a while since the Windows distribution has been updated in an earlier (unrelated) message:

> > I'm using the CLISP-2.27-win32 binary distribution on a 
> MS-W*2k system.
> 
> this is very old.
> we _are_ overdue for a release.
>

Any chance that a new release will occur sometime soon (in the next few days)?

-- 

Bill Clementson

---------------------------------
Do You Yahoo!?
Yahoo! Sports - Coverage of the 2002 Olympic Games

---

From: Sam Steingold <[email-masked]>
Date: Thu Feb 21 11:39:07 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Next release of CLISP?"
> * Sent on Thu, 21 Feb 2002 09:48:25 -0800 (PST)
> * Honorable Bill Clementson <[email-masked]> writes:
>
> 1. Include instructions on how to download the cvs version of
> clisp-indent.el (I do this already) and install.lisp (I don't do this
> - are there any dependencies that would make this not work properly if
> downloaded & installed on the standard CLISP 2.27 Windows
> distribution?).
no

> Any chance that a new release will occur sometime soon (in the next few days)?
no

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
There are two ways to write error-free programs; only the third one works.

---

From: Kaz Kylheku <[email-masked]>
Date: Tue Mar 12 14:05:02 2002

(with-open-file (f ".cvsignore" :direction :output) ...)

*** - no file name given: #P"/some/path/to/.cvsignore"

-- 
Meta-CVS: version control with directory structure versioning over top of CVS.
http://users.footprints.net/~kaz/mcvs.html

---

From: Peter Wood <[email-masked]>
Date: Tue Mar 12 14:21:01 2002

Hi

> *** - no file name given: #P"/some/path/to/.cvsignore"

Clisp thinks the bit after the dot is the type, not the name.

#<output buffered file-stream character #P"/home/prw/dot.txt" @1>
[2]> (pathname-name #P".inputrc")
nil
[3]> (pathname-type #P".inputrc")
"inputrc"
[4]> (pathname-name (make-pathname :name ".inputrc"))
".inputrc"
[5]> (dribble)

:-(

Regards,
Peter

---

From: Russell Senior <[email-masked]>
Date: Tue Mar 12 14:52:02 2002

I've got a lisp library in ~/lisp/foo.lisp.  I have another file,
bar.lisp which "requires" it:

   $ cat bar.lisp
   (require "foo")

When I load bar:

   $ clisp -q -norc

   [1]> (lisp-implementation-version)
   "2.28 (released 2002-03-03) (built 3224363402) (memory 3224363613)"

$ clisp -q -norc

   [1]> *load-paths* 
   (#P"" "~/lisp/**/")
   [2]> (load "bar")
   ;; Loading file /home/russell/bar.lisp ...
   *** - A file with name foo does not exist
   1. Break [3]> *load-paths* 
   (#P"/home/russell/" . #P"/home/russell/bar.lisp")
   1. Break [3]> 
   [4]> *load-paths* 
   (#P"" "~/lisp/**/")
   [5]> 

This used to work (i.e., foo was found with the require) in earlier
versions of CLISP.

-- 
Russell Senior         ``The two chiefs turned to each other.        
[email-masked]      Bellison uncorked a flood of horrible       
                         profanity, which, translated meant, `This is
                         extremely unusual.' ''