Subject: [clisp-list] (no subject)

From: Lennart Staflin <[email-masked]>
Date: Sun Feb 3 07:49:01 2002

Hi,
I have compiled the latest CVS version of CLISP and found the following 
problem:

     [8]> (defmethod foo ((x (eql 1))) x)

     *** - SYMBOL-PACKAGE: 1 is not a symbol

This worked with the version of CLISP I compiled from CVS a month ago.

//Lennart Staflin

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 3 09:11:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] (no subject)"
> * Sent on Sun, 3 Feb 2002 16:47:28 +0100
> * Honorable Lennart Staflin <[email-masked]> writes:
>

fixed in the CVS.
thanks for the bug report
(of course, if you use CVS, you are supposed to subscribe to clisp-devel
and report problems there -- blah blah ... :-)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I haven't lost my mind -- it's backed up on tape somewhere.