Subject: [clisp-list] idea about how to design CLISP's socket functions (or CLISP's FFI for UFFI): target ACL-COMPAT

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Fri Aug 2 00:35:53 2002

Hi CLISP users,

Jochen Schmidt wrote in cll about
>Re: Question on using Scheme on Large Projects
>As maintainer of ACL-COMPAT which is used by a webserver (Portable 
>AllegroServe) I tend to disagree. It's a complete Socket API which is 
>portable between ACL, CMUCL,  LispWorks, MCL and OpenMCL. Chris Double has 
>written a library which makes that API accessible for Corman Lisp too.
>Please if you have looked at it and still have issues about interoperability 
>then contact us and we will see what we can do.

We had a discussion recently about socket-connect-timeout and other socket issues.
Maybe it would be useful to design future CLISP socket functionality so that it can easily support ACL-COMPAT?

I had similar thoughts about the CLISP FFI and the possibility for UFFI to support CLISP, especially about how to define a module (aka foreign library) as a set of foreign library functions. What matters here is how to reference the module by short alias instead of system and environment dependent pathname.

The thought was: why should I care about this, since UFFI already includes such functionality? So the new goal might become: "How to supply just enough functionality so that UFFI macros can easily map onto these low-level primitives?"

This is easier to achieve than invent yet another high-level foreign library declaration and management system.

I believe similar thoughts could apply to providing new socket extensions to CLISP. The driving question could become: "What low-level functionality must be there to make it easy for Jochen Schmidt of ACL-COMPAT fame to support CLISP as well?"

Regards,
	Jörg Höhle.

---

From: Sam Steingold <[email-masked]>
Date: Fri Aug 2 08:15:04 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] idea about how to design CLISP's socket functions (or CLISP's FFI for UFFI): target ACL-COMPAT"
> * Sent on Fri, 2 Aug 2002 09:32:52 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> Maybe it would be useful to design future CLISP socket functionality
> so that it can easily support ACL-COMPAT?

why can't CLISP support ACL-COMPAT now?

> The thought was: why should I care about this, since UFFI already
> includes such functionality? So the new goal might become: "How to
> supply just enough functionality so that UFFI macros can easily map
> onto these low-level primitives?"
> 
> This is easier to achieve than invent yet another high-level foreign
> library declaration and management system.

just do it then!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
There are 3 kinds of people: those who can count and those who cannot.