Subject: [clisp-list] Re: CLISP - compile troubles (Cygwin porting)

From: Jari Aalto <[email-masked]>
Date: Fri Sep 19 12:55:11 2003

[Keep CC, thank you]

    >     root@w2kpicasso:/usr/src/build/clisp/clisp-2.31# ls -la build-cygwin/
    >     total 0
    >     drwxr-xr-x    2 root     None            0 Sep 15 23:19 .
    >     drwxr-xr-x   22 root     None            0 Sep 15 22:25 ..
    > 
    > Let me know how to proceed

    please replace "--install" with "--build --install".  sorry.

    if you do not have libsigsegv installed, I suggest
    getting it from ftp://ftp.gnu.org/pub/gnu/libsigsegv/libsigsegv-2.1.tar.gz 
    and installing it with
    ./configure --prefix /usr/local/libsigsegv-cygwin
    make && make check && make install
    (you can omit --prefix here in
    --with-libsigsegv-prefix=/usr/local/libsigsegv-cygwin in CLISP config if
    you do not need libsigsegv/mingw).
    this is not required, but _highly_ recommended.
    this is a _build-time_ dependency only (not a run-time dependency!)

I had to port libsegv to cygwin first (Just announced ITP in cygwin-apps
mailing list), so I'm back in clisp again. Here is the latest build
messages, let me know how to proceed.

        ./configure                     \
        --prefix=/usr                   \
        --exec-prefix=/usr              \
        --with-dynamic-ffi              \
        --with-module=syscalls          \
        --with-module=regexp            \
        --fsstnd=redhat                 \
        --with-module=dirkey            \
        --with-module=bindings/win32    \
        --with-libsigsegv-prefix=/usr/lib \
        --install --build cygwin

I used ftp://ftp.gnu.org/pub/gnu/libsigsegv/ which had version
libsigsegv-2.0 (You mentioned 2.1 ?)

Jari

ln -s ../src/nls_cp1257.c nls_cp1257.c
ln -s ../src/nls_hp_roman8.c nls_hp_roman8.c
ln -s ../src/nls_nextstep.c nls_nextstep.c
ln -s ../src/nls_jisx0201.c nls_jisx0201.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -c encoding.c
encoding.d: In function `nls_range':
encoding.d:1658: warning: `i1' might be used uninitialized in this function
encoding.d:1659: warning: `i2' might be used uninitialized in this function
ln -s ../src/pathname.d pathname.d
./comment5 pathname.d | ./ansidecl | ./varbrace > pathname.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -c pathname.c
pathname.d: In function `parse_logical_word':
pathname.d:1529: warning: `ch' might be used uninitialized in this function
pathname.d: In function `C_launch':
pathname.d:10862: warning: variable `exit_code' might be clobbered by `longjmp' or `vfork'
ln -s ../src/stream.d stream.d
./comment5 stream.d | ./ansidecl | ./varbrace > stream.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -c stream.c
stream.d: In function `iconv_range':
stream.d:3932: warning: `i1' might be used uninitialized in this function
stream.d:3933: warning: `i2' might be used uninitialized in this function
stream.d: In function `lisp_completion':
stream.d:9147: warning: variable `array' might be clobbered by `longjmp' or `vfork'
stream.d:9154: warning: variable `ptr' might be clobbered by `longjmp' or `vfork'
stream.d:9169: warning: variable `ptr1' might be clobbered by `longjmp' or `vfork'
make: *** [stream.o] Interrupt

---

From: Jari Aalto <[email-masked]>
Date: Sun Sep 21 02:52:06 2003

I'm receiving large amounts of audio and picture files from spammers
and any response to my previous mail got mistakenly sent to /dev/null
by my spam filters. The filters are now fixed so, if you could kindly
answer to this mail once again.

[Keep CC, thank you]

        ./configure                     \
        --prefix=/usr                   \
        --exec-prefix=/usr              \
        --with-dynamic-ffi              \
        --with-module=syscalls          \
        --with-module=regexp            \
        --fsstnd=redhat                 \
        --with-module=dirkey            \

Jari