Subject: [clisp-list] LDAP-support in CLISP.

From: Johannes Groedem <[email-masked]>
Date: Thu Oct 18 20:02:15 2001

The dirkey-support in clisp (2.27) seem to be missing some
#ifdef WIN32_NATIVEs.  Or am I doing something wrong with
configuration?  (I'm basically just giving --with-dir-key,
and when I try to compile, it just barfs out lots of messages
about how HKEY isn't defined, etc.)

-- 
johs

---

From: Sam Steingold <[email-masked]>
Date: Fri Oct 19 05:56:10 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] LDAP-support in CLISP."
> * Sent on Fri, 19 Oct 2001 05:01:49 +0200
> * Honorable Johannes Groedem <[email-masked]> writes:
>

What is your platform?
LDAP is not implemented yet - win32 HKEY only.
Would you like to work on LDAP?

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
((lambda (x) `(,x ',x)) '(lambda (x) `(,x ',x)))

---

From: Johannes Groedem <[email-masked]>
Date: Fri Oct 19 10:35:17 2001

> What is your platform?

FreeBSD-4.4, i386.

> LDAP is not implemented yet - win32 HKEY only.

Ah, that explains why I couldn't find any references to any
ldap-functions. :)

> Would you like to work on LDAP?

I might.  I'm kind of new to Lisp, though, but I guess it's
mostly C, right?  (Also, I don't know anything about clisp's
ffi, but that can all be learned, I guess.)

-- 
johs

---

From: Erik Arneson <[email-masked]>
Date: Fri Oct 19 10:41:09 2001

> ffi, but that can all be learned, I guess.)

You might want to look at the LDAP code in some of the newer versions of
XEmacs.  They've got a very nice interface, and it links into OpenLDAP,
so you might be able to get a good idea of how to do things.

-- 
# Erik Arneson <[email-masked]>    AARG Net <http://www.aarg.net/> #
# GPG Key ID: 1024D/43AD6AB8           <http://erik.arneson.org/> #
# "Resistance to tyrants is obedience to God!" - Thomas Jefferson #