Subject: [clisp-list] clisp-link bug

From: Johannes Groedem <[email-masked]>
Date: Sun Oct 21 15:27:13 2001

Hi,

I just thought I'd mention that clisp-link breaks when the LIBS-variable
contains commas.  (In my case, it contained "-Wl,E" (passes -export-dynamic
to the linker), which causes sed to barf out an invalid option error,
or something.  This is on FreeBSD-4.4, by the way, with BSD Sed, not GNU
sed.  If GNU sed is installed, it will most likely be called "gsed".

Anyway, I've attached a simple patch that seems to work for me.

--- clisp-link.orig	Sun Oct 21 22:16:08 2001
+++ clisp-link	Mon Oct 22 00:10:09 2001
@@ -278,6 +278,7 @@
     done
     verbose "$destinationdir"/lisp.run -B "$installbasedir" -M "$lispinitdir"/lispinit.mem -norc -q -i $to_load -x "(saveinitmem \"$destinationdir/lispinit.mem\")"
     # Generate new makevars
+    LIBS=$(echo $LIBS | sed s/','/'\\,'/g)
     sed -e "s,^LIBS=.*\$,LIBS='${LIBS}'," -e "s,^FILES=.*\$,FILES='${FILES}'," < "$sourcedir"/makevars > "$destinationdir"/makevars
     # Done.
     trap '' 1 2 15
@@ -416,6 +417,7 @@
         verbose "$destinationdir"/lisp.run -B "$installbasedir" -M "$sourcedir"/lispinit.mem -norc -q -i ${LOAD} -x "(saveinitmem \"$destinationdir/lispinit.mem\")"
       fi
       # Generate new makevars
+      LIBS=$(echo $LIBS | sed s/','/'\\,'/g)
       sed -e "s,^LIBS=.*\$,LIBS='${LIBS}'," -e "s,^FILES=.*\$,FILES='${FILES}'," < "$sourcedir"/makevars > "$destinationdir"/makevars
     fi
     # Done.

-- 
johs

---

From: Sam Steingold <[email-masked]>
Date: Tue Oct 23 10:07:02 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp-link bug"
> * Sent on Mon, 22 Oct 2001 00:26:36 +0200
> * Honorable Johannes Groedem <[email-masked]> writes:
>
> contains commas

thanks for the patch.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
When you are arguing with an idiot, your opponent is doing the same.