Subject: [clisp-list] latest gettext breaks compilation on solaris

From: Sam Steingold <[email-masked]>
Date: 23 Mar 2001 17:57:17 -0500

make[1]: Entering directory `/kdd3/opt/local/src/clisp/pristine/build/gettext/intl'
bison -y -d --name-prefix=__gettext --output plural.c plural.y
Usage: bison [-dhltvyV] [-b file-prefix] [-o outfile] [-p name-prefix]
       [--debug] [--defines] [--fixed-output-files] [--no-lines]
       [--verbose] [--version] [--help] [--yacc]
       [--file-prefix=prefix] [--name-prefix=prefix]
       [--output=outfile] grammar-file
make[1]: *** [plural.c] Error 1
make[1]: Leaving directory `/kdd3/opt/local/src/clisp/pristine/build/gettext/int

attempting a quick fix:

$ bison -y -d -p __gettext -o plural.c plural.y
conflicts:  7 shift/reduce
$ make
gcc -O -c -DLOCALEDIR=\"/usr/local/share/locale\" -DLOCALE_ALIAS_PATH=\"/usr/local/share/locale\" -DLIBDIR=\"/usr/local/lib\" -DHAVE_CONFIG_H -I.. -I. -I../intl    plural.c
/opt/gnu/lib/bison.simple:141: conflicting types for `gettextparse__'
gettextP.h:232: previous declaration of `gettextparse__'
/opt/gnu/lib/bison.simple: In function `gettextparse__':
/opt/gnu/lib/bison.simple:354: too few arguments to function `__gettextlex'
plural.y:181: `arg' undeclared (first use in this function)
plural.y:181: (Each undeclared identifier is reported only once
plural.y:181: for each function it appears in.)
make: *** [plural.o] Error 1

--
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Never succeed from the first try - if you do, nobody will think it was hard.

---

From: Bruno Haible <[email-masked]>
Date: Sat, 24 Mar 2001 01:22:49 +0100 (CET)

> make[1]: Leaving directory `/kdd3/opt/local/src/clisp/pristine/build/gettext/int

First, this doesn't happen with the distribution, because the
distribution has plural.c newer than plural.y:

$ tar tvfz clisp-2.25.tar.gz | grep /plural
-rw-r--r-- root/root     34050 2001-03-12 21:21:24 clisp-2.25/src/gettext/intl/plural.c
-rw-r--r-- root/root      7717 2001-03-12 21:14:00 clisp-2.25/src/gettext/intl/plural.y

> attempting a quick fix:

Second, bison-1.24 is very old. (Btw, you should have mentioned the
version of bison you use.) At least bison-1.26 is needed for clisp
hacking. The current release is bison-1.28.

Bruno