Subject: [clisp-list] Sparc issues

From: Sean Callanan <[email-masked]>
Date: Thu Oct 18 10:35:14 2001

Dear mailing list:

This is (I suppose) a follow-up to Ben Collins' e-mails around
3/19/2000:

http://www.geocrawler.com/archives/3/1124/2000/3/0/3459057/

regarding segfaults of lisp.run - specifically during the make process.
This is still the case.
--
*** Segmentation fault
Register dump:

 PSR: ff990084 PC: 00013410 NPC: 00013414   Y: 00000000
 g0: 00000000 g1: 00000075  g2: 0023c188  g3: 19c38000
 g4: 00000000  g5: 00000000  g6: 00000000  g7: ffffff00
 o0: 00000000  o1: 00000000  o2: 00000000  o3: 00000000
 o4: 00000000  o5: 00000000  sp: efffeff0  o7: 00000000
 l0: 00000000  l1: 00000000  l2: 00000000  l3: 00000000
 l4: 00000000  l5: 00000000  l6: 00000000  l7: 00000000
 i0: fffffffc  i1: 00000000  i2: 00000000  i3: 00000000
 i4: 00000000  i5: 00000000  fp: effff058  i7: 00013464

 Old mask: 08000000

Backtrace:
/home/sc843/clisp/clisp/with-gcc-wall/spvw_garcol.d:404(gc_mark_stack)[0x13410]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_garcol.d:431(gc_markphase)[0x13464]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_garcol.d:1614(gar_col_normal)[0x13b04]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_garcol.d:2389(do_gar_col_simple)[0x14868]

/home/sc843/clisp/clisp/with-gcc-wall/predtype.d:2840(with_gc_statistics)[0x94448]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_garcol.d:2417(gar_col_simple)[0x14894]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_allocate.d:236(make_space_gc_true)[0x14a0c]

/home/sc843/clisp/clisp/with-gcc-wall/spvw_typealloc.d:97(allocate_vector)[0x14ddc]

/home/sc843/clisp/clisp/with-gcc-wall/subrkw.d:4(init_subr_tab_2)[0x17718]

/home/sc843/clisp/clisp/with-gcc-wall/spvw.d:1406(initmem)[0x1901c]
/home/sc843/clisp/clisp/with-gcc-wall/spvw.d:2519(main)[0x1a530]
/lib/libc.so.6(__libc_start_main+0x14c)[0x700ce6a0]
??:0(_start)[0x12290]
--
The result of "grep cl_cv_address_ config.cache" for the Ultra I'm using
is
--
cl_cv_address_code=${cl_cv_address_code='0x00000000'}
cl_cv_address_malloc=${cl_cv_address_malloc='0x00000000'}
cl_cv_address_shlib=${cl_cv_address_shlib='0x70000000'}
cl_cv_address_stack=${cl_cv_address_stack='0xEF000000'}
--
The box is a Sun Ultra 10, with a TI UltraSparc IIi, and 128MB of RAM.
I'd love to help in any way I can.
Sincerely,
Sean Callanan

---

From: Sam Steingold <[email-masked]>
Date: Thu Oct 18 11:55:14 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Sparc issues"
> * Sent on Thu, 18 Oct 2001 13:38:11 -0400
> * Honorable Sean Callanan <[email-masked]> writes:
>

we are painfully aware of this Linux/Sparc problem.

the problem appears to be with glibc2.2.
CLISP works just fine with glibc2.1 (all Linux platforms), but fails on
Sparc Linux with glibc2.2.  It does work fine on Sun Solaris and Linux
i386 glibc2.2.

If you can figure out the root of the problem...

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
C combines the power of assembler with the portability of assembler.