Subject: [clisp-list] Re: emacs refuses to save file in the same encoding it was read

From: Kenichi Handa <[email-masked]>
Date: Mon Oct 13 17:58:51 2003

In article <[email-masked]>, Sam Steingold <[email-masked]> writes:
> I have a file which starts with this line:
> ;;; -*- coding: utf-8-unix -*-

> it is opened and displayed by emacs correctly.
> however, when I try to modify and save it, I get the following question:

> Selected encoding mule-utf-8-unix disagrees with iso-2022-7bit specified
> by file contents.  Really save (else edit coding cookies and try again)?
> (y or n)

> when I answer affirmatively, the file is saved, but a line
> ;; -*- coding: iso-2022-7bit; -*-
> is added in front of my cookie.

> what is going on?

I can't reproduce this bug.  Could you please send me the
file that causes this problem in 8-bit safe way (base64 or
uuencode)?

---
Ken'ichi HANDA
[email-masked]

---

From: Pascal J.Bourguignon <[email-masked]>
Date: Mon Oct 13 20:43:04 2003

> file that causes this problem in 8-bit safe way (base64 or

I  had  recently  a  similar   problem  (without  a  -*-  coding:  -*-
line). I've got an answer on  usenet saying that emacs did not support
yet fully unicode, so when you have japanese characters, you must save
in iso-2022.

-- 
__Pascal_Bourguignon__
http://www.informatimago.com/
Do not adjust your mind, there is a fault in reality.