Subject: [clisp-list] clisp on sparcv9?

From: Jedrzej Nasiadek <[email-masked]>
Date: Wed Jan 16 09:53:06 2002

Hi!

Is it possible to compile clisp on sparcv9?
on my UltraSparc-III I see:
$ export CC="cc -xarch=v9"
$ ./configure my-sunwcc
...
...
...
/opt/SUNWspro/bin/../WS6U1/bin/fbe: "avcall-sparc64.s", line 941: error: 
detect global register use not covered .register pseudo-op
/opt/SUNWspro/bin/../WS6U1/bin/fbe: "avcall-sparc64.s", line 942: error: 
detect global register use not covered .register pseudo-op
cc: assembler failed for avcall-sparc64.s
*** Error code 1
make: Fatal error: Command failed for target `avcall-sparc64.lo'

Any ideas on how to fix it?

      regards,
           Jedrzej

---

From: Sam Steingold <[email-masked]>
Date: Wed Jan 16 12:32:11 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp on sparcv9?"
> * Sent on Wed, 16 Jan 2002 18:49:27 +0100
> * Honorable Jedrzej Nasiadek <[email-masked]> writes:
>
> ....
> ....
> ....

1. try GCC

2. the errors are in FFI - try disabling it (./configure
   --with-dynamic-ffi)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Nostalgia isn't what it used to be.