Subject: RE: [clisp-list] Trouble running on cygwin, Windows 2000

From: "Young, David" <[email-masked]>
Date: Wed Jul 31 11:51:02 2002

Hi Jeremy. No, you're not being pompous. And, I understand your question.
Let's see if I can answer it, at least from my perspective.

First, let me say that I've been an exclusive "unix" user (with a smattering
of Symbolics and Apple) for over 17 years. It's only within the last 12
months that I've found myself working on Windows platforms. The reality is
that 1) right now I build expert systems for a living; and 2) the
environments I use, as determined by my employers, happen to run on Windows
2000.

Now. I'm at a stage in my life where I strive for simplicity. Since I use
win2k at work, and I often work at home, I use win2k there as well. I just
don't want a mix of machines where I use one for my bread-and-butter work,
another for my open source work. I now have a single machine -- my notebook
-- that serves both purposes. It runs win2k.

So. Why cygwin? For me, the simplest answer I can give is that cygwin allows
me to build a hybrid environment that yields an acceptable "computing
platform" for my daily efforts. I'd really like to use VMware to host Linux
on my notebook, but I can't justify the $300 price tag to my Better Half.
It's worth the money, I just can't justify it.

I want clisp on cygwin because, for command line stuff, I prefer working
within the bash/cygwin environment, given the constraints I've previously
described. And, since clisp is one of the supported Lisp platforms for my
sourceforge project, well...

Finally, building clisp on a new (for myself) platform was fun. It was an
interesting distraction.

Hope this helps.

-- dey

-----Original Message-----
From: Jeremy Doolin [mailto:[email-masked]]
Sent: Wednesday, July 31, 2002 2:29 PM
To: Young, David
Subject: Re: [clisp-list] Trouble running on cygwin, Windows 2000

Ok, I have to know something.  I've been listening on this list for some
time now and I see a plethora of Cygwin problems.  It seems as though every
couple days, somebody is having a problem getting clisp to work on Cygwin.  

My question is this:  Why run Cygwin?

---

From: youngde <[email-masked]>
Date: Wed Jul 31 12:00:02 2002

Forgive me. Intended to reply just to Jeremy. Sigh...

-- dey

>On Wed, 31 Jul 2002 14:42:52 -0400 "Young, David"
<[email-masked]> wrote.
>Let's see if I can answer it, at least from my perspective...

---

From: youngde <[email-masked]>
Date: Thu Aug 1 07:10:03 2002

Hello Reini. Hmm; I probably wasn't clear in my original post. I downloaded
the clisp 2.29 *source* distribution, built it on Windows 2000 and then
installed (make install). This procedure worked just fine, but running the
newly build clisp executable results in the behavior I reported. I saw no
symlinks in the installation (/usr/local/lib/clisp/...).

Perhaps I've misunderstood your post?

-- dey

>On Thu, 01 Aug 2002 12:51:34  0100 Reini Urban <[email-masked]> wrote.
>Young, David schrieb:
>> Greetings. I've successfully built clisp 2.29 on Dell P-III, cygwin
>> 1.13.12/windows 2000. However, after installing (make install), running
>> clisp results in an endless loop of "UNIX error 13" messages:
>
>> ;; Loading file /cygdrive/h/dyoung/.clisprc.lisp ...
>> ;; Loading of file /cygdrive/h/dyoung/.clisprc.lisp is finished.
>> [1]>
>> *** - UNIX error 13 (EACCES): Permission denied
>> *** - UNIX error 13 (EACCES): Permission denied
>> ...
>> [1]   Stopped                 clisp
>
>
>Most symlinks in the binary cygwin tar
>point to a not existing "c:\gnu\clisp\clisp-2.29" dir, which is wrong.
>The symlinks must be relative, not absolute!
>
>You can fix that manually, by providing a mount for 
>c:\gnu\clisp\clisp-2.29 to your install dir.
>something like:
>
>$ mount -f -s -b "`cygpath -w $PWD`" "/cygdrive/c/clisp/clisp-2.29"
>
>-- 
>Reini Urban
>http://xarch.tu-graz.ac.at/home/rurban/
>
>
>
>-------------------------------------------------------
>This sf.net email is sponsored by:ThinkGeek
>Welcome to geek heaven.
>http://thinkgeek.com/sf
>_______________________________________________
>clisp-list mailing list
>[email-masked]
>https://lists.sourceforge.net/lists/listinfo/clisp-list

---

From: "Young, David" <[email-masked]>
Date: Thu Aug 1 10:05:53 2002

Yes. The error is definitely occuring *after* the prompt. Also, after CLISP
loads .clisprc.lisp.

I'll follow your debugging suggestions and send a report when I have the
data. And, I'll try the CVS head as well.

-- dey

-----Original Message-----
From: Sam Steingold [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 12:50 PM
To: Young, David
Cc: [email-masked]'
Subject: Re: [clisp-list] Trouble running on cygwin, Windows 2000

> * In message
<[email-masked]>
> * On the subject of "[clisp-list] Trouble running on cygwin, Windows 2000"
> * Sent on Wed, 31 Jul 2002 13:00:05 -0400
> * Honorable "Young, David" <[email-masked]> writes:
>
> bash-2.05b$ clisp

are you really getting this __after__ CLISP prints the prompt?!

> [1]+  Stopped                 clisp
> I'd appreciate suggestions.

I cannot reproduce this, alas, either with the current CVS head or with
2.29 release on w2k.

could you please debug this?
1. ./configure --with-debug --build build-g
2. cd build-g
3. gdb -nw
(gdb) break OS_error
(gdb) run
...
(gdb) where

and try to find out what is that illegal trick that CLISP is trying to
pull.

please also try CVS head.

thanks.

> Oh, and note that building clisp on my Vaio notebook (P-III mobile),
> Windows 2000, cygwin, results in an internal compiler error for
> gcc. But, I suppose this is a gcc problem and should be reported to
> the proper authorities.

please do report this.
CLISP appears to be a major source for GCC bug reports :-)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Between grand theft and a legal fee, there only stands a law degree.

---

From: "Young, David" <[email-masked]>
Date: Thu Aug 1 11:50:24 2002

I'm grabbing the CVS head right now. I'll also back out the "better-termcap"
as well. Stay tuned...

-- dey

-----Original Message-----
From: Sam Steingold [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 2:46 PM
To: Young, David
Cc: [email-masked]'
Subject: Re: [clisp-list] Trouble running on cygwin, Windows 2000

> * In message
<[email-masked]>
> * On the subject of "RE: [clisp-list] Trouble running on cygwin, Windows
2000"
> * Sent on Thu, 1 Aug 2002 14:21:45 -0400 
> Ok, here's the deal. Sam, I followed your instructions precisely for
> building a debuggable version of clisp 2.29. If I run the resultant
> program from within gdb, or even strace, it works fine. If I run the
> exe from bash, however, the problem manifests itself.

wow!!!

> I'm using the "better-termcap" available in the distro, and TERM is
> set to 'cygwin32', although I've tried the run both this way and with
> stock cygwin. This sure smells of some type of console issue (?)

don't use this `better-termcap'.
readline should work without it.
it will be gone in the next release anyway.

did you try CVS head?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Trespassers will be shot.  Survivors will be SHOT AGAIN!