Subject: [clisp-list] Port of ffcall to Linux/hppa

From: Will Newton <[email-masked]>
Date: Mon Apr 8 19:30:02 2002

I've started a port of ffcall to Linux/hppa. Currently it is almost complete 
pending a toolchain problem. The parts I have and know work I will split up 
into patches and you can look them over. These bits should not affect the 
build on other arches.

avcall-hppa-linux.c:

avcall implementation for Linux/hppa.

avcall-hppa-linux.s:

Assembler compiled from above file with gcc 3.0.4.

clisp-2.28-avcall-makefile.diff:

Additions to ffcall/avcall/Makefile.devel to produce assembler.

vacall-hppa-linux.s:

Vacall code compiled with gcc 3.0.4.

clisp-2.28-vacall-makefile.diff:

Changes to ffcall/vacall/Makefile.devel to produce above file.

--- clisp-2.28.old/ffcall/vacall/Makefile.devel	Mon Aug 27 18:04:25 2001
+++ clisp-2.28/ffcall/vacall/Makefile.devel	Tue Apr  9 03:09:17 2002
@@ -9,7 +9,7 @@
 SED = sed
 ROFF_MAN = groff -Tascii -mandoc
 
-all : vacall-i386-macro.S vacall-i386-msvc.c vacall-i386-mingw32.c vacall-m68k.mit.S vacall-m68k.mot.s vacall-mips.S vacall-mipsn32.S vacall-mips64.S vacall-sparc.S vacall-sparc64.S vacall-alpha.s vacall-hppa.s vacall-arm.S vacall-rs6000-aix.old.s vacall-rs6000-aix.new.s vacall-rs6000-sysv4.s vacall-m88k.s vacall-convex.s vacall-ia64.s vacall.man \
+all : vacall-i386-macro.S vacall-i386-msvc.c vacall-i386-mingw32.c vacall-m68k.mit.S vacall-m68k.mot.s vacall-mips.S vacall-mipsn32.S vacall-mips64.S vacall-sparc.S vacall-sparc64.S vacall-alpha.s vacall-hppa.s vacall-hppa-linux.s vacall-arm.S vacall-rs6000-aix.old.s vacall-rs6000-aix.new.s vacall-rs6000-sysv4.s vacall-m88k.s vacall-convex.s vacall-ia64.s vacall.man \
       vacall.h.msvc config.h.msvc vacall.h.mingw32 config.h.mingw32
 
 vacall-i386-macro.S : vacall-i386.c vacall.h.in asmi386.sh
@@ -63,6 +63,9 @@
 
 vacall-hppa.s : vacall-hppa.c vacall.h.in
 	$(GCC) -V 2.6.3 -b hppa1.0-hpux $(GCCFLAGS) -D__hppa__ -S vacall-hppa.c -o vacall-hppa.s
+
+vacall-hppa-linux.s : vacall-hppa.c vacall.h.in
+	$(GCC) -D__hppa__ -march=1.0 -fPIC -DHAVE_LONGLONG -S vacall-hppa.c -o vacall-hppa-linux.s
 
 vacall-arm.S : vacall-arm.c vacall.h.in asmarm.sh
 	$(GCC) -V 2.6.3 -b arm-acorn-riscix $(GCCFLAGS) -D__arm__ -S vacall-arm.c -o vacall-arm.s
--- clisp-2.28.old/ffcall/avcall/Makefile.devel	Sat Aug 18 21:04:59 2001
+++ clisp-2.28/ffcall/avcall/Makefile.devel	Tue Apr  9 03:07:15 2002
@@ -9,7 +9,7 @@
 SED = sed
 ROFF_MAN = groff -Tascii -mandoc
 
-all : avcall-i386-macro.S avcall-i386-msvc.c avcall-i386-mingw32.c avcall.h.msvc avcall.h.mingw32 avcall-m68k.mit.S avcall-m68k.mot.s avcall-m68k-amiga.s avcall-mips.S avcall-mipsn32.S avcall-mips64.S avcall-sparc.S avcall-sparc64.S avcall-alpha.s avcall-hppa.s avcall-arm.S avcall-rs6000-aix.old.s avcall-rs6000-aix.new.s avcall-rs6000-sysv4.s avcall-m88k.s avcall-convex.s avcall-ia64.s avcall.man
+all : avcall-i386-macro.S avcall-i386-msvc.c avcall-i386-mingw32.c avcall.h.msvc avcall.h.mingw32 avcall-m68k.mit.S avcall-m68k.mot.s avcall-m68k-amiga.s avcall-mips.S avcall-mipsn32.S avcall-mips64.S avcall-sparc.S avcall-sparc64.S avcall-alpha.s avcall-hppa.s avcall-hppa-linux.s avcall-arm.S avcall-rs6000-aix.old.s avcall-rs6000-aix.new.s avcall-rs6000-sysv4.s avcall-m88k.s avcall-convex.s avcall-ia64.s avcall.man
 
 avcall-i386-macro.S : avcall-i386.c avcall.h.in asmi386.sh
 	$(GCC) -V 2.7.2 -b i486-linuxaout $(GCCFLAGS) -D__i386__ -fno-omit-frame-pointer -S avcall-i386.c -o avcall-i386.s
@@ -72,9 +72,13 @@
 	$(RM) avcall-alpha-temp.s
 
 avcall-hppa.s : avcall-hppa.c avcall.h.in
-	$(GCC) -V 2.6.3 -b hppa1.0-hpux $(GCCFLAGS) -D__hppa__ -S avcall-hppa.c -o avcall-hppa-temp.s
+	$(GCC) -V 2.6.3 -b hppa1.0-hpux $(GCCFLAGS) -D__hppa__ -S avcall-hppa.c
+	-o avcall-hppa-temp.s
 	$(SED) -e 's/120/1060/g' < avcall-hppa-temp.s > avcall-hppa.s
 	$(RM) avcall-hppa-temp.s
+
+avcall-hppa-linux.s: avcall-hppa-linux.c avcall.h.in
+	$(GCC) -D__hppa__ -march=1.0 -fPIC -S avcall-hppa-linux.c -o avcall-hppa-linux.s
 
 avcall-arm.S : avcall-arm.c avcall.h.in asmarm.sh
 	$(GCC) -V 2.6.3 -b arm-acorn-riscix $(GCCFLAGS) -D__arm__ -S avcall-arm.c -o avcall-arm.s

---

From: Will Newton <[email-masked]>
Date: Tue Apr 9 08:38:56 2002

On Tuesday 09 Apr 2002 3:28 am, Will Newton wrote:

> I've started a port of ffcall to Linux/hppa. Currently it is almost
> complete pending a toolchain problem. The parts I have and know work I will
> split up into patches and you can look them over. These bits should not
> affect the build on other arches.

I'm going to redo these patches against the latest CVS so they apply cleanly. 
I should have everything complete within a week.

---

From: Sam Steingold <[email-masked]>
Date: Tue Apr 9 10:45:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Port of ffcall to Linux/hppa"
> * Sent on Tue, 9 Apr 2002 16:28:28 +0100
> * Honorable Will Newton <[email-masked]> writes:
>
> I'm going to redo these patches against the latest CVS so they apply
> cleanly.  I should have everything complete within a week.

thank you!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I don't want to be young again, I just don't want to get any older.