Subject: [clisp-list] clisp on ARM processor

From: ryan tolboom cis stnt <[email-masked]>
Date: Tue Feb 5 23:25:02 2002

Hello!

I am trying to compile clisp on an ARM processor, and am experiencing some
difficulty.  I was wondering if anyone has been succesfull in doing this
or if you would have some advice. 

I noticed an earlier post about clisp on an iPAQ running
linux.  Unfortunately the former post seemed to end without saying
whether or not he got it working.

My goal is to make a binary for the Zaurus SL-5000D, which also uses the
StrongARM processor and runs linux.  I am currently compiling 
on a compaq development machine that has a StrongARM processor and
runs linux.

Here is some info that I hope will help:

The host system is detected as armv4l-unknown-linux-gnu.

Source code used:
CVS as of Wed Feb  6 02:00:32 EST 2002

Commands Executed:
[ from the clisp directory ]
./configure

[ it completes and gives me this output ]
make: *** No rule to make target `avcall-armv4l.lo', needed by `avcall.lo'.  Stop.

To continue building CLISP, the following commands are recommended
(cf. unix/INSTALL step 4):
    cd src
    ./makemake  --with-readline --with-gettext > Makefile
    make config.lisp
    vi config.lisp
    make
    make check

cd src
./makemake --with-readline --with-gettext > Makefile
make config.lisp

[ after this I add -DSAFETY=3 to the CFLAGS in Makefile ]
[ as was recommended on this list previously. I then run... ]
make

[ it gives me the result ]
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type
-fomit-frame-pointer -Wno-sign-compare -O2 -DUNICODE -DSAFETY=3 -c spvw.c
In file included from lispbibl.d:1751,
                 from spvw.d:22:
unix.d:874: conflicting types for `iconv'
/usr/include/iconv.h:45: previous declaration of `iconv'
In file included from spvw.d:22:
lispbibl.d:6933: warning: volatile register variables don't work as you
might wish
spvw.d: In function `main':
spvw.d:1709: warning: variable `argv_memneed' might be clobbered by
`longjmp' or `vfork'
make: *** [spvw.o] Error 1

Any ideas?  Need more info?  Please let me know,

	-ryan

---

From: ryan tolboom cis stnt <[email-masked]>
Date: Thu Feb 14 07:27:11 2002

OK, I figured it out.  I'll include a link to a web page I made about it
if your want to see more,

http://web.njit.edu/~rxt1077/clisp-maxima-zaurus.html

	-ryan

On Wed, 6 Feb 2002, ryan tolboom cis stnt wrote:

> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list
>