Subject: [clisp-list] package locking confusion

From: William Harold Newman <[email-masked]>
Date: Sat Feb 9 13:16:04 2002

I don't understand this error (in clisp checked out of CVS this
morning):

$ clisp -q
[1]> (compile nil
              '(LAMBDA (LIST)
                 (FLET
                   ((ENABLE (X) (PUSHNEW X LIST))
                    (DISABLE (X) (SETF LIST (REMOVE X LIST))))
                   (ENABLE :SB-AFTER-XC-CORE) LIST)))

** - Continuable Error
INTERN("NIL-ENABLE"): #<PACKAGE COMMON-LISP> is locked
If you continue (by typing 'continue'): Ignore the lock and proceed
1. Break [2]> 

-- 
William Harold Newman <[email-masked]>
"Look on my works, ye Mighty, and despair!" -- Ozymandias, King of Kings 
PGP key fingerprint 85 CE 1C BA 79 8D 51 8C  B9 25 FB EE E0 C3 E5 7C

---

From: Sam Steingold <[email-masked]>
Date: Mon Feb 11 07:50:16 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] package locking confusion"
> * Sent on Sat, 9 Feb 2002 15:02:40 -0600
> * Honorable William Harold Newman <[email-masked]> writes:
>

thanks for bug report - I just fixed it in the CVS.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Lottery is a tax on statistics ignorants.  MS is a tax on computer-idiots.