Subject: [clisp-list] more detail about bug report 451901

From: Dave MacDonald <[email-masked]>
Date: 17 Aug 2001 12:10:34 -0400

>
> I submitted this bug report (FAS-loader problem) and failed to submit
> the sample file due to some browser problem.  Anyway, the file is
> attached.

I observe identical behavior from CMUCL 18c and CLISP.
please try again.

BTW, clisp-devel is a member-only list.
please post to clisp-list or use the SF bug tracker _when logged on_

Thanks for your bug report.

*****

Sorry about incorrect use of the bug tracker and clisp-devel.

The following is a sequence of dribble output, first from debian
CMUCL, and next from CVS-as-of-2001-Aug-17-11AM CLISP.  I forgot to
mention what platform I'm working on:
        uname -a
        Linux debian 2.4.3 #2 Sun Apr 8 14:07:16 EDT 2001 i686 unknown

"structtest.lisp" source file:
+++++++
(defun required-argument ()
  (error "A required argument was not supplied"))

(eval-when (:compile-toplevel :load-toplevel :execute)
  (defstruct (struct (:constructor make-struct (slot)))
    (slot (required-argument) :type cons)))

(defmethod make-load-form ((obj struct) &optional env)
    (declare (ignore env))
    (make-load-form-saving-slots obj))

(defun handle-struct (struct)
  (format t "~A" (struct-slot struct)))

(defmacro test ()
  `(let ()
    (let ((var (make-struct (list 10))))
      `(progn
	(eval-when (:compile-toplevel :load-toplevel :execute)
	  (handle-struct ',var))))))

(defmacro moretest()
  (test))
+++++

"structtest1.lisp" contains the single form "(moretest)".

Here's the dribble output:

+++++ <CMUCL output>
* (lisp-implementation-version)

"release x86-linux 2.5.2 18c+  2 May 2001 build 2173"
* (compile-file "structtest.lisp")

Python version 1.0, VM version Intel x86 on 17 AUG 01 11:37:16 am.
Compiling: /home/dave/packages/sbcl-work1/structtest.lisp 16 AUG 01 09:25:43 pm

Converted REQUIRED-ARGUMENT.
Compiling DEFUN REQUIRED-ARGUMENT: 
Byte Compiling Top-Level Form: 
Converted MAKE-STRUCT.
Compiling DEFSTRUCT STRUCT: 
Converted |(PCL::FAST-METHOD MAKE-LOAD-FORM (STRUCT))|.
Compiling DEFMETHOD MAKE-LOAD-FORM (STRUCT): 
Converted HANDLE-STRUCT.
Compiling DEFUN HANDLE-STRUCT: 
Converted TEST.
Compiling DEFMACRO TEST: 
Converted MORETEST.
Compiling DEFMACRO MORETEST: 
Byte Compiling Top-Level Form: 

structtest.x86f written.
Compilation finished in 0:00:01.

#p"/home/dave/packages/sbcl-work1/structtest.x86f"
NIL
NIL
* (load "structtest")

; Loading #p"/home/dave/packages/sbcl-work1/structtest.x86f".
T
* (compile-file "structtest1.lisp")

Python version 1.0, VM version Intel x86 on 17 AUG 01 11:37:40 am.
Compiling: /home/dave/packages/sbcl-work1/structtest1.lisp 16 AUG 01 08:59:43 pm

(10)Byte Compiling Top-Level Form: 

structtest1.x86f written.
Compilation finished in 0:00:00.

#p"/home/dave/packages/sbcl-work1/structtest1.x86f"
NIL
NIL
* (load "structtest1")

; Loading #p"/home/dave/packages/sbcl-work1/structtest1.x86f".
(10)
T

+++++++++ <CVS CLISP output>
[2]> (lisp-implementation-version)
"2.27.1 (released 2001-07-17) (built 3207050781) (memory 3207051035)"
[3]> (compile-file "structtest.lisp")

Compiling file /home/dave/packages/sbcl-work1/structtest.lisp ...

Compilation of file /home/dave/packages/sbcl-work1/structtest.lisp is finished.
0 errors, 0 warnings
#P"/home/dave/packages/sbcl-work1/structtest.fas" ;
NIL ;
NIL
[4]> (load "structtest")
;; Loading file /home/dave/packages/sbcl-work1/structtest.fas ...
;; Loading of file /home/dave/packages/sbcl-work1/structtest.fas is finished.
T
[5]> (compile-file "structtest1.lisp")

Compiling file /home/dave/packages/sbcl-work1/structtest1.lisp ...(10)

Compilation of file /home/dave/packages/sbcl-work1/structtest1.lisp is finished.
0 errors, 0 warnings
#P"/home/dave/packages/sbcl-work1/structtest1.fas" ;
NIL ;
NIL
[6]> (load "structtest1")
;; Loading file /home/dave/packages/sbcl-work1/structtest1.fas ...
*** - A required argument was not supplied
1. Break [7]>

---

From: Sam Steingold <[email-masked]>
Date: 18 Aug 2001 14:22:03 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] more detail about bug report 451901"
> * Sent on 17 Aug 2001 12:10:34 -0400
> * Honorable Dave MacDonald <[email-masked]> writes:
>

I just fixed this bug.
thanks for reporting it.
please try again.

please submit further bug reports to the tracker _when logged on_ (this
way you will get notified by e-mail when the bug is fixed).

[the official policy is that the release users should report bug and ask
questions here, on <clisp-list>, while the users of the development CVS
tree should subscribe to <clisp-devel> and report bugs there]

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
We're too busy mopping the floor to turn off the faucet.