Subject: [clisp-list] Seeking place for CLISP documentation

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Mar 27 05:52:05 2002

Hi,

I'd be happy to know if there's some place where to put extra documentation, "howto" or whatever about CLISP. For some things I've written, impnotes is not the correct place.

Sometimes I thought about using parts of Cliki (ww.telent.net/cliki/), since I like "maintainerless" places (appropriate for CLISP FAQ?).

The Sourceforge documentation page seems empty for most projects I've visited there.
What about clisp.cons.org?

So where can I put up things? For example, I have written an article about extending CLISP via external modules, a tiny part of which describes how to use the regexp module with MS-Windoos (see another mail from today).

Thanks for locations pointers,
	Jörg Höhle

---

From: Reini Urban <[email-masked]>
Date: Wed Mar 27 06:15:02 2002

what about posting it here at first, to let people check its usefulness.

> So where can I put up things? For example, I have written an article about extending CLISP via external modules, a tiny part of which describes how to use the regexp module with MS-Windoos (see ano…

the Cliki is a good place for me.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 27 07:16:27 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Seeking place for CLISP documentation"
> * Sent on Wed, 27 Mar 2002 14:51:02 +0100
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>
> I'd be happy to know if there's some place where to put extra
> documentation, "howto" or whatever about CLISP. For some things I've
> written, impnotes is not the correct place.

Impnotes _is_ the correct place for all documentation about CLISP.
Using DocBook/XML will save you a lot of work.
Impnotes were originally a plain text file.
I re-wrote it in HTML in parallel with CLHS and then converted to
DocBook/XML.  This was a lot of effort, but I do not regret it.
It is easy to learn and you will not regret it.

DocBook/XML is _the_ way to go if you want to produce logically
structured interlinked documents.

You will be able to produce stand-alone documents as well as documents
linked into impnotes.

> Sometimes I thought about using parts of Cliki (ww.telent.net/cliki/),
> since I like "maintainerless" places (appropriate for CLISP FAQ?).

CLISP FAQ should be on CLISP pages, not Cliki.

> So where can I put up things?

If you listen to me and use DocBook/XML, you should put the DocBook/XML
files into CLISP/doc/ and the generated HTML to the CLISP pages on
clisp.cons.org and mirrors (for details, let's move the discussion to
<clisp-devel>).

> For example, I have written an article about extending CLISP via
> external modules, a tiny part of which describes how to use the regexp
> module with MS-Windoos (see another mail from today).

Fire up your emacs and write it in DocBook/XML.
Then get xerxes and look at CLISP/doc/Makefile for hints on how to
produce HTML from it.  You can also produce PDF and other formats.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Lottery is a tax on statistics ignorants.  MS is a tax on computer-idiots.