Subject: [clisp-list] MacOSX avcall-rs600-... troubles

From: Ben Hyde <[email-masked]>
Date: 8 Jun 2001 15:31:43 -0000

My MacOSX install has the developer tools and I added
bash, set CONFIG_SHELL as recomeneded, and bumped
up the stack size all as outlined in unix/PLATFORMS.

Late in the ./configure it dives down into
src/avcall and invokes make.  That doesn't
work out.  I've clipped out the offending portion.

It appears that the C compiler thought the assembler
code was C code?  The only pot shots I took were
to revise the make file in src/avcall to remove
the -O and use bash; since that is implied in
unix/PLATFORMS.

Any help gratefully accepted :-).   - ben

ps. Humm looks like the mailer is reformating the log.

creating ./config.status 
creating Makefile 
creating config.h 
case "darwin1.3.3" in \ 
  aix3*) syntax=aix.old;; \ 
  aix*) syntax=aix.new;; \ 
  linux*) syntax=linux;; \ 
  *) syntax=sysv4;; \ 
esac; \ 
/bin/sh ./libtool --mode=compile cc -O -traditional-cpp -x none -c
../../ffcall/avcall/avcall-rs6000-${syntax}.s ; \ 
cp avcall-rs6000-${syntax}.lo avcall-rs6000.lo ; rm -f
avcall-rs6000-${syntax}.lo ; \ 
if test -f avcall-rs6000-${syntax}.o; then mv avcall-rs6000-${syntax}.o
avcall-rs6000.o; fi 
cc -O -traditional-cpp -x none -c
../../ffcall/avcall/avcall-rs6000-sysv4.s -o avcall-rs6000-sysv4.o 
avcall-rs6000.c:3:Expected comma after segment-name 
avcall-rs6000.c:3:Rest of line ignored. 1st junk character valued 32 (
). 
avcall-rs6000.c:5:Unknown pseudo-op: .type 
avcall-rs6000.c:5:Rest of line ignored. 1st junk character valued 95
(_). 
avcall-rs6000.c:5:Invalid mnemonic 'function' 
avcall-rs6000.c:7:Unknown pseudo-op: .extern

---

From: Sam Steingold <[email-masked]>
Date: 08 Jun 2001 13:55:09 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] MacOSX avcall-rs600-... troubles"
> * Sent on 8 Jun 2001 15:31:43 -0000
> * Honorable Ben Hyde <[email-masked]> writes:
>

that's okay - FFI won't work, the rest will.
Can you make FFI work on OSX?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
(let((a'(list'let(list(list'a(list'quote a)))a)))`(let((a(quote ,a))),a))

---

From: Dave Lee <[email-masked]>
Date: Fri, 8 Jun 2001 12:47:10 -0600 (MDT)

Sam Steingold wrote:
> *snip snip* ...

I like your footers, and I see you use Gnus, but where did you get the
content for them?  Is it all yours?