Subject: [clisp-list] Building clips 2.30 on jaguar : problems

From: Hervé Blanchon <[email-masked]>
Date: Tue Apr 22 08:54:20 2003

Dear all,

I am trying to build clips 2.30 on my PowerBook G4 with Mac OS X 10.2.5

1)
I first got some error in the log while doing the configuration : 
problems with the "avcall-rs6000.c" file but it did not seemed to 
harmfull for the process.

2)
I was then prompted with  how to continue, however with a problem of 
stack size I was not able to solve.

# The default stack size on your platform is insufficient
# and must be increased to at least 8192.  You must do either
#    'ulimit -s 8192' (for Bourne shell derivarives, e.g., bash and 
zsh) or
#    'limit stacksize 8192' (for C shell derivarives, e.g., tcsh)

The commands were not understood by my bash shell.

3)
The "./makemake > Makefile" went fine.

4)
The "make config.lisp" went fine also

5)
I edited the config.lisp file to set up an editor and the site names

6)
The make went bad.

gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  
-fomit-frame-pointer -Wno-sign-compare -O2 --traditional-cpp -DUNICODE 
-DNO_GETTEXT -DNO_SIGSEGV -c spvw.c
lispbibl.d:1950: unbalanced #endif
lispbibl.d:6683: unterminated #else conditional
spvw_objsize.d:110: unterminated #else conditional
make: *** [spvw.o] Error 1

So I made it step by step.

make inti delivered the following message "test -d bindings || mkdir -p 
bindings"
make allc delivered the following message "test -d bindings || mkdir -p 
bindings"
make lisp.run delivered the following error message :

gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  
-fomit-frame-pointer -Wno-sign-compare -O2 --traditional-cpp -DUNICODE 
-DNO_GETTEXT -DNO_SIGSEGV -c spvw.c
lispbibl.d:1950: unbalanced #endif
lispbibl.d:6683: unterminated #else conditional
spvw_objsize.d:110: unterminated #else conditional
make: *** [spvw.o] Error 1

Thank you for any help.

Amitiés, Hervé.

---------------------
Herve BLANCHON               E.Mail : [email-masked]

GETA-CLIPS
IMAG-Campus, BP 53,
F-38041 Grenoble Cedex 9, FRANCE
Telephone :  +33  4 76 51 43 59
Fax       :  +33  4 76 44 66 75
---------------------

---

From: Sam Steingold <[email-masked]>
Date: Sat Apr 26 12:47:05 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Building clips 2.30 on jaguar : problems"
> * Sent on Tue, 22 Apr 2003 17:53:18 +0200
> * Honorable Hervé Blanchon <[email-masked]> writes:
>
> # 'ulimit -s 8192' (for Bourne shell derivarives, e.g., bash and zsh) or

are you sure it's bash?
what was the error message?

> make: *** [spvw.o] Error 1

what's gcc --version?
what if you omit --traditional-cpp?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
I don't want to be young again, I just don't want to get any older.