Subject: [clisp-list] Clisp 2.26 Clos consing?

From: Karsten <[email-masked]>
Date: Tue, 12 Jun 2001 23:28:08 +0200

I just tried my CLOS-application in the new release and it conses a lot
although I wouldn't cons at all in Clisp 2000-03-06.

I know that it is quite normal that clos starts consing but normally after 
a while (a methods called)
stops doing so

The problem is not only the consing, also the runtime doubled (even without gc)

Platform is Windows ME, both with distributed version and cygwin self 
compiled version

The following test exposes the problem:

(defclass root ()
(
(some-slot :initform nil :accessor root-some-slot)
)
)

(defmethod test-method ((me root))
(setf (root-some-slot me) 23))

(defclass medium (root)
(
(other-slot :initform nil :accessor medium-other-slot)
)
)

(defmethod test-method ((me medium))
(call-next-method)
(setf (medium-other-slot me) 42))

(defclass leaf (medium)
(
(last-slot :initform nil :accessor leaf-last-slot)
)
)

(defmethod test-method ((me leaf))
(call-next-method)
(setf (leaf-last-slot me) 15))

(defun test ()
(let ((was (make-instance 'leaf)))
(dotimes (x 100)
(test-method was))
(time (test-method was))
23))

---

From: Sam Steingold <[email-masked]>
Date: 16 Jun 2001 13:33:32 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Clisp 2.26 Clos consing?"
> * Sent on Tue, 12 Jun 2001 23:28:08 +0200
> * Honorable Karsten <[email-masked]> writes:
>

Yes, this was (unintentionally) caused by the 2000-06-11 patch (see
src/ChangeLog).  We hope to fix this.  Thanks for the bug report.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
The only thing worse than X Windows: (X Windows) - X

---

From: Sam Steingold <[email-masked]>
Date: 25 Jun 2001 11:24:40 -0400

> although I wouldn't cons at all in Clisp 2000-03-06.

Bruno just committed a fix for this to the CVS tree.
Either wait for the next release or get the latest version from CVS.
(caveat &c).

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
MS DOS: Keyboard not found. Press F1 to continue.