Subject: [clisp-list] does zebu still need to be patched to work with clisp?

From: Joe Corneli <[email-masked]>
Date: Mon Mar 29 13:25:05 2004

On the CLiki page for Zebu, it says you need to patch clisp to make
it work with clisp 2.30.  Should I assume that this is still the
case?

I have gotten zebu _running_ - but it doesn't seem to work.

[8]> (zb:zebu-compile-file "~/lisp-systems/zebu/zebu-3.5.5/test/simple.zb")

; Zebu Compiling (Version 3.5.5)
; #P"/Users/arided/lisp-systems/zebu/zebu-3.5.5/test/simple.zb" to #P"/Users/arided/lisp-systems/zebu/zebu-3.5.5/test/simple.tab"

Reading grammar from /Users/arided/lisp-systems/zebu/zebu-3.5.5/test/simple.zb

WARNING:
Compiling with :GRAMMAR "null-grammar".
To use the meta grammar use: :GRAMMAR "zebu-mg" in options list!
Start symbols is: E

*** - READ from 
#<INPUT BUFFERED FILE-STREAM CHARACTER
  #P"/Users/arided/lisp-systems/zebu/zebu-3.5.5/test/simple.zb" @35>: illegal character #\Sub

---

From: Joe Corneli <[email-masked]>
Date: Mon Mar 29 13:32:01 2004

Nevermind... I just realized what the problem was; each of the .zb
files is terminated by a ^Z character; CLISP doesn't care for that.