Subject: [clisp-list] Trouble running on cygwin, Windows 2000

From: "Young, David" <[email-masked]>
Date: Wed Jul 31 10:07:06 2002

Greetings. I've successfully built clisp 2.29 on Dell P-III, cygwin
1.13.12/windows 2000. However, after installing (make install), running
clisp results in an endless loop of "UNIX error 13" messages:

bash-2.05b$ clisp
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2002

;; Loading file /cygdrive/h/dyoung/.clisprc.lisp ...
;; Loading of file /cygdrive/h/dyoung/.clisprc.lisp is finished.
[1]>
*** - UNIX error 13 (EACCES): Permission denied
*** - UNIX error 13 (EACCES): Permission denied
...
[1]+  Stopped                 clisp

I'd appreciate suggestions.

Oh, and note that building clisp on my Vaio notebook (P-III mobile), Windows
2000, cygwin, results in an internal compiler error for gcc. But, I suppose
this is a gcc problem and should be reported to the proper authorities.

Cheers,
--
------------------------------------------
David E. Young
[email-masked]
http://www.bloodhoundinc.com

"Those who expect to reap the blessings of liberty
 must undergo the fatigues of supporting it."
  -- Thomas Paine

"But all the world understands my language."
  -- Franz Joseph Haydn (1732-1809)

---

From: Reini Urban <[email-masked]>
Date: Thu Aug 1 04:52:04 2002

> *** - UNIX error 13 (EACCES): Permission denied

Most symlinks in the binary cygwin tar
point to a not existing "c:\gnu\clisp\clisp-2.29" dir, which is wrong.
The symlinks must be relative, not absolute!

You can fix that manually, by providing a mount for 
c:\gnu\clisp\clisp-2.29 to your install dir.
something like:

$ mount -f -s -b "`cygpath -w $PWD`" "/cygdrive/c/clisp/clisp-2.29"

-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Sam Steingold <[email-masked]>
Date: Thu Aug 1 09:52:43 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Trouble running on cygwin, Windows 2000"
> * Sent on Wed, 31 Jul 2002 13:00:05 -0400
> * Honorable "Young, David" <[email-masked]> writes:
>

are you really getting this __after__ CLISP prints the prompt?!

> I'd appreciate suggestions.

I cannot reproduce this, alas, either with the current CVS head or with
2.29 release on w2k.

could you please debug this?
1. ./configure --with-debug --build build-g
2. cd build-g
3. gdb -nw
(gdb) break OS_error
(gdb) run
...
(gdb) where

and try to find out what is that illegal trick that CLISP is trying to
pull.

please also try CVS head.

thanks.

> Oh, and note that building clisp on my Vaio notebook (P-III mobile),
> Windows 2000, cygwin, results in an internal compiler error for
> gcc. But, I suppose this is a gcc problem and should be reported to
> the proper authorities.

please do report this.
CLISP appears to be a major source for GCC bug reports :-)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Between grand theft and a legal fee, there only stands a law degree.