Subject: AW: [clisp-list] arguments to a saved image? 3 suggestions.

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Tue Mar 18 02:27:22 2003

Hi,

I think Sam did a great job in his reply by addressing each of Pascal's issues one at a time.

What I notice
clisp --help says:
 -x expression - execute the expression, then exit
Obviously it should mention expressions (plural) instead
- RFE/Documentation bug

Furthermore, clisp.html would live from a few examples (like those from Sam in his reply). That IMHO provides for a good mix between reference (where one must read a lot), quick refreshing of memory and even raising curiosity of casual readers. Would you like to supply a patch, based on your experience? Other manpages also present examples (e.g. ps).

About '--'. I thought CLISP already supplied all options after -- in ext:*args*?!? Maybe I misunderstood something in past trafic of clisp-list?
E.g. lisp.run -M foo.mem -i myfile -i myfiletoo.lisp -- to-be-found-in-args
?

At least, I think that would be nice in interactive mode as well.
-- and consistent with file-load mode.

Regards,
	Jorg Hohle.

---

From: Pascal Bourguignon <[email-masked]>
Date: Tue Mar 18 03:05:12 2003

Hoehle, Joerg-Cyril writes:
> 
> About '--'. I thought CLISP already supplied all options after -- in
> ext:*args*?!? Maybe I misunderstood something in past trafic of
> clisp-list?  E.g. lisp.run -M foo.mem -i myfile -i myfiletoo.lisp --
> to-be-found-in-args ?

At least, my 2.30 gives an error when passed --:

[pascal@thalassa zebu-3.5.5]$ clisp -K full -M `pwd`/Zebu-Compiler.mem -- -h
GNU CLISP (http://clisp.cons.org/) is an ANSI Common Lisp.
Usage:  /local/languages/clisp/lib/clisp/full/lisp.run [options] [lispfile [argument ...]]
...

With an empty argument it works:

[pascal@thalassa zebu-3.5.5]$ clisp -K full -M `pwd`/Zebu-Compiler.mem "" -h
Usage:
    Zebu-Compile input output [-v] [-d] [-r file] [-h]

WARNING:
No input file specified!

-- 
__Pascal_Bourguignon__                   http://www.informatimago.com/
----------------------------------------------------------------------
Do not adjust your mind, there is a fault in reality.