Subject: [clisp-list] Problem building clisp regarding clisp.h

From: Dave Pearson <[email-masked]>
Date: Mon, 23 Apr 2001 17:34:56 +0100

I wonder of someone might be able to see where I'm going wrong when building
clisp from sources pulled from CVS.

Each time I pull the sources I go into the build directory that was created
when I did a configure on clisp (clisp/with-gcc-wall in this case) and issue
a "make clean" followed by a "make".

The build system always dies after a while with:

,----
| chmod a+x clisp-link
| test -d linkkit || mkdir linkkit
| cd linkkit && ln -s ../modules.d modules.d
| cd linkkit && ln -s ../modules.c modules.c
| cd linkkit && ln -s ../clisp.h clisp.h
| ln: clisp.h: File exists
| make: *** [linkkit] Error 1
`----

If I clean some of the content of with-gcc-wall/linkkit:

,----
| davep@hagbard:/usr/local/src/clisp/with-gcc-wall$ ls -lG linkkit/
| total 0
| lrwxrwxrwx    1 davep          10 Apr 20 13:13 clisp.h -> ../clisp.h
| lrwxrwxrwx    1 davep          12 Apr 23 17:22 modules.c -> ../modules.c
| lrwxrwxrwx    1 davep          12 Apr 23 17:22 modules.d -> ../modules.d
`----

and issue a "make" again, the build carries on.

Am I doing something wrong here? When I pull an update from CVS should I be
going back a level in the build process or something?

-- 
Dave Pearson
http://www.davep.org/

---

From: Reini Urban <[email-masked]>
Date: Mon, 23 Apr 2001 17:28:28 +0000

> | ln: clisp.h: File exists

this is impossible. you should have an empty linkkit dir.
if not delete linkkit/clisp.h.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Sam Steingold <[email-masked]>
Date: 23 Apr 2001 14:21:11 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Problem building clisp regarding clisp.h"
> * Sent on Mon, 23 Apr 2001 17:34:56 +0100
> * Honorable Dave Pearson <[email-masked]> writes:
>

I have known about this for quite a while, but assumed that it was "just
me" and did `rm -rf linkkit` here.

I will fix this.  You will have to remake your Makefile using makemake
(see `head -20 Makefile`) after remaking makemake using makemake.in (see
configure). 

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
He who laughs last thinks slowest.