Subject: [clisp-list] (make-pathname :directory (:absolute :wild))

From: Pascal Bourguignon <[email-masked]>
Date: Thu Jun 12 10:18:02 2003

I cannot find anything in CLHS that prevents:

    (make-pathname :directory '(:absolute :wild))

(or any of its variants:
    
    (make-pathname :directory '(:relative :wild))
    (make-pathname :directory '(:absolute "a" :wild "b"))
    (make-pathname :directory '(:relative "a" :wild "b"))
)

but clisp does not accept it:

[pascal@thalassa pascal]$ clisp -q -norc

[1]> (make-pathname :directory '(:absolute :wild))

*** - MAKE-PATHNAME: illegal :DIRECTORY argument (:ABSOLUTE :WILD)
1. Break [2]> 
[3]> (make-pathname :directory '(:relative :wild))

*** - MAKE-PATHNAME: illegal :DIRECTORY argument (:RELATIVE :WILD)
1. Break [4]> 
[5]> (make-pathname :directory '(:absolute "a" :wild "b"))

*** - MAKE-PATHNAME: illegal :DIRECTORY argument (:ABSOLUTE "a" :WILD "b")
1. Break [6]> 
[7]> (make-pathname :directory '(:relative "a" :wild "b"))

*** - MAKE-PATHNAME: illegal :DIRECTORY argument (:RELATIVE "a" :WILD "b")
1. Break [8]> 
[9]> (lisp-implementation-version)
"2.30 (released 2002-09-15) (built on thalassa.informatimago.com [213.220.35.225])"

Note that PATHNAME does not have that same reticence:

[14]> (pathname "/*/")
#P"/*/"
[15]> (pathname "/a/*/b/")
#P"/a/*/b/"
[16]> (pathname "a/*/b/")
#P"a/*/b/"
[17]> (pathname "*/")
#P"*/"
[18]> 

MAKE-PATHNAME takes a "valid pathname directory":

    valid pathname directory n. a string, a list of strings, nil,
    :wild, :unspecific, or some other object defined by the
    implementation to be a valid directory component.

-- 
__Pascal_Bourguignon__                   http://www.informatimago.com/
----------------------------------------------------------------------
Do not adjust your mind, there is a fault in reality.

---

From: Sam Steingold <[email-masked]>
Date: Thu Jun 12 15:23:08 2003

> * In message <[email-masked]>
> * On the subject of "(make-pathname :directory (:absolute :wild))"
> * Sent on Thu, 12 Jun 2003 19:15:13 +0200 (CEST)
> * Honorable Pascal Bourguignon <[email-masked]> writes:
>

should be fixed in the CVS.
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
If you try to fail, and succeed, which have you done?