Subject: [clisp-list] building stumpwm with clisp

From: Joe Corneli <[email-masked]>
Date: Sat Mar 27 21:12:01 2004

Following SDS's instructions, I seem to have gotten new-clx to work
"out of the box" under CLISP.  It doesn't show up in the package
list (there are no errors when loading this stuff up)...

> (list-all-packages)
(#<PACKAGE GSTREAM> #<PACKAGE GRAY> #<PACKAGE I18N> #<PACKAGE SOCKET> #<PACKAGE FFI>
 #<PACKAGE SCREEN> #<PACKAGE CUSTOM> #<PACKAGE EXT> #<PACKAGE CLOS>
 #<PACKAGE CHARSET> #<PACKAGE KEYWORD> #<PACKAGE SYSTEM> #<PACKAGE COMMON-LISP-USER>
 #<PACKAGE COMMON-LISP> #<PACKAGE XLIB> #<PACKAGE XPM> #<PACKAGE MAKE>
 #<PACKAGE PORT> #<PACKAGE ASDF>)

But I can play Sokoban if I run

> (load "~/clisp/src/clx/new-clx/demos/clx-demos.lisp")
> (clx-demos:sokoban)

However, when I try to run `(asdf:operate 'asdf:load-op 'stumpwm)',
I find trouble.

> (asdf:operate 'asdf:load-op 'stumpwm)
; loading system definition from /Users/arided/lisp-systems/stumpwm.asd into #<PACKAGE
;   ASDF3328>
;; Loading file /Users/arided/lisp-systems/stumpwm.asd ...
;; Loaded file /Users/arided/lisp-systems/stumpwm.asd
*** - Condition of type ASDF:MISSING-DEPENDENCY.

If I comment out the line

  :depends-on (:clx :port)

from stumpwm.asd, then I get a little further along.  (Could it be a
problem with new-clx as opposed to mit-clx?)

> (asdf:operate 'asdf:load-op 'stumpwm)
; loading system definition from /Users/arided/lisp-systems/stumpwm.asd into #<PACKAGE
;   ASDF2380>
;; Loading file /Users/arided/lisp-systems/stumpwm.asd ...
; registering #<SYSTEM :STUMPWM #x19EF0779> as STUMPWM
;; Loaded file /Users/arided/lisp-systems/stumpwm.asd
;; Loading file /Users/arided/lisp-systems/stumpwm/package.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/package.fas
;; Loading file /Users/arided/lisp-systems/stumpwm/primitives.fas ...
** - Continuable Error
FUNCALL: undefined function XLIB:CHARACTER->KEYSYMS
If you continue (by typing 'continue'): Retry
The following restarts are also available:
STORE-VALUE    :R1      You may input a new value for (FDEFINITION 'XLIB:CHARACTER->KEYSYMS).
USE-VALUE      :R2      You may input a value to be used instead of (FDEFINITION 'XLIB:CHARACTER->KEYSYMS).
RETRY          :R3      
Retry performing #<ASDF:LOAD-OP NIL #x19EEFDB1> on #<ASDF:CL-SOURCE-FILE
  "primitives" #x19EED195>.
ACCEPT         :R4      
Continue, treating #<ASDF:LOAD-OP NIL #x19EEFDB1> on #<ASDF:CL-SOURCE-FILE
  "primitives" #x19EED195> as having been successful.

---

From: Sam Steingold <[email-masked]>
Date: Sat Mar 27 21:49:02 2004

> * Joe Corneli <[email-masked]> [2004-03-27 23:11:51 -0600]:
>
> It doesn't show up in the package list

no, here it is:

> #<PACKAGE XLIB>

> problem with new-clx as opposed to mit-clx?)

it appears to expect you to load CLOCC/PORT and CLOCC/CLX.

> FUNCALL: undefined function XLIB:CHARACTER->KEYSYMS

new-clx is incomplete.
try mit-clx instead - ot CLOCC/CLX which is more or less the same.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Someone has changed your life.  Save? (y/n)

---

From: Joe Corneli <[email-masked]>
Date: Sun Mar 28 08:56:04 2004

Is there a good way to "make clean"?  Having built CLISP, once,
trying to configure it again I get

% ./configure --with-module=clx/mit-clx
../src/lndir: destination already exists: /Users/arided/clisp/src/berkeley-db

---

From: Sam Steingold <[email-masked]>
Date: Sun Mar 28 09:12:02 2004

> * Joe Corneli <[email-masked]> [2004-03-28 10:55:17 -0600]:
>
> Is there a good way to "make clean"?

"make distclean"

I always build in a separate directory "build-...", e.g.

$ ./configure --with-debug --build build-g

or

$ ./configure --with-module=clx/new-clx --build build-nclx

or

$ ./configure --with-module=clx/mit-clx --build build-mitx

so that "clean" just means

$ rm -rf build-*

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Takeoffs are optional.  Landings are mandatory.

---

From: Shawn Betts <[email-masked]>
Date: Sun Mar 28 21:56:02 2004

> FUNCALL: undefined function XLIB:CHARACTER->KEYSYMS

Well that sucks. I don't really know much about all the keysym
functions in clx, so I've just been digging around in the source. I'll
get some existing clx apps and see what they do for key input (always
been a bit of a mystery).

Thanks for the heads up. As for fixing that...well..it might be a bit
involved :). But you could quick fix it by replacing all the calls to
that fn with the keysym for whatever character I'm trying to get at.

-Shawn

---

From: Joe Corneli <[email-masked]>
Date: Sun Mar 28 22:27:04 2004

Achtung! They don't all seem to do the right thing all the time.
For example, Sokoban (running under new-clx) doesn't recognize
Mode_switch+<char>, as in

  keycode 10 = e E Down

for example.

BTW, I tried to load up stump when running mit-clx and got the same
"*** - Condition of type ASDF:MISSING-DEPENDENCY."  But upon
commenting out the ":depends-on (:clx :port)", I got the following
-- I.e. stump actually seems to load.  But I'm still not quite sure
how to actually run it...

[4]> (asdf:operate 'asdf:load-op 'stumpwm)
; loading system definition from /Users/arided/lisp-systems/stumpwm.asd into #<PACKAGE
;   ASDF2625>
;; Loading file /Users/arided/lisp-systems/stumpwm.asd ...
;; Loaded file /Users/arided/lisp-systems/stumpwm.asd
;; Loading file /Users/arided/lisp-systems/stumpwm/package.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/package.fas
;; Loading file /Users/arided/lisp-systems/stumpwm/primitives.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/primitives.fas
Compiling file /Users/arided/lisp-systems/stumpwm/input.lisp ...
WARNING in READ-ONE-LINE-KEY-LOOP in lines 76..95 :
Duplicate CASE label QUOTE : 
(CASE RET ('DONE (RETURN (VALUES INPUT 'DONE)))
 ('ABORT (RETURN (VALUES INPUT 'ABORT))))
WARNING in PROCESS-INPUT in lines 122..155 :
Duplicate CASE label QUOTE : 
(CASE RET ('DONE (VALUES INP 'DONE)) ('ABORT (VALUES INP 'ABORT))
 (T (DRAW-INPUT-BUCKET SCREEN PROMPT INP) (VALUES INP T)))
WARNING in UPDATE-MODIFIER-MAP in lines 157..180 :
NULL was called with 2 arguments, but it requires 1 argument.
WARNING in UPDATE-MODIFIER-MAP in lines 157..180 :
MODIFIERS-META is neither declared nor bound,
it will be treated as if it were declared SPECIAL.
WARNING in COOK-KEYCODE in lines 207..208 :
X11MOD->STUMPMOD was called with 1 arguments, but it requires 2 arguments.
[X11MOD->STUMPMOD was defined in lines 182..194]

Wrote file /Users/arided/lisp-systems/stumpwm/input.fas
WARNING:
COMPILE-FILE warned while performing #<COMPILE-OP NIL #x19F5C189> on #<CL-SOURCE-FILE
  "input" #x19F5A9A5>.
WARNING:
COMPILE-FILE failed while performing #<COMPILE-OP NIL #x19F5C0ED> on #<CL-SOURCE-FILE
  "input" #x19F5A939>.
;; Loading file /Users/arided/lisp-systems/stumpwm/input.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/input.fas
Compiling file /Users/arided/lisp-systems/stumpwm/core.lisp ...
WARNING in G4156 in lines 588..595 :
variable WINDOW is not used.
Misspelled or missing IGNORE declaration?

Wrote file /Users/arided/lisp-systems/stumpwm/core.fas
WARNING:
COMPILE-FILE warned while performing #<COMPILE-OP NIL #x19F5C0BD> on #<CL-SOURCE-FILE
  "core" #x19F5A9A5>.
WARNING:
COMPILE-FILE failed while performing #<COMPILE-OP NIL #x19F5C0BD> on #<CL-SOURCE-FILE
  "core" #x19F5A9A5>.
;; Loading file /Users/arided/lisp-systems/stumpwm/core.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/core.fas
Compiling file /Users/arided/lisp-systems/stumpwm/user.lisp ...
WARNING in SET-DEFAULT-BINDINGS-1 in lines 33..54 :
variable S is not used.
Misspelled or missing IGNORE declaration?

Wrote file /Users/arided/lisp-systems/stumpwm/user.fas
WARNING:
COMPILE-FILE warned while performing #<COMPILE-OP NIL #x19F5C0BD> on #<CL-SOURCE-FILE
  "user" #x19F5AA41>.
WARNING:
COMPILE-FILE failed while performing #<COMPILE-OP NIL #x19F5C0BD> on #<CL-SOURCE-FILE
  "user" #x19F5AA41>.
Compiling file /Users/arided/lisp-systems/stumpwm/stumpwm.lisp ...

Wrote file /Users/arided/lisp-systems/stumpwm/stumpwm.fas
WARNING:
COMPILE-FILE warned while performing #<COMPILE-OP NIL #x19F5C08D> on #<CL-SOURCE-FILE
  "stumpwm" #x19F5AAAD>.
WARNING:
COMPILE-FILE failed while performing #<COMPILE-OP NIL #x19F5C08D> on #<CL-SOURCE-FILE
  "stumpwm" #x19F5AAAD>.
;; Loading file /Users/arided/lisp-systems/stumpwm/user.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/user.fas
;; Loading file /Users/arided/lisp-systems/stumpwm/stumpwm.fas ...
;; Loaded file /Users/arided/lisp-systems/stumpwm/stumpwm.fas
The following functions were used but not defined:
 :MOD1 STUMPWM::KEYSYM->CHARACTER
The following special variables were not defined:
 STUMPWM::MODIFIERS-META
0 errors, 7 warnings
NIL
[5]>