Subject: [clisp-list] CLISP and ILISP

From: Lennart Staflin <[email-masked]>
Date: Sun Feb 3 08:01:17 2002

I have started to use the ILISP mode for Emacs and found a problem. I 
don't know how ILISP communicates with the Lisp process, it don't seem 
to be PTYs. The *terminal-io* stream exhibits the following behaviour

[2]> (finish-output t)
*** - UNIX error 45 (EOPNOTSUPP): Operation not supported on socket

//Lennart

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 3 08:28:16 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CLISP and ILISP"
> * Sent on Sun, 3 Feb 2002 16:59:21 +0100
> * Honorable Lennart Staflin <[email-masked]> writes:
>

what is the value of *terminal-io*?
why do you need to call FINISH-OUTPUT on it?
please report this to the ILISP people.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Your mouse has moved - WinNT has to be restarted for this to take effect.

---

From: Lennart Staflin <[email-masked]>
Date: Sun Feb 3 13:36:02 2002

> what is the value of *terminal-io*?

#<IO TERMINAL-STREAM>

> why do you need to call FINISH-OUTPUT on it?

It is part of a logging routine that could send its output to some other 
stream, but usually it goes to *terminal-io*.

> please report this to the ILISP people.

Hmm. Do you mean that finish-output could reasonably fail for some type 
of stream.

//Lennart

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 3 16:57:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] CLISP and ILISP"
> * Sent on Sun, 3 Feb 2002 22:34:15 +0100

please report all the details.
1. OS name and version
2. CLISP version
3. ILISP version
4. Emacs version

try to isolate the problem:
does the error manifests itself only under ILISP?
what about the standard inferior lisp mode?
what about xterm?
what is the backtrace?

ideally, for me to fix the bug, I need to be able to reproduce it with
some minimal setup (i.e., "clisp -norc -i foo.lisp" and get an error
where foo.lisp is <10 lines)

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Who is General Failure and why is he reading my hard disk?

---

From: Lennart Staflin <[email-masked]>
Date: Sat Feb 9 05:31:04 2002

> please report all the details.

Darwin localhost 5.2 Darwin Kernel Version 5.2: Fri Dec  7 21:39:35 PST 
2001; root:xnu/xnu-201.14.obj~1/RELEASE_PPC  Power Macintosh powerpc

> 2. CLISP version

GNU CLISP 2.27.2 (released 2001-10-05) (built 3221719001) (memory 
3222242925)

 From the binary release on cons.org.

> 4. Emacs version

Let's forget about ILISP and Emacs, here is a short test case:

  clisp -norc -q -x "(finish-output t)" | cat

//Lennart