Subject: [clisp-list] Re: clisp command history

From: Elvin Peterson <[email-masked]>
Date: Mon Jul 12 18:11:17 2004

--- Sam Steingold <[email-masked]> wrote:
> > * Elvin Peterson <[email-masked]>
> [2004-07-11 09:42:12 -0700]:
> >
> > Adding the history calls looks like a
> straightforward job, but I can't
> > figure out the file it is defined in
> and appropriate calls to read_history() to
> stream.d:init_streamvars()

14441c14441,14442
<   # rl_readline_name = "CLisp";
---
>   rl_readline_name = "CLisp";
>   read_history(NULL);

> and to write_history() to spvw.d:quit().

25a26,30
> #ifdef GNU_READLINE
>   #include <readline/readline.h>
>   #include <readline/history.h>
> #endif
>
3090a3096,3098
>  #ifdef GNU_READLINE
>   write_history(NULL);
>  #endif

__________________________________
Do you Yahoo!?
Yahoo! Mail - You care about security. So do we.
http://promotions.yahoo.com/new_mail

---

From: Sam Steingold <[email-masked]>
Date: Tue Jul 13 05:34:04 2004

> * Elvin Peterson <[email-masked]> [2004-07-12 18:10:48 -0700]:
>

1. all diffs should be "-u" (unified context)

2. the above does not allow the user to disable history saving and to
   specify the file where the history is to be saved.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Don't ascribe to malice what can be adequately explained by stupidity.