Subject: [clisp-list] Random function

From: "Justice, Randy -CONT" <[email-masked]>
Date: Tue, 14 Nov 2000 12:51:25 -0600

Hi.
   I am using the random function.  Very strangely, it looks like the same
sets of numbers keep appearing. 

   In other languages, I have seen the same results. Other languages has a
function 
   to "seed" the random function.  

   Does CLISP have a function to "seed" random function?

   Thank You

   Randy

---

From: Sam Steingold <[email-masked]>
Date: 14 Nov 2000 16:16:39 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Random function"
> * Sent on Tue, 14 Nov 2000 12:51:25 -0600
> * Honorable "Justice, Randy -CONT" <[email-masked]> writes:
>
>    I am using the random function.  Very strangely, it looks like the
> same sets of numbers keep appearing.
> 
>    In other languages, I have seen the same results. Other languages
> has a function to "seed" the random function.
> 

Please see 
http://www.lisp.org/HyperSpec/Body/fun_random.html
http://www.lisp.org/HyperSpec/Body/fun_make-random-state.html

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
The only guy who got all his work done by Friday was Robinson Crusoe.