Subject: [clisp-list] Q: problem with run-program in Win32

From: [email-masked]
Date: Wed Feb 20 11:51:20 2002

Thanks - that is helpful for the built-in shell commands, but I also need to
run some compiled C code, and for that I get the same file_not_found error,
even though I am starting LISP from the same directory as where the compiled
C code is located, and the C code does run fine on its own outside of CLISP:

[6]>(run-program "lispcri.exe")

[%s:10790]
*** - Win32 error 2 (ERROR_FILE_NOT_FOUND): The system cannot find the file
specified.

Thanks again,

Tara

*  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  
Tara C. Matise, Ph.D.           Associate Research Professor       
Department of Genetics       732-445-3125 (P)
Rutgers University              732-445-4972 (F)
              [email-masked]
              http://compgen.rutgers.edu

Nelson Biological Laboratories - B211
604 Allison Road
Piscataway, NJ  08854-8082

---

From: Sam Steingold <[email-masked]>
Date: Wed Feb 20 12:37:48 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Q: problem with run-program in Win32"
> * Sent on Wed, 20 Feb 2002 14:49:17 -0500
> * Honorable [email-masked] writes:
>

WFM on Linux.  please be more adventurous. :-)
try supplying full path (remember to use the right slashes).
try SHELL, RUN-SHELL-COMMAND, EXECUTE ...

any other woe32 users here who can help Tara?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
There is Truth, and its value is T.  Or just non-NIL.  So 0 is True!