Subject: [clisp-list] Failure building clisp in Red Hat Linux 7

From: José Romildo Malaquias <[email-masked]>
Date: Mon, 16 Oct 2000 09:23:31 -0200

Hello.

While trying to build the latest CLISP version
on a Red Hat Linux 7 box I have got the
following messages:

=================================
[...]
Test failed.
To see which tests failed, type
    cat *.erg
make[1]: *** [compare] Error 1
make[1]: Leaving directory `/home/romildo/rpms/BUILD/clisp-2000-03-06/build/suit
e'
make: *** [testsuite] Error 2
=================================

"cat build/suit/*.erg" gives me

Form: (STREAM-ELEMENT-TYPE *TERMINAL-IO*)
CORRECT: CHARACTER
CLISP: (OR CHARACTER INTEGER)

Any hints?

Romildo
-- 
Prof. José Romildo Malaquias <[email-masked]>
Departamento de Computação
Universidade Federal de Ouro Preto
Brasil

---

From: Sam Steingold <[email-masked]>
Date: 16 Oct 2000 10:57:45 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Failure building clisp in Red Hat Linux 7"
> * Sent on Mon, 16 Oct 2000 09:23:31 -0200
> * Honorable José Romildo Malaquias <[email-masked]> writes:
>

this has been fixed in the latest development sources.
thanks for reporting the bug.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
I don't want to be young again, I just don't want to get any older.

---

From: José Romildo Malaquias <[email-masked]>
Date: Tue, 17 Oct 2000 07:41:13 -0200

> thanks for reporting the bug.

Does latest development sources mean CVS repository?

I am not a CLISP experienced user. So, tell me, is
the latest development sources "stable enough" for
use, or should I wait for the next release (which
time I do not have any idea)?

If it is not usable, is (or would be) there a patch
that fixes the mentioned problem in the latest
released version?

PS: I am needing CLISP to run Common Music.

Thanks.

Romildo

---

From: Sam Steingold <[email-masked]>
Date: 17 Oct 2000 11:02:17 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Failure building clisp in Red Hat Linux 7"
> * Sent on Tue, 17 Oct 2000 07:41:13 -0200

yes.

> time I do not have any idea)?

it's stable enough for me on Solaris.
I can give no assurances for other platforms, but I do not expect any
problems there either.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Don't use force -- get a bigger hammer.

---

From: Bruno Haible <[email-masked]>
Date: Sat, 21 Oct 2000 22:20:35 +0200 (CEST)

> So, tell me, is the latest development sources "stable enough" for
> use, or should I wait for the next release

The current clisp CVS should be approximately as good as the last release.

> PS: I am needing CLISP to run Common Music.

For that purpose, you can ignore the testsuite failure and use the
released version nevertheless.

    Bruno