Subject: [clisp-list] load error

From: [email-masked]
Date: Mon Dec 2 15:02:02 2002

I am not sure if this is a known bug or its been fixed in the current cvs,
but:
On MS Windows 2000, loading garnet with Clisp version 2.30,i
I and another user get the following error:

*** - STRING=: argument #P".lisp" should be a string, a symbol or a character
This problem is coming from load, from the following form.

               ;; File with precisely this name not present.
               ;; Search among the files the most recent one
               ;; with the same name and the Extensions "LISP", "FAS"
               (let ((present-files
                      (search-file filename
(progn (print extra-file-types) (print *compiled-file-types*)
(print *source-file-types*)
                                   (append extra-file-types
                                           *compiled-file-types*
                                           *source-file-types*))))))

Where *source-file-types* has the value (#P".lisp" "lisp" "lsp" "cl").
This is around line 1270 in init.lisp.
Does this problem jog anyones memory, and if so, was there a patch?
Thanks,
Dan Stanger

---

From: Sam Steingold <[email-masked]>
Date: Mon Dec 2 16:28:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] load error"
> * Sent on Mon, 2 Dec 2002 16:03:31 -0700 (MST)
> * Honorable [email-masked] writes:
>

search your sources for a form that modifies *SOURCE-FILE-TYPES* and
fix it.
See <http://clisp.cons.org/impnotes/system.html#loadfile>.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Why use Windows, when there are Doors?

---

From: Sam Steingold <[email-masked]>
Date: Mon Dec 2 18:32:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] load error"
> * Sent on Mon, 02 Dec 2002 19:20:45 -0700
> * Honorable Dan Stanger <[email-masked]> writes:
>
> Shouldn't it be possible to push a pathname on to source-file-types?

file type is a string, not a pathname.

> Also this behaviour changed from 2.28 where it worked to 2.30 where it doesn't.

indeed, see the NEWS file.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Winners never quit; quitters never win; idiots neither win nor quit.