Subject: [clisp-list] clisp not installing on XP

From: William Brown <[email-masked]>
Date: Tue Feb 24 11:17:03 2004

Mr. Steingold,

I have downloaded Clist 2.32 win 32 onto my HP Pavilion N5425 laptop using Windows XP.  However, the program will not install by clicking on the install.bat file nor by using Run on the Start menu.

I read your readme notes on Installation:  but cannot understand what you are asking.  Change what strings in src/config.lisp?  Change them to what?  There is only one lisp.exe file and it has a long name lisp.exe-0F44C2DE.pf.  It will not start when clicked nor using RUN on the Start menu.  Also the lisp.exe file resides in c:\windows\prefetch.

Is there something I am missing?  Is it an XP problem?  Is there a fix?

William C. Brown, Ph.D.
[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: Tue Feb 24 12:15:10 2004

> * William Brown <[email-masked]> [2004-02-24 11:07:39 -0800]:
>
> I have downloaded Clist 2.32 win 32 onto my HP Pavilion N5425 laptop
> using Windows XP.  However, the program will not install by clicking
> on the install.bat file nor by using Run on the Start menu.

please try
<http://cvs.sourceforge.net/viewcvs.py/*checkout*/clisp/clisp/src/install.bat>
instead.

> Change what strings in src/config.lisp?

*editor*, *load-paths*, *clhs-root-default* and others as you see fit.

> Change them to what?

to whatever better reflects your environment.

> There is only one lisp.exe file and it has a long name
> lisp.exe-0F44C2DE.pf.  It will not start when clicked nor using RUN on
> the Start menu.  Also the lisp.exe file resides in
> c:\windows\prefetch.

you should have downloaded a zip file and un-zipped it into a
directory, something like "c:\gnu\clisp-2.32\".
if winzip or windows, in a miguided attempt to protect you from viruses,
do not let you do that, you will need to download info-zip. (google for it)

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
There are two ways to write error-free programs; only the third one works.