Subject: [clisp-list] Build fix for alpha

From: Will Newton <[email-masked]>
Date: Wed Mar 20 07:31:11 2002

This patch should fix the build on certain alphas. I don't have one to test, 
but it looks correct.

--- clisp-2.28/src/autoconf/aclocal.m4.old      Wed Mar 20 15:28:40 2002
+++ clisp-2.28/src/autoconf/aclocal.m4  Wed Mar 20 15:29:07 2002
@@ -748,7 +748,7 @@
   i[4567]86 )
     host_cpu=i386
     ;;
-  alphaev[4-7] | alphaev56 | alphapca5[67] )
+  alphaev[4-8] | alphaev56 | alphapca5[67] | alphaev6[78] )
     host_cpu=alpha
     ;;
   hppa1.0 | hppa1.1 | hppa2.0 )

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 21 07:30:14 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Build fix for alpha"
> * Sent on Wed, 20 Mar 2002 15:32:04 +0000
> * Honorable Will Newton <[email-masked]> writes:
>
> This patch should fix the build on certain alphas.
is it broken?

> I don't have one to test, but it looks correct.
> 

why not just have

    alpha*)
      host_cpu=alpha
    ;;

??

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Parachute for sale, used once, never opened, small stain.

---

From: Will Newton <[email-masked]>
Date: Thu Mar 21 08:08:12 2002

> > This patch should fix the build on certain alphas.

On certain alphas, yes.

>       host_cpu=alpha

Yes, that works too. Keeping it explicit means if e.g. alpha128 is released 
in 2 years time it will not be caught by that condition. A matter of taste.