Subject: Re: [clisp-list] Re: clisp 2.32 with clx

From: [email-masked]
Date: Tue Mar 9 23:19:05 2004

In einer eMail vom 06.03.04 16:29:55 (MEZ) Mitteleuropäische Zeit schreibt 
[email-masked]:

<< this appears to be a bug.  we need to investigate it.
 please try the above commands, start with ":bt >>
Hello, 
[]> ....clisp-2.32/full/lisp.run -M ....clisp-2.32/full/lispinit.mem
[]> (cd "....clocc/src/gui/clx/demo")
[]> (load "qix.lisp")
[]> (in-package :xlib)
[]>(qix :host "k")  =>OK
[]>(user::load "hello.lisp")
[]>(hello-world "k")  => class #<BUILT-IN-CLASS T> has no slot named FONT-INFO
BREAK> :tb
BREAK> :b      => (TEXT-WIDTH FONT STRING)
after removing the line with this form and restarting:
(hello-world "k")      => the same error
BREAK> :bt
BREAK> :b           => (DRAW-GLYPHS WINDOW GCONTEXT X Y STRING)

K

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 10 06:51:03 2004

> *  <[email-masked]> [2004-03-10 02:01:06 -0500]:
>

either this is not CLISP or you have edited both prompts and output.
please copy and paste everything.
if you are using interpreted code (which appears to be the case), you
can evaluate the arguments to DRAW-GLYPHS (window &c).
please do it.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
non-smoking section in a restaurant == non-peeing section in a swimming pool