Subject: [clisp-list] making ANSI-image

From: Stig E Sandoe <[email-masked]>
Date: Sat, 7 Jul 2001 17:18:35 +0200

hi,

I'm trying to make a clisp-image that is in ANSI-mode initially,
but I have some problems:  [Using current cvs]

stig@palomba(17:39)[~] 565> clisp -norc -q -ansi

[1]> custom::*ansi*
T
[2]> (ext:saveinitmem "test.mem" :quiet t)
904596 ;
524288
[3]> 

stig@palomba(17:39)[~] 566> clisp -norc -M test.mem

[1]> custom::*ansi*
NIL
[2]> custom:*print-pathnames-ansi*
NIL
[3]> 

This contradicts the docs which says:
"""
Please note that if you run CLISP with the -a switch or set 
the SYMBOL-MACRO custom:*ansi* to T and save image, then all 
subsequent invocations of CLISP with this image will be as 
if with -a (regardless whether you actually supply the -a switch)
"""

[Noting that -a tells me to use -ansi]

Any ideas?

-- 
------------------------------------------------------------------
Stig Erik Sandoe     [email-masked]    http://www.ii.uib.no/~stig/

---

From: Peter Wood <[email-masked]>
Date: Sun, 8 Jul 2001 07:12:58 +0200

> but I have some problems:  [Using current cvs]
                              ^^^^^^^^^^^^^^^^

The same problem seems to exist in 2.26.  I setf custom:*ansi* to t
and dumped an image, but custom:*ansi* is NIL in that image.

Peter

---

From: Sam Steingold <[email-masked]>
Date: 09 Jul 2001 11:06:33 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] making ANSI-image"
> * Sent on Sun, 8 Jul 2001 07:12:58 +0200
> * Honorable Peter Wood <[email-masked]> writes:
>

confirmed - I broke this on 2001-05-01.  sorry.  thanks for reporting.
fix in progress - please monitor clisp-devel.

PS: bugs in the CVS versions should be reported to clisp-devel, not clisp-list.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Apathy Club meeting this Friday.  If you want to come, you're not invited.