Subject: [clisp-list] module problem

From: Roland Averkamp <[email-masked]>
Date: Sat, 31 Mar 2001 13:22:16 +0200

Hi,
I have a problem with modules.
I created a simple module with a c-file with just one function.
creating the the new moduleset via 
clisp-link create-module-set ....

and

adding the module-set via 
clisp-link add-module-set ....

works fine

calling the new moduleset via

clisp -K /home/averkamp/full+test
and then evaluating expressions works too,

BUT:
clisp exits if an error occurs:

[3]> (list 1 2 3 4)
(1 2 3 4)
[4]> 332432
332432
[5]> (car 1)
Bye.

what is wrong?

Is there some switch somewhere which has to be set? (the standard clisp
works without problems)

I had the same problem with the mit-clx module.

I use suse linux 6.2, the clisp is the march-2001 version. It was built
on my computer.

Roland Averkamp

---

From: Peter Wood <[email-masked]>
Date: 31 Mar 2001 20:25:59 +0200

> clisp exits if an error occurs:

Try putting this in your .clisprc:

(if (eq sys::*break-driver* #'sys::batchmode-break-driver)
(setf sys::*break-driver* #'sys::break-loop))

And see if it helps.  The break-driver in "full" is set incorrectly.

Regards,
Peter

---

From: Peter Wood <[email-masked]>
Date: 31 Mar 2001 20:45:30 +0200

> And see if it helps.  The break-driver in "full" is set incorrectly.

Or, if you prefer, run "clisp -K full" and set the break-driver:

(setf sys::*break-driver* #'sys::break-loop)

Then save the image: (saveinitmem "lispinit.mem") and replace the
memory image in /usr/lib/clisp/full with the new one.  Then you won't
need the line in your .clisprc. Which might mess things up if you run
clisp in batchmode, I suppose :( Does CLISP read the initfile when it
runs in batchmode?)

Peter