Subject: [clisp-list] Failure to build Clisp 2.28 on FreeBSD/Alpha

From: Jeffrey Katcher <[email-masked]>
Date: Thu May 9 11:53:04 2002

I'm a big fan of Clisp, but can't get it to build on
my Compaq XP1000 running FreeBSD 4.6.

I've tried both the default cc (gcc 2.95.x) and Compaq
C with no success.  With both compiles, the configure
works clean, but the make stops in:

gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit
-Wreturn-type -fomit-frame-pointer -Wno-sign-compare
-O -DUNICODE -DDYNAMIC_FFI -c spvw.c
In file included from spvw.d:22:
lispbibl.d:2607: #error "oint_addr_mask doesn't cover
CODE_ADDRESS_RANGE !!"
lispbibl.d:2610: #error "oint_addr_mask doesn't cover
MALLOC_ADDRESS_RANGE !!"
*** Error code 1

Using ccc, it stops in the same file with a long list
of error messages concerning typedefs.

Best regards,

Jeff Katcher

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Mother's Day is May 12th!
http://shopping.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Thu May 9 12:13:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Failure to build Clisp 2.28 on FreeBSD/Alpha"
> * Sent on Thu, 9 May 2002 11:52:57 -0700 (PDT)
> * Honorable Jeffrey Katcher <[email-masked]> writes:
>

look around src/lispbibl.d:633 and figure out why WIDE_HARD is not
getting defined.

use "gcc -E -dM src/lispbibl.d" to get at CODE_ADDRESS_RANGE,
addr_shift, oint_addr_mask, oint_addr_shift, MALLOC_ADDRESS_RANGE.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.palestine-central.com/> <http://www.mideasttruth.com/>
A poet who reads his verse in public may have other nasty habits.