Subject: [clisp-list] maxima on clisp

From: JC Loredo-Osti <[email-masked]>
Date: Mon, 16 Oct 2000 17:46:42 -0400 (EDT)

Maybe this is not the place for this message. If so, I appologize.

This weekend I got maxima to run in my alpha machine under clisp and as
far as I went, it likes whatever I tryed (weel only very basic stuff, but
it seems to work).

It this the right place to post the patch file?

thanks,
-j

Here is a test output.

CLISP 2000-03-06 (March 2000)
Maxima 5.4 Thu Mar 25 16:49:44 CST 1999 (with enhancements by W.
Schelter).
Licensed under the GNU Public License (see file COPYING)
(C1) f(x):=x^2+y;
					 2
(D1) 			        F(X) := X  + Y
(C2) f(2);
(D2) 				     Y + 4
(C3) ev(f(2),y:7);
(D3) 				      11
(C4) integrate(f(x),x,1,2);
			       6 Y + 8	 3 Y + 1
(D4) 			       ------- - -------
				  3	    3
(C5) factor(%);
				    3 Y + 7
(D5) 				    -------
				       3
(C6) f(x):=sin(x)^2+1;
					 2
(D6) 			      F(X) := SIN (X) + 1
(C7) f(x+1);
				   2
(D7) 			        SIN (X + 1) + 1
(C8) diff(f(x),x);
(D8) 			        2 COS(X) SIN(X)
(C9) g(y,z):=f(z)+3*y;
(D9) 			     G(Y, Z) := F(Z) + 3 Y
(C10) ev(g(2*y+z,-0.5),y:7)
(D10) 			 3 (Z + 14) + 1.22984884706593
(C11)h(n):=sum(i*x^i,1,0,n);					 I
(D11) 			  H(N) := SUM(I X , I, 0, N)
(C12) h(7);
		     7	    6	   5	  4	 3      2
(D12) 		  7 X  + 6 X  + 5 X  + 4 X  + 3 X  + 2 X  + X
(C13) functions;
(D13) 			     [F(X), G(Y, Z), H(N)]
(C14) t[n](x):=ratexpand(2*x*t[n-1](x)-t[n-2](x));
(D14) 		 T (X) := RATEXPAND(2 X T     (X) - T	  (X))
		  N			 N - 1	     N - 2
(C15) t[0](x):=1;
(D15) 				  T (X) := 1
				   0
(C16) t[1](x):=x;
(D16) 				  T (X) := X
				   1
(C17) t[4](y);
				   4	  2
(D17) 			        8 Y  - 8 Y  + 1
(C18) g[n](x):=sum(ev(x),i,n,n+2);
(D18) 		       G (X) := SUM(EV(X), I, N, N + 2)
			N
(C19) h(n,x):=sum(ev(x),i,n,n+2);
(D19) 		      H(N, X) := SUM(EV(X), I, N, N + 2)
(C20) g[2](i^2);
					2
(D20) 				     3 I
(C21) h(2,i^2);
(D21) 				      29
(C22) p[n](x):=ratsimp(1/2^n*n!)*diff((x^2-1)^n,x,n));
				    1	       2     N
(D22) 		 P (X) := RATSIMP(----- DIFF((X  - 1) , X, N))
		  N		   N
				  2  N!
(C23)q(n,x):=ratsimp(1/2^n*n!)*diff((x^2-1)^n,x,n)); 
				     1	        2     N
(D23) 	        Q(N, X) := RATSIMP(----- DIFF((X  - 1) , X, N))
				    N
				   2  N!
(C24) p[2];
					    2
					 3 X  - 1
(D24) 			     LAMBDA([X], --------)
					    2
(C25) p[2](y+1);
					 2
				3 (Y + 1)  - 1
(D25) 			        --------------
				      2
(C26) q(2,y);
				      2
				   3 Y  - 1
(D26) 				   --------
				      2
(C27) p[2](5);
(D27) 				      37
(C28) f[i,j](x,y):=x^i+y^j
					    I	 J
(D28) 			    F	 (X, Y) := X  + Y
			     I, J
(C29) g(fun,a,b):=PRINT(FUN," applied to ",A," and ",B," is ",FUN(A,B));
(D29) G(FUN, A, B) := PRINT(FUN, " applied to ", A, " and ", B, " is ", FUN(A, B))

(C30) G(F[2,1],SIN(%PI),2*C);
 		    2
LAMBDA([X, Y], Y + X )  applied to  0  and  2 C  is  2 C 
(D30) 				      2 C
(C31) romberg(sin(y),y,1,%pi);
(D31) 			       1.540302306426815
(C32) quit();

---

From: Sam Steingold <[email-masked]>
Date: 16 Oct 2000 23:05:49 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] maxima on clisp"
> * Sent on Mon, 16 Oct 2000 17:46:42 -0400 (EDT)
> * Honorable JC Loredo-Osti <[email-masked]> writes:
>
> This weekend I got maxima to run in my alpha machine under clisp and
> as far as I went, it likes whatever I tryed (weel only very basic
> stuff, but it seems to work).
> 

You should also send it to
Bill Schelter <[email-masked]>

did you use my patches or is this completely independent?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
"Complete Idiots Guide to Running LINUX Unleashed in a Nutshell for Dummies"

---

From: JC Loredo-Osti <[email-masked]>
Date: Mon, 16 Oct 2000 23:57:58 -0400 (EDT)

> did you use my patches or is this completely independent?

Dear Sam,
nothing is completely independent nowdays, but I didn't try your patches.
However, I'd like to see them. Where can I obtain the file(s). What I did
was to start with an old version of maxima (because it showed fewer errors
at compiling time), then I downloaded maxima from the  cvs sources and I
tryed to do the same.

The recipe:
copy the patch file inside "maxima/src" and ungzip it, then move
"makefile" to "makefile.orig". The patch creates a "Makefile". Edit
the first lines of that Makefile to reflect your system and that's it.
After typing "make" and before installing it you may like to try
"./maxima". Some things are not yet, e.g., debug refuses to work.

Best regards,
-j