Subject: [clisp-list] pathname error [Win2K]

From: Eduardo Muñoz <[email-masked]>
Date: Fri Jan 30 15:24:21 2004

Clisp fails to open pathnames that have a semicolon:

[57]> (lisp-implementation-version)
"2.32 (2003-12-29) (built 3281848709) (memory 3281887410)"
[58]> (directory "d:\\Temp\\clisp\\*")
(#P"D:\\Temp\\clisp\\foo;bar.baz")
[59]> (defvar foo (open (car *)))
*** - PARSE-NAMESTRING: syntax error in filename "D:\\Temp\\clisp\\foo;bar.baz" at position 2
Break 1 [60]> 

This is on windows 2000. The file can be opened on Linux
(same clisp version).

P.S. This one is the second time that I send this post to
gmane. Hopefully it wont be a duplicate.

-- 
Eduardo Muñoz          | (prog () 10 (print "Hello world!")
http://213.97.131.125/ |          20 (go 10))

---

From: Sam Steingold <[email-masked]>
Date: Sat Jan 31 16:08:03 2004

> * Eduardo Muñoz <[email-masked]> [2004-01-31 00:14:04 +0100]:
>

you neglected to mention that this is an -ansi invocation.
OPEN calls TRUENAME which, after resolving symbolic links, invokes
PARSE-NAMESTRING, which, in ANSI mode, thinks that this is a logical
pathname (because it contains a semicolon).
Are you sure you need pathnames with embedded semicolons?

> gmane. Hopefully it wont be a duplicate.

indeed, it _was_ a duplicate.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Sex is like air.  It's only a big deal if you can't get any.

---

From: Eduardo Muñoz <[email-masked]>
Date: Sun Feb 1 05:10:03 2004

* Sam Steingold <[email-masked]>
| > * Eduardo Muñoz <[email-masked]> [2004-01-31 00:14:04 +0100]:
| [...]
| > This is on windows 2000. The file can be opened on Linux
| > (same clisp version).
| 
| you neglected to mention that this is an -ansi invocation.
| OPEN calls TRUENAME which, after resolving symbolic links, invokes
| PARSE-NAMESTRING, which, in ANSI mode, thinks that this is a logical
| pathname (because it contains a semicolon).

Indeed, my clisp.bat file uses -ansi to run clisp. I forgot
about it.

| Are you sure you need pathnames with embedded semicolons?

No, but I like to use clisp as a scripting language and got
an error while getting the size of a file. I can rename the
file.

| > P.S. This one is the second time that I send this post to
| > gmane. Hopefully it wont be a duplicate.
| 
| indeed, it _was_ a duplicate.

It did not show in gmane six hours after posting it, so I
thought that a repost was appropiate.

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 1 06:24:06 2004

> * Eduardo Muñoz <[email-masked]> [2004-02-01 13:58:52 +0100]:
>
> No, but I like to use clisp as a scripting language and got an error
> while getting the size of a file. I can rename the file.

I fixed this in the CVS.
CLISP builds OOTB with cygwin/mingw, so you should have no problems
rebuilding it.

> thought that a repost was appropiate.

Gmane is experiencing growing pains.
if you do not trust it, just set up gnus to send e-mail to
clisp-list@... when you post to gmane.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
To a Lisp hacker, XML is S-expressions with extra cruft.

---

From: Eduardo Muñoz <[email-masked]>
Date: Sun Feb 1 16:10:22 2004

* Sam Steingold <[email-masked]>
| > * Eduardo Muñoz <[email-masked]> [2004-02-01 13:58:52 +0100]:
| >
| > No, but I like to use clisp as a scripting language and got an error
| > while getting the size of a file. I can rename the file.
| 
| I fixed this in the CVS.
| CLISP builds OOTB with cygwin/mingw, so you should have no problems
| rebuilding it.

Downloaded the source from CVS and built it with msvc. I
dont know what OOTB means anyway :)

The instructions to build on windows are really clear,
thanks for that. After building and testing the reported
problem is gone, so thanks again :)

BTW, the building process halts with:

NMAKE : fatal error U1073: don't know how to make '_clisp.1'
Stop.

fortunately after building lisp.exe and lispinit.mem

One more question. How can I make clisp-2.32-win32.zip?
nmake distrib does not seems like the way to go.

---

From: Sam Steingold <[email-masked]>
Date: Sun Feb 1 17:24:02 2004

> * Eduardo Muñoz <[email-masked]> [2004-02-02 00:25:41 +0100]:
>

Out Of The Box.

> nmake distrib does not seems like the way to go.

I use "make distrib" with mingw.

with mingw, you can use modules (regexp, pcre, syscalls &c)
and CLISP runs _faster_ than when compiled with MSVC.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
When you are arguing with an idiot, your opponent is doing the same.