Subject: [clisp-list] CLISP-2.28 Windows Installation Question

From: Helmut Leitner <[email-masked]>
Date: Mon Mar 11 23:07:07 2002

When I struggled with compiling config.lisp I saw the
file
   install.bat
and wondered about its function. 

BTW it doesn't work the way it is, because install.bat
contains only LF as line-separators, so the content is
seen by DOS as one long echo command that does nothing. 

When one isolates the only real command:
   lisp.exe -B . -M lispinit.mem -norc -C src/install.lisp

It results in an error:

   [pathname.d:7947]
   *** - Win32 error 161 (ERROR_BAD_PATHNAME): The specified path is invalid.

Can someone explain or help?

BTW is there a way to get at the offending pathname and/or 
source file line number in such an error situation?

--
Helmut Leitner    [email-masked]   
Graz, Austria   www.hls-software.com

---

From: Arseny Slobodjuck <[email-masked]>
Date: Tue Mar 12 00:58:01 2002

Hello Helmut,

Tuesday, March 12, 2002, 5:05:23 PM, you wrote:

Helmut> When I struggled with compiling config.lisp I saw the
Helmut> file
Helmut>    install.bat
Helmut> and wondered about its function. 

Helmut> BTW it doesn't work the way it is, because install.bat
Helmut> contains only LF as line-separators, so the content is
Helmut> seen by DOS as one long echo command that does nothing. 

Helmut> When one isolates the only real command:
Helmut>    lisp.exe -B . -M lispinit.mem -norc -C src/install.lisp

Helmut> It results in an error:

Helmut>    [pathname.d:7947]
Helmut>    *** - Win32 error 161 (ERROR_BAD_PATHNAME): The specified path is invalid.

Helmut> Can someone explain or help?

I think you use windows 95 or 98, because in NT

a) LF's are understanded
b) Another error message appears:
   *** - A file with name src\install.lisp does not exist
   which is strange and should be investigated. Maybe it's
   caused by latter changes in pathname.d, not OS.

install.bat should be used for installing files in distributive set,
not in sources. You may create src directory and copy install.lisp
there.

-- 
Best regards,
 Arseny                            mailto:[email-masked]