Subject: [clisp-list] making clisp 2.20

From: Giulio Quaresima <[email-masked]>
Date: Sun May 25 13:24:05 2003

Dear Mr. Haible
I'm an italian student interested in Linguistics and Computer Science, so I have downloaded some versions of your Common Lisp interpreter. My trouble is that I was'nt able to install if from the source. With the RPM package, working in Red Hat 8 and 9, no problems, while neither in RH nor in Debian I can compile the sources. All goes OK until the step
$ make lisp.run
or
# make lisp.run
when I obtain the same error messages showed in the file make_lisp.run_sterr.log which I have attached. Why?
I thank you very much for your work and for your patience.

Giulio Quaresima
Perugia, Italy

P. S. Sorry for my TERRIBLE english!

libtool: install: warning: remember to run `libtool --finish /usr/local/lib'
In file included from spvw.d:22:
lispbibl.d:7183: warning: register used for two global register variables
spvw.d: In function `main':
spvw.d:1688: warning: variable `argv_memneed' might be clobbered by `longjmp' or `vfork'
In file included from spvwtabf.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from spvwtabs.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from spvwtabo.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from eval.d:6:
lispbibl.d:7183: warning: register used for two global register variables
eval.d: In function `invoke_handlers':
eval.d:628: warning: variable `other_ranges' might be clobbered by `longjmp' or `vfork'
eval.d:631: warning: variable `FRAME' might be clobbered by `longjmp' or `vfork'
eval.d:643: warning: variable `i' might be clobbered by `longjmp' or `vfork'
eval.d: In function `funcall_iclosure':
eval.d:2444: warning: argument `closure' might be clobbered by `longjmp' or `vfork'
eval.d:2445: warning: argument `args_pointer' might be clobbered by `longjmp' or `vfork'
eval.d:2446: warning: argument `argcount' might be clobbered by `longjmp' or `vfork'
eval.d: In function `eval':
eval.d:2943: warning: argument `form' might be clobbered by `longjmp' or `vfork'
eval.d: In function `eval_no_hooks':
eval.d:3000: warning: argument `form' might be clobbered by `longjmp' or `vfork'
eval.d: In function `interpret_bytecode_':
eval.d:5947: warning: variable `byteptr' might be clobbered by `longjmp' or `vfork'
eval.d:5956: warning: variable `closureptr' might be clobbered by `longjmp' or `vfork'
eval.d:5936: warning: argument `closure' might be clobbered by `longjmp' or `vfork'
eval.d:5937: warning: argument `codeptr' might be clobbered by `longjmp' or `vfork'
In file included from control.d:4:
lispbibl.d:7183: warning: register used for two global register variables
control.d: In function `C_tagbody':
control.d:1671: warning: variable `body' might be clobbered by `longjmp' or `vfork'
In file included from encoding.d:5:
lispbibl.d:7183: warning: register used for two global register variables
encoding.d: In function `nls_range':
encoding.d:1602: warning: `i1' might be used uninitialized in this function
encoding.d:1603: warning: `i2' might be used uninitialized in this function
In file included from pathname.d:7:
lispbibl.d:7183: warning: register used for two global register variables
pathname.d: In function `parse_logical_word':
pathname.d:1585: warning: `ch' might be used uninitialized in this function
In file included from stream.d:8:
lispbibl.d:7183: warning: register used for two global register variables
stream.d: In function `iconv_range':
stream.d:3981: warning: `i1' might be used uninitialized in this function
stream.d:3982: warning: `i2' might be used uninitialized in this function
In file included from socket.d:44:
lispbibl.d:7183: warning: register used for two global register variables
In file included from io.d:7:
lispbibl.d:7183: warning: register used for two global register variables
io.d: In function `C_bit_vector_reader':
io.d:3379: warning: `ch' might be used uninitialized in this function
io.d: In function `C_vector_reader':
io.d:3464: warning: `el' might be used uninitialized in this function
In file included from array.d:4:
lispbibl.d:7183: warning: register used for two global register variables
array.d: In function `C_make_array':
array.d:5069: warning: `fillpointer' might be used uninitialized in this function
array.d: In function `C_adjust_array':
array.d:5361: warning: `fillpointer' might be used uninitialized in this function
In file included from hashtabl.d:6:
lispbibl.d:7183: warning: register used for two global register variables
In file included from list.d:7:
lispbibl.d:7183: warning: register used for two global register variables
In file included from package.d:6:
lispbibl.d:7183: warning: register used for two global register variables
In file included from record.d:6:
lispbibl.d:7183: warning: register used for two global register variables
In file included from sequence.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from charstrg.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from debug.d:6:
lispbibl.d:7183: warning: register used for two global register variables
In file included from error.d:9:
lispbibl.d:7183: warning: register used for two global register variables
In file included from misc.d:4:
lispbibl.d:7183: warning: register used for two global register variables
In file included from time.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from predtype.d:4:
lispbibl.d:7183: warning: register used for two global register variables
In file included from symbol.d:4:
lispbibl.d:7183: warning: register used for two global register variables
In file included from lisparit.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from i18n.d:5:
lispbibl.d:7183: warning: register used for two global register variables
libtool: install: warning: remember to run `libtool --finish /usr/local/lib'
libtool: install: warning: remember to run `libtool --finish /usr/local/lib'
In file included from foreign.d:5:
lispbibl.d:7183: warning: register used for two global register variables
foreign.d: In function `do_va_start':
foreign.d:3119: warning: left-hand operand of comma expression has no effect
foreign.d:3121: warning: left-hand operand of comma expression has no effect
In file included from unixaux.d:5:
lispbibl.d:7183: warning: register used for two global register variables
In file included from genclisph.d:6:
lispbibl.d:7183: warning: register used for two global register variables
In file included from modules.d:11:
clisp.h:442: warning: register used for two global register variables
spvw.o: In function `update_linelength':
spvw.o(.text+0xdf9): undefined reference to `tgetent'
spvw.o(.text+0xe0e): undefined reference to `tgetnum'
stream.o: In function `make_keyboard_stream':
stream.o(.text+0xadc2): undefined reference to `tgetent'
stream.o(.text+0xadf4): undefined reference to `tgetstr'
stream.o(.text+0xae56): undefined reference to `tgetstr'
stream.o(.text+0xaeb6): undefined reference to `tgetstr'
stream.o(.text+0xaf16): undefined reference to `tgetstr'
stream.o(.text+0xafba): undefined reference to `tgetstr'
stream.o(.text+0xb05e): more undefined references to `tgetstr' follow
stream.o: In function `out_capstring':
stream.o(.text+0xc443): undefined reference to `tputs'
stream.o: In function `out_cap1string':
stream.o(.text+0xc470): undefined reference to `tgoto'
stream.o(.text+0xc479): undefined reference to `tputs'
stream.o: In function `cap_cost':
stream.o(.text+0xc4ad): undefined reference to `tputs'
stream.o: In function `gofromto':
stream.o(.text+0xc8d7): undefined reference to `tgoto'
stream.o(.text+0xc9c6): undefined reference to `tgoto'
stream.o: In function `insert_line':
stream.o(.text+0xd15e): undefined reference to `tgoto'
stream.o(.text+0xd1a9): undefined reference to `tgoto'
stream.o: In function `delete_line':
stream.o(.text+0xd2c1): undefined reference to `tgoto'
stream.o(.text+0xd30c): more undefined references to `tgoto' follow
stream.o: In function `init_term':
stream.o(.text+0xd42d): undefined reference to `tgetent'
stream.o(.text+0xd46d): undefined reference to `tgetnum'
stream.o(.text+0xd490): undefined reference to `tgetnum'
stream.o(.text+0xd4b3): undefined reference to `tgetflag'
stream.o(.text+0xd4db): undefined reference to `tgetflag'
stream.o(.text+0xd509): undefined reference to `tgetflag'
stream.o(.text+0xd536): undefined reference to `tgetstr'
stream.o(.text+0xd56e): undefined reference to `tgetstr'
stream.o(.text+0xd59b): undefined reference to `tgetflag'
stream.o(.text+0xd5ad): undefined reference to `tgetflag'
stream.o(.text+0xd5d0): undefined reference to `tgetstr'
stream.o(.text+0xd5e7): undefined reference to `tgetstr'
stream.o(.text+0xd601): undefined reference to `tgetstr'
stream.o(.text+0xd61a): undefined reference to `tgetflag'
stream.o(.text+0xd633): undefined reference to `tgetstr'
stream.o(.text+0xd658): undefined reference to `tgetstr'
stream.o(.text+0xd680): undefined reference to `tgetstr'
stream.o(.text+0xd6a8): undefined reference to `tgetstr'
stream.o(.text+0xd6d0): undefined reference to `tgetstr'
stream.o(.text+0xd6e7): more undefined references to `tgetstr' follow
stream.o: In function `init_term':
stream.o(.text+0xd713): undefined reference to `tgetnum'
stream.o(.text+0xd727): undefined reference to `tgetnum'
stream.o(.text+0xd79f): undefined reference to `tgetstr'
stream.o(.text+0xd7b6): undefined reference to `tgetstr'
stream.o(.text+0xd7d0): undefined reference to `tgetstr'
stream.o(.text+0xd7e7): undefined reference to `tgetstr'
stream.o(.text+0xd822): undefined reference to `tgetstr'
stream.o(.text+0xd839): more undefined references to `tgetstr' follow
stream.o: In function `init_term':
stream.o(.text+0xda3d): undefined reference to `tgetflag'
stream.o: In function `init_curr':
stream.o(.text+0xdcf6): undefined reference to `tgoto'
collect2: ld returned 1 exit status
make: *** [lisp.run] Error 1
sed -e 's/@''HAVE__BOOL''@/0/g' < stdbool.h.in > stdbool.h
builddir="`pwd`"; cd libcharset && make && make install-lib libdir="$builddir" includedir="$builddir"
make[1]: Entering directory `/usr/local/clisp-2.30/src/libcharset'
cd lib && make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/libcharset/lib'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/libcharset/lib'
make[1]: Leaving directory `/usr/local/clisp-2.30/src/libcharset'
make[1]: Entering directory `/usr/local/clisp-2.30/src/libcharset'
cd lib && make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/libcharset/lib'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/libcharset/lib'
cd lib && make install-lib libdir='/usr/local/clisp-2.30/src' includedir='/usr/local/clisp-2.30/src'
make[2]: Entering directory `/usr/local/clisp-2.30/src/libcharset/lib'
/bin/sh ../../../libcharset/lib/../autoconf/mkinstalldirs /usr/local/clisp-2.30/src
/bin/sh ../libtool --mode=install /usr/bin/install -c -m 644 libcharset.la /usr/local/clisp-2.30/src/libcharset.la
/usr/bin/install -c -m 644 .libs/libcharset.so.1.0.0 /usr/local/clisp-2.30/src/libcharset.so.1.0.0
(cd /usr/local/clisp-2.30/src && rm -f libcharset.so.1 && ln -s libcharset.so.1.0.0 libcharset.so.1)
(cd /usr/local/clisp-2.30/src && rm -f libcharset.so && ln -s libcharset.so.1.0.0 libcharset.so)
/usr/bin/install -c -m 644 .libs/libcharset.lai /usr/local/clisp-2.30/src/libcharset.la
/usr/bin/install -c -m 644 .libs/libcharset.a /usr/local/clisp-2.30/src/libcharset.a
ranlib /usr/local/clisp-2.30/src/libcharset.a
chmod 644 /usr/local/clisp-2.30/src/libcharset.a
test -f /usr/local/clisp-2.30/src/charset.alias && orig=/usr/local/clisp-2.30/src/charset.alias \
                                || orig=charset.alias; \
sed -f ref-add.sed $orig > /usr/local/clisp-2.30/src/t-charset.alias; \
/usr/bin/install -c -m 644 /usr/local/clisp-2.30/src/t-charset.alias /usr/local/clisp-2.30/src/charset.alias; \
rm -f /usr/local/clisp-2.30/src/t-charset.alias
make[2]: Leaving directory `/usr/local/clisp-2.30/src/libcharset/lib'
/bin/sh ../../libcharset/autoconf/mkinstalldirs /usr/local/clisp-2.30/src
/usr/bin/install -c -m 644 include/libcharset.h /usr/local/clisp-2.30/src/libcharset.h
make[1]: Leaving directory `/usr/local/clisp-2.30/src/libcharset'
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c spvw.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c spvwtabf.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c spvwtabs.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c spvwtabo.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c eval.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c control.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c encoding.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c pathname.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c stream.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c socket.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c io.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c array.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c hashtabl.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c list.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c package.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c record.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c sequence.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c charstrg.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c debug.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c error.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c misc.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c time.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c predtype.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c symbol.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c lisparit.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c i18n.c
builddir="`pwd`"; cd avcall && make && make check && make install-lib libdir="$builddir" includedir="$builddir"
make[1]: Entering directory `/usr/local/clisp-2.30/src/avcall'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/local/clisp-2.30/src/avcall'
make[1]: Entering directory `/usr/local/clisp-2.30/src/avcall'
./minitests > minitests.out
uniq -u < minitests.out > minitests.output.i686-pc-linux-gnu
test '!' -s minitests.output.i686-pc-linux-gnu
make[1]: Leaving directory `/usr/local/clisp-2.30/src/avcall'
make[1]: Entering directory `/usr/local/clisp-2.30/src/avcall'
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/bin/sh ./libtool --mode=install /usr/bin/install -c -m 644 libavcall.la /usr/local/clisp-2.30/src/libavcall.la
/usr/bin/install -c -m 644 .libs/libavcall.lai /usr/local/clisp-2.30/src/libavcall.la
/usr/bin/install -c -m 644 .libs/libavcall.a /usr/local/clisp-2.30/src/libavcall.a
ranlib /usr/local/clisp-2.30/src/libavcall.a
chmod 644 /usr/local/clisp-2.30/src/libavcall.a
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/usr/bin/install -c -m 644 avcall.h /usr/local/clisp-2.30/src/avcall.h
make[1]: Leaving directory `/usr/local/clisp-2.30/src/avcall'
builddir="`pwd`"; cd callback && make && make check && make install-lib libdir="$builddir" includedir="$builddir"
make[1]: Entering directory `/usr/local/clisp-2.30/src/callback'
cd vacall_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/vacall_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/vacall_r'
cd trampoline_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
make[1]: Leaving directory `/usr/local/clisp-2.30/src/callback'
make[1]: Entering directory `/usr/local/clisp-2.30/src/callback'
cd vacall_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/vacall_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/vacall_r'
cd trampoline_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
cd vacall_r; make check
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/vacall_r'
make[2]: Nothing to be done for `check'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/vacall_r'
cd trampoline_r; make check
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
./test1
Works, test1 passed.
./test2
test2 passed.
touch tests.passed.i686-pc-linux-gnu
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
./minitests > minitests.out
uniq -u < minitests.out > minitests.output.i686-pc-linux-gnu
test '!' -s minitests.output.i686-pc-linux-gnu
make[1]: Leaving directory `/usr/local/clisp-2.30/src/callback'
make[1]: Entering directory `/usr/local/clisp-2.30/src/callback'
cd vacall_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/vacall_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/vacall_r'
cd trampoline_r; make all
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
cd vacall_r; make install-lib libdir='/usr/local/clisp-2.30/src' includedir='/usr/local/clisp-2.30/src'
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/vacall_r'
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/usr/bin/install -c -m 644 vacall_r.h /usr/local/clisp-2.30/src/vacall_r.h
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/vacall_r'
cd trampoline_r; make install-lib libdir='/usr/local/clisp-2.30/src' includedir='/usr/local/clisp-2.30/src'
make[2]: Entering directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/usr/bin/install -c -m 644 trampoline_r.h /usr/local/clisp-2.30/src/trampoline_r.h
make[2]: Leaving directory `/usr/local/clisp-2.30/src/callback/trampoline_r'
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/bin/sh ./libtool --mode=install /usr/bin/install -c -m 644 libcallback.la /usr/local/clisp-2.30/src/libcallback.la
/usr/bin/install -c -m 644 .libs/libcallback.lai /usr/local/clisp-2.30/src/libcallback.la
/usr/bin/install -c -m 644 .libs/libcallback.a /usr/local/clisp-2.30/src/libcallback.a
ranlib /usr/local/clisp-2.30/src/libcallback.a
chmod 644 /usr/local/clisp-2.30/src/libcallback.a
if [ ! -d /usr/local/clisp-2.30/src ] ; then mkdir /usr/local/clisp-2.30/src ; fi
/usr/bin/install -c -m 644 callback.h /usr/local/clisp-2.30/src/callback.h
make[1]: Leaving directory `/usr/local/clisp-2.30/src/callback'
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c foreign.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c unixaux.c
gcc -E ari80386.c | grep -v '^#' > ari80386.s
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -x assembler -c ari80386.s
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -O0 -c genclisph.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -x none genclisph.o -o genclisph
(echo '#ifndef _CLISP_H' ; echo '#define _CLISP_H' ; echo ; grep '^#' unixconf.h ; echo ; grep '^#' intparam.h ; echo ; ./genclisph ; echo ; echo '#endif /* _CLISP_H */') > clisp.h
rm -f genclisph
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -c modules.c
if test -d locale; then rm -rf locale; fi
mkdir locale
(cd po && make && make install datadir=.. localedir='$(datadir)/locale' INSTALL_DATA=ln) || (rm -rf locale ; exit 1)
make[1]: Entering directory `/usr/local/clisp-2.30/src/po'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/local/clisp-2.30/src/po'
make[1]: Entering directory `/usr/local/clisp-2.30/src/po'
installing en.gmo as ../locale/en/LC_MESSAGES/clisp.mo
installing clisplow_en.gmo as ../locale/en/LC_MESSAGES/clisplow.mo
installing de.gmo as ../locale/de/LC_MESSAGES/clisp.mo
installing clisplow_de.gmo as ../locale/de/LC_MESSAGES/clisplow.mo
installing fr.gmo as ../locale/fr/LC_MESSAGES/clisp.mo
installing clisplow_fr.gmo as ../locale/fr/LC_MESSAGES/clisplow.mo
installing es.gmo as ../locale/es/LC_MESSAGES/clisp.mo
installing clisplow_es.gmo as ../locale/es/LC_MESSAGES/clisplow.mo
installing nl.gmo as ../locale/nl/LC_MESSAGES/clisp.mo
installing clisplow_nl.gmo as ../locale/nl/LC_MESSAGES/clisplow.mo
installing ru.gmo as ../locale/ru/LC_MESSAGES/clisp.mo
installing clisplow_ru.gmo as ../locale/ru/LC_MESSAGES/clisplow.mo
make[1]: Leaving directory `/usr/local/clisp-2.30/src/po'
rm -rf data
mkdir data
cd data && ln -s ../../utils/unicode/ftp.unicode.org/UnicodeData.txt .
cd data && ln -s ../../src/clhs.txt .
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type  -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -I. -x none spvw.o spvwtabf.o spvwtabs.o spvwtabo.o eval.o control.o encoding.o pathname.o stream.o socket.o io.o array.o hashtabl.o list.o package.o record.o sequence.o charstrg.o debug.o error.o misc.o time.o predtype.o symbol.o lisparit.o i18n.o foreign.o unixaux.o ari80386.o modules.o libcharset.a libavcall.a libcallback.a  -ldl /usr/local/lib/libiconv.so -Wl,-rpath -Wl,/usr/local/lib /usr/local/lib/libsigsegv.a -lc -o lisp.run

---

From: Sam Steingold <[email-masked]>
Date: Sun May 25 17:22:02 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] making clisp 2.20"
> * Sent on Sun, 25 May 2003 22:23:10 +0200
> * Honorable Giulio Quaresima <[email-masked]> writes:
>

do you have ncurses installed?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Life is a sexually transmitted disease with 100% mortality.