Subject: [clisp-list] CLISP-DOS: Error on "(compile-file "config.lsp")"

From: "Thiago F.G. Albuquerque" <[email-masked]>
Date: Mon, 07 Feb 2000 04:37:49 -0200

Hi,

I encountered the following problem when installing CLisp

c:\temp\clisp>lisp.exe -M lispinit.mem
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I I I I I I I      8         8           8     8        8    8
  I I I I I I I      8         8           8      ooooo   8oooo
  I  \ `+' /  I      8         8           8           8  8
   \  `-+-'  /       8     o   8           8     o     8  8
    `-__|__-'         ooooo    8oooooo  ooo8ooo   ooooo   8
        |
  ------+------     Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
                    Copyright (c) Bruno Haible, Marcus Daniels 1994-1997

> (compile-file "config.lsp")

*** - UNIX library error 9 (EBADF): Bad file number
1. Break>
> (lisp-implementation-version)
"1997-12-06 (December 1997)"
Bye.
--------------------

Can anybody help me, please?

I use 4DOS under Win95.

Thanks.
Thiago

---

From: Bruno Haible <[email-masked]>
Date: Mon, 7 Feb 2000 16:19:57 +0100 (MET)

Thiago F. G. Albuquerque writes:

> ...
> ...

You are using the DOS binaries of CLISP on Win32. This is suboptimal; it
may cause problems with long filenames and other things. DOS /= Win32.

I suggest you try the Win32 binaries, available from
ftp://clisp.cons.org/pub/lisp/clisp/binaries/win32/.

Bruno

---

From: "Thiago F.G. Albuquerque" <[email-masked]>
Date: Mon, 07 Feb 2000 11:01:51 -0200

>may cause problems with long filenames and other things. DOS /= Win32.

Yes, I know. I am using it because the DOS port has a better shell. The
Win32 port doesn't support the arrow keys, nor the completion feature (TAB).

Thiago

---

From: Bruno Haible <[email-masked]>
Date: Mon, 7 Feb 2000 22:28:06 +0100 (MET)

Thiago F. G. Albuquerque writes:

> Win32 port doesn't support the arrow keys

Windows 95/98 box does not support the arrow keys. Windows NT does. Ask
Microsoft why...

> nor the completion feature (TAB).

Yes, this is missing from the native Win32 ports of clisp, indeed.

Bruno