Subject: RE: [clisp-list] CLISP 2.30 compilation under cygwin errors.

From: Eric Moncrieff <[email-masked]>
Date: Tue Sep 17 08:51:02 2002

Same result.  

I think there's something funny in the way Cygwin handles the
'src/lndir' script; as I mentioned in my first posting, that's
what actually generates the error.  

I'm not sure where to proceed on 'debugging' the lndir script,
if indeed it's a bug in that and not Cygwin (or my thinking). 

I'm not sure where lndir sucks in config information, because

$ grep FIND src/* 

returns the empty set.

Yet, 

$ src/lndir modules/bindings \
/cygdrive/c/WINNT/Profiles/ericm/Personal/src/clisp-2.30/build/bindings 

generates the same error as the ./configure script, complete with the
string FIND called.  

However, when I call the above prefixed by 

$ bash -x COMMAND

and observe what the shell thinks it's doing, it seems sane.

Hm.  I don't know.

Eric
-----Original Message-----
From: Marco Baringer [mailto:[email-masked]]
Sent: Tuesday, September 17, 2002 11:43 AM
To: Eric Moncrieff
Cc: [email-masked]'; [email-masked]'
Subject: Re: [clisp-list] CLISP 2.30 compilation under cygwin errors.

Eric Moncrieff <[email-masked]> writes:

> bash-2.05b$ cd ..
> bash-2.05b$ rm -rf clisp-2.30
> bash-2.05b$ bzip2 -dc clisp-2.30.tar.bz2 | tar xvf -
> bash-2.05b$ cd clisp-2.30
> bash-2.05b$ ./configure build
> mkdir: cannot create directory
>
`/cygdrive/c/WINNT/Profiles/ericm/Personal/src/clisp-2.30/build/bindingsFIND
> :': No such file or directory
> 
> Same result...
> 
> Eric

is CLISP trying to mkdir build/bindingsFIND without having mkdir'd
build? try changing line 278 of configure from

maybe_mkdir() { test -d "$1" || mkdir "$1"; }

to

makybe_mkdir() { test -d "$1" || mkdir -p "$1"; }

and see what happens.

-- 
-Marco
Ring the bells that still can ring.
Forget your perfect offering.
There is a crack in everything.
That's how the light gets in.
     -Leonard Cohen

---

From: Randall R Schulz <[email-masked]>
Date: Tue Sep 17 09:03:05 2002

Hi,

If you have XFree86/Cygwin installed, you have a binary called "lndir" in 
/usr/X11R6/bin ("/usr/X11R6/bin/lndir.exe" to be precise). Depending on 
your PATH setting, you might be invoking that instead of any lndir script 
that's part of the CLISP build system.

Also, if line endings are an issue, there's also the text vs. binary mount 
business in Cygwin (not to mention the "binmode" option in the CYGWIN 
environment variable). If you're using Cygwin to build software, you need 
to understand how Cygwin handles the variant text file encodings of Windows 
and Unix.

Randall Schulz
Mountain View, CA USA

At 08:51 2002-09-17, Eric Moncrieff wrote:
>what actually generates the error...