Subject: [clisp-list] Bug in Visual C++ build Visual C++ in a "non-standard directory"

From: [email-masked] (Thaddeus L. Olczyk)
Date: Tue Jan 29 05:20:04 2002

In the file win32msvc/makefile.msvc5,
the line
MSVCDIR = "C:/Program Files/Microsoft Visual Studio/VC98"
Should be commented out.
The problem of course is if this is not the path, you should have all
sorts of problems.
MSVCDIR should be set by the program
vcvars32.bat which Microsoft Visual C++ installs when you install
VC++ ( just use the file find dialog  to get it ). I copy mine to my
cygwin/bin direectory so I always have it at hand.

If you create a batch file to configure and setup, then it should be 
called via:
call vcvars32.bat 
( which is similar to the "source" command in bash ).

---

From: Sam Steingold <[email-masked]>
Date: Tue Jan 29 07:49:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Bug in Visual C++ build Visual C++ in a "non-standard directory""
> * Sent on Tue, 29 Jan 2002 13:19:29 GMT
> * Honorable [email-masked] (Thaddeus L. Olczyk) writes:
>

I prefer editing Makefile once to set MSVCDIR correctly.
YMMV - do as you like.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
He who laughs last thinks slowest.