Subject: RE: [clisp-list] Trouble running on cygwin, Windows 2000

From: "Young, David" <[email-masked]>
Date: Thu Aug 1 11:32:24 2002

Ok, here's the deal. Sam, I followed your instructions precisely for
building a debuggable version of clisp 2.29. If I run the resultant program
from within gdb, or even strace, it works fine. If I run the exe from bash,
however, the problem manifests itself. I'm using the "better-termcap"
available in the distro, and TERM is set to 'cygwin32', although I've tried
the run both this way and with stock cygwin. This sure smells of some type
of console issue (?)

NB: If I install a standard win32 version of clisp I can run it just fine
from bash. Something's going wrong when I build from scratch in my
environment.

-- dey

-----Original Message-----
From: Sam Steingold [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 12:50 PM
To: Young, David
Cc: [email-masked]'
Subject: Re: [clisp-list] Trouble running on cygwin, Windows 2000

> * In message
<[email-masked]>
> * On the subject of "[clisp-list] Trouble running on cygwin, Windows 2000"
> * Sent on Wed, 31 Jul 2002 13:00:05 -0400
> * Honorable "Young, David" <[email-masked]> writes:
>
> Greetings. I've successfully built clisp 2.29 on Dell P-III, cygwin
> 1.13.12/windows 2000. However, after installing (make install), running
> clisp results in an endless loop of "UNIX error 13" messages:
> 
> bash-2.05b$ clisp
> ;; Loading file /cygdrive/h/dyoung/.clisprc.lisp ...
> ;; Loading of file /cygdrive/h/dyoung/.clisprc.lisp is finished.
> [1]>

are you really getting this __after__ CLISP prints the prompt?!

> *** - UNIX error 13 (EACCES): Permission denied
> *** - UNIX error 13 (EACCES): Permission denied
> ...
> [1]+  Stopped                 clisp
> 
> I'd appreciate suggestions.

I cannot reproduce this, alas, either with the current CVS head or with
2.29 release on w2k.

could you please debug this?
1. ./configure --with-debug --build build-g
2. cd build-g
3. gdb -nw
(gdb) break OS_error
(gdb) run
...
(gdb) where

---

From: Sam Steingold <[email-masked]>
Date: Thu Aug 1 11:49:05 2002

> * In message <[email-masked]>
> * On the subject of "RE: [clisp-list] Trouble running on cygwin, Windows 2000"
> * Sent on Thu, 1 Aug 2002 14:21:45 -0400 
> building a debuggable version of clisp 2.29. If I run the resultant
> program from within gdb, or even strace, it works fine. If I run the
> exe from bash, however, the problem manifests itself.

wow!!!

> I'm using the "better-termcap" available in the distro, and TERM is
> set to 'cygwin32', although I've tried the run both this way and with
> stock cygwin. This sure smells of some type of console issue (?)

don't use this `better-termcap'.
readline should work without it.
it will be gone in the next release anyway.

did you try CVS head?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Trespassers will be shot.  Survivors will be SHOT AGAIN!