Subject: [clisp-list] Re: A problem with Windows

From: Francisco Jesús Martín Mateos <[email-masked]>
Date: Mon, 06 Nov 2000 20:02:03 +0100

When I use "clisp" in "emacs" in my Windows 98, I have the following
error message
    "(ERROR_BAD_NETPATH) The network path was not found"

Anyone can tell me how to avoid that?

---

From: Sam Steingold <[email-masked]>
Date: 06 Nov 2000 17:46:28 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Re: A problem with Windows"
> * Sent on Mon, 06 Nov 2000 20:02:03 +0100
> * Honorable Francisco Jesús Martín Mateos <[email-masked]> writes:
>

could you please be more specific?
what are you doing in Emacs?
(like, which variable do you set, what do you type, what is the exact
contents of the *Backtrace* buffer when you set debug-on-error to t)

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Stupidity, like virtue, is its own reward.

---

From: Francisco Jesús Martín Mateos <[email-masked]>
Date: Wed, 08 Nov 2000 19:23:02 +0100

> contents of the *Backtrace* buffer when you set debug-on-error to t)

I've used the following in "_emacs"
    (setq inferior-lisp-program "c:/clisp/lisp.exe  -M c:/clisp/lispinit.mem")

When I do "M-x run-lisp", I have the following error message

[pathname.d:8514]
*** - Win32 error 53 (ERROR_BAD_NETPATH): The network path was not found.

I've set the "debug-on-error" to t, but the *Backtrace* buffer didn't appear

---

From: Bruno Haible <[email-masked]>
Date: Wed, 8 Nov 2000 20:42:07 +0100 (CET)

> *** - Win32 error 53 (ERROR_BAD_NETPATH): The network path was not found.

Thanks for the details. Apparently clisp is searching for the startup
file _clisprc in your home directory, but that directory is not
accessible; thus the error.

There are three workarounds:
  - Mount (i.e. "map network drive") the HOME directory,
  - change the HOME or HOMEDRIVE/HOMEPATH environment variables,
  - (setq inferior-lisp-program "c:/clisp/lisp.exe -norc -M c:/clisp/lispinit.mem")

In the next version, this error will not occur any more.

Bruno

---

From: Sam Steingold <[email-masked]>
Date: 08 Nov 2000 15:04:30 -0500

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Re: A problem with Windows"
> * Sent on Wed, 08 Nov 2000 19:23:02 +0100

This is a CLISP error (this wasn't clear before - you omitted the
crucial [pathname.d:8514] part).
I am not getting it on my WinNT4sp6 box.

Do you have your $HOME set?
Where is your _emacs?
Do you have a _clisprc in your $HOME?
Could you please try creating an empty _clisprc?

Thanks.

> I've set the "debug-on-error" to t, but the *Backtrace* buffer didn't appear

no wonder, this is a CLISP message, not an Emacs error.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Flying is not dangerous; crashing is.