Subject: [clisp-list] compile error in pathname.d

From: [email-masked]
Date: Sun Nov 11 15:27:01 2001

Hi All,

I have been attempting to build the latest clisp CVS and encountered the
following error in src/pathname.d:

touch pathname.d
make
---

test -d bindings || mkdir bindings
./comment5 pathname.d | ./ansidecl | ./varbrace > pathname.c
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -c pathname.c
In file included from pathname.d:6:
lispbibl.d:7025: warning: register used for two global register variables
pathname.d: In function `parse_logical_word':
pathname.d:1528: warning: `ch' might be used uninitialized in this function
pathname.d: In function `C_cd':
pathname.d:9639: warning: implicit declaration of function `pslashp'
gcc -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-frame-pointer -Wno-sign-compare -O2 -fexpensive-optimizations -DUNICODE -DDYNAMIC_FFI -x none spvw.o spvwtabf.o spvwtabs.o spvwtabo.o eval.o control.o encoding.o pathname.o stream.o socket.o io.o array.o hashtabl.o list.o package.o record.o sequence.o charstrg.o debug.o error.o misc.o time.o predtype.o symbol.o lisparit.o i18n.o foreign.o unixaux.o ari80386.o modules.o libsigsegv.a libintl.a libiconv.a libreadline.a libavcall.a libcallback.a  -lncurses -ldl  -o lisp.run
pathname.o: In function `C_cd':
pathname.o(.text+0x7d7e): undefined reference to `pslashp'
collect2: ld returned 1 exit status
make: *** [lisp.run] Error 1

---
Note that I ran configure without any options enabled.

Disabling line 2680 of pathname.d allows clisp to build correctly on my
system (Debian "Woody" Linux; gcc 2:2.95.4-8):

-#undef pslashp
+# undef pslashp

No doubt there is a more correct and subtle solution than this. :-)

Cheers,
Andrew Smith

---

From: Sam Steingold <[email-masked]>
Date: Mon Nov 12 08:10:08 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] compile error in pathname.d"
> * Sent on Mon, 12 Nov 2001 10:26:08 +1100
> * Honorable [email-masked] writes:
>
> I have been attempting to build the latest clisp CVS and encountered
> the following error in src/pathname.d:

this should be fixed now.

Note that all mail regarding CVS CLISP should go to <clisp-devel>.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Only adults have difficulty with childproof caps.