Subject: [clisp-list] calling open-gl functions with clisp

From: Reza Alemi <[email-masked]>
Date: Sat Jun 15 17:10:01 2002

Dear List members,

Can anyone please tell me how can I call opengl
routines from clisp? there are loads of packages out
there for allegro and cmucl, but they don't work in
clisp.

I saw Larry Bales has used FFI:DEF-C-CALL-OUT for
glClearIndex, but when I try it, it says it can't find
entry for glClearIndex.
 
I've lost hair and sleep over this, now losing sanity
:)
Thank you. 

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Mon Jun 17 14:24:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] calling open-gl functions with clisp"
> * Sent on Sat, 15 Jun 2002 17:09:07 -0700 (PDT)
> * Honorable Reza Alemi <[email-masked]> writes:
>
> Can anyone please tell me how can I call opengl routines from clisp?
> there are loads of packages out there for allegro and cmucl, but they
> don't work in clisp.

you will need to create an opengl CLISP module.
this sounds harder than it actually is, so do not despair.
basically, you should look at the modules in the CLISP distribution
(clisp/modules/*), e.g., postgresql or queens or whatever
and "do something similar", namely, create Makefile, link.sh and
opengl.lisp files.  The latter should contain many DEF-CALL-OUT forms,
one for each opengl function, as well as other stuff.

you can use cparse <http://www.bricoworks.com/~moore/cparse/> to
automate some of the opengl.h --> opengl.lisp conversion.
Dan Stanger <[email-masked]> patched cparse to produce CLISP
output, but it does not appear that the patch has been integrated
yet --
-- Dan, could you please nag Tim to get the patch in and mentioned
on his web page that cparse works with CLISP?

I hope other FFI users will be more specific.
More docs can be found here:
<http://clisp.cons.org/impnotes/modules.html>

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
will write code that writes code that writes code for food

---

From: Dan Stanger <[email-masked]>
Date: Mon Jun 17 17:20:04 2002

I would recomend that you create a module similar to new-clx, rather than using
the ffi interface.  You might try using the awk code for the gdi module that
I am working on.  IMO, its a lot easier to debug a module than the ffi code,
and you have a lot more control.
Dan

Sam Steingold wrote:

> ----------------------------------------------------------------------------------------------------
>                                      Sponsor's Message
> ----------------------------------------------------------------------------------------------------
>                       Bringing you mounds of caffeinated joy
>                          >>>     http://thinkgeek.com/sf    <<<
>
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list

---

From: Sam Steingold <[email-masked]>
Date: Tue Jun 18 06:56:04 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] calling open-gl functions with clisp"
> * Sent on Mon, 17 Jun 2002 18:21:20 -0600
> * Honorable Dan Stanger <[email-masked]> writes:
>
> I would recomend that you create a module similar to new-clx, rather
> than using the ffi interface.  You might try using the awk code for
> the gdi module that I am working on.  IMO, its a lot easier to debug a
> module than the ffi code, and you have a lot more control.  Dan

BTW, would you like your gdi module to be distributed with CLISP?
Also, I forgot what gdi stands for (neither your readme nor google are
of any help here...)

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
XFM: Exit file manager? [Continue] [Cancel] [Abort]

---

From: Dave Pearson <[email-masked]>
Date: Thu Jun 20 08:45:06 2002

* Sam Steingold <[email-masked]> [2002-06-18 09:54:59 -0400]:

> Also, I forgot what gdi stands for (neither your readme nor google are of
> any help here...)

<URL:http://www.foldoc.org/foldoc/foldoc.cgi?query=GDI>?

-- 
Dave Pearson
http://www.davep.org/