Subject: [clisp-list] internationalization problem

From: bernard URBAN <[email-masked]>
Date: Wed, 11 Apr 2001 19:05:20 +0200

I have send this message some days again as a bug, but it seems to have
disappeared from the bug list ?

So it is here again:

                Hello!

                For clisp-2.25 (installed without problems with
                gcc-2.95.3):

                $ clisp -q -norc

                [1]> (machine-instance)
                "sylla [137.129.xxx.xxx]"
                [2]> (machine-version)
                "SUN4US"
                [3]> (quit)
                $ clisp -q -norc

                [1]> (/ 0)

                *** - division by zero
                1. Break [2]> (quit)
                $ clisp -q -norc -L francais

                [1]> (/ 0)

                *** - Message inimprimable
                1. Break [2]> (quit)
                $ clisp -q -norc -L deutsch

                [1]> (/ 0)

                *** - Division durch Null
                1. Break [2]> (quit)
                $ clisp -q -norc -L spanish

                [1]> (/ 0)

                *** - invalid byte #xF3 in CHARSET:UTF-8 conversion,
                not a Unicode-16
                1. Break [2]> (quit)
                $

                The problem seems to be triggered by messages
                containing accented letters.
                Any hint ?

                Regards.

                --

                Bernard Urban

I add that clisp-2.25.1 exhibits the same behaviour.
And about internationalization, how do the clisp
developpers edit their files with all these Unicode codings ?
Basic emacs does not seem to understand Unicode.

--

Bernard Urban

---

From: Sam Steingold <[email-masked]>
Date: 11 Apr 2001 13:53:25 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] internationalization problem"
> * Sent on Wed, 11 Apr 2001 19:05:20 +0200
> * Honorable bernard URBAN <[email-masked]> writes:
>

Please try the following:
 - build libiconv (part of CLISP)
 - install libiconv
 - reconfigure and re-build CLISP.

> Basic emacs does not seem to understand Unicode.

Emacs 21 does - that's what I use (I have access to the CVS).

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
MS: Brain off-line, please wait.