Subject: [clisp-list] trouble with clisp-2.30-i686-unknown-linux-2.4.18-10.tar.gz

From: [email-masked] (Don Cohen)
Date: Tue Apr 29 01:18:05 2003

downloaded from
http://sourceforge.net/project/showfiles.php?group_id=1355

  [root@we-24-130-19-131 clisp-2.30]# make
  cc -O  base/modules.o base/lisp.a base/libcharset.a base/libavcall.a base/libcallback.a -lreadline -lncurses -ldl base//usr/local/lib/libsigsegv.a -lc -lm -o base/lisp.run
  cc: base//usr/local/lib/libsigsegv.a: No such file or directory
  make: *** [base/lisp.run] Error 1

I now remove the base/ from the above line in Makefile.

  [root@we-24-130-19-131 clisp-2.30]# make
  cc -O  base/modules.o base/lisp.a base/libcharset.a base/libavcall.a base/libcallback.a -lreadline -lncurses -ldl /usr/local/lib/libsigsegv.a -lc -lm -o base/lisp.run
  base/lisp.a(lisp.o): In function `rd_ch_terminal3':
  lisp.o(.text+0x34101): undefined reference to `rl_already_prompted'
  base/lisp.a(lisp.o): In function `make_terminal_stream_':
  lisp.o(.text+0x346f2): undefined reference to `rl_gnu_readline_p'
  base/lisp.a(lisp.o): In function `rl_memory_abort':
  lisp.o(.text+0x392db): undefined reference to `rl_gnu_readline_p'
  base/lisp.a(lisp.o): In function `lisp_completion_more':
  lisp.o(.text+0x33fa5): undefined reference to `rl_filename_completion_function'
  collect2: ld returned 1 exit status
  make: *** [base/lisp.run] Error 1

I see from a web search something that looks relevant:

    FROM: Sam Steingold
    DATE: 09/28/2002 17:19:28
    SUBJECT: RE:  [clisp-list] clisp-2.30 build problems on Red Hat Linux 6.2
     
  ...
    I think you have a _very_ old readline version (where everything was
    called "foo" instead of "rl_foo" in the newer readline)

I just downloaded and installed readline-4.3 so that must not be it.

    you can also do

    $ ./configure --without-readline --build build-no-readline
I now try the source distribution from the same place and get the
same result from the line above.  (Not quite but almost - no complaint
about lisp_completion_more, the hex numbers are different and the
complaints come from stream.o instead of lisp.o)

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 30 09:36:06 2003

> * In message <[email-masked]>
> * On the subject of "trouble with clisp-2.30-i686-unknown-linux-2.4.18-10.tar.gz"
> * Sent on Tue, 29 Apr 2003 01:10:08 -0700
> * Honorable [email-masked] (Don Cohen) writes:
>
> downloaded from

are you sure that there is no rogue libreadline.so in an odd place?
$ type libls
libls is a function
libls () 
{ 
    ls -Fs --color=tty `echo -e /lib\\\\n/usr/lib |cat - /etc/ld.so.conf |sed s.\$./$*.`
}
$ libls \*readline\*
ls: /lib/*readline*: No such file or directory
ls: /usr/kerberos/lib/*readline*: No such file or directory
ls: /usr/X11R6/lib/*readline*: No such file or directory
ls: /*readline*: No such file or directory
ls: /usr/lib/mysql/*readline*: No such file or directory
ls: /usr/lib/qt-3.0.5/lib/*readline*: No such file or directory
ls: /usr/lib/wine/*readline*: No such file or directory
ls: /usr/lib/qt-3.1/lib/*readline*: No such file or directory
ls: /usr/lib/sane/*readline*: No such file or directory
  12 /usr/lib/libguilereadline-v-12.a
   4 /usr/lib/libguilereadline-v-12.la*
   0 /usr/lib/libguilereadline-v-12.so@
   0 /usr/lib/libguilereadline-v-12.so.12@
  16 /usr/lib/libguilereadline-v-12.so.12.3.0*
 256 /usr/lib/libreadline.a
   0 /usr/lib/libreadline.so@
   0 /usr/lib/libreadline.so.4@
 176 /usr/lib/libreadline.so.4.3*

> I now try the source distribution from the same place and get the same
> result from the line above.  (Not quite but almost - no complaint

what about CVS head?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Old Age Comes at a Bad Time.