Subject: [clisp-list] task proposal: find missing 'implementation-dependent' issues

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Tue May 13 08:56:15 2003

Hi,

CLHS says in the glossary: "A conforming implementation is encouraged (but not required) to document its treatment of each item in this specification which is marked implementation-dependent [...]". 

Indeed, CLISP's impnotes looks like a list, chapter by chapter, of all such items where CLHS says "is implementation-dependent".

However, impnotes first documented CLtL1, then CLtL2, and now ANSI-CL implementation-dependent issues. Therefore, some may be missing which were added in-between.

Is somebody willing to cross-check the current impnotes against possible clarifications?

BTW, impnotes was proof-read by me recently, resulting in several clarifications. Therefore, it would be wise to start reading from CVS or
http://cvs2.cons.org/ftp-area/clisp/snapshots/impnotes/
for this job.
The above URL is updated almost daily from CVS by Sam Steingold, thanks Sam!

For those who don't know yet ,the URL is one location of the split impnotes. Instead of one 1MB file, you can read it in smaller pieces in your browser.

I'm still collecting items where quality of impnotes could be improved. Feedback is welcome!

Thanks,
	Jörg Höhle.

---

From: Sam Steingold <[email-masked]>
Date: Tue May 13 09:28:29 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] task proposal: find missing 'implementation-dependent' issues"
> * Sent on Tue, 13 May 2003 17:55:46 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>

another task is to convert them to DocBook/EBNF.
the original text notes used BNF, then the bnf was converted to tables
(html&docbook).  Now that DocBook supports EBNF, someone has to look
for ::== and convert the tables and lists to DocBook/EBNF...

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Don't ascribe to malice what can be adequately explained by stupidity.