Subject: RE: [clisp-list] warning messages

From: "Justice, Randy -CONT(DYN)" <[email-masked]>
Date: Fri Feb 8 11:30:05 2002

Thank You

-----Original Message-----
From: Ram Krishnan [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:26 PM
To: Raymond Toy
Cc: Justice, Randy -CONT(DYN); [email-masked]
Subject: Re: [clisp-list] warning messages

On Friday, February 8, 2002, at 11:14 AM, Raymond Toy wrote:

>>>>>> "Randy" == DYN  <Justice> writes:
>
>     Randy> Thanks for your input.
>
>     Randy> Ok,  I missing some concept.
>     Randy> I don't know what a "special" variable is.  I'm trying to
>
> It means it has dynamic binding.  Look in a Lisp book or ask in
> comp.lang.lisp.

This is somewhat off-topic, but speaking of books on Lisp, Paul Graham, 
author of "ANSI Common Lisp", just recently released an on-line copy of 
his earlier work "On Lisp" which has been out of print for a long while. 
This is a great reference on Lisp (especially macros) and is available 
from: <http://www.paulgraham.com/onlisptext.html>

Enjoy.

-ram

---

From: Ram Krishnan <[email-masked]>
Date: Fri Feb 8 11:42:10 2002

Randy,

Another on-line reference "Basic Lisp Techniques" is a good introductory 
text, albeit a little Allegro CL centric.

<http://www.franz.com/resources/educational_resources/cooper.book.pdf>

It specifically talks about lexical and dynamic scope which should answer 
some of your questions.

Paul Graham's other book "ANSI Common Lisp" is a very good book as well - 
it's more of an introductory text than "On Lisp."

Regards,

-ram