Subject: [clisp-list] Debugger

From: "Justice, Randy -CONT" <[email-masked]>
Date: Mon, 8 Jan 2001 07:06:19 -0600

Is there a debugger that works with CLISP environment?

Randy

---

From: Sam Steingold <[email-masked]>
Date: 08 Jan 2001 10:06:17 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Debugger"
> * Sent on Mon, 8 Jan 2001 07:06:19 -0600
> * Honorable "Justice, Randy -CONT" <[email-masked]> writes:
>

in addition to the built-in CLISP debugger
(http://clisp.sourceforge.net/impnotes.html#debugger)
there is a GUI http://bewoner.dma.be/marclisp/intro.html

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Yeah, yeah, I love cats too... wanna trade recipes?

---

From: James Amundson <[email-masked]>
Date: Fri, 12 Jan 2001 10:31:10 -0600

> there is a GUI http://bewoner.dma.be/marclisp/intro.html

Have others had luck using the above-mentioned GUI with CLISP? I tried
about six months ago, but I simply couldn't get it to work. If others
have it working, I'll try again.

--Jim Amundson

---

From: Reini Urban <[email-masked]>
Date: Sat, 13 Jan 2001 04:58:10 +0200

> have it working, I'll try again.

hmm, doesn't seem to be good for my system either.
my bash (cygwin) seems to fail on internal function definitions today.

cd lispdebug-0.92/cfiles
/lisp/lispdebug-0.92/cfiles$ ./configure
./configure: 520: Syntax error: "(" unexpected

/lisp/lispdebug-0.92/cfiles$ head -n530 configure |tail
function exit_error ()
{
 echo "Failed to configure the interface"
 echo "ERROR::$1"
 exit -1
}

/lisp/lispdebug-0.92/cfiles$ autoconf
/lisp/lispdebug-0.92/cfiles$ ./configure
./configure: 520: Syntax error: "(" unexpected

/lisp/lispdebug-0.92/cfiles$ grep -n CAHCE *.in
configure.in:4:define([AC_CAHCE_SAVE],)dnl

/lisp/lispdebug-0.92$ ./install-clisp add /usr/local . /usr/local/lisp lisp
./install-clisp: 36: Syntax error: "(" unexpected

-- 
Reini Urban
http://xarch.tu-graz.ac.at/autocad/news/faq/autolisp.html