Subject: [clisp-list] help!!!

From: Moses Masenda <[email-masked]>
Date: Tue Dec 4 09:07:02 2001

Can somebody help me with this program? I would
appreciate it very much: 

Description
For this homework, you will need to download the Lisp
example program “GENETIC.CL” from
http://www.cs.washington.edu/research/metip/eaicl2.html.
All of your work should be done in this file. While
your work may be written and tested on any machine
using any Common Lisp, your program must load and run
successfully in CLISP on a CS UNIX machine for
complete credit.

1.        Write a new mutation (mutate3) that randomly
selects a position between 0 and 4 in the chromosome
and then rotates all of the cities to the RIGHT (not
left, as the handout originally stated) of the
position. Position 0 is before the first city,
position 1 is between city 1 and city 2, and so on.
For example, if you had the following chromosome:
     (portland spokane portland wenatchee spokane)
and you randomly chose position two (between spokane
and portland), then the mutation would be:
     (portland spokane wenatchee spokane portland)

.

2.    Write a new crossover (crossover2) that randomly
selects a position (x) between 0 and 4 in the
chromosome and a length (y) between 1 and (5 – x),
then replaces the y cities starting at position x in
chromosome B with the corresponding cities in
chromosome A. For example, if you had the following
chromosomes:
     A  (portland spokane portland wenatchee spokane)
     B  (seattle portland wenatchee bellingham
wenatchee)
and you randomly chose position two (between spokane
and portland) and length two, then the mutation would
be:
         (seattle portland portland wenatchee
wenatchee)

3.    Modify the code so that the new mutation and the
new crossover are considered along with the existing
two mutations and the one original crossover.

=====

Moses

Do not forget to entertain strangers, for by so doing some
people have entertained angels without knowing it.
-- Hebrews 13:2

http://masenda.isbad.net -> Check my website here

__________________________________________________
Do You Yahoo!?
Buy the perfect holiday gifts at Yahoo! Shopping.
http://shopping.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Tue Dec 4 10:31:02 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] help!!!"
> * Sent on Tue, 4 Dec 2001 09:06:03 -0800 (PST)
> * Honorable Moses Masenda <[email-masked]> writes:
>
> Can somebody help me with this program?

no.
we do _not_ do you homework.

if you have specific problems with CLISP, we will certainly help.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
I'd give my right arm to be ambidextrous.