Subject: [clisp-list] Re: 2.32 looms!

From: Douglas Philips <[email-masked]>
Date: Tue Dec 23 07:31:01 2003

On Tuesday, December 23, 2003, at 10:19AM, Sam Steingold <[email-masked]> wrote:

>>  > (do-external-symbols (sym (find-package "CHARSET"))
>>      (print sym)
>>      (make-encoding :charset (encoding-charset (symbol-value sym))))
>>
>> *** - EVAL: undefined function DO-EXTERNAL-SYMBOLS
>> 1. Break>
>
>you said you managed to build CLISP by commenting out some stuff, right?
>so use that image!

When I did that (I won't be back to being at that system until tomorrow :-( ) it printed many many strings (dozens) with no errors. I'm wondering if switching back to the commented out code (in type.lisp, the section that says there is now a faster version in C) might not shed some light.
I'll try again tomorrow with further debugging, but not sure what direction I should take that.

<D\'gou

---

From: Sam Steingold <[email-masked]>
Date: Tue Dec 23 08:09:01 2003

> * Douglas Philips <[email-masked]> [2003-12-23 10:30:08 -0500]:
>

1. get a working lispinit.mem - comment out whatever you want, just get
   an image (e.g., try the appended patch).

2. start CLISP with that image and evaluate the DO-EXTERNAL-SYMBOLS form
   I sent you the other day.
   it will print plenty of junk, but the last message before the error
   will tell you which encoding is missing on your system.

3. try the appended patch and see if that solves the original problem.

4. *OPTIONAL* install gnu libiconv and see if that solves the original
   problem.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
God had a deadline, so He wrote it all in Lisp.

--- type.lisp.~1.49.~	2003-07-22 19:42:26.104255800 -0400
+++ type.lisp	2003-12-22 10:57:31.654212800 -0500
@@ -1342,7 +1342,10 @@
   (defun get-charset-range (charset &optional maxintervals)
     (or (gethash charset table)
         (setf (gethash charset table)
-              (charset-range (make-encoding :charset charset)
+              (charset-range (if (and (symbolp charset)
+                                      (encodingp (symbol-value charset)))
+                                 (symbol-value charset)
+                                 (make-encoding :charset charset))
                              (code-char 0) (code-char (1- char-code-limit))
                              maxintervals))))
   ;; Fill the cache, but cache only the results with small lists of intervals.

---

From: Douglas Philips <[email-masked]>
Date: Tue Dec 23 14:04:06 2003

>    an image (e.g., try the appended patch).

The appended patch did not work.

I used the "fix" I posted a few days ago.

>    will tell you which encoding is missing on your system.

% ./clisp
   i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
   I I I I I I I      8     8   8           8     8     o  8    8
   I  \ `+' /  I      8         8           8     8        8    8
    \  `-+-'  /       8         8           8      ooooo   8oooo
     `-__|__-'        8         8           8           8  8
         |            8     o   8           8     o     8  8
   ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2003

[1]>   (do-external-symbols (sym (find-package "CHARSET"))
     (print sym)
     (make-encoding :charset (encoding-charset (symbol-value sym))))

CHARSET:ISO-2022-KR
CHARSET:MAC-ROMAN
CHARSET:CP1253
CHARSET:UNICODE-32-LITTLE-ENDIAN
CHARSET:UNICODE-16-LITTLE-ENDIAN
CHARSET:CP1254
CHARSET:MAC-SYMBOL
CHARSET:ISO-2022-JP
CHARSET:CP1255
CHARSET:MAC-THAI
CHARSET:CP1256
CHARSET:UTF-16
CHARSET:ISO-2022-CN
CHARSET:UNICODE-32-BIG-ENDIAN
CHARSET:UNICODE-16-BIG-ENDIAN
CHARSET:CP1257
CHARSET:MAC-UKRAINE
CHARSET:NEXTSTEP
CHARSET:MAC-CYRILLIC
CHARSET:TIS-620
CHARSET:CP861-IBM
CHARSET:CP865-IBM
CHARSET:CP869-IBM
CHARSET:MAC-CENTRAL-EUROPE
CHARSET:CP869
CHARSET:KOI8-U
CHARSET:UCS-2
CHARSET:CP1133
CHARSET:CP949
CHARSET:CP852-IBM
CHARSET:UCS-4
CHARSET:KOI8-R
CHARSET:EUC-TW
CHARSET:CP860
CHARSET:EUC-JP
CHARSET:CP861
CHARSET:BIG5
CHARSET:ISO-8859-9
CHARSET:CP862
CHARSET:CP775
CHARSET:EUC-KR
CHARSET:CP863
CHARSET:MAC-DINGBAT
CHARSET:ISO-8859-8
CHARSET:CP864
CHARSET:MAC-HEBREW
CHARSET:MULELAO-1
CHARSET:CP865
CHARSET:CP866
CHARSET:ISO-2022-JP-1
CHARSET:CP860-IBM
CHARSET:CP864-IBM
CHARSET:TCVN
CHARSET:ISO-8859-3
CHARSET:ISO-8859-2
CHARSET:ISO-2022-JP-2
CHARSET:ISO-8859-1
CHARSET:CP737
CHARSET:MAC-ARABIC
CHARSET:ISO-8859-7
CHARSET:ISO-8859-6
CHARSET:ARMSCII-8
CHARSET:ISO-8859-5
CHARSET:ISO-8859-4
CHARSET:GB18030
CHARSET:WINDOWS-1258
CHARSET:GBK
CHARSET:ISO-8859-16
CHARSET:UNICODE-32
CHARSET:KOI8-RU
CHARSET:WINDOWS-1255
CHARSET:JOHAB
CHARSET:ISO-8859-14
CHARSET:VISCII
CHARSET:ISO-8859-15
CHARSET:WINDOWS-1254
CHARSET:CP863-IBM
CHARSET:WINDOWS-1257
CHARSET:UNICODE-16
CHARSET:ISO-8859-13
CHARSET:HP-ROMAN8
CHARSET:WINDOWS-1256
CHARSET:BIG5-HKSCS
CHARSET:ISO-8859-10
CHARSET:WINDOWS-1251
CHARSET:WINDOWS-1250
CHARSET:WINDOWS-1253
CHARSET:WINDOWS-1252
CHARSET:UTF-8
CHARSET:GEORGIAN-PS
CHARSET:HZ
CHARSET:EUC-CN
CHARSET:MAC-GREEK
CHARSET:CP874-IBM
CHARSET:GEORGIAN-ACADEMY
CHARSET:CP950
CHARSET:CP1258
CHARSET:CP850
CHARSET:UTF-7
CHARSET:CP437
CHARSET:MAC-CROATIAN
CHARSET:MAC-ROMANIA
CHARSET:CP874
CHARSET:CP862-IBM
CHARSET:JIS_X0201
CHARSET:CP852
CHARSET:ASCII
CHARSET:ISO-2022-CN-EXT
CHARSET:CP932
CHARSET:CP855
CHARSET:MACINTOSH
CHARSET:SHIFT-JIS
CHARSET:CP857
CHARSET:CP1250
CHARSET:JAVA
CHARSET:CP936
CHARSET:CP1251
CHARSET:CP437-IBM
CHARSET:MAC-ICELAND
CHARSET:CP1252
CHARSET:MAC-TURKISH
NIL
[2]>

no error happened.

---

From: Sam Steingold <[email-masked]>
Date: Tue Dec 23 15:21:02 2003

So I was missing the point. sorry.
please try --with-debug, it will tell you which file/line signals the
error.
also, please run under gdb:
(gdb) break OS_error
(gdb) run -q -norc -B .
> (load "init.lisp")
(gdb) where
(gdb) zbacktrace

please use zout/xout to figure what is going on.

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
If you're beeing passed on the right, you're in the wrong lane.

---

From: Douglas Philips <[email-masked]>
Date: Mon Jan 12 05:38:00 2004

A long time ago (in internet time), on a keyboard far far away,

> please use zout/xout to figure what is going on.

Between the holidays and cranky (move me and I'll break. You did and I 
did) hardware, I haven't had the chance to look into this further, but 
I haven't forgotten.

Also, the machine I had running RedHat 8 is dead. The new machine will 
be running OpenBSD. Similarly my YellowDog 3 machine is also now 
running OpenBSD. From the looks of the OpenBSD mailing lists, there are 
some issues there, so hopefully I can help out with that too.

I hope to have my hardware issues resolved this week and be able to get 
back to this by the weekend.

<D\'gou