Subject: RE: [clisp-list] CLISP 2.30 compilation under cygwin errors.

From: Eric Moncrieff <[email-masked]>
Date: Tue Sep 17 06:35:01 2002

Same result:

bash-2.05b$ rm -rf build
bash-2.05b$ ./configure build
mkdir: cannot create directory
`/cygdrive/c/WINNT/Profiles/ericm/Personal/src/clisp-2.30/build/bindingsFIND
:': No such file or directory
bash-2.05b$ 

So maybe I trashed the source tree, I thought.  So I 

bash-2.05b$ cd ..
bash-2.05b$ rm -rf clisp-2.30
bash-2.05b$ bzip2 -dc clisp-2.30.tar.bz2 | tar xvf -
bash-2.05b$ cd clisp-2.30
bash-2.05b$ ./configure build
mkdir: cannot create directory
`/cygdrive/c/WINNT/Profiles/ericm/Personal/src/clisp-2.30/build/bindingsFIND
:': No such file or directory

Same result...

Eric

-----Original Message-----
From: Sam Steingold [mailto:[email-masked]]
Sent: Tuesday, September 17, 2002 9:27 AM
To: Eric Moncrieff
Cc: [email-masked]'
Subject: Re: [clisp-list] CLISP 2.30 compilation under cygwin errors.

> * In message <9160B867AADDD311AE7900C04F0649BB267258@IS~MAIL>
> * On the subject of "[clisp-list] CLISP 2.30 compilation under cygwin
errors."
> * Sent on Mon, 16 Sep 2002 11:21:54 -0400
> * Honorable Eric Moncrieff <[email-masked]> writes:
>
> I'm trying to compile CLISP 2.30 under WinNT4.0 with cygwin,
> and encountering the following error:
> 
> bash-2.05b$ mkdir build
> bash-2.05b$ ./configure build
> mkdir: cannot create directory

$ rm -rf build
$ ./configure build

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
I'm out of my mind, but feel free to leave a message...

---

From: Marco Baringer <[email-masked]>
Date: Tue Sep 17 08:42:06 2002

> :': No such file or directory

is CLISP trying to mkdir build/bindingsFIND without having mkdir'd
build? try changing line 278 of configure from

maybe_mkdir() { test -d "$1" || mkdir "$1"; }

to

makybe_mkdir() { test -d "$1" || mkdir -p "$1"; }

and see what happens.

-- 
-Marco
Ring the bells that still can ring.
Forget your perfect offering.
There is a crack in everything.
That's how the light gets in.
     -Leonard Cohen