Subject: [clisp-list] garnet install

From: "isaac councill" <[email-masked]>
Date: Tue, 15 May 2001 10:58:03 -0400

Hello all,

Thanks to the advice of Sam Steingold and Peter Wood, I now have a working nclx on my system.  Unfortunately, I still cannot get Garnet to load properly.  The people on the Garnet list have told me that the garnet-loader.lisp file requires modification to work with clisp, but couldn't tell me exactly what.  Though I have been able to make substantial progres (clisp loads about a third of the garnet files now, up from zero), I simply don't know enough about clisp, or lisp for that matter, to go the distance on this procedure.  Does anyone out there use garnet with clisp?  If so, what did you do to install it?  The roadblock that I am stuck on is the error:

*** -LISP: MAKE-ENCODING: illegal :OUTPUT-ERROR-ACTION argument 63548

This occurs upon the loading of a particular gadgets file, which I have not altered.  If anyone can translate this error message for me, that would be quite helpful as well.
    I am loading garnet-prepare-compile.lisp with the command:

clisp -K full -norc -i garnet-prepare-compile.lisp

which works nicely at the start.

Thanks,
Isaac

---

From: Sam Steingold <[email-masked]>
Date: 15 May 2001 11:13:24 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] garnet install"
> * Sent on Tue, 15 May 2001 10:58:03 -0400
> * Honorable "isaac councill" <[email-masked]> writes:
>
> The roadblock that I am stuck on is the error:
> 
> This occurs upon the loading of a particular gadgets file, which I
> have not altered.  If anyone can translate this error message for me,
> that would be quite helpful as well.  I am loading
> garnet-prepare-compile.lisp with the command:
> 

do

clisp -K full -norc -x '(load "garnet-prepare-compile.lisp" :print t)'

to find out which form generates the error.  if it's a load form, add
":print t" to it, as above.

when you have the exact form which generates the error, please send it
to clisp-list.

Good luck!

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
In C you can make mistakes, while in C++ you can also inherit them!

---

From: "isaac councill" <[email-masked]>
Date: Tue, 15 May 2001 12:32:06 -0400

By commenting out the loading of offending files one at a time, I found that
four files produce the exact same error.  Interestingly, these are
save-gadget.lisp, load-gadget.lisp, motif-save-gadget.lisp, and
motif-load-gadget.lisp.  When none of these files are loaded,
garnet-loader.lisp loads everything else.
    Attached are the 4 problematic files.

Thanks,
Isaac

----- Original Message -----
From: Sam Steingold <[email-masked]>
To: isaac councill <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, May 15, 2001 11:13 AM
Subject: Re: [clisp-list] garnet install

> _______________________________________________
> clisp-list mailing list
> [email-masked]
> http://lists.sourceforge.net/lists/listinfo/clisp-list
>

---

From: Sam Steingold <[email-masked]>
Date: 15 May 2001 18:43:06 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] garnet install"
> * Sent on Tue, 15 May 2001 12:32:06 -0400

I downloaded garnet src-2000-Mar-12.tar.gz and tried with the CVS
version.
I could load garnet-prepare-compile and garnet-loader without any
problems, and I got an error on garnet-compiler.
The error turned out to be a bug in nclx which I have just fixed.

I suggest that you get the CLISP from the CVS and try again.
garnet works out of the box for me with the current CLISP.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Daddy, why doesn't this magnet pick up this floppy disk?

---

From: Paolo Amoroso <[email-masked]>
Date: Wed, 16 May 2001 17:02:57 +0200

On Tue, 15 May 2001 10:58:03 -0400, Isaac Councill <[email-masked]> wrote:

> Does anyone out there use garnet with clisp?  If so, what did you do to
> install it?

A few months ago I was able to use Garnet with the then latest CLISP and
NCLX on Red Hat Linux. It still had some--apparently--minor problems, but I
was able to run most of the Garnet demos and tools.

I seem to remember that I didn't do anything fancy to compile it at the
time, but I am unable to provide more details now. If necessary, I can dig
up an old message summarizing my experience. I have been meaning to play a
bit more extensively with Garnet myself, but I currently don't have much
time.

Paolo
-- 
EncyCMUCLopedia * Extensive collection of CMU Common Lisp documentation
http://cvs2.cons.org:8000/cmucl/doc/EncyCMUCLopedia/