Subject: [clisp-list] Failure to build 2.29 on Sparc Sol 8/Gcc 3.1

From: Jeffrey Katcher <[email-masked]>
Date: Fri Jul 26 10:23:05 2002

System: Fujitsu GP7000F/400
OS: Solaris 2.8 MU7
Compiler: gcc 3.1

System successfully completes 'configure' (even
getting past previous gcc 3.1 stoppages).

Make builds all object code cleanly, but lisp.run seg
faults on 1st invocation.

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

---

From: Sam Steingold <[email-masked]>
Date: Fri Jul 26 14:10:03 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Failure to build 2.29 on Sparc Sol 8/Gcc 3.1"
> * Sent on Fri, 26 Jul 2002 10:22:47 -0700 (PDT)
> * Honorable Jeffrey Katcher <[email-masked]> writes:
>
good.

> Make builds all object code cleanly, 

do you have <sys/int_types.h>?  does it conflict with stdint.h?

> but lisp.run seg faults on 1st invocation.

oops!  can you try to debug it?

thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
The only thing worse than X Windows: (X Windows) - X

---

From: Jeffrey Katcher <[email-masked]>
Date: Fri Jul 26 14:18:02 2002

This system does have sys/int_types.h, but I didn't
notice any type conflicts in a quick exam.  

Before I debug, I'm trying to build a gcc 3.1.1 (which
contains fixes for a number of Sparc issues) which
I'll use to build clisp 2.29.

FYI, It does build and run well in my FreeBSD/Intel
environment using the system gcc 2.95.x compiler.

Jeff Katcher

---

From: Sam Steingold <[email-masked]>
Date: Fri Jul 26 14:58:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Failure to build 2.29 on Sparc Sol 8/Gcc 3.1"
> * Sent on Fri, 26 Jul 2002 14:17:40 -0700 (PDT)

yes, of course - I forgot that you are dealing with 2.29,
not the CVS devel version.

> Before I debug, I'm trying to build a gcc 3.1.1 (which contains fixes
> for a number of Sparc issues) which I'll use to build clisp 2.29.

interesting.

Could you please also try to build the current CVS head?
Thanks.

> environment using the system gcc 2.95.x compiler.

man, you _are_ versatile! Solaris 8, FreeBSD/Intel, FreeBSD/Alpha....
Could you please make the binaries available?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
A computer scientist is someone who fixes things that aren't broken.

---

From: Jeffrey Katcher <[email-masked]>
Date: Fri Jul 26 17:20:02 2002

I'd be happy to provide binaries from my working
versions.  Just let me know what procedure you'd like
me to follow.

I have Solaris 2.8/Sparc, FreeBSD/i386, &
FreeBSD/Alpha (my larger machines were purchased at
scrap prices on eBay).  Right now I have 2.29 Sparc &
FreeBSD/i386 working, both built with Gcc2.95.2. 
FreeBSD/Alpha is totally broken with 2.29 (crapping
out in the make in the segv handler test with all 3
compilers).  A Sparc GCC 3.1/3.1.1 build hasn't yet
happened.

Jeff

---

From: Sam Steingold <[email-masked]>
Date: Fri Jul 26 20:05:04 2002

> * In message <[email-masked]>
> * Sent on Fri, 26 Jul 2002 17:19:08 -0700 (PDT)
> I'd be happy to provide binaries from my working versions.
> Just let me know what procedure you'd like me to follow.

'make distrib' in your build directory and put the
        clisp-2.29-'platform-id'.tar,gz 
somewhere I could download it from.

> FreeBSD/Alpha is totally broken with 2.29 (crapping out in the make in
> the segv handler test with all 3 compilers).

I think this has been fixed in the CVS but not put into the 2.29.
Could you please check that the CVS head works on your platforms?

thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
I don't have an attitude problem. You have a perception problem.

---

From: Jeffrey Katcher <[email-masked]>
Date: Mon Jul 29 09:30:16 2002

clisp-2.29-sun4-sparc-sunos-5.8.tar.gz 
clisp-2.29-i386-i386-freebsd-4.6-STABLE.tar.gz

have been uploaded to
telia.dl.sourceforge.net/incoming.

If someone could move them to the appropriate place...

---

From: Sam Steingold <[email-masked]>
Date: Mon Jul 29 10:03:02 2002

> * In message <[email-masked]>
> * Sent on Mon, 29 Jul 2002 09:29:39 -0700 (PDT)

cool. which gcc? any tweaks?

> If someone could move them to the appropriate place...

I copied them to the usual CLISP distribution places.
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
I haven't lost my mind -- it's backed up on tape somewhere.