Subject: Re: [clisp-list] poll: DELETE-FILE return value

From: Douglas Philips <[email-masked]>
Date: Tue Feb 17 10:19:07 2004

On Tuesday, February 17, 2004, at 01:00PM, Sam Steingold <[email-masked]> wrote:
>2. return T when *ANSI* is T and truename otherwise.
>   (I think introducing an extra user variable for this is silly)

That seems the most sensible. If I were to get a vote, that would be my vote.

<D\'gou

---

From: Bruno Haible <[email-masked]>
Date: Mon Feb 23 05:47:05 2004

Marco Antoniotti wrote:

>>> Return T and the truename as a second value.
>>
>> this is not compliant either.
>> DELETE-FILE returns 1 value.
> 
> A conformant program would not break.

The program

  (length (multiple-value-list (delete-file "foo")))

would break.

See also CLHS section 1.6 "Language Extensions":

   An implementation must return exactly the number of return
   values specified by this standard unless the standard
   specifically indicates otherwise. 

Bruno