Subject: [clisp-list] CLISP FFI and Win32

From: "Alex Peake" <[email-masked]>
Date: Sun Jul 13 15:12:06 2003

I have been reading the FFI part of the "impnotes".

(Perhaps) naturally the examples of "executing" are UNIX based, which because I work in Windows are
a bit "alien" to me.

Does anyone have an example of building a simple call to a C function on the Windows platform
(compiling, linking and such)?

Is it possible to use a Dynamic Link Library (DLL)? Is it possible dynamically - the example seems
to suggest (but I do not follow exactly) that static linking is necessay? What is Lisp.a?

Thanks,

Alex

---

From: Sam Steingold <[email-masked]>
Date: Sun Jul 13 17:40:13 2003

> * In message <[email-masked]>
> * On the subject of "CLISP FFI and Win32"
> * Sent on Sun, 13 Jul 2003 15:12:15 -0700
> * Honorable "Alex Peake" <[email-masked]> writes:
>
> (Perhaps) naturally the examples of "executing" are UNIX based, which
> because I work in Windows are a bit "alien" to me.

get cygwin and build CLISP with

$ ./configure --with-mingw --with-module=regexp

you will get CLISP with a working module (and it will be a regular win32
executable without any run-time cygwin dependencies).

then, just follow the UNIXy examples in the impnotes and you will be
able to add modules of your own.

I hope Jorg will offer you a piece of his wisdom -- read his excellent
writeups (search mailing list archives).

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Small languages require big programs, large languages enable small programs.