Subject: [clisp-list] CVS and my set of patches

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Apr 24 05:29:05 2002

Hi,

> Please do not move any of the CLISP-related work into private e-mail.
> Remember, our private e-mail is not archived the same way the SF
Ok, I understand. I'm starting to use the patches section of SF.

> 3. please send the unified patches (-u); they are smaller and easier to read.
ok.

> > It causes me more work than if I throw all at once on you, but maybe
> > it's better for discussion.
> yes, please do keep the patches small.

> your patch breaks FOREIGN-ADDRESS-NULL in foreign1.lisp,
> but that's okay, I will fix that.
Thanks.
Actually, none of my patches really work, since they are fake
diffs. The code worked as a module (as posted to the list), then
I added lines by hand to subr.d, constsym.d, and copy&paste
from the module to foreign.d and foreign1.lisp.
I will not test every piece of a patch by seeing if CLISP still
compiles -- every change to constsym.d needs recompilation, and
we agreed on small patches.
This is reserved for the end (fix typo and copy&paste bugs).
Thanks again for smoothing things out.

The typical "thanks, bug now fixed in CVS" reply says:
>(be advised that between
>releases the CVS tree is very unstable and may not even build
>on your platform).
This is exactly why I feel I must stay away from CVS.
I feel a need for a stable platform.

I just noticed I did too much copy&paste:
constsym.d should contain LISPSYM lines, not LISPFUN.
LISPSYM(exec_with_stack,"%FOREIGN-ON-STACK",ffi)

Peter: sorry:
LISPFUNN(mark_invalid_foreign,1)
# { value1=T; mv_count=1; } broken
{ skipSTACK(1); value1=T; mv_count=1; }
I'll send the the real thing to the patches section of sourceforge
as soon as I beautify it.

> BTW, could you please send me your spvw.d patch against the CVS?
No yet rewritten.

> > > please do submit your FFI testsuite.
> are you sure you appended the whole patch?
The part 1 which goes into foreign.d. -- any problems there?
I never sent part 2 (foreign.tst) which still needs to be rewritten to use stable parts of the new FFI, not redefine-foreign-function history.

Regards,
	Jorg Hohle.

---

From: Sam Steingold <[email-masked]>
Date: Wed Apr 24 06:13:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] CVS and my set of patches"
> * Sent on Wed, 24 Apr 2002 14:26:49 +0200
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>

This is intended for the _users_.
You are a _developer_.

> I feel a need for a stable platform.

this is not fair.  this places too much burden on _me_.
you are turning me into QA for your code, on platforms which I don't
even have access to.

> LISPSYM(exec_with_stack,"%FOREIGN-ON-STACK",ffi)

this is ugly - C name too different from Lisp name.  I changed that.
unless you use the CVS, your future patches will not apply cleanly,
thus causing much aggravation to both of us.

> > BTW, could you please send me your spvw.d patch against the CVS?

please make it a priority: this is a bug fix, and as such it should
come before new features.

> The part 1 which goes into foreign.d. -- any problems there?

I have no idea what you are talking about here. Sorry.
I receive too much clisp mail to be able to track this down by hand.
Your e-mail does not have references (this is Outlook fault, right?),
so I cannot get the message you are replying to automatically,
and its subject is not too informative.
Please send the patch under discussion again.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.palestine-central.com/> <http://www.mideasttruth.com/>
Winners never quit; quitters never win; idiots neither win nor quit.