Subject: [clisp-list] clisp 2.30 and readline problems

From: "Vadim V. Zhytnikov" <[email-masked]>
Date: Fri Oct 18 06:17:02 2002

Hi!

I experience some readline related problems with clisp 2.30 CVS.
Pressing  Tab to get command completion always causes segfault.
As far as I can remember clisp 2.30  release notes mention
readline 4.3 but I have older readline 4.2a.  

-- 
     Vadim V. Zhytnikov

      <[email-masked]> 
     <[email-masked]>
     <[email-masked]>
    <[email-masked]>

---

From: Sam Steingold <[email-masked]>
Date: Fri Oct 18 07:08:04 2002

> * In message <[email-masked]>
> * On the subject of "clisp 2.30 and readline problems"
> * Sent on Fri, 18 Oct 2002 17:16:02 +0300
> * Honorable "Vadim V. Zhytnikov" <[email-masked]> writes:
>

is it release 2.30 or the current CVS head?
what is your platform?

> readline 4.3 but I have older readline 4.2a.  --

Could you please './configure --with-debug' and give me the backtrace?
Thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
He who laughs last thinks slowest.

---

From: Stefan Kain <[email-masked]>
Date: Fri Oct 18 13:11:04 2002

Hello,

I experienced the same problem.

> readline 4.3 but I have older readline 4.2a. 

After I had installed libsigsegv and readline 4.3 and recompiled
clisp, the problems disappeared.

I cannot say which one was the real problem solver,
the new libsigsegv or the new readline library.

Maybe give readline-4.3 a try, first. If the segmentation fault is still
triggered, compile with libsigsegv (1.8 is the current release)

Bye,
Stefan

---

From: "Vadim V. Zhytnikov" <[email-masked]>
Date: Sat Oct 19 10:26:01 2002

>is it release 2.30 or the current CVS head?
Both 2.30 release and CVS. My platform is
Linux 2.4.18, glibc 2.2.6, readline 4.2a, gcc 3.2.1

>Could you please './configure --with-debug' and give me the backtrace?
I'll try.

-- 
     Vadim V. Zhytnikov

      <[email-masked]> 
     <[email-masked]>
     <[email-masked]>
    <[email-masked]>

---

From: "Vadim V. Zhytnikov" <[email-masked]>
Date: Sat Oct 19 10:26:02 2002

> clisp, the problems disappeared.
Are you sure?  

Firstly, I also upgraded to redline 4.3 and rebuild clisp (cvs HEAD).
Sutuation improved a bit some segfaults dissapeared but not all.

Next I installed libsigsegv.  Fine, no segfaults!
But now I can see error (stack owerflow) which caused
these segfault without libsigsegv:

Script started on Sat Oct 19 14:43:08 2002
[vadim@proxl vadim]$ clisp
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2002

[1]> ab<TAB>
*** - Program stack overflow. RESET
[2]>

-- 
     Vadim V. Zhytnikov

      <[email-masked]> 
     <[email-masked]>
     <[email-masked]>
    <[email-masked]>

---

From: Sam Steingold <[email-masked]>
Date: Sat Oct 19 14:05:02 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] clisp 2.30 and readline problems"
> * Sent on Sat, 19 Oct 2002 21:24:45 +0300

I do not observe this (linux2.4.18, libc 2.2.93, rh8, no libsigsegv).
Could you please try to debug this a little bit?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
The difference between theory and practice is that in theory there isn't any.

---

From: Marco Antoniotti <[email-masked]>
Date: Wed Oct 23 12:01:04 2002

Hi

I just installed clisp 2.30 (tar.gz file from Sourceforge).

I get the following error.

==============================================================================
[marcoxa@tapulon ~]$ clisp
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

;; Loading file /home/marcoxa/.clisprc ...
;; Loaded file /home/marcoxa/.clisprc
[1]> (compile-file-pathname "foo.lisp")

*** - UNIX error 13 (EACCES): Permission denied
1. Break [2]> 
==============================================================================

Note that .clisprc is empty.  Is this known?

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
715 Broadway 10th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.