Subject: [clisp-list] avcall on hppa

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Mar 21 02:33:02 2002

Will Newton wrote:
> problem when I saw this in avcall.h.in:
> #if defined(__hppa__) && defined(__GNUC__) && (__GNUC_MINOR__ < 7)
>                                   __AV_OLDGCC_STRUCT_RETURN |
> #endif
> 
> I'm almost certain this is wrong. __GNUC_MINOR__ is the minor 
> version of GCC, so with 3.0.4 it is 0.

This code was written at a time when gcc-2.5.8, 2.6.x and 2.7.2 were in common use (gcc-2.7.0/1 were somewhat buggy IIRC).

I don't know what a good checking heuristic would be. Maybe drop the GNUC_MINOR check completely and hope old, once solved bugs don't reappear in gcc-3.x.y. Sometimes in history, simplification does wonders.

Regards,
	Jörg Höhle

---

From: Will Newton <[email-masked]>
Date: Thu Mar 21 04:19:02 2002

On Thursday 21 Mar 2002 10:18 am, you wrote:

> I don't know what a good checking heuristic would be. Maybe drop the
> GNUC_MINOR check completely and hope old, once solved bugs don't reappear
> in gcc-3.x.y. Sometimes in history, simplification does wonders.

This might work:

#if defined(__hppa__) && defined(__GNUC__) && (__GNUC__MAJOR__ < 3) && 
(__GNUC_MINOR__ < 7)
                                  __AV_OLDGCC_STRUCT_RETURN |
#endif

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 21 07:25:01 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] avcall on hppa"
> * Sent on Thu, 21 Mar 2002 12:20:04 +0000
> * Honorable Will Newton <[email-masked]> writes:
>

Actually, there is no __GNUC__MAJOR__.
__GNUC__ is the major version.
thanks for the bug report!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
When C++ is your hammer, everything looks like a thumb.