Subject: [clisp-list] Re: CLISP files usage question

From: Wong Tsun Hin John <[email-masked]>
Date: Mon, 27 Mar 2000 10:16:29 +0800 (HKT)

Thank you for your kind reply. =)
I've try out /usr/local/lib/full/lisp.run in xwin but got an error
message:
----------------------------------
/usr/local/lib/clisp/full/lisp.run
module `clx' requires package XPM.
----------------------------------

I'm sure I have the current xpm library installed. What's the problem?

Regards
	John

On Sun, 26 Mar 2000, Sam Steingold wrote:

> "John T. H. Wong" wrote:
> > 
> >     I've installed clisp and now learning lisp with it. It's fantastic!
> 
> I am glad to hear this!
> 
> >     I have one question that i can't find the answer from documentation
> > and the web site, i.e. the difference & usage of
> > /usr/local/lib/clisp/base and /usr/local/lib/clisp/full
> 
> base is the "base" build, which includes just the basic CL.
> fill includes many more modules, the exact set depends on your build.
> You can find out the difference by examining the *features* variable.
> 
> What system are you using? How did you build CLISP?
> if you did something like
> 
> ./configure --with-module=ABC --with-module=DEF --with-module=GHI
> 
> then base is just the vanilla CL and full contains ABC, DEF and GHI 
> in addition to the basic CL.
> 
> >     Can i remove any one of them?
> 
> they are independent, so you can remove one if you are only using the
> other.
> 
> If you are using CLISP, you should subscribe to clisp-list mailing list
> and ask 
> your questions there - this way more people are available to answer them
> and you
> might benefit from the questions others ask and answer.
> Please visit http://clisp.cons.org to subscribe to the list.
> 
> Happy Lisping!
>

---

From: Bruno Haible <[email-masked]>
Date: Mon, 27 Mar 2000 12:09:19 +0200 (MET DST)

> I've try out /usr/local/lib/full/lisp.run in xwin but got an error

The documented way to use a particular binary (see clisp.1 and clisp.html)
is through the "-K" option. Please try:

clisp -K full

Bruno

---

From: Sam Steingold <[email-masked]>
Date: 27 Mar 2000 10:05:12 -0500

>>>> In message <[email-masked]>
>>>> On the subject of "[clisp-list] Re: CLISP files usage question"
>>>> Sent on Sun Mar 26 21:22:07 EST 2000
>>>> Honorable Wong Tsun Hin John <[email-masked]> writes:

you are supposed to use the wrapper /usr/local/bin/clisp
to run CLISP, try `clisp --help` (you want -K option)

 >> module `clx' requires package XPM.

please specify
 - OS type and version (e.g., Solaris 2.5.1, Linux 2.2.4)
  - in case of Linux, the distribution name and version (e.g., RedHat 5.1)
 - CLISP version (e.g., 2000-03-06) and type (release or snapshot, if
   unsure, specify the place where you got it from)
 - How you compiled CLISP (the exact command line)
 - How you installed XMP

Thanks.

-- 
Sam Steingold (http://www.podval.org/~sds)
Micros**t is not the answer.  Micros**t is a question, and the answer is Linux,
(http://www.linux.org) the choice of the GNU (http://www.gnu.org) generation.
Don't use force -- get a bigger hammer.