Subject: [clisp-list] uniformative debugger w.r.t restarts (inconsistency)

From: lin8080 <[email-masked]>
Date: Thu Apr 11 17:49:02 2002

Betreff: 
        [clisp-list] uniformative debugger w.r.t. restarts
(inconsistency)
 Datum: 
        Thu, 11 Apr 2002 23:40:51 +0200
    Von: 
        lin8080 <[email-masked]>
     An: 
        "[email-masked]"
<[email-masked]>

Von: 
"Hoehle, Joerg-Cyril" <[email-masked]>
An: [email-masked]

Hi,

I found the help of the debugger w.r.t. restarts to be misleading:

2. Break [8]> (clhs 'car)
** - Continuable Error
SYSTEM::CLISP-DATA-FILE: file
#P"H:\\sspace\\src\\clisp-2.28\\data\\clhs.txt" does not
exist - adjust *LIB-DIRECTORY*
If you continue (by typing 'continue'): You may input a new value.
The following restarts are available, too:
R1 = You may input a new value.

The naive user now asks: "How to invoke that restart?"
----------------------------------------------

Hallo

When I do the (clhs 'car) command, it returns :

[28]> (clhs 'car)
;; Reading `C:\clisp\data\clhs.txt' [45,476 bytes]...done [0.61 sec]
BROWSE-URL: no browser specified; please point your browser at
 -->
<URL:file://C|/LISP/HYPER1/Front/X_Master.htm/Body/acc_carcm_cdr_darcm_cddd
dr.html>
NIL
[29]>

As a naive user I ask now: How can I invoke the browser ?
(netscape 4.7 on win98)

But Wow. It is frustrating, to know that there is a command, but to not
know, where to find documents. Also I found out how to get a copy from
the cl-dos-box :) so:

[32]> (clhs 'browser)

*** - No HyperSpec doc for `BROWSER'
1. Break [33]> abort

stefan

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Apr 11 18:42:02 2002

Hello, lin8080,

Friday, April 12, 2002, 11:38:49 AM, you wrote:

lin8080> As a naive user I ask now: How can I invoke the browser ?
lin8080> (netscape 4.7 on win98)
Naive users should use 'apropos'. See *browser* and *browsers*.
That's open an IE (but page doesn't open anyway - another bug...)

(push '(:IE "C:\Program Files\Plus!\Microsoft Internet\IEXPLORE.EXE" "~A") *browsers*)
(setf *browser* :IE)
(clhs 'apropos)

-- 
Best regards,
 Arseny