Subject: [clisp-list] ia64 build problems

From: Will Newton <[email-masked]>
Date: Thu Mar 21 07:34:05 2002

clisp is failing to build on ia64. The problem is in sigsegv, where test3.c 
seems to hit an infinite loop. Looking at the code it appears there is no 
provision for ia64 in the code, so it may not even be supported. ffcall does 
have ia64 support however.

Has clisp ever been built on ia64?

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 21 08:34:51 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] ia64 build problems"
> * Sent on Thu, 21 Mar 2002 15:35:10 +0000
> * Honorable Will Newton <[email-masked]> writes:
>
> clisp is failing to build on ia64. The problem is in sigsegv, where
> test3.c seems to hit an infinite loop. Looking at the code it appears
> there is no provision for ia64 in the code, so it may not even be
> supported. ffcall does have ia64 support however.
> 

dunno.  can you fix sigsegv?

PS.  Thanks for your patches - who are you?
     Why are you building CLISP on all these platforms?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
God had a deadline, so He wrote it all in Lisp.

---

From: Will Newton <[email-masked]>
Date: Thu Mar 21 09:13:23 2002

> dunno.  can you fix sigsegv?

I'll have a go, but I have never even seen a ia64 machine. :)

>      Why are you building CLISP on all these platforms?

New Debian maintainer of clisp. Trying to get it building on as many arches 
as possible so Debian 3.0 can ship with it.

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 21 09:34:04 2002

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] ia64 build problems"
> * Sent on Thu, 21 Mar 2002 16:49:55 +0000
thanks.

> New Debian maintainer of clisp. Trying to get it building on as many
> arches as possible so Debian 3.0 can ship with it.

cool!
when is Debian 3.0 due?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
A man paints with his brains and not with his hands.