Subject: [clisp-list] Re: Can McCLIM work with CLISP?

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Dec 17 08:07:10 2003

Hi,

Timothy Moore wrote:
>No, we use as much of the MOP as we can.
There's nothing wrong with that.

There was a time when CLISP had not built-in support for CLOS.
Back then, CLISP would simply load PCL, like CMUCL.

I wonder why nobody tries to make PCL work again with CLISP in case they need the MOP.

>McCLIM also works in a 
>non-threaded mode which only allows one application to run at a time.
That's enough for quite some situations, for a start.
I'd then probably miss CMUCL's ability to still serve GUI events *and* give me a listener prompt.
That has always been a very nice of CMUCL, and threading wasn't that much missed thanks to this feature.

Regards,
	Jorg.

---

From: Sam Steingold <[email-masked]>
Date: Wed Dec 17 08:37:03 2003

> * Hoehle, Joerg-Cyril <[email-masked]> [2003-12-17 17:04:45 +0100]:
>
> Timothy Moore wrote:

because native CLOS is faster?

> much missed thanks to this feature. 

I think this can be done in CLISP too - it just requires that the
low-level i/o go through a select().
any takers?

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Someone has changed your life.  Save? (y/n)