Subject: RE: [clisp-list] Still Problems compiling on HP

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Wed Apr 3 09:32:45 2002

I removed the.gdbinit file and then ran the command:

artn@bs742> gdb ./lisp.run
GNU gdb 5.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "hppa2.0-hp-hpux10.20"...(no debugging symbols
found)...
(gdb) run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load
\"init.lisp\") 
Starting program: /tmp_mnt/users/artn/clisp-2.28-CVS/src/./lisp.run -B . -N
locale -Efile UTF-8 -norc -m 750KW -x "(load \"init.lisp\")
(sys::%saveinitmem) (exit)"

But I never get a prompt back.  All I can do is kill it from another xterm.

Thanks for the help,

Art

> -----Original Message-----
> From: Will Newton [mailto:[email-masked]]
> Sent: Wednesday, April 03, 2002 9:58 AM
> To: [email-masked]
> Subject: Re: [clisp-list] Still Problems compiling on HP
> 
> 
> On Wednesday 03 Apr 2002 4:06 pm, Nuzzo Art-CINT116 wrote:
> 
> > Now it will just hang there.  I'm not sure if it is from 
> lisp.run or I did
> > something wrong when I compiled gdb or it is waiting for me to do
> > something.
> 
> The problem is that for some reason (I assume it is an error, 
> I cannot 
> believe it has any use) there is a .gdbinit file in the 
> source directory. To 
> make matters worse it is copied to the build directory also. 
> If you have the 
> time could you please try this:
> 
> (% is shell propmt, >> is gdb prompt)
> 
> % cd to wherever you are building, defaults to clisp-2.28/src
> % rm .gdbinit
> % gdb ./lisp.run
> >> run -B . -N locale -Efile UTF-8 -norc -m 750KW -x "(load 
> \"init.lisp\") 
> (sys::%saveinitmem) (exit)"
> 
> And see if that crashes - it should drop to the debugger with 
> SIGSEGV caught 
> or something along those lines.
> 
> If so please try:
> 
> >> backtrace
> 
> Hopefully that should print something.
> 
> NB: It would be really nice if someone would remove that 
> .gdbinit file, it 
> makes it a lot harder to get good bug reports.
>  
> 
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list
>

---

From: Will Newton <[email-masked]>
Date: Wed Apr 3 20:57:05 2002

> But I never get a prompt back.  All I can do is kill it from another xterm.

Very strange. Unfortunately my only PA-RISC machine has Linux on it so I 
can't test this.