Subject: [clisp-list] ffi under windows msvc6

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Thu Jan 9 06:04:04 2003

Hi,

Christian Schuhegger
>Extensions-2.3. The Foreign Function Call Facility
>which states that a foreign function description has to be 
>compiled with
>clisp and then compiled and linked against lisp.a. which file is the
>equivalent file of lisp.a on a windows system?

You don't need a lisp.a. What I regularly do is add to the msvc makefile a section like this:

################################ Joerg's gdi playground
GDIOBJECT = H:\Code\gdi\gdi.obj
lispg.exe : $(GDIOBJECT) $(REGEXDYNMODOBJECTS) $(OBJECTS) modules.obj avcall.lib callback.lib iconv.lib sigsegv.lib data
	$(RM) lisp.ilk
	$(CC) $(CFLAGS) $(CLFLAGS) $(GDIOBJECT) $(REGEXDYNMODOBJECTS) $(OBJECTS) modules.obj gdi32.lib $(LIBS) /link /out:lispg.exe
	editbin /stack:3145728 lispg.exe
################################

In other words, I modify the lisp.exe dependency and add some object files.

Of course, you must add one line defining your module to modules.h and regenerate modules.obj

Building lisp.a is a waste of space when you build CLISP yourself: It just contains all the .obj again. It would be of some use for binary distributions, allowing people to add modules without needing all the CLISP sources. Who needs/wants that?

>a little hello world example would be really helpful to 
>understand the ffi in clisp under windows.
I'll send you my MS-Word (can you read that?) text on building modules with CLISP.

Regards,
	Jörg Höhle.

---

From: Sam Steingold <[email-masked]>
Date: Thu Jan 9 06:54:02 2003

> * In message <[email-masked]>
> * On the subject of "ffi under windows msvc6"
> * Sent on Thu, 9 Jan 2003 15:02:54 +0100
> * Honorable "Hoehle, Joerg-Cyril" <[email-masked]> writes:
>

it would be nice if you could produce a version that could be put on
the CLISP web site.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Sufficiently advanced stupidity is indistinguishable from malice.