Subject: [clisp-list] Building CLISP Modules on Solaris 8

From: [email-masked]
Date: Wed Mar 20 05:08:07 2002

Greetings,

I ran into a problem building CLISP from CVS (19-March-2002) on
Solaris 8. The build fails when I try to build modules. I am
able to build these same modules (and my own) under GNU/Linux.

The gcc version is 2.95.3 and was obtained from the Sun Freeware
site.

Thanks !

Here are fragments from the build script and log:

configure --prefix=/usr/local/CLISP \
   --with-module=clx/new-clx \
   --with-module=regexp \
   --with-module=wildcard \
   sun

cd sun

./makemake  \
   --prefix=/usr/local/CLISP \
   --with-module=clx/new-clx \
   --with-module=regexp \
   --with-module=wildcard \
   --with-readline \
   --with-gettext \
   --with-dynamic-ffi > Makefile
.
.
.
make
.
.
.
uniq -u < minitests.out > minitests.output.sparcuniq -u < minitetest
   '!' -s minitests.output.sparc-sun-solaris2.temake:
*** [check] Error 1

The file sun/avcall/minitests.output.sparc-sun-solaris2.8 contains the 
following:

Int f(Int,Int,Int):({1},{2},{3})->{6}
Int f(Int,Int,Int):({1},{2},{3})->{9}
J f(J,int,J):({47,11},2,{73,55})->{120,68}
J f(J,int,J):({47,11},2,{73,55})->{9,902231815}

---

From: Sam Steingold <[email-masked]>
Date: Wed Mar 20 06:54:14 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Building CLISP Modules on Solaris 8"
> * Sent on Wed, 20 Mar 2002 08:07:32 -0500
> * Honorable [email-masked] writes:
>

if you use CLISP from CVS, you should subscribe to clisp-devel and post
there.

> The gcc version is 2.95.3 and was obtained from the Sun Freeware site.

are you sure this is not gcc 3?

> J f(J,int,J):({47,11},2,{73,55})->{9,902231815}

I think you can ignore these FFI problems.
the last command was something like
cd avcall && make && make check && make install ....
cut and paste removing "make check"

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Good programmers treat Microsoft products as damage and route around it.