Subject: [clisp-list] FW: Q: problem with RUN-PROGRAM and EXECUTE in Win32

From: [email-masked]
Date: Tue Feb 26 05:57:04 2002

> Thanks for suggestions from several individuals.  However, I am still
> unable to make run-program work to run a non-shell executable.  I am
> running version clisp-2.27-win32.
> 
> To summarize what I have tried, and what works and what doesn't:
> 
> > (cd) works (tells me what directory I am in).
> 
> > (cd "c:\\some\\path\\") works to change my directory
> 
> However, (run-program "myexe") does not work and always produces this
> error message 
> 
> *** - Win32 error 2 (ERROR_FILE_NOT_FOUND): The system cannot find the
> file specified.
> 
> regardless of whether the executable is in my current directory, or the
> exe is in the path, or whether the full path to the exe is specified in
> the run-program command.
> 
> I have tested this with a very simple C program that just writes a number
> to an output file (this exe works fine outside of CLISP).  
> 
> Also:  (run-program "dir" :indirect t) does not work and returns "INDIRECT
> is illegal for RUN-PROGRAM" error message.
> 
Given this, I thought I might have to use EXECUTE instead, but it does not
work properly either - I can make it run my executable once.  However, if I
try to run it again, I get this error:  

> *** - Win32 error 6 (ERROR_INVALID_HANDLE): The handle is invalid.
> 
I have tested EXECUTE with 2 simple programs, one which simply writes a
number to the screen, and one which writes a number to an output file, I get
this message for both executables when I try to run them more than once.  

Still not able to port my Unix code to Win32 :-(

Thanks for any further suggestions:

Tara
> *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  *  
> Tara C. Matise, Ph.D.           Associate Research Professor       
> Department of Genetics       732-445-3125 (P)
> Rutgers University              732-445-4972 (F)
>               [email-masked]
>               http://compgen.rutgers.edu
> 
> Nelson Biological Laboratories - B211
> 604 Allison Road
> Piscataway, NJ  08854-8082
>

---

From: Eduardo Muñoz <[email-masked]>
Date: Tue Feb 26 10:14:14 2002

> > *** - Win32 error 2 (ERROR_FILE_NOT_FOUND): The system cannot find the

Maybe this will help:
(I'm running Clisp on Windows 2000)

D:\Datos\Programacion\Lisp>clisp

[1]> (lisp-implementation-type)
"CLISP"
[2]> (lisp-implementation-version)
"2.27 (released 2001-07-17) (built on ssteingold.exapps.com
[172.23.101.12])"
[3]> (run-program "notepad.exe")
T
[4]> (cd "d:/datos/programacion/c++/arcom/bin/")
#P"D:\\datos\\programacion\\c++\\arcom\\bin\\"
[5]> (run-program "arcom.exe")

Arcom ® 2001 Eduardo Mu±oz
Uso: Arcom Fichero.prt
T
[6]> (exit)

D:\Datos\Programacion\Lisp>

Arcom.exe is a simple program written by me.

HTH

---

From: Sam Steingold <[email-masked]>
Date: Tue Feb 26 11:38:31 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] FW: Q: problem with RUN-PROGRAM and EXECUTE in Win32"
> * Sent on Tue, 26 Feb 2002 08:55:43 -0500
> * Honorable [email-masked] writes:
>
> > 
> Given this,

please be more proactive.
DESCRIBE will give you the list of acceptable keywords.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
There is Truth, and its value is T.  Or just non-NIL.  So 0 is True!