Subject: [clisp-list] two, now three interfaces to dynamic loading of libraries/objects

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Fri Apr 5 00:35:01 2002

Hi,

Sam wrote:
> IIUC, libltdl (part of GNU libtool) is exactly that:
I went to
http://www.gnu.org/software/libtool/manual.html#Using%20libltdl

I liked that:
o it says "a small C source file"
o lt_dlopen does reference counting itself, whereas FOREIGN.D
 (currently AMIGAOS only) implements its own lib-handle factory
 via O(foreign_libraries) to avoid multiple opens.

I felt it's a little over-engineered for my purpose. It provides 16 functions, search-path, its own module concept and more.

> * libtool's dlpreopen
I don't have plans to incorporate a thing which has yet again it's own module creation convention (modulename_LTX_ prefix to symbols).

> This is GNU libltdl, a system independent dlopen wrapper for 
> GNU libtool.
[many platforms ...]
> * load_add_on (BeOS)
> * GNU DLD (emulates dynamic linking for static libraries)

I guess it's probably as easy to integrate as sysdll.c. And it already contains autoconf stuff for UNIX. Wait and see what users report.

Regards,
	Jorg Hohle.

---

From: Reini Urban <[email-masked]>
Date: Tue Apr 9 05:18:04 2002

> I felt it's a little over-engineered for my purpose. It provides 16 functions, search-path, its own module concept and more.

true.

> I don't have plans to incorporate a thing which has yet again it's own module creation convention (modulename_LTX_ prefix to symbols).

hmm, but not that complicated.
since libtldl seems to support more platforms in the long run, I would vote
for libtldl.

> I guess it's probably as easy to integrate as sysdll.c. And it already contains autoconf stuff for > UNIX. Wait and see what users report.

IMHO the main advantage of the xemacs code over libtldl is the more liberal
license :)
but since rms forced bruno to use the GPL we don't need to care.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Peter Wood <[email-masked]>
Date: Thu Apr 11 07:03:19 2002

Hi,

On Tue, Apr 09, 2002 at 12:16:02PM +0000, Reini Urban wrote:

> IMHO the main advantage of the xemacs code over libltdl is the more liberal
> license :)

Xemacs is under the GPL.  libltdl is under the GNU library GPL.  In
fact, ltdl contains a 'special exception' which allows it to be
distributed under the same license terms as your program if your
program uses libtool.  So, in FACT, libltdl license is much more
liberal.

I personally would not be using Clisp if it was not under the GPL.

A LUTA CONTINUA! :-) 

Regards,
Peter