Subject: [clisp-list] clisp rpm oddness

From: Paul Heinlein <[email-masked]>
Date: Fri Mar 28 14:41:19 2003

I'm not a LISP hacker, but I needed to build[1] CLISP for a couple 
researchers here at OGI.

I grabbed the clisp-2.30.tar.gz tarball[2], read the documentation 
about building it on Unix, ran 'configure --help', and then built it. 
Everything went fine, and it passed the testsuite without error.

So I encapsulated my build instructions into a .spec file (anally, I 
tend to write my own, so I didn't use Sam's version in the 
distribution tree) and ran rpmbuild.

Ack! Errors (apparently at the beginning of streams.tst):

(MULTIPLE-VALUE-SETQ (A B) (VALUES 10 20)) 
EQL-OK: 10
B 
EQL-OK: 20
*** - handle_fault error2 ! address = 0x20324060 not in [0x201F4000,0x202E333C) !
SIGSEGV cannot be cured. Fault address = 0x20324060.
make[1]: *** [tests] Segmentation fault
make[1]: Leaving directory `/var/tmp/rpmbuild/clisp-2.30/src/suite'
make: *** [testsuite] Error 2

Experienced rpm builders will see that my %_builddir is set to
/var/tmp/rpmbuild, instead of the standard /usr/src/redhat/BUILD.

And *that* was the trouble:

  Build directory[3]    Result of 'make check'
  --------------------  ----------------------
  /tmp                  pass
  /var/tmp              pass
  /var/tmp/rpmbuild     fail
  /var/tmp/rpmbuil      pass
  /var/tmp/rpmbuilc     fail
  /var/tmp/rpmbuilcd    pass
  /var/tmp/xxxxxxxx     fail
  /var/tmp/xxxxxxx      pass

Any build in a directory named /var/tmp/<8 letters> failed.

Wierder, all those /var/tmp/rpmbuil* directories were actually the
same directory; I just renameded it between test builds. I even
deleted one incarnation of /var/tmp/rpmbuild and mkdir-ed another,
just for the heck of it. Same results. I tried mounting
/var/tmp/rpmbuild as a tmpfs volume. Same results. I tried the build
on a different, but similarly configured system. Same results.

I'm not a member of this list, but if someone could tell why the
testsuite fails in this manner -- be it my own mistake or not -- I'd
be much obliged.

+-----------------------------------------+----------------------+
| Paul Heinlein                           | [email-masked] |
| Research Systems Engineer               |      +1 503 748-1472 |
| Dept. of Computer Science & Engineering | 20000 NW Walker Road |
| OGI School of Science & Engineering     |  Beaverton, OR 97006 |
| Oregon Health & Science University      |                  USA |
+-----------------------------------------+----------------------+

[1] Build host info:
    * Red Hat 8, fully patched, 2.4.18-27.8.0 i686
    * gcc 3.2
    * GNU libc 2.3.2
    * Intel(R) Pentium(R) 4 CPU 1.80GHz

[2] md5sum: 57a8688957ddb8914a8a3ebb6a7c8676

[3] There are no typos in any of the directory names.

---

From: Sam Steingold <[email-masked]>
Date: Fri Mar 28 16:54:29 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp rpm oddness"
> * Sent on Fri, 28 Mar 2003 14:40:11 -0800 (PST)
> * Honorable Paul Heinlein <[email-masked]> writes:
>

I do not observe this.

>   Build directory[3]    Result of 'make check'

wow!

what about /tmp/foo-bar-baz-zot?

could you please try debugging this?  I.e.,

$ ./configure --with-debug --build
<segfault>
$ gdb
> run
> (load "suite/tests")
> (run-all-tests)

(or something like that)

thanks.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
What's the difference between Apathy & Ignorance? -I don't know and don't care!