Subject: [clisp-list] Problem with install.lisp in Windows

From: Bill Clementson <[email-masked]>
Date: Fri Feb 22 10:22:14 2002

The install.lisp program (in CVS) creates a batch file for starting CLISP in Windows. However, if CLISP is installed in a directory that has spaces in it's name (e.g. - "c:\Program Files\clisp-2.27", the batch file will not work correctly. When a directory name has spaces in it, the entire path & file should be surrounded by quotes (e.g. - "c:\Program Files\clisp-2.27\lisp.exe" -B etc). Since Windows users typically install programs in the c:\Program Files\ directory, the install.lisp program should probably account for this. For the time being, the work-arounds are to do one of the following:

1. Install clisp in a directory where this is not an issue (e.g. - c:\clisp or c:\home\bin\clisp)
2. Manually modify the clisp.bat file that is created by the install.lisp program to include the quotes

--
Bill Clementson

---------------------------------
Do You Yahoo!?
Yahoo! Sports - Coverage of the 2002 Olympic Games

---

From: Sam Steingold <[email-masked]>
Date: Fri Feb 22 18:29:01 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Problem with install.lisp in Windows"
> * Sent on Fri, 22 Feb 2002 10:21:35 -0800 (PST)
> * Honorable Bill Clementson <[email-masked]> writes:
>
> The install.lisp program (in CVS) creates a batch file for starting
> CLISP in Windows. However, if CLISP is installed in a directory that
> has spaces in it's name (e.g. - "c:\Program Files\clisp-2.27", the
> batch file will not work correctly.

oops - my fault (I always put CLISP in c:/gnu/clisp)...
just fixed it in the CVS
thanks for such thorough testing!

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.2 GNU/Linux
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Lisp is a language for doing what you've been told is impossible. - Kent Pitman