Subject: [clisp-list] common-lisp-controller

From: Christophe Rhodes <[email-masked]>
Date: Sun, 29 Apr 2001 22:48:57 +0100

Dear all,

Has anyone (apart from me) tried to convince clisp to play ball with
common-lisp-controller[*]? I don't think it's terribly deep (basically,
it involves setting up a couple of logical hosts for pathnames, and
ensuring that defsystem is loaded) but I haven't managed; there seems
to be some discrepancy between the ways clisp and cmucl/sbcl treat
logical pathnames.

The last time I tried was in February, so this may have changed;
before trying again, I'd want to know that no-one else is quietly
sitting with a correctly-functioning common-lisp-controllerized clisp.

Cheers,

Christophe

[*] http://ww.telent.net/cliki/common-lisp-controller
-- 
Jesus College, Cambridge, CB5 8BL                           +44 1223 524 842
http://www-jcsu.jesus.cam.ac.uk/~csr21/                  (defun pling-dollar 
(str schar arg) (first (last +))) (make-dispatch-macro-character #\! t)
(set-dispatch-macro-character #\! #\$ #'pling-dollar)

---

From: Sam Steingold <[email-masked]>
Date: 30 Apr 2001 11:04:02 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] common-lisp-controller"
> * Sent on Sun, 29 Apr 2001 22:48:57 +0100
> * Honorable Christophe Rhodes <[email-masked]> writes:
>
> basically, it involves setting up a couple of logical hosts

I suspect you should look at
http://clisp.sourceforge.net/impnotes.html#parsename

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
War doesn't determine who's right, just who's left.

---

From: Marco Antoniotti <[email-masked]>
Date: Mon, 30 Apr 2001 16:09:06 -0400

> http://clisp.sourceforge.net/impnotes.html#parsename

Isn't *PARSE-NAMESTRING-ANSI* set to T when Clisp is started with the
ANSI switch?

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group	tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA			http://bioinformatics.cat.nyu.edu
	       "Hello New York! We'll do what we can!"
			Bill Murray in `Ghostbusters'.

---

From: Sam Steingold <[email-masked]>
Date: 30 Apr 2001 16:16:11 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] common-lisp-controller"
> * Sent on Mon, 30 Apr 2001 16:09:06 -0400
> * Honorable Marco Antoniotti <[email-masked]> writes:
>

yeah - so?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Those who can't write, write manuals.

---

From: Marco Antoniotti <[email-masked]>
Date: Mon, 30 Apr 2001 22:53:22 -0400

> X-Envelope-To: 	
> Cc: [email-masked], [email-masked]
> Reply-To: [email-masked]
> Mail-Copies-To: never
> From: Sam Steingold <[email-masked]>
> Date: 30 Apr 2001 16:16:11 -0400
> User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.103
> Content-Type: text/plain; charset=us-ascii
> Content-Length: 662
> 

Just asking.  It is not so clear in the docs.  At least not in the
#parsename bit.

Cheers