Subject: [clisp-list] def-call-in problem

From: "Hoehle, Joerg-Cyril" <[email-masked]>
Date: Wed Mar 27 08:40:10 2002

Peter Wood wrote:

> > Using 2.28 (well, CVS, actually)  on Gnu/Linux:

> > *** - The value of *terminal-io* was not a stream: #<closed 
> terminal-stream>. It has been changed to #<io terminal-stream>.

You're using CVS CLISP. Are you sure it's ok?, esp. the dribble change?

The message appears when *terminal-io* was closed (for whatever reason) and when later on, an attempt is made to use it. For example, all ancient streams are closed when an image restarts. Then CLISP reinitializes *terminal-io* to a new terminal stream.

> Has anyone tried it?
Not yet. And I have no CLISP on UNIX. So on Ms-Windows, I wouldn't run the clisp-link script.

Regards,
	Jorg Hohle.

---

From: Peter Wood <[email-masked]>
Date: Wed Mar 27 10:25:04 2002

Hi

> You're using CVS CLISP. Are you sure it's ok?, esp. the dribble change?

I am sure it's NOT ok.  It is breaking in both 2.28 (with the dribble
bug) and a clisp with the dribble bug fixed (CVS - approximately 3
days old).  I am just rebuilding 2.27 now, and will try it there too.

> The message appears when *terminal-io* was closed (for whatever reason) and when later on, an attempt is made to use it. For example, all ancient streams are closed when an image restarts. Then CLI…

OK.  I take it nothing in the code jumped out at you as being a
sigsegv culprit.

By the way, I enjoyed reading your article on Extending Clisp.  I am
still digesting it.  On page 2, you have a TODO comment regarding 'mit
Kanonen auf Spatzen schiessen' ... if it means 'shooting sparrows with
a cannon', as I believe, then the English idiom is probably 'using a
sledgehammer to crack a nut'.  The Danes have an identical saying to
the German, but I have lived here so long, I had to ask a Danish
friend living in England!! what the English version might be.

Regards,
Peter

---

From: Peter Wood <[email-masked]>
Date: Wed Mar 27 10:59:33 2002

On Wed, Mar 27, 2002 at 07:10:02PM +0100, Peter Wood wrote:

>  I am just rebuilding 2.27 now, and will try it there too.

I get the same result with 2.27, both with my module, and the test
described earlier: the *terminal-io* message followed by a segfault:

*** - The value of *TERMINAL-IO* was not a stream: #<CLOSED TERMINAL-STREAM>. It has been changed to #<IO TERMINAL-STREAM>.
*** - handle_fault error2 ! address = 0xFFFFFFF8 not in [0x68084260,0x680A5000) !
SIGSEGV cannot be cured. Fault address = 0xFFFFFFF8.
/usr/bin/clisp-link: line 2: 18450 Segmentation fault      (core dumped) "$@"

Regards,
Peter