Subject: [clisp-list] editor-name ?

From: Pascal Bourguignon <[email-masked]>
Date: Fri May 30 20:53:03 2003

There  is this strange  behavior of  system::editor-name which  is not
even coherent with its source in edit.lisp:

[46]> system::*editor*
"emacsclient --no-wait"
[47]> (system::editor-name)
"emacsclient"
[48]> custom::*editor*
"emacsclient --no-wait"
[49]> (custom::editor-name)

What's the difference  between system::*editor* and custom::*editor* ?
None it seems. But then, it's even worse for system::editor-name:

[51]> (setq custom::*editor* "toto")
"toto"
[52]> system::*editor*
"toto"
[53]> (system::editor-name)
"emacsclient"

I think I'll  write my own ED function... We must  wait when editing a
function, but when  editing a file, I'd prefer  being able to continue
using clisp.

[54]> (lisp-implementation-version)
"2.30 (released 2002-09-15) (built on thalassa.informatimago.com [213.220.35.225])"

-- 
__Pascal_Bourguignon__                   http://www.informatimago.com/
----------------------------------------------------------------------
Do not adjust your mind, there is a fault in reality.

---

From: Sam Steingold <[email-masked]>
Date: Mon Jun 2 10:28:30 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] editor-name ?"
> * Sent on Sat, 31 May 2003 05:49:27 +0200 (CEST)
> * Honorable Pascal Bourguignon <[email-masked]> writes:
>

none:

(eq 'system::*editor* 'custom::*editor*)
T

> But then, it's even worse for system::editor-name:
> 

editor-name is defined in config.lisp like this:

(defun editor-name () (or (getenv "EDITOR") *editor*))

it is up to you to edit config.lisp to your tastes.

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
The only substitute for good manners is fast reflexes.

---

From: Pascal Bourguignon <[email-masked]>
Date: Mon Jun 2 14:40:03 2003

> it is up to you to edit config.lisp to your tastes.

Thank you.