Subject: Re: [clisp-list] garnet install

From: "isaac councill" <[email-masked]>
Date: Tue, 15 May 2001 15:34:29 -0400

Below is a sample of problematic code.  

;line# ->
(:DIR-INPUT ,GARNET-GADGETS:SCROLLING-LABELED-BOX
      (:LEFT ,(o-formula (gvl :parent :left) 10))
      (:TOP ,(o-formula (gvl :parent :top) 24))
      (:WIDTH ,(o-formula (gvl :parent :min-gadget-width) 240))
      (:MIN-FRAME-WIDTH NIL)
      (:FIELD-FONT ,(o-formula (gvl :parent :dir-input-field-font)))
      (:FIELD-OFFSET 0)
      (:LABEL-OFFSET 5)
      (:LABEL-FONT ,(o-formula (gvl :parent :dir-input-label-font)))
      (:GROW-P T)
      (:LABEL-STRING "Directory:")
      (:VALUE ,(o-formula (directory-namestring
   (truename (gvl :parent :initial-directory)))))
      (:SELECTION-FUNCTION Update-File-Menu))

The commas seem to be really messing with clisp's understanding of what should happen here.  When I run this in the garnet-load procedure, clisp complains of an illegal operation: commas are not allowed outside of back-quote.  When I remove the commas, there is a problem of an expected comma before SCROLLING-LABELED-BOX.  I place a comma immediately before SCROLLING-LABELED-BOX and then I get the message:

*** - READ from
    #< BUFFERED FILE-STREAM CHARACTER
        #P"FOO/save-gadget.lisp" @line#>:

    #<PACKAGE GARNET-GADGETS> has no external symbol with name " "

Can anyone see in this code what problem clisp might have with it?  The full file is attached to previous message.

Thanks,
Isaac

---

From: Sam Steingold <[email-masked]>
Date: 15 May 2001 16:17:43 -0400

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] garnet install"
> * Sent on Tue, 15 May 2001 15:34:29 -0400
> * Honorable "isaac councill" <[email-masked]> writes:
>
> The commas seem to be really messing with clisp's understanding of
> what should happen here.  When I run this in the garnet-load
> procedure, clisp complains of an illegal operation: commas are not
> allowed outside of back-quote.

commas _are_ illegal outside of backquote, so this cannot be a
top-level form.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
MS Windows: error: the operation completed successfully.