Subject: [clisp-list] Re: saveinitmem bug

From: Bernard Urban <[email-masked]>
Date: Mon Oct 22 01:24:06 2001

Sam Steingold writew:
> this appears to have been fixed in the current sources.
> could you please try CVS?

Sorry, same problem with current CVS:

Original lispinitmem:
(lisp-implementation-version)
"2.27.2 (released 2001-10-05) (built 3212500507) (memory 3212500696)"

After saveinitmem:
(lisp-implementation-version)

*** - Date incorrecte : 500507/0/507, 0h0m0s, heure NIL

Notice that I use a french locale, if that matters.

-- 

Bernard Urban

---

From: Sam Steingold <[email-masked]>
Date: Tue Oct 23 06:57:06 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Re: saveinitmem bug"
> * Sent on 19 Oct 2001 19:27:24 +0200
> * Honorable Bernard Urban <[email-masked]> writes:
>
> Sam Steingold writew:

could you please try the C locale?
please describe your system (OS,HW,C compiler, libc version &c).

$ clisp -q -norc -x '(saveinitmem "foo")'
1029880 ;
524288
$ clisp -q -norc -B build -M foo.mem -x '(lisp-implementation-version)'
"2.27.2 (released 2001-10-05) (built 3212404253) (memory 3212833923)"

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Of course, I haven't tried it. But it will work. [Isaak Asimov]

---

From: Bernard Urban <[email-masked]>
Date: Tue Oct 23 09:44:07 2001

> "2.27.2 (released 2001-10-05) (built 3212404253) (memory 3212833923)"

ramses@merceron:~/src/Lisp/clisp-2.28beta/clisp/build$ echo $LANG
fr_FR@euro
ramses@merceron:~/src/Lisp/clisp-2.28beta/clisp/build$ uname -a
Linux merceron 2.4.5 #1 Wed Jul 18 13:34:14 CEST 2001 i686 unknown
ramses@merceron:~/src/Lisp/clisp-2.28beta/clisp/build$ dpkg --status libc6
Package: libc6
Status: install ok installed
Priority: required
Section: base
Installed-Size: 12636
Maintainer: Ben Collins <[email-masked]>
Source: glibc
Version: 2.2.4-3
Replaces: ldso (<= 1.9.11-9), timezone, timezones, gconv-modules, libtricks, libc6-bin, netkit-rpc, netbase (<< 4.0)
Provides: glibc-2.2.4-3
Suggests: locales, glibc-doc
Conflicts: strace (<< 4.0-0), libnss-db (<< 2.2-3), timezone, timezones, gconv-modules, libtricks, libc6-doc, libc5 (<< 5.4.33-7), libpthread0 (<< 0.7-10), libc6-bin, libwcsmbs, apt (<< 0.3.0), libglib1.2 (<< 1.2.1-2), libc6-i586, libc6-i686, libc6-v9, netkit-rpc
Conffiles:
 /etc/default/devpts fc857c5ac5fb84d80720ed4d1c624f6e
Description: GNU C Library: Shared libraries and Timezone data
 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C library
 and the standard math library, as well as many others.
 Timezone data is also included.

ramses@merceron:~/src/Lisp/clisp-2.28beta/clisp/build$ dpkg --status gcc
Package: gcc
Status: install ok installed
Priority: standard
Section: devel
Installed-Size: 52
Maintainer: Debian GCC maintainers <[email-masked]>
Source: gcc-defaults (0.13)
Version: 2:2.95.4-6
Provides: c-compiler
Depends: cpp (>= 2:2.95.4-6), gcc-2.95, cpp-2.95
Recommends: libc-dev
Suggests: make, manpages-dev, autoconf, automake, libtool, flex, bison, gdb
Description: The GNU C compiler.
 The default GNU C compiler for Debian GNU/Linux systems.
 .
 This is currently version 2.95.4 for this architecture (i386).

and with LANG=C, same problem with message:

*** - incorrect date: 500507.0.507, 0h0m0s, time zone NIL

To obtain proper localization, I compiled clisp-2.28 with LANG=fr_FR@euro.

Regards.

-- 

Bernard Urban

---

From: Sam Steingold <[email-masked]>
Date: Tue Oct 23 12:34:19 2001

> * In message <[email-masked]>
> * On the subject of "Re: [clisp-list] Re: saveinitmem bug"
> * Sent on 23 Oct 2001 18:43:26 +0200

I just fixed this in the CVS.  thanks for reporting the bug
the reproducible case is:

$ ./lisp.run -B . -q -norc -M lispinit.mem -x '(lisp-implementation-version)(saveinitmem "foo")'
"2.27.2 (released 2001-10-05) (built 3212404253) (memory 3212845079)"
1030112 ;
524288
$ ./lisp.run -B . -q -norc -M foo.mem --version
GNU CLISP 
*** - incorrect date: 404253.0.253, 0h0m0s, time zone NIL

> To obtain proper localization, I compiled clisp-2.28 with LANG=fr_FR@euro.

what does this mean?

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
If you want it done right, you have to do it yourself