Subject: [clisp-list] clisp apparently hangs

From: Nico <[email-masked]>
Date: Fri Jan 25 14:59:01 2002

Out of boredom I ran the following on CLISP today

(load "aima.lisp")
(aima-load 'all)
(dotimes (n 100) (test 'all) (format t "~%Test number = ~A~%" (1+ n)))

to 'stress' test CLISP. The AIMA package is the lisp source code from
the book
Artificial Intelligence: A Modern Approach by Peter Norvig and Stuart
Russell
(available on the web).
At some point it hangs and just eats up processor time.
I tried this on Windows NT4.0 and FreeBSD 4.5, both with Clisp 2.27.
I did not expect this. Any explanations for this ?

Nico Swart.

---

From: Sam Steingold <[email-masked]>
Date: Fri Jan 25 17:31:01 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp apparently hangs"
> * Sent on Fri, 25 Jan 2002 17:34:26 -0500
> * Honorable Nico <[email-masked]> writes:
>

please figure out which form hangs CLISP and create a stand-alone test.
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Save your burned out bulbs for me, I'm building my own dark room.

---

From: Sam Steingold <[email-masked]>
Date: Sat Jan 26 11:47:02 2002

> Out of boredom I ran the following on CLISP today

if you have nothing better to do with your time,
maybe you could write some code for us?
See <http://clisp.cons.org>  -->  Tasks
(<http://sourceforge.net/pm/?group_id=1355>)

> (aima-load 'all)
you forgot (aima-compile)
> (dotimes (n 100) (test 'all) (format t "~%Test number = ~A~%" (1+ n)))

with the current CVS CLISP on a nt4sp6 400MHz,

> (time (test 'all))
...
Real time: 65.204 sec.
Run time: 39.67705 sec.
Space: 55824376 Bytes
GC: 36, GC time: 19.588167 sec.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
MS: Brain off-line, please wait.