Subject: [clisp-list] linux: unable to build with gettext

From: Arseny Slobodjuck <[email-masked]>
Date: Tue Mar 25 01:57:14 2003

Hi,

  Alexander Semashko told me he was unable to build clisp 2.30 (not
  CVS) under Linux (Alt Linux) with gettext. I.e. clisp builds, but
  *features* doesn't contain GETTEXT. He uses gettext  0.11.5.  He
  claims that there's no -DNO_GETTEXT in makefile. How can it be ?
  I have no problem with FreeBSD & clisp CVS.

-- 
Best regards,
 Arseny                          mailto:[email-masked]

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 25 07:10:37 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] linux: unable to build with gettext"
> * Sent on Tue, 25 Mar 2003 18:08:58 +1000
> * Honorable Arseny Slobodjuck <[email-masked]> writes:
>
>   claims that there's no -DNO_GETTEXT in makefile. How can it be ?  I
>   have no problem with FreeBSD & clisp CVS.

$ grep -i gettext config.log
configure:4535: checking for xgettext
configure:4563: result: /usr/bin/xgettext
configure:4673: checking for GNU gettext in libc
ac_cv_path_XGETTEXT=/usr/bin/xgettext
gt_cv_func_gnugettext2_libc=yes
XGETTEXT='/usr/bin/xgettext'
#define HAVE_DCGETTEXT 1
#define HAVE_GETTEXT 1
$

what does he have there?

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
There are two kinds of egotists: 1) Those who admit it  2) The rest of us

---

From: Arseny Slobodjuck <[email-masked]>
Date: Thu Mar 27 05:14:25 2003

Hello Sam,

> what does he have there?

He has

configure:4261: checking for xgettext
configure:4289: result: /usr/local/bin/xgettext
configure:4399: checking for GNU gettext in libc
ac_cv_path_XGETTEXT=/usr/local/bin/xgettext
gt_cv_func_gnugettext2_libc=yes

#define HAVE_GETTEXT 1
#define HAVE_DCGETTEXT 1

Does it tell you something ?

---

From: Sam Steingold <[email-masked]>
Date: Thu Mar 27 06:47:20 2003

> * In message <[email-masked]>
> * On the subject of "Re[2]: [clisp-list] linux: unable to build with gettext"
> * Sent on Thu, 27 Mar 2003 18:16:43 +1000

src/lispbibl.d:
# Whether to use the GNU gettext library for internationalization:
#if defined(ENABLE_NLS) && !defined(NO_GETTEXT)
  #define GNU_GETTEXT
#endif

src/spvw.d:

     #ifdef GNU_GETTEXT
      " :GETTEXT"
     #endif

i.e., he has to check for ENABLE_NLS too:

$ grep -i NLS config.log
configure:4647: checking whether NLS is requested
USE_NLS='yes'
#define ENABLE_NLS 1
$

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
You can have it good, soon or cheap.  Pick two...