Subject: [clisp-list] Database interfaces

From: "Rohan Nicholls" <[email-masked]>
Date: Thu Jan 17 01:35:05 2002

Hello,

I am enjoying using Clisp a lot, especially when integrated with emacs.  I have a question as a relative newbie, to both Lisp and Clisp in particular.

Does anyone know where I might find clisp database interfaces, mostly relational at this point as that is what I am running into a lot.  If not any ideas on where I might find information on how to create my own interface.  I will need any help I can get as it will be diving into previously unexplored territory.

Tia,

Rohan

---

From: Sam Steingold <[email-masked]>
Date: Thu Jan 17 06:41:14 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Database interfaces"
> * Sent on Thu, 17 Jan 2002 10:34:51 +0100
> * Honorable "Rohan Nicholls" <[email-masked]> writes:
>
> Does anyone know where I might find clisp database interfaces, mostly
> relational at this point as that is what I am running into a lot.  If
> not any ideas on where I might find information on how to create my
> own interface.  I will need any help I can get as it will be diving
> into previously unexplored territory.

UncommonSQL <http://alpha.onshored.com/lisp-software/> is one option.
CLISP PostgreSQL modules another.

-- 
Sam Steingold (http://www.podval.org/~sds)
Keep Jerusalem united! <http://www.onejerusalem.org/Petition.asp>
Read, think and remember! <http://www.iris.org.il> <http://www.memri.org/>
Lottery is a tax on statistics ignorants.  MS is a tax on computer-idiots.

---

From: Eric Marsden <[email-masked]>
Date: Thu Jan 17 07:03:09 2002

>>>>> "sam" == Sam Steingold <[email-masked]> writes:

  rn> Does anyone know where I might find clisp database interfaces, mostly
  rn> relational at this point as that is what I am running into a lot.  If
  rn> not any ideas on where I might find information on how to create my
  rn> own interface.  I will need any help I can get as it will be diving
  rn> into previously unexplored territory.

  sam> UncommonSQL <http://alpha.onshored.com/lisp-software/> is one option.
  sam> CLISP PostgreSQL modules another.

another is pg.lisp, which is a socket-level interface to PostgreSQL
(avoiding problems with FFI calls to the client-side C libraries). It
provides much less functionality than UncommonSQL, though: it just
returns the results of SQL queries sent as strings into Lisp objects.
You can get it from

   <URL:http://purl.org/net/emarsden/home/downloads>
  
-- 
Eric Marsden                          <URL:http://www.laas.fr/~emarsden/>