Subject: [clisp-list] Solaris 7/sun4m build problem

From: Ayan George <[email-masked]>
Date: Tue Apr 2 06:18:02 2002

Guys,

I'm trying to compile clisp 2.28 under Solaris 2.7.  As you can see, the
configure script fails after performing one of the minitests.

Here is the output of ``gcc -v'':

	Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.7/3.0.3/specs
	Configured with: ../configure --with-as=/usr/local/bin/as --with-ld=/usr/local/bin/ld
	Thread model: posix
	gcc version 3.0.3

Here is ``uname -a'':

	SunOS sol 5.7 Generic_106541-19 sun4m sparc SUNW,SPARCstation-10

What follows is the last 25 lines of the configure script output.  I
have placed an entire transscript at:

	http://www.ayan.net/clisp/configure.txt

Thanks in advanced.

/bin/sh ./libtool --mode=link gcc -o libcallback.la -rpath /usr/local/lib vacall_r/vacall.lo vacall_r/misc.lo vacall_r/structcpy.lo trampoline_r/*.lo
mkdir .libs
rm -fr .libs/libcallback.la .libs/libcallback.* .libs/libcallback.*
ar cru .libs/libcallback.a  vacall_r/vacall.o vacall_r/misc.o vacall_r/structcpy.o trampoline_r/cache-sparc.o trampoline_r/trampoline.o 
ranlib .libs/libcallback.a
creating libcallback.la
(cd .libs && rm -f libcallback.la && ln -s ../libcallback.la libcallback.la)
gcc -g -O2 -I. -I../../ffcall/avcall -S ../../ffcall/avcall/minitests.c
gcc -g -O2 -I. -I../../ffcall/avcall -c ../../ffcall/avcall/minitests.c
/bin/sh ./libtool --mode=link gcc -g -O2 -x none minitests.o libavcall.la -o minitests
gcc -g -O2 -x none minitests.o -o minitests  ./.libs/libavcall.a
./minitests > minitests.out
uniq -u < minitests.out > minitests.output.sparc-sun-solaris2.7
test '!' -s minitests.output.sparc-sun-solaris2.7
*** Error code 1
make: Fatal error: Command failed for target `check'

To continue building CLISP, the following commands are recommended
(cf. unix/INSTALL step 4):
    cd sol-build
    ./makemake  --with-readline --with-gettext > Makefile
    make config.lisp
    vi config.lisp
    make
    make check
root@sol:/usr/local/source_builds/clisp-2.28#

---

From: Ayan George <[email-masked]>
Date: Tue Apr 2 06:53:06 2002

There already appears to be a related thread.

Please ignore.

-Ayan

On Tue, 2 Apr 2002, Ayan George wrote:

> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list
>