Subject: [clisp-list] Help: Cannot compile

From: bruce <[email-masked]>
Date: Mon, 26 Mar 2001 17:34:49 +0800

Dear friends,

I just downloaded clisp-2.25, but I found myself not able to compile it 
on Debian-2.2r2.  When I run

./configure

It reports that my gcc is not working.  Why that'so?

Best!

-- 
Kaufman's First Law of Party Physics:
	Population density is inversely proportional
	to the square of the distance from the keg.

---

From: Matt Curtin <[email-masked]>
Date: 26 Mar 2001 09:36:25 -0500

>>>>> "bruce" == bruce  <[email-masked]> writes:

  bruce> It reports that my gcc is not working.  Why that'so?

Could you please provide some more detail?  Like the version of your
compiler? 

 $ gcc -v

The version of your system?

 $ uname -a

Results of a trivial C program compilation?

 $ cat <<EOF > foo.c
#include <stdio.h>

int main(void) {
  printf("Hello, world!\n");
}
EOF

 $ gcc -o foo foo.c

And if it compiles, what happens if you run it?

 $ ./foo
Hello, world!

-- 
Matt Curtin, Founder  Interhack Corporation  http://www.interhack.net/
"Building the Internet, Securely." research | development | consulting

---

From: bruce <[email-masked]>
Date: Tue, 27 Mar 2001 09:54:31 +0800

> Could you please provide some more detail?  Like the version of your

gcc version 2.95.2 20000220 (Debian GNU/Linux)

> The version of your system?

Linux My-hostname 2.2.18pre21 #1 Sat Nov 18 18:47:15 EST 2000 i686 unknown

>   printf("Hello, world!\n");

It cannot compile, because it cannot find stdio.h. 

I see now the reason. I've updated libc6 to version 2.2.2-1to use the 
latest XFree86-4 but didn't do so for libc6-dev.  The old libc6-dev was 
already uninstalled during updating.

Thanks a lot for your help.

Best!