Subject: [clisp-list] No input stream on argument line!

From: Pascal Bourguignon <[email-masked]>
Date: Sun Dec 15 10:46:02 2002

Why executing on argument line has no input stream?

[pascal@thalassa clisp]$ clisp -norc -q -x '(read-line)'

*** - READ: input stream #<INPUT STRING-INPUT-STREAM> has reached its end

[pascal@thalassa clisp]$ clisp -norc -q 

[1]> (read-line)
[1]> hello
"hello" ;
NIL
[2]> 

-- 
__Pascal_Bourguignon__                   http://www.informatimago.com/
----------------------------------------------------------------------
There is a fault in reality. do not adjust your minds. -- Salman Rushdie

---

From: Sam Steingold <[email-masked]>
Date: Sun Dec 15 11:29:02 2002

> * In message <[email-masked]>
> * On the subject of "[clisp-list] No input stream on argument line!"
> * Sent on Sun, 15 Dec 2002 19:45:02 +0100 (CET)
> * Honorable Pascal Bourguignon <[email-masked]> writes:
>

because -x binds *standard-input* to a STRING-INPUT-STREAM reading from
the -x argument.

> *** - READ: input stream #<INPUT STRING-INPUT-STREAM> has reached its end

$ clisp -norc -q -x '(read-line *terminal-io*)'
hello
"hello" ;
NIL
$

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat8 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
XFM: Exit file manager? [Continue] [Cancel] [Abort]