Subject: [clisp-list] new-clx-bug

From: Peter Wood <[email-masked]>
Date: Thu, 8 Mar 2001 22:34:17 +0100

Hi

$ clisp --version
CLISP 2000-03-06 (March 2000)

[2]> *features*
(:CLX-ANSI-COMMON-LISP :CLX :CLOS :LOOP :COMPILER :CLISP :CLTL2 :COMMON-LISP
  :INTERPRETER :LOGICAL-PATHNAMES :FFI :GETTEXT :UNICODE :BASE-CHAR=CHARACTER
  :PC386 :UNIX
)
[9]> (defun beep (hertz milisec)
  (let ((dsp (xlib:open-display "localhost")))
    (xlib:change-keyboard-control dsp 
				  :bell-pitch hertz 
				  :bell-duration milisec)
    (xlib:bell dsp)
    (xlib:display-finish-output dsp)
    (xlib:close-display dsp)))
BEEP
[10]> (beep 440 200)
*** - internal error: statement in file "clx.e", line 9656 has been reached!!
Please send the authors of the program a description how you produced this error!
1. Break [11]> 

It works in cmucl.  I recompiled clisp to use the old mit-clx and it
works fine, so I think it must be a bug in new-clx.

Regards,
Peter

---

From: Sam Steingold <[email-masked]>
Date: 18 Mar 2001 21:01:49 -0500

> * In message <[email-masked]>
> * On the subject of "[clisp-list] new-clx-bug"
> * Sent on Thu, 8 Mar 2001 22:34:17 +0100
> * Honorable Peter Wood <[email-masked]> writes:
>

if you look in the sources, you will see that this stems from the fact
that `xlib:change-keyboard-control' is not implemented.
actually, quite a few functions there are not implemented.

wanna give us a hand?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Computer are like air conditioners: they don't work with open windows!

---

From: Peter Wood <[email-masked]>
Date: 19 Mar 2001 09:24:49 +0100

> actually, quite a few functions there are not implemented.

I'll have a look. But don't hold your breath 'cause ...

> wanna give us a hand?

there's no project I'd rather help than clisp, but with my programming
abilities, you are probably better off without.

Regards,

Peter