Subject: [clisp-list] (no subject)

From: "Williams, Jack" <[email-masked]>
Date: Mon Aug 11 09:30:04 2003

I am trying to build clisp 3.30 on Solaris 9 and am not meeting with much success. The system that I am running may be configured for an ASCII rather than ISO character set.

The system is being build using gcc 2.95.3 from the Sun freeware cd included with the operating system.

LD_LIBRARY_PATH=/usr/lib:/opt/sfw/lib

Attempt with no options
./configure jw.test

...
executing /opt/home/jwilliam/lisp/clisp-2.30/jw.test/libcharset/configure --srcdir=../../libcharset --cache-file=../config.cache
loading cache ../config.cache
configure: syntax error at line 393: `(' unexpected

Since I suspect that Unicode issues could be involved, I tried a build with the --without-unicode option:

./configure --without-unicode jw.test2

...
executing /opt/home/jwilliam/lisp/clisp-2.30/jw.test2/libcharset/configure --srcdir=../../libcharset --without-unicode --cache-file=../config.cache
loading cache ../config.cache
configure: syntax error at line 393: `(' unexpected

I would appreciate any help you can provide on getting a working Solaris build.

Thanks,

Jack Williams

---

From: Sam Steingold <[email-masked]>
Date: Mon Aug 11 10:09:08 2003

> * In message <[email-masked]>
> * On the subject of "(no subject)"
> * Sent on Mon, 11 Aug 2003 10:45:45 -0500
> * Honorable "Williams, Jack" <[email-masked]> writes:
>

and what does jw.test/config.cache:393 look like?

I think you are stuck with a broken shell.
please try
$ CONFIG_SHELL=/bin/bash ./configure jw.test1

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
He who laughs last thinks slowest.