Subject: [clisp-list] Incorrect DEBUG_CLX test in CVS modules/clx/new-clx.clx.f

From: Barry Fishman <[email-masked]>
Date: Fri Oct 31 05:47:12 2003

I unsuccessfully tried posting this to gmane.lisp.clisp.devel.

The  dump_image() function is always being called.
A patch follows.

Note that the dump_image() function only displays little-endian
bitmaps correctly, such as those created with XLIB:READ-BITMAP-FILE.
It can probably be removed now that the problem being testing is
fixed.

Index: clx.f
===================================================================
RCS file: /cvsroot/clisp/clisp/modules/clx/new-clx/clx.f,v
retrieving revision 2.9
diff -c -r2.9 clx.f
*** clx.f	7 Oct 2003 17:48:47 -0000	2.9
--- clx.f	26 Oct 2003 20:36:47 -0000
***************
*** 4130,4136 ****
    fehler (error, "Sorry, my implementation of XLIB:PUT-IMAGE is still not complete.");
  }
  
! #if defined(DEBUG_CLX)
  /* from Barry Fishman <[email-masked]>
     http://article.gmane.org/gmane.lisp.clisp.general/7587  */
  void dump_image (XImage *image)
--- 4130,4136 ----
    fehler (error, "Sorry, my implementation of XLIB:PUT-IMAGE is still not complete.");
  }
  
! #if DEBUG_CLX
  /* from Barry Fishman <[email-masked]>
     http://article.gmane.org/gmane.lisp.clisp.general/7587  */
  void dump_image (XImage *image)

---

From: Sam Steingold <[email-masked]>
Date: Fri Oct 31 07:15:04 2003

> * Barry Fishman <[email-masked]> [2003-10-31 08:44:24 -0500]:
>

are you subscribed?

> The  dump_image() function is always being called.

thanks!

> bitmaps correctly, such as those created with XLIB:READ-BITMAP-FILE.

can you make it work with big-endian bitmaps too?
(not that I know whether this question makes any sense at all :-)

> It can probably be removed now that the problem being testing is

something tells me that this is not the last problem... :-(

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
I don't have an attitude problem. You have a perception problem.