Subject: [clisp-list] SIGSEGV in 2.29; format.lisp

From: Manuel Nunez <[email-masked]>
Date: Fri Aug 2 04:01:16 2002

Hi,

I am not able to compile CLISP 2.29 at work & home.
This is what I get at work:

;; Datei format.lisp wird geladen...
*** - handle_fault error2 ! address = 0xFFFFFF88 not in 
[0x68049180,0x680AB000) !
SIGSEGV kann nicht behoben werden. Fehler-Adresse = 0xFFFFFF88.
make: *** [interpreted.mem] Speicherzugriffsfehler (core dumped)
Command exited with non-zero status 2

The same happens at home: SIGSEGV & core dump when loading format.lisp.
I tried with optimization disabled, with optimization enabled + 
-fno-gcse, etc., the result is always the same.

Config at work:
   gcc -v
   Reading specs from /usr/lib/gcc-lib/i586-pc-linux-gnu/3.1.1/specs
   Configured with: ../gcc-3.1/configure --prefix=/usr
   --enable-languages=c,c++,java,f77
   Thread model: single
   gcc version 3.1.1

   libc is 2.1.1

   uname -a
   Linux feynmann.xxx 2.4.18-ngpt #7 SMP Don Jul 18 16:19:42 CEST
   2002 i586 unknown

   CPU is AMD K6

Config at home:

   gcc as above (3.1.1)

   libc is 2.2.5

   kernel 2.4.18 without patches

   CPU is PIII

Tried compiling with -g, but gdb backtrace seems not useful to me
(I'm not an expert) - only two frames visible when gdb ./lisp.run core,
last frame in context __setfpucw(_FPU_IEEE);. I beg pardon if this info
is not useful...
Please tell me if any other info neccessary.

Regards & tanks in advance,

   --manuel

---

From: Sam Steingold <[email-masked]>
Date: Fri Aug 2 08:21:06 2002

could you please try CVS head?

> * In message <[email-masked]>
> * On the subject of "[clisp-list] SIGSEGV in 2.29; format.lisp"
> * Sent on Fri, 02 Aug 2002 12:58:54 +0200
> * Honorable Manuel Nunez <[email-masked]> writes:
>
> Hi,
> 
> -------------------------------------------------------
> This sf.net email is sponsored by:ThinkGeek
> Welcome to geek heaven.
> http://thinkgeek.com/sf
> _______________________________________________
> clisp-list mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/clisp-list

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat7.3 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Small languages require big programs, large languages enable small programs.