Subject: [clisp-list] last built-in function

From: [email-masked]
Date: Sun Sep 2 19:32:01 2001

According to the common lisp hyperspec

	(last '(a.b) 0) => b

but clisp 2.27 on debian "potato" linux returns nil.

Cheers,
Andrew

---

From: Bruce <[email-masked]>
Date: Sun Sep 2 19:45:01 2001

> but clisp 2.27 on debian "potato" linux returns nil.

CLHS: If n is zero, the atom that terminates the list is returned.

CLISP implementation is conformant. Maybe you mean
      (last '(a . b) 0) => B
and that is what CLISP does.

Best!

-- 
Give your very best today.  Heaven knows it's little enough.