Subject: [clisp-list] (package-nicknames "KEYWORD")

From: Marco Antoniotti <[email-masked]>
Date: Sat, 25 Aug 2001 14:40:43 -0400

... returns ("").

While working with CL-XML, this causes problems.  Is the above
nickname conformant?

Cheers

BTW.  The same happens in CMUCL.

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.

---

From: Sam Steingold <[email-masked]>
Date: 25 Aug 2001 16:27:32 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] (package-nicknames "KEYWORD")"
> * Sent on Sat, 25 Aug 2001 14:40:43 -0400
> * Honorable Marco Antoniotti <[email-masked]> writes:
>
> .... returns ("").
> Is the above nickname conformant?

yes, why not?

> While working with CL-XML, this causes problems.  

it caused me no problems with CLLIB/xml.lisp

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Flying is not dangerous; crashing is.

---

From: Marco Antoniotti <[email-masked]>
Date: Sun, 26 Aug 2001 15:45:11 -0400

> Cc: [email-masked]
> Reply-To: [email-masked]
> Mail-Copies-To: never
> From: Sam Steingold <[email-masked]>
> User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.105
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.5
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <http://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <http://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://lists.sourceforge.net/archives//clisp-list/>
> Date: 25 Aug 2001 16:27:32 -0400
> X-Filter-Version: 1.7 (cat)
> Content-Length: 805
> 

I don't know.  I haven't checked the CLHS.  Looks like ACL, CMUCL and
CLisp do this, while MCL and LW return ().

> it caused me no problems with CLLIB/xml.lisp

CL-XML is a different package.

       http://homepage.mac.com/james_anderson/XML/

Cheers