Subject: [clisp-list] RE: Problem compiling on hp-ux 11.11

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Mon May 24 11:33:03 2004

Sure, no problem.  Here it is.

artn@bs713> gcc -o malloc unix/malloc.c
unix/malloc.c: In function `printf_address':
unix/malloc.c:13: warning: right shift count >= width of type
artn@bs713> for x in 1000000 100000 10000 1000; do ./malloc $x; done
malloc(1000000) = #x40003158
&main = #x400010A2
malloc(100000) = #x40003158
&main = #x400010A2
malloc(10000) = #x40003158
&main = #x400010A2
malloc(1000) = #x40003158
&main = #x400010A2
artn@bs713> rm -f malloc

> -----Original Message-----
> From: Sam Steingold [mailto:[email-masked]] 
> Sent: Monday, May 24, 2004 1:11 PM
> To: [email-masked]; Nuzzo Art-CINT116
> Cc: Bruno Haible
> Subject: Re: Problem compiling on hp-ux 11.11
> 
> 
> Thanks a lot!
> could you please aso do
> $ gcc -o malloc unix/malloc.c
> $ for x in 1000000 100000 10000 1000; do ./malloc $x; done
> $ rm -f malloc
> 
> thanks!
> 
> > * Nuzzo Art-CINT116 <[email-masked]> [2004-05-24 12:41:32 
> > -0500]:
> >
> > If I do the ./configure --prefix=/users/artn --build 
> build-O it does a 
> > core dump when it tries to run ./lisp.run
> >
> >
> > chmod +w config.lisp
> > echo '(setq *clhs-root-default* 
> "http://www.lisp.org/HyperSpec/")' >> 
> > config.lisp ./lisp.run -B . -Efile UTF-8 -Eterminal UTF-8 
> -norc -m 750KW -x "(and (load \"init.lisp\") 
> (sys::%saveinitmem) (ext::exit))"
> > make: *** [interpreted.mem] Bus error (core dumped)         
>                                                  
> >
> > Here is the backtrace:
> >
> > artn@bs713> gdb
> > GNU gdb 5.3
> > Copyright 2002 Free Software Foundation, Inc.
> > GDB is free software, covered by the GNU General Public 
> License, and 
> > you are welcome to change it and/or distribute copies of it under 
> > certain conditions. Type "show copying" to see the 
> conditions. There 
> > is absolutely no warranty for GDB.  Type "show warranty" 
> for details. 
> > This GDB was configured as "hppa2.0w-hp-hpux11.11". Breakpoint 1 at 
> > 0x3a30c Breakpoint 2 at 0x38d24
> > Breakpoint 3 at 0x37028
> > Breakpoint 4 at 0x3b62c
> > Breakpoint 5 at 0x28df0
> > .gdbinit:116: Error in sourced command file:
> > No symbol "back_trace" in current context.
> > (gdb) run ./lisp.run -B . -Efile UTF-8 -Eterminal UTF-8 
> -norc -m 750KW -x "(and (load \"init.lisp\") 
> (sys::%saveinitmem) (ext::exit))"
> > Starting program: /users/artn/clisp-2.33/build-O/lisp.run 
> ./lisp.run -B . -Efile UTF-8 -Eterminal UTF-8 -norc -m 750KW 
> -x "(and (load \"init.lisp\") (sys::%saveinitmem) (ext::exit))"
> >
> > Program received signal SIGSEGV, Segmentation fault. 0x00026fb4 in 
> > gar_col_normal ()
> > (gdb) bt
> > #0  0x00026fb4 in gar_col_normal ()
> > #1  0x00028d1c in do_gar_col_simple ()
> > #2  0x000bfeec in with_gc_statistics ()
> > #3  0x00028d80 in gar_col_simple ()
> > #4  0x00028fc0 in make_space_gc ()
> > #5  0x000293c8 in allocate_vector ()
> > #6  0x0002c11c in init_subr_tab_2 ()
> > #7  0x0002df60 in initmem ()
> > #8  0x0002f608 in main ()
> > #9  0x7af36440 in _start () from /usr/lib/libc.2
> > (gdb)
> >
> >
> >
> > I also tried with the Makefile modified with -O1, -O0, and the 
> > combination -O0 with -DNO_GENERATIONAL_GC added to the 
> CFLAGS. In all 
> > cases the compile coredumped at the same loction. A make clean was 
> > done between each make.
> >
> 
> -- 
> Sam Steingold (http://www.podval.org/~sds) running w2k 
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/> <http://www.mideasttruth.com/> <http://www.honestreporting.com> Type louder, please.

---

From: Nuzzo Art-CINT116 <[email-masked]>
Date: Thu Jun 3 05:54:01 2004

Has anyone been successful in compliling Clips on HP-UX 11.11?  

I have tried to compile it again with the latest version clisp-2.33.2 with the same results.  It will do a core dump when it tries to run the lisp.run command.

Any other ideas what I might try?

Thanks for any help,

Art Nuzzo

> From: Nuzzo Art-CINT116 <[email-masked]>
> To: "[email-masked]'"
> 	 <[email-masked]>
> Date: Mon, 24 May 2004 13:31:28 -0500
> Subject: [clisp-list] RE: Problem compiling on hp-ux 11.11
> 
> <http://www.camera.org> <http://www.iris.org.il> 
<http://www.memri.org/> <http://www.mideasttruth.com/> <http://www.honestreporting.com> Type louder, please.