Subject: [clisp-list] clisp on Linux/AMD64

From: Yoriaki FUJIMORI <[email-masked]>
Date: Wed May 21 05:09:11 2003

Dear Listers,

I am trying to compile clisp on an opteron based linux box.
By defining IA64, i.e. `cc -DIA64', I created a binary.
But, it does not run.  I saw something like, STACK OVERFLOW error.
Is there anyone challengin a similar task here?
I am happy in getting any clue or pointer for the compilation.

Thanks in advance for any responses.

Yoriaki

---

From: Sam Steingold <[email-masked]>
Date: Wed May 21 07:24:06 2003

> * In message <[email-masked]>
> * On the subject of "[clisp-list] clisp on Linux/AMD64"
> * Sent on Wed, 21 May 2003 21:07:06 +0900
> * Honorable Yoriaki FUJIMORI <[email-masked]> writes:
>

take a look here:
<http://clisp.cons.org/clisp.html#bugs>
<http://clisp.cons.org/faq.html#stack>

-- 
Sam Steingold (http://www.podval.org/~sds) running RedHat9 GNU/Linux
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.palestine-central.com/links.html>
Is there another word for synonym?

---

From: Yoriaki FUJIMORI <[email-masked]>
Date: Thu May 22 00:23:06 2003

I recomiled libsigsegv.a after modifying fault-posix.c in it.
Then I recompiled clisp with gcc3.3 with -DIA64 and without
optimization.

Lisp.run started to create *.mem, but in the middle of
loading macros1.lisp, it dies with core.
On gdb, I read

  Program received signal SIGABRT. Aborted.
  0x0000002a958f4059 in kill() from /lib64/libc.so.6

Hmm....  Any clues?

Yoriaki