Subject: [clisp-list] obtaining CVS clisp

From: Joe Corneli <[email-masked]>
Date: Sun Mar 7 21:31:04 2004

Hi, 

in the CVS tarball on the clisp home page, everything has a `,v'
suffix.  

Why is this, 

should I try to rid of them with find...xargs..., 

and/or is there a better way to "check clisp out of cvs" than
downloading this tarball?

Thanks,
Joe

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 8 08:04:06 2004

> * Joe Corneli <[email-masked]> [2004-03-07 23:14:42 -0600]:
>

that's the CVS files - in case you want to create your own CVS CLISP
repository.  read <http://www.cvshome.org>

> downloading this tarball?

<http://sourceforge.net/cvs/?group_id=1355>

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
MS Windows vs IBM OS/2: Why marketing matters more than technology...

---

From: Joe Corneli <[email-masked]>
Date: Mon Mar 8 08:52:03 2004

Thanks.

---

From: Joe Corneli <[email-masked]>
Date: Mon Mar 8 14:19:07 2004

Following the instructions posted there resulted in this -
please advise --

[~]% cvs -d:pserver:[email-masked]:/cvsroot/clisp login
(Logging in to [email-masked])
CVS password: 
[~]% cvs -z3 -d:pserver:[email-masked]:/cvsroot/clisp co clisp
cvs checkout: in directory .:
cvs [checkout aborted]: *PANIC* administration files missing

---

From: Sam Steingold <[email-masked]>
Date: Mon Mar 8 15:57:02 2004

> * Joe Corneli <[email-masked]> [2004-03-08 16:01:44 -0600]:
>

I cannot reproduce this.
please try again.
if the problem persists, please file a SourceForge support request
(not a CLISP one, but for the SF site!)

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
UNIX, car: hard to learn/easy to use; Windows, bike: hard to learn/hard to use.

---

From: Joe Corneli <[email-masked]>
Date: Mon Mar 8 17:10:02 2004

OK, I figured out how to use the tarball from the webpage.  It might
be helpful to include a 3 line README.CLISP-CVS like this along with
the tarball

To use this, untar to produce a directory called "clisp" and then,
setenv CVSROOT <full_path_to_that_directory>
cvs checkout clisp

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 9 06:57:03 2004

> * Joe Corneli <[email-masked]> [2004-03-08 18:51:24 -0600]:
>

this is a _VERY_ bad idea: you get the snapshot but not subsequent updates.
if you want to use the bleeding edge, check out the CVS HEAD from SF.

the CVS repository tarball which you downloaded is there for backup
purposes only.

(you need it also if you work on CLISP and do not have a network connection...)

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
If a train station is a place where a train stops, what's a workstation?

---

From: Joe Corneli <[email-masked]>
Date: Tue Mar 9 07:17:06 2004

Since I couldn't get my machine to download from the SF CVS
repository, I essentially didn't have a network connection (to the
CVS repository).  

Anyway, a README describing the tarball's intended use wouldn't be a
bad thing - it could also give information on how to obtain the
bleeding edge sources.

By the way, I noticed that if I run the normal cvs checkout routine
from inside the directory I made via the above process, I get the
following, instead of a panic over missing administration files
(which I still get if I try the normal routine in the normal way).
I think this log is full of errors, but at least I was able to get
somewhere.

[~/clisp]% cvs -d:pserver:[email-masked]:/cvsroot/clisp login
(Logging in to [email-masked])
CVS password:
[~/clisp]% cvs -z3 -d:pserver:[email-masked]:/cvsroot/clisp co clisp
cvs checkout: ignoring clisp (CVS/Repository missing)
cvs checkout: in directory clisp:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp
U clisp/.cvsignore
U clisp/ANNOUNCE
U clisp/COPYRIGHT
U clisp/GNU-GPL
U clisp/INSTALL
U clisp/Makefile.devel
U clisp/SUMMARY
U clisp/clisp.lsm
U clisp/clisp.spec
U clisp/configure
cvs checkout: in directory clisp/acorn:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/acorn
cvs checkout: in directory clisp/amiga:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga
cvs checkout: in directory clisp/amiga/jchlib:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga/jchlib
cvs checkout: in directory clisp/amiga/jchlib/include:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga/jchlib/include
cvs checkout: in directory clisp/amiga/jchlib/lib:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga/jchlib/lib
cvs checkout: in directory clisp/amiga/jchlib/misc:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga/jchlib/misc
cvs checkout: in directory clisp/amiga/jchlib/startup:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/amiga/jchlib/startup
cvs checkout: in directory clisp/benchmarks:
cvs checkout: cannot open CVS/Entries for reading: No such file or directory
cvs server: Updating clisp/benchmarks
U clisp/benchmarks/.cvsignore
cvs [checkout aborted]: cannot open CVS/Entries.Log: No such file or directory
[~/clisp]%

---

From: Sam Steingold <[email-masked]>
Date: Tue Mar 9 07:51:05 2004

> * Joe Corneli <[email-masked]> [2004-03-09 08:59:43 -0600]:
>

do 'rm -rf clisp' before this command.

PS. btw, what's the status of your effort to convert the final dpANS
draft into CLISP doc?

-- 
Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Daddy, what does "format disk c: complete" mean?

---

From: Joe Corneli <[email-masked]>
Date: Tue Mar 9 08:24:03 2004

OK, that looks to be just right.

I am wrote to XANALYS to ask about the copyright status of these
documents (Pitman said they might know) and also to ask if they
might just release the HyperSpec under the FDL.  Haven't heard back
yet. I'll contact them again soon.