Subject: [clisp-list] ask help "How To Install Clisp-2.28-win32"

From: Huaiyan Gao <[email-masked]>
Date: Tue Aug 6 02:20:03 2002

Hi

When I install clisp-2.28-win32, I encounter the following problems:

1. I excute the command lisp.exe -M lispinit.mem from  command line, the work is done well.

2. I excute the command (compile-file "src/config.lisp") from clisp prompt line, the work is done well.

3. But when I use load command do this work , e.g. (load "src/config.fas"), the work is done incorrectly, the message displays on screen:

** Continuable error

DEFUN/DEFMACRO(SHORT-SITE-NAME): #(PACKAGE COMMON-LISP) is locked.

Who may tell me how can I install clisp-2.28-win32 correctly?

Thanks.

HuaiYan Gao

---------------------------------
Get a bigger mailbox -- choose a size that fits your needs.

http://uk.docs.yahoo.com/mail_storage.html

---

From: Arseny Slobodjuck <[email-masked]>
Date: Tue Aug 6 06:04:03 2002

Hi,

> Who may tell me how can I install clisp-2.28-win32 correctly?

Why don't you use 2.29 version ?

Try either typing :c at every continuable error (actually a warning)
or run config.fas with command

(without-package-lock nil (load "src/config.fas"))

readme is somewhat outdated - after (saveinitmem) you can use install.bat
to associate file extensions. But install.bat in 2.28 and 2.29 doesn't
support win95/98, just NT..XP. Right install.bat is in CVS :(

-- 
Best regards,
 Arseny