Subject: [clisp-list] How do I make .exe files in CLISP?

From: [email-masked]
Date: Sat Oct 6 18:21:03 2001

Is there any way to build a standalone excutable file using CLISP?

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Oct 8 05:08:04 2001

Hello CavaleiroZ,

Sunday, October 07, 2001, 11:20:46 AM, you wrote:

CavaleiroZ> Is there any way to build a
CavaleiroZ> standalone excutable file using CLISP?
No.

-- 
Best regards,
 Arseny

---

From: Reini Urban <[email-masked]>
Date: Mon Oct 8 05:31:02 2001

> No.

sorry. that's wrong. There are many ways. Some ways are described in the docs.

you just have to create a loader, which initializes clisp with your image.
see clisp.c

under windows you can also embed the lisp image inside the exe, 
as it is done in cormanlisp for example. (one-file-exe in a custom binary
resource)
no big deal.
or you can undump an exe with the image data as it is done in emacs/xemacs, 
similar to most lisps. 

under unix you can follow impnotes.html#quickstart
the easiest is something like:

#!/bin/sh
exec clisp <<EOF
(lisp-form)
(another-lisp-form)
(yet-another-lisp-form)
EOF
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/

---

From: Marco Antoniotti <[email-masked]>
Date: Mon Oct 8 09:32:02 2001

> From: Arseny Slobodjuck <[email-masked]>
> Reply-To: Arseny Slobodjuck <[email-masked]>
> Organization: ICH
> X-Priority: 3 (Normal)
> CC: [email-masked]
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.5
> Precedence: bulk
> List-Help: <mailto:[email-masked]?subject=help>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=subscribe>
> List-Id: CLISP user discussion <clisp-list.lists.sourceforge.net>
> List-Unsubscribe: <https://lists.sourceforge.net/lists/listinfo/clisp-list>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <https://lists.sourceforge.net/archives//clisp-list/>
> X-Original-Date: Mon, 8 Oct 2001 23:05:11 +1000
> Date: Mon, 8 Oct 2001 23:05:11 +1000
> Content-Length: 356
> 
> Hello CavaleiroZ,
> 

Well.  Define "standalone".  You can always construct a .BAT file and
run it from there.  Would this be ok?  If not, why?

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
719 Broadway 12th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Mon Oct 8 17:55:03 2001

Hello Marco,

>> CavaleiroZ> standalone excutable file using CLISP?

Marco> Well.  Define "standalone".  You can always construct a .BAT file and
Marco> run it from there.  Would this be ok?  If not, why?

Reading the question with telepathic mode on I decided that standalone
executable mean simply 'binary native OS executable generated by
compiler from sources'. While one can always use clisp itself as a
stand (not so)alone executable it will not executable being built by user.

-- 
Best regards,
 Arseny

---

From: Sam Steingold <[email-masked]>
Date: Tue Oct 9 09:22:12 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] How do I make .exe files in CLISP?"
> * Sent on Sat, 6 Oct 2001 21:20:46 EDT
> * Honorable [email-masked] writes:
>

I don't think that the notion "standalone executable file" makes sense.
There have been no such things since DLL/SO (dynamically linked
libraries/shared objects) have been introduced.

Please see <http://clisp.cons.org/impnotes.html#quickstart> for the
answer to the question you meant to ask :-)

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
There's always free cheese in a mousetrap.