Subject: [clisp-list] Problems trying to build on SunOS 5.8

From: "Thomas F. Burdick" <[email-masked]>
Date: Wed Sep 5 20:15:02 2001

The subject kind of says it all.  I got the 2.27 tarball from
sourceforge, unpacked it, and you can see the rest below...

[tfb@apocalypse]/opt/local/src/users/tfb/clisp-2.27$ uname -a
SunOS apocalypse.OCF.Berkeley.EDU 5.8 Generic_108528-09 sun4u sparc SUNW,Ultra-1
[tfb@apocalypse]/opt/local/src/users/tfb/clisp-2.27$ ./configure --prefix=~ --config
executing src/configure ...
creating cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking how to run the C preprocessor... gcc -O -E -w
checking for AIX... no
checking whether using GNU C... yes
checking whether using C++... no
checking whether using ANSI C... yes
checking whether CPP likes indented directives... yes
checking whether CPP likes empty macro arguments... yes
checking for underscore in external names... no
checking for ranlib... ranlib
checking for a BSD compatible install... /opt/local/bin/ginstall -c
checking how to copy files... cp -p
checking how to make hard links... ln
checking whether ln -s works... yes
checking how to make hard links to symlinks... hln
checking for groff... groff
checking for getpwnam... yes
checking for DYNIX/ptx libseq or libsocket... no
checking whether gethostent requires -lnsl... yes
checking whether setsockopt requires -lsocket... yes
checking whether CC works at all... yes
checking host system type... sparc-sun-solaris2.8
checking for 64-bit SPARC... no
checking for inline... inline
checking for working void... yes
checking for working "return void"... yes
checking for long long type... yes
checking for ANSI C header files... yes
checking for offsetof in stddef.h... yes
checking for stdbool.h... no
checking for locale.h... yes
checking for unistd.h... yes
checking for sys/file.h... yes
checking for R_OK in unistd.h... yes
checking for sys/file.h... (cached) yes
checking for O_RDWR in fcntl.h... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for sys/utsname.h and struct utsname... yes
checking for netdb.h... yes
checking for sys/shm.h... yes
checking for sys/ipc.h... yes
checking for termios.h... yes
checking for termio.h... yes
checking for sys/termio.h... yes
checking for sgtty.h... yes
checking for tcgetattr... yes
checking for tcsetattr declaration... 
         extern int tcsetattr (int, int, const struct termios *);
checking for TCSAFLUSH in termios.h... yes
checking for struct winsize in termios.h... yes
checking for X11
checking for xmkmf... yes
checking for X... libraries /usr/openwin/lib, headers /usr/openwin/include
checking for caddr_t in sys/types.h... yes
checking for socklen_t in sys/socket.h... yes
checking for d_namlen in struct dirent... no
checking for struct tm in sys/time.h... yes
checking for strlen declaration... 
         extern size_t strlen (const char*);
checking for memset declaration... 
         extern char* memset (char*, int, int);
checking for broken HP/UX malloc... no
checking for malloc declaration... 
         extern void* malloc (unsigned int);
checking for free declaration... 
         extern void free (void*);
checking for working alloca.h... yes
checking for alloca... yes
checking for _setjmp... yes
checking for _longjmp... yes
checking return type of signal handlers... void
checking whether the signal handler function type needs dots... no
checking for sighold... yes
checking for sigprocmask... yes
checking for sigblock... no
checking for signal blocking interfaces... SystemV POSIX
checking for sigprocmask declaration... 
         extern int sigprocmask (int, const sigset_t*, sigset_t*);
checking whether signal handlers need to be reinstalled... yes
checking whether signals are blocked when signal handlers are entered... no
checking whether other signals are blocked when signal handlers are entered... no
checking for sigaction... yes
checking whether sigaction handlers need to be reinstalled... no
checking whether signals are blocked when sigaction handlers are entered... yes
checking for siginterrupt... yes
checking for fpu_control_t... no
checking for __setfpucw... no
checking for raise... yes
checking for abort declaration... 
         extern void abort (void);
checking for perror declaration... yes
checking for strerror... yes
checking for sys_errlist declaration... 
         extern char* sys_errlist[];
checking for getenv declaration... 
         extern char* getenv (const char*);
checking for putenv... yes
checking for putenv declaration... 
         extern int putenv (char*);
checking for setlocale declaration... 
         extern char* setlocale (int, const char*);
checking for setrlimit... yes
checking for getrlimit declaration... 
         extern int getrlimit (int, struct rlimit *);
checking for setrlimit declaration... 
         extern int setrlimit (int, const struct rlimit *);
checking for ANSI C header files... yes
checking for pid_t... yes
checking for vfork.h... no
checking for working vfork... yes
checking for vfork declaration... 
         extern pid_t vfork (void);
checking for setsid... yes
checking for setpgid... yes
checking for execv declaration... 
         extern int execv (const char*, char* const[]);
checking for execl declaration... 
         extern int execl (const char*, const char*, ...);
checking for waitpid declaration... 
         extern pid_t waitpid (pid_t, int*, int);
checking for sys/resource.h... yes
checking for sys/times.h... yes
checking for getrusage... yes
checking for getrusage declaration... 
         extern int getrusage (int, struct rusage *);
checking for getcwd... yes
checking for getcwd declaration... 
         extern char* getcwd (char*, size_t);
checking for chdir declaration... 
         extern int chdir (const char*);
checking for mkdir declaration... 
         extern int mkdir (const char*, mode_t);
checking for rmdir declaration... 
         extern int rmdir (const char*);
checking whether stat file-mode macros are broken... no
checking for fstat declaration... 
         extern int fstat (int, struct stat *);
checking for stat declaration... 
         extern int stat (const char*, struct stat *);
checking for lstat... yes
checking for lstat declaration... 
         extern int lstat (const char*, struct stat *);
checking for readlink... yes
checking for readlink declaration... 
         extern int readlink (const char*, char*, size_t);
checking for ELOOP... yes
checking for opendir declaration... 
         extern DIR* opendir (const char*);
checking for closedir declaration... 
         extern int closedir (DIR*);
checking for usable closedir return value... yes
checking for open declaration... 
         extern int open (const char*, int, ...);
checking for read declaration... 
         extern int read (int, void*, size_t);
checking for write declaration... 
         extern int write (int, const void*, size_t);
checking for rename declaration... 
         extern int rename (const char*, const char*);
checking for unlink declaration... 
         extern int unlink (const char*);
checking for fsync... yes
checking for ioctl declaration... 
         extern int ioctl (int, int, ...);
checking for FIONREAD... no
checking for FIONREAD in sys/filio.h... yes
checking for reliable FIONREAD... yes
checking for fcntl declaration... 
         extern int fcntl (int, int, ...);
checking for select... yes
checking for sys/select.h... yes
checking for select declaration... 
         extern int select (int, fd_set *, fd_set *, fd_set *, struct timeval *);
checking for ualarm... yes
checking for setitimer... yes
checking for setitimer declaration... 
         extern int setitimer (int, struct itimerval *, struct itimerval *);
checking for usleep... yes
checking for localtime declaration... 
         extern struct tm * localtime (const time_t*);
checking for gettimeofday... yes
checking for gettimeofday declaration... 
         extern int gettimeofday (struct timeval *, void *);
checking for ftime... yes
checking for getpwnam declaration... 
         extern struct passwd * getpwnam (const char*);
checking for getpwuid declaration... 
         extern struct passwd * getpwuid (uid_t);
checking for gethostname... yes
checking for gethostname declaration... 
         extern int gethostname (char*, int);
checking for gethostbyname declaration... 
         extern struct hostent * gethostbyname (const char*);
checking for connect declaration... 
         extern int connect (int, const struct sockaddr *, size_t);
checking for sys/un.h... yes
checking for sun_len in struct sockaddr_un... no
checking for IPv4 sockets... yes
checking for IPv6 sockets... yes
checking for inet_pton... yes
checking for inet_ntop... yes
checking for netinet/in.h... yes
checking for arpa/inet.h... yes
checking for inet_addr declaration... 
         extern unsigned int inet_addr (const char*);
checking for netinet/tcp.h... yes
checking for setsockopt declaration... 
         extern int setsockopt (int, int, int, const void*, unsigned int);
checking for the code address range... 0x00000000
checking for the malloc address range... 0x00000000
checking for the shared library address range... 0xFF000000
checking for the stack address range... 0xFF000000
checking for getpagesize... yes
checking for getpagesize declaration... 
         extern int getpagesize (void);
checking for vadvise... no
checking for vm_allocate... no
checking for sys/mman.h... yes
checking for mmap... yes
checking for mmap declaration... 
         extern caddr_t mmap (caddr_t, size_t, int, int, int, off_t);
checking for working mmap... yes
checking for munmap... yes
checking for msync... yes
checking for mprotect... yes
checking for mprotect declaration... 
         extern int mprotect (caddr_t, size_t, int);
checking for working mprotect... yes
checking for shmget declaration... 
         extern int shmget (key_t, size_t, int);
checking for shmat declaration... 
         extern void* shmat (int, const void*, int);
checking for shmdt declaration... 
         extern int shmdt (char*);
checking for shmctl declaration... 
         extern int shmctl (int, int, struct shmid_ds *);
checking for working shared memory... yes
checking for sys/sysmacros.h... yes
checking for attachability of removed shared memory... no
checking for dlopen... yes
checking for dlsym declaration... 
         extern void* dlsym (void* handle, const char* symbol);
checking for dlerror declaration... 
         extern char * dlerror ();
checking for iconv... yes
checking for iconv declaration... 
         extern size_t iconv (iconv_t cd, const char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t* outbytesleft);
checking for tgetent... no
checking for tgetent in -lncurses... no
checking for tgetent in -ltermcap... yes
checking for the valid characters in filenames... 8-bit
checking for inline __builtin_strlen... no
checking whether characters are unsigned... no
checking for integer types and behaviour
creating intparam.h
updating cache ./config.cache
creating ./config.status
creating makemake
creating unixconf.h
executing src/libiconv/configure ...
loading cache ../config.cache
checking whether make sets $(MAKE)... yes
checking for gcc... (cached) gcc -O
checking whether the C compiler (gcc -O  ) works... yes
checking whether the C compiler (gcc -O  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking how to run the C preprocessor... (cached) gcc -O -E -w
checking whether -traditional is needed for gcc -O on this system... no
checking for ranlib... (cached) ranlib
checking for a BSD compatible install... (cached) /opt/local/bin/ginstall -c
checking how to copy files... (cached) cp -p
checking how to make hard links... (cached) ln
checking whether ln -s works... (cached) yes
checking host system type... (cached) sparc-sun-solaris2.8
checking for AIX... (cached) no
checking for minix/config.h... no
checking for POSIXized ISC... no
checking for object suffix... o
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for executable suffix... no
checking build system type... sparc-sun-solaris2.8
checking for ld used by GCC... /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... no
checking for /usr/ccs/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/ccs/bin/nm -p
checking how to recognise dependant libraries... pass_all
checking command to parse /usr/ccs/bin/nm -p output... ok
checking for dlfcn.h... yes
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... 
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/ccs/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... solaris2.8 ld.so
checking if libtool supports shared libraries... yes
creating libtool
checking for locale.h... (cached) yes
checking for stdlib.h... yes
checking for mbstate_t... yes
checking for iconv... (cached) yes
checking for iconv declaration... (cached) 
         extern size_t iconv (iconv_t cd, const char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t* outbytesleft);
checking for mbrtowc... yes
checking for wcrtomb... yes
checking for mbsinit... yes
checking for setlocale... yes
checking byte ordering... big endian
updating cache ../config.cache
creating ./config.status
creating Makefile
creating lib/Makefile
creating src/Makefile
creating man/Makefile
creating tests/Makefile
creating include/iconv.h
creating lib/config.h
configuring in libcharset
running /bin/sh ../../../libiconv/libcharset/configure  '--prefix=~' --enable-static --disable-shared --cache-file=../../config.cache --srcdir=../../../libiconv/libcharset
loading cache ../../config.cache
checking whether make sets ${MAKE}... (cached) yes
checking for gcc... (cached) gcc -O
checking whether the C compiler (gcc -O  ) works... yes
checking whether the C compiler (gcc -O  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc -O accepts -g... yes
checking how to run the C preprocessor... (cached) gcc -O -E -w
checking whether gcc -O needs -traditional... (cached) no
checking for a BSD compatible install... /opt/local/bin/ginstall -c
checking host system type... sparc-sun-solaris2.8
checking for AIX... no
checking for minix/config.h... (cached) no
checking for POSIXized ISC... no
checking for object suffix... (cached) o
checking for Cygwin environment... (cached) no
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking build system type... sparc-sun-solaris2.8
checking for ld used by GCC... (cached) /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... (cached) no
checking for /usr/ccs/bin/ld option to reload object files... (cached) -r
checking for BSD-compatible nm... (cached) /usr/ccs/bin/nm -p
checking whether ln -s works... yes
checking how to recognise dependant libraries... (cached) pass_all
checking command to parse /usr/ccs/bin/nm -p output... (cached) ok
checking for dlfcn.h... (cached) yes
checking for ranlib... (cached) ranlib
checking for strip... (cached) strip
checking for objdir... .libs
checking for gcc option to produce PIC... (cached)  -fPIC
checking if gcc PIC flag  -fPIC works... (cached) yes
checking if gcc static flag -static works... (cached) yes
checking if gcc supports -c -o file.o... (cached) yes
checking if gcc supports -c -o file.lo... (cached) 
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/ccs/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... solaris2.8 ld.so
checking if libtool supports shared libraries... yes
creating libtool
checking for langinfo.h... yes
checking for nl_langinfo... yes
checking for nl_langinfo and CODESET... yes
checking whether we are using the GNU C Library 2.1 or newer... no
checking for stddef.h... yes
checking for stdlib.h... (cached) yes
checking for string.h... yes
checking for setlocale... (cached) yes
updating cache ../../config.cache
creating ./config.status
creating Makefile
creating lib/Makefile
creating config.h
builddir="`pwd`"; cd libcharset && make all && make install-lib libdir="$builddir/lib" includedir="$builddir/lib"
if [ ! -d include ] ; then mkdir include ; fi
cp ../../../libiconv/libcharset/include/libcharset.h.in include/libcharset.h
cd lib && make all
/bin/sh ../libtool --mode=compile gcc -O -I. -I../../../../libiconv/libcharset/lib -I.. -I../../../../libiconv/libcharset/lib/.. -g -O2  -DHAVE_CONFIG_H -DLIBDIR=\"~/lib\" -c ../../../../libiconv/libcharset/lib/localcharset.c
gcc -O -I. -I../../../../libiconv/libcharset/lib -I.. -I../../../../libiconv/libcharset/lib/.. -g -O2 -DHAVE_CONFIG_H "-DLIBDIR=\"~/lib\"" -c ../../../../libiconv/libcharset/lib/localcharset.c -o localcharset.o
echo timestamp > localcharset.lo
/bin/sh ../libtool --mode=link gcc -O  -o libcharset.la -rpath ~/lib -version-info 1:0:0 -no-undefined localcharset.lo
libtool: link: only absolute run-paths are allowed
*** Error code 1
make: Fatal error: Command failed for target `libcharset.la'
Current working directory /opt/src/users/tfb/clisp-2.27/src/libiconv/libcharset/lib
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory /opt/src/users/tfb/clisp-2.27/src/libiconv/libcharset
*** Error code 1
make: Fatal error: Command failed for target `all'

---

From: Sam Steingold <[email-masked]>
Date: Thu Sep 6 06:11:07 2001

> * In message <[email-masked]>
> * On the subject of "[clisp-list] Problems trying to build on SunOS 5.8"
> * Sent on Wed, 5 Sep 2001 20:14:51 -0700
> * Honorable "Thomas F. Burdick" <[email-masked]> writes:
>
                                                                            ^
> ...
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> *** Error code 1

give an absolute path to the --prefix argument.

(of course, you must make distclean first; if it doesn't work - since
configuration failed - remove the source tree and unpack the tarball again)

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
The early bird may get the worm, but the second mouse gets the cheese.

---

From: "Thomas F. Burdick" <[email-masked]>
Date: Thu Sep 6 18:38:02 2001

> > libtool: link: only absolute run-paths are allowed

Oops, shows how lousy my shell skills are (I thought it would expand
the ~).  That did it, thanks.