Subject: [clisp-list] Ilisp hangs with clisp...

From: Eric Moncrieff <[email-masked]>
Date: Wed Aug 14 06:32:02 2002

Hello,

I'm not sure if this is a clisp-specific problem, but it
didn't seem to happen under other Lisps I've tried.  

As you're probably all aware, Ilisp normally pops up some 
information about the function you're calling in the 
minibuffer as you type.  However, under the setup I'm 
forced to use at work (Emacs 21.2, Ilisp CVS snapshot, 
CLISP 2.29, M$ Windows NT4.0), when I type

(defun<space>

the program becomes non-responsive for something like
30 seconds.  I can C-g to kill whatever emacs thinks 
it's doing, but as soon as I hit <space> again, it 
starts doing it again.

As you can imagine, this makes writing code difficult.

Any suggestions as to how to make this irritating 
behaviour stop?

Thanks,
Eric Moncrieff

---

From: Eduardo Muñoz <[email-masked]>
Date: Wed Aug 14 15:52:02 2002

> 30 seconds. [...]

 The following patch seems to avoid this behaviour.
ilisp-snd.el is the file edited by me and ilisp-snd.old.el is the one that
comes with the ilisp-5.12.0 distribution:

diff ilisp-snd.el ilisp-snd.old.el
611c611
<               (sit-for 0 1 t)
---
>            ;; (sit-for 0)  ; 19990912 Pretty useless.

So edit the file ilisp-snd.el and recompile ilisp.

P.S. I sent this bug report to [email-masked] but haven't
got any anwer yet.

---

From: Marco Antoniotti <[email-masked]>
Date: Wed Aug 14 15:58:04 2002

> From: =?iso-8859-1?Q?Eduardo_Mu=F1oz?= <[email-masked]>
> X-Priority: 3
> X-MSMail-Priority: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6700
> Sender: [email-masked]
> X-Original-Date: Thu, 15 Aug 2002 00:52:03 +0200
> Date: Thu, 15 Aug 2002 00:52:03 +0200
> 

Evindently the [email-masked] addresses are not active.  The move of
the physical machine may have created problems with these addresses.

Please try <[email-masked]>

Cheers

-- 
Marco Antoniotti ========================================================
NYU Courant Bioinformatics Group        tel. +1 - 212 - 998 3488
715 Broadway 10th Floor                 fax  +1 - 212 - 995 4122
New York, NY 10003, USA                 http://bioinformatics.cat.nyu.edu
                    "Hello New York! We'll do what we can!"
                           Bill Murray in `Ghostbusters'.