Subject: [clisp-list] (no subject)

From: Arseny Slobodjuck <[email-masked]>
Date: Mon, 16 Jul 2001 22:37:38 +1000

Hi,

There's a patches:

;---- patch 1 : see the file w32strm.d (a part of stream.d
after "#if defined(WIN32_NATIVE)" ).
Contains some small patches here and there, national character thanslation
and buffered output (much faster than char-by char).

;---- patch 2 :
Function legal_namechar(ch) in file
pathname.d,  when compiling for win32 defines valid characters
in pathnames:

   return ((c >= 1) && (c <= 127) && (c != 34)             /*&& (c != 42)*/
       && (c != 47) && (c != 58) && (c != 60) && (c != 62) /*&& (c != 63)*/
       && (c != 92)) || (c == 131) || ((c >= 160) && (c != 197) && (c != 206));

The codes 197 and 206 are capital versions of two most often used cyrillic
characters in win-1251 codepage and maybe somebody else's favorite
characters. I personally not using local characters
in pathnames, but Microsoft does, so any directory scanning fails :( I
wonder, why 197 and 206 are there but 13 and 11 are not.

;---- patch 3 :
file stream.d, win32 console keyboard input,
function  local object rd_ch_keyboard(stream_)
It will be nice to change
if ((event.Event.KeyEvent.uAsciiChar) <= ' ') {
to
if (((uintB)event.Event.KeyEvent.uAsciiChar) <= ' ') {
since (in MSVC) char is signed.
For proper input of national chars > 127 also need a line:

ev.code = as_chart((uintB)event.Event.KeyEvent.uAsciiChar);
# FIXME: This should take into account the encoding.
# ampy : you're damn right. that's it
OemToCharBuff((char *)&ev.code,(char *)&ev.code,1);

-- 
Best regards,
 Arseny

---

From: Sam Steingold <[email-masked]>
Date: 17 Jul 2001 17:40:27 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] (no subject)"
> * Sent on Mon, 16 Jul 2001 22:37:38 +1000
> * Honorable Arseny Slobodjuck <[email-masked]> writes:
>
> There's a patches:

could you please send the diff -u against src/stream.d?
thanks.

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
The difference between genius and stupidity is that genius has its limits.

---

From: Arseny Slobodjuck <[email-masked]>
Date: Wed, 18 Jul 2001 13:54:37 +1000

Hello Sam,

>> There's a patches:

SS> could you please send the diff -u against src/stream.d?
SS> thanks.
I'll try to do it this week first introdusing the patches
to newest version. Currently I'm working with
2000-03-06 sources and diff is quite big...

-- 
Best regards,
 Arseny                            mailto:[email-masked]