Subject: [clisp-list] A minor bug when at break

From: Bruce <[email-masked]>
Date: Tue, 10 Jul 2001 08:36:10 +0800

This bug is very easy to reproduce.

[2]> (defun my-div (x y)
   (/ x y))
MY-DIV
[11]> (my-div 5 0)
*** - division by 0
1. Break [12]> Backtrace-1
*** - EVAL: variable BACKTRACE-1 has no value
2. Break [13]> Backtrace-1
[Now normal backtrace]

It also works fine if type "help" before "Backtrace-1". This does not 
occur in 2.25 and 2000-03-06.

I'm using clisp 2.26 on Debian/GNU woody and have the first four patches 
applied.

Best!
-- 
I'll burn my books.
		-- Christopher Marlowe

---

From: Sam Steingold <[email-masked]>
Date: 11 Jul 2001 14:13:19 -0400

> * In message <[email-masked]>
> * On the subject of "[clisp-list] A minor bug when  at break"
> * Sent on Tue, 10 Jul 2001 08:36:10 +0800
> * Honorable Bruce <[email-masked]> writes:
>

I cannot reproduce it.
are you sure you do not have why whitespace around commands?

-- 
Sam Steingold (http://www.podval.org/~sds)
Support Israel's right to defend herself! <http://www.i-charity.com/go/israel>
Read what the Arab leaders say to their people on <http://www.memri.org/>
Between grand theft and a legal fee, there only stands a law degree.